We help IT Professionals succeed at work.

DNS

26K

Solutions

26K

Contributors

The Domain Name System (DNS) is a hierarchical, globally distributed system responsible for associating the name of a computer, service or other resource into an IP address for connecting to the Internet or a private network. Most prominently, it translates domain names to the numerical IP addresses needed for the purpose of computer services and devices worldwide.

I have tried all the resolutions I could find to be able to view all computers on my domain. I have turned on network discovery file sharing and print sharing,
Started these services "Function Discovery Provider Host" and "Function Discovery Resource Publication"  DNS Client - Automatic, SSDP Discovery - Automatic, UPnP Device Host
Enabled SMB 1.0/CIFS File in Programs and Features both the SMB 1.0/CIFS Client and Server.
Ran this command from admin cmd prompt netsh advfirewall firewall set rule group="Network Discovery" new enable=Yes

I still an unable to see all computers and before win 10 I could even see my servers cannot now.
0
*Assistance setting up an Exchange 2019 Server's DNS records as, this is my first Exchange Server deployment
The server is a Windows 2019 Standard system and is a member of a domain.
Exchange 2019 CU5 was successfully installed and so, the proper Send Connector, Accepted Domain and Recipients have been added and this server is an on-premise Exchange Server.
The Exchange server can send and receive in and out bound mail with the exception of out bound mail be received as spam hence, the big question(s) re: DNS coming up...
This is the server information:
Exchange Server Static WAN IP 123.456.789.321
Exchange Server Static LAN IP:  10.0.0.1
Exchange Server (computer name): mailserver
Exchange Server e-mail domain:  mydomain.com
Here is where I am seeking advice...
1. Exactly what for DNS would I enter on the Exchange server if necessary?  Please be specific and detailed based on the Exchange settings I provided.

2. Exactly what DNS settings should I insert regarding DNS settings on the registrar?  Please be specific and detailed based on the Exchange settings I provided.

3.  Exactly what DNS information should I provide the ISP that provided the static WAN IP? Please be specific and detailed based on the Exchange settings I provided.

Your assistance with the DNS settings is greatly appreciated.
0
I have an external domain that is being advertised via our zone files. For the setup of AAD Connect the connector to synch our internal AD with the Azure cloud, it is asking us to create either TXT or MX records on our zone file for our local domain i.e. ABC.local domain which our users exist on.

Do we need to create this under my external DNS, ABC.com.fj domain or do I create a seperate domain with a seperate DNS record for my ABC.local domain?
0
DNS issues after replacing SBS 2011 Domain Controller with Windows 2019 Standard Server.
Setup 2019 server as domain controller. All users were picked up by the new DC. The issue is that some domain member computers loose contact with the domain. Drives mapped using server names fail but when mapped by IP address they work.
On some computers adding a domain user to the local administrators group the add function does not see the domain.
My rather unsophisticated assumption is that this is a DNS issue and I "blame" the new DC since it is also the DNS server and DHCP server for the domain.
Any troubleshooting tips would be very much appreciated.
0
I'm getting Quickbooks error H202 multiple times per day when using multi-user mode:

You are trying to work with a company file that is located on another computer, and this copy of QuickBooks cannot reach the server on that computer. (H202).

Open in new window


  1. I can ping between all of the workstations and the QB server by DNS name.
  2. I have been able to cause 100% packet loss by setting the packet size to anything over 23,672 bytes.
  3. Does the 23,672 byte limit make any sense regarding the H202 error and/or does it imply any kind of network problem?
0
Public DNS issue
My company uses Bind DNS for our public DNS.  
We are trying to create an easy web address to type for specific customers.  We want that address to point to a specific place on one of our public web servers.  This web server then redirects them to another 3rd party web site on a specific area on that site.  What i'm think should work, isn't working.

(1) In the BIND public DNS server I have the alias quest.careatc.com pointing to portal,careatc.com/pha/quest using the a record.
(2) portal,careatc.com/pha/quest is an actual web server that then redirects to https://appointment.questdiagnostics.com/schedule/appointment?labcard=false&reasonforvisit=PHLEBOTOMY

Number 2 above works when typed into a browser. It forward me to the link.  
Number 1 above doesnt resolve and redirect to the #2 link
When I do a public DNS lookup on quest.careatc.com, it shows that it goes to portal,careatc.com/pha/quest
Im not sure what is wrong besides something I am doing.
0
After permanently removing the Exchange 2010 in my network, I still find a MX record in my AD DNS. Should I manually remove it ?

Thx
DNSrecord.png
0
Hello to everyone

I need to restore from backup our domain controllers in sandbox mode to test Shema change and update for 2FHA. And we want to be sure work before implemented on our production environment. When i recover our 3 domain controllers in the isolated network i get a lot of errors. We don't have this problem on a production site. A really be appreciated help.

C:\Windows\system32>dcdiag

Directory Server Diagnosis

Performing initial setup:
   Trying to find home server...
   Home Server = Sheriff-DC2
   * Identified AD Forest.
   Done gathering initial info.

Doing initial required tests

   Testing server: SJ\SHERIFF-DC2
      Starting test: Connectivity
         ......................... SHERIFF-DC2 passed test Connectivity

Doing primary tests

   Testing server: SJ\SHERIFF-DC2
      Starting test: Advertising
         Fatal Error:DsGetDcName (SHERIFF-DC2) call failed, error 1355
         The Locator could not find the server.
         ......................... SHERIFF-DC2 failed test Advertising
      Starting test: FrsEvent
         There are warning or error events within the last 24 hours after the SYSVOL has been shared.  Failing SYSVOL replication
         problems may cause Group Policy problems.
         ......................... SHERIFF-DC2 passed test FrsEvent
      Starting test: DFSREvent
         ......................... SHERIFF-DC2 passed test DFSREvent
      Starting test: SysVolCheck
         …
0
I am having a problem with my DHCP server or should I say my network. I have had an old Windows 2003 DC on my network which used to control DNS, DHCP, WINS, Etc.. but over the years I have moved those services off that server and on to new servers (Windows 2008 R2 and Windows 2012 R2) and everything has been working great.

Over the weekend I decided to decommsion that server and move the FSMO roles over to one of the newer servers (Windows 2012R2) and raise the domain from 2003 to 2008R2 since I still have 2008R2 DC's on my network. Everything seemed to go fine but now I am experiencing issues with some of the workstations.

When I look at the configuration of the workstation it is set to DHCP but when I run ipconfig /all it shows the old DC that I decommissioned as the DHCP server and the DNS servers that are on those workstations are incorrect. When I manually add the DNS to the network config it works fine but if I remove then we are back to square one. I have ipconfig /release and ipconfig /renew with no success. I looked at my DHCP scope options and Reservations and found that some of the problem machines were on the reservations list so I deleted those machines, restarted/powered off but when they come back up still the same symptoms.  

What can I do to fix this issue or where do I start?
0
How do i verify the domain of a linux server which it belongs to .When logging through  putty nothing comes up .As I m new to this kind of topics I 'm ready for a session from a expert if anyone is willing to .I'm based out in USA .
0
Environment:

2008 FFL/DFL - 3 DCs

-HOMEDC01 - 2008 SP2 - DNS, GC

-HOMEPDC -  2008 R2 SP1 - FSMO, DHCP, DNS, WINS, GC

-HOMESDC (VM) -  2016 - DNS, GC

IPV6 enabled on all per articles found online.

DC01 has been on the network for years and did everything before.  Then I brought up PDC a few years ago and transferred over all roles from DC01.  2 weeks ago I brought up SDC and set it up with DNS.  Everything looks to be in order and the plan was to demote DC01 and retire it.  I shut down DC01 for a few days and all of a sudden we started experiencing extremely slow loading times for any webpages.  I brought it back up and everything went back to normal.

I made the necessary adjustments in DHCP to only provide PDC and SDC to clients for DNS.

I ran dcdiag /test:DNS /DNSALL /e /v to see whats going on and the only thing I can see is that root hints only seem to be showing up on DC01 in the output.  I check DNS on PDC and SDC and they both have them, so not sure why they show up for only one server in the output.  Is that my problem?  What am I missing? (see attached output run from SDC, I also ran it on the other 2)

When I had DC01 off, before turning it back on, I ran nslookup and got major delays/time-outs the first time around but then would get a response eventually.  Tried clearing cache on both PDC and SDC and re-registering both.  No change.

Any direction or insight would be greatly appreciated.  TIA
DCDIAG-DNSV.txt
0
My CIO came to me and suggested we investigate moving our domain controller to the cloud.  His rational is that we use it for authentication from all of our devices.  We have several sites that have their own internet connection, but we have a VPN connection from each of the sites for authentication.  He thinks that when people log in it slows down our internet, so with that said he wants us to look into it.

I have done some research and everyone says AWS or Microsoft Azure AD Services, but I have no clue where to start.  I also understand that this migration does not take into affect the GPO's which we rely on.  Our domain server houses not only our AD, but our DHCP and DNS.  Can someone point me in the right direction so I can at least start to make some sense out of this project.
0
after my difficulties getting simon installed, i looked for alternatives.  has anyone ever used deepspeech?  i'm trying very hard to find  a ubuntu alternative to dragon naturally speaking.  DNS seems good  for windows but i get frustrated with the windows updates.  i used mint also which seems very good.  I've heard of, but never tried, raspberry pi.  pretty much i would  like a very good speech to text program in linux.  i'm tired of typing so slowly with my left index finger.  I lose my train of thought in mid sentence.  it is understandably difficult for you to figure out my question.
0
Hello, I am in the process of changing a mail server to google and website to Wix, and the domain is with Go Daddy. In the past, I have done something like this before and I setup Cloudflare to manage the DNS setting but I didn't put in my notes why I did this so my question is if my domain is with go-daddy and website is with Wix but email is with google should I just set up the DNS on go daddy or setup Cloudflare? Its been a while since I have done this.
0
Hello Experts,

I have access to my control panel for my domain www.domain.com and I want using to be redirected to it when they type shop.domain.com.
Do you know in the DNS entering what do I need to add for the redirection to happen.

Thank you,
0
Having trouble creating a DNS redirect in BIND DNS manager.
We have a domain (I will not use the real domain name in my examples.  

ourdomain.com

We have many aliases like
mail.ourdomain.com     ->     oulook.office365.com.
publicknowledge.ourdomain.com     - >      publicknowledge.help.docs.blablabla.com.

Im having trouble with adding this alias address
somthing.ourdomain.com     ->     appt.SomeoneElsesDomain.com.schedule.appointment?labcard=false&reasonforvisit=PHLEBOTOMY
The destination usually looks like this.  https://appt.SomeoneElsesDomain.com/schedule/appointment?labcard=false&reasonforvisit=PHLEBOTOMY

I get an error that the name is too long.  not sure how to move forward or figure out a way to do this.  
Thanks for any assistance.
0
I am hosting two sites on a windows server.  One is standard IIS using port 80 forced to ssl on port 443.
I also have a tomcat instance with port 8080 forced to 8443.
I would like to create two separate host names with separate dns entries.  One host name should only allow the iis connections and the other should only allow the tomcat connections.  so if someone tries to connect to iis.mysite.com or iis2.mysite.com - dns would point to that machine but only on the correct port.  

I think I know how to do this in bind, but I don't know if it can be done in windows dns.  And I won't turn down information on how to do it in bind just in case I'm wrong in what I remember.

Thank you.
0
Hello,

I am trying to find out the company who owes is IP address as it is being blacked list - 74.208.4.197.  

I am using this link https://www.ultratools.com/tools/ipWhoisLookupResult and see the IP belongs to a server in 1and1network.  

Please advise if there are additional thing I should do.  

Thanks,
0
HyperV  VM  IP addressing questions.

I have setup a test server i want to take live and have made some progress but wondering about IP addressing under the circumstances below.


My server is Windows Server 2016 Standard and it's the host.
It's ipV4 is set to automatically detect from an ethernet port on my wireless router.

That ethenet from the router is connected to the built in ethernet port on my server.
It's ip from the wifi box is 192.168.1.4
Gateway is 192.168.1.1

I added a Hyper V Switch that is connected to a hardware ethernet card installed INSIDE the server

I have a VM of Windows Server 2016 Standard.
I have added the following roles:  AD, DNS, DHCP

So I want my test laptop to connect to the AD Domain to be in the 10.0.0.?  range

Overall, I want to know how i need to setup all the ip addressing, such as:

What ipv4 address should the Hyper-V Switch be? (Its on that ethernet card I added and I have the Hyper-V Switch pointed to that card)
What ipv4  and DNS scope info so I need as it relates to the AD, DNS and DHCP (scope?)
0
Please see attached text file for detailed description of process and failure(s)

I have rebuilt the VM from scratch twice and some of the promo failures vary but in the end the promo scripts just lose dns in one way or another. OTOH none of my physical machines are having any problems with this & I can create, promote and demote a dc on a physical machine with no problems of any kind.

Totally at a loss of how to get this to work.
dc-promo-fail.txt
0
DHCP problems on VM with Active Directory Role, DNS Role, DHCP Role

This is a test server that I want to take live after I resolve issues.

So I have 2016 Server Standard with one Hyper-V VM installed.
It has the following roles: Active Directory, DNS, DHCP

I have a test laptop with Windows 10.
My test internet connection is coming from my offices Wifi Router (DHCP enable) via an ethernet port on the back of the router.

Until I installed the DHCP role ... my laptop would connect to the domain with the laptops ipV4 set for automatic IP and DNS set specifically for the IP of VM

After the DHCP Role , my laptop won't login to the domain.
If I look at ifconfig, there's an IP but no gateway and no internet
I tried setting the ipv4 to automatic for IP and DNS but still no gateway and no internet

Help
0
Quick question, where does Windows store the DDoS attempts when RRL is enabled or in logonly mode? Would it log in the DNS Server event log? If so what event ID would I be looking for? Or is there a log file and of so what is the path? Thanks!
0
I am migrating a 2003 server to a 2008R2 server in preparation to migrate to a 2019 server. As part of the first phase, I have transferred all 5 FSMO roles to the new 2008R2 server, removed the global catalog from the 2003 server.  I was ready to dcpromo down the 2003 server when I get the message that the 2008R2 cannot be contacted.  I do not have the "This server is the last domain controller in the domain" checked.  I am pulling hair as to what I have missed.

Running dcdiag yields this:

Domain Controller Diagnosis

Performing initial setup:
   Done gathering initial info.

Doing initial required tests
   
   Testing server: Default-First-Site-Name\FS1
      Starting test: Connectivity
         ......................... FS1 passed test Connectivity

Doing primary tests
   
   Testing server: Default-First-Site-Name\FS1
      Starting test: Replications
         ......................... FS1 passed test Replications
      Starting test: NCSecDesc
         ......................... FS1 passed test NCSecDesc
      Starting test: NetLogons
         ......................... FS1 passed test NetLogons
      Starting test: Advertising
         ......................... FS1 passed test Advertising
      Starting test: KnowsOfRoleHolders
         ......................... FS1 passed test KnowsOfRoleHolders
      Starting test: RidManager
         ......................... FS1 passed test RidManager
      Starting test: MachineAccount
         …
0
I have a Hyper-V VM with Server 2016 and added the role for AD.
I added my first user and tried to connect but that the AD Domain Controller could not be contacted.
... an error occurred when DNS was queried for the service location..... DNS name does not exist. BTW my domain name is AGHSRV.LOCAL    
Not sure if using local is good or not??

So in my VM under the DNS section is error id 4013 ,  The DNS server is waiting for Active Directory Domain Services to signal that the initial synchronization of the directory has been completed.

I'm not sure if this error is playing into it or not.
0
We are going to be moving a server to a new Location and the IP address on the server needs to change.

What would be the steps to take on the server when you have to change it to another IP address.

I found these steps online. Can you let me know it this is accurate?


[b]To perform this procedure, you must be a member of the Domain Admins group in the domain of the domain controller whose IP address you are changing.

To change the static IP address of a domain controller
Log on locally (also known as interactively) to the system console of the domain controller whose IP address you want to change. If you are not able to log on to the domain controller by using the domain, you may have to start the domain controller in Directory Services Restore Mode (DSRM). For more information, see Restart the domain controller in Directory Services Restore Mode locally (https://lazyadminblog.wordpress.com/2015/04/11/restart-the-domain-controller-in-directory-services-restore-mode-locally/).
On the desktop, right-click My Network Places, and then click Properties.

In theNetwork Connections dialog box, right-click Local Area Connection, and then click Properties.
In theLocal Area Connection Properties dialog box, double-click Internet Protocol (TCP/IP).
In theInternet Protocol (TCP/IP) Properties dialog box, in the IP address box, type the new address.
In theSubnet mask box, type the subnet mask.
In theDefault gateway box, type the default gateway.
In thePreferred
0

DNS

26K

Solutions

26K

Contributors

The Domain Name System (DNS) is a hierarchical, globally distributed system responsible for associating the name of a computer, service or other resource into an IP address for connecting to the Internet or a private network. Most prominently, it translates domain names to the numerical IP addresses needed for the purpose of computer services and devices worldwide.