DNS

26K

Solutions

26K

Contributors

The Domain Name System (DNS) is a hierarchical, globally distributed system responsible for associating the name of a computer, service or other resource into an IP address for connecting to the Internet or a private network. Most prominently, it translates domain names to the numerical IP addresses needed for the purpose of computer services and devices worldwide.

Share tech news, updates, or what's on your mind.

Sign up to Post

We have moved machines from domain Alpha to domain Omega (mock names).  Anyway, we removed the windows 10 computers from the domain to a workgroup, restarted the PCs Win 10), joined them to the new domain, 'Omega'.  They join fine.  Users logon and it seems good.  However, they cannot map drives to the file server 'Data' on the domain.

Also, on the machines, that have the issue, when they ping the DC or file server, it is appending the old domain to the response.  There is only one DNS server currently in the new domain being set up.  Roughly half of the users have no issues and can map drives and surf the web.  The other half has a problem mapping drives, locating local devices and can surf the external internet sites.

I'm not seeing anything on the DNS side.  One machine effected, I have looked at the registry and found several keys referring to the old domain lingering.  I removed them and fixed the ping issue.

Ideas on a course of action?
0
Fundamentals of JavaScript
LVL 13
Fundamentals of JavaScript

Learn the fundamentals of the popular programming language JavaScript so that you can explore the realm of web development.

I run dnscmd /zoneexport mydomain.local backup\mydomain.local.bak to back up my DNS each week. I then rename the file mydomain.local.bak and copy it out of System32\dns to an alternative location. I need the syntax that will import the entire file into DNS. dnscmd /zoneadd just created a new zone. Again, I need the syntax that will import the entire file into DNS. No powershell please if possible
0
Hello,

Is anyone know how to create SRV record from GUI or command line on Cisco Network Registrar 7.1.2.1 ?

Thank you.

Regards,

Xavier De Arburn
0
We have a UTM Sophos XG 85. The client is having issues with the websites loading very slow. I put another router in all fine.

Any suggestions?
0
Hello,

Hello All,

During the Team Center migration we had an issue where the DNS cache on all Domain.com forest DNS servers needed to be cleared as some were responding with the old IP address of the server that was moved (and is in the domain2.com domain). After testing it appears that the default TTL is set to one day. I am asking for opinions on what this should be set to going forward. Should we make it a global change or do it on a record by record basis depending on use case? Should we make it a low default until we get through are IP address reconfigurations?

If I look at the ad.Domain.com domain it looks as though the default TTL for the DNS record is one hour.

I fear this will be an issue for us going forward with the DC 2.0 migrations.
0
Have a network running as a domain.   I know the  DC should be running the domain but the router in this case is.  All of a sudden 4 of the 5 computers cannot reach the DNS,   They are a mixture of Windows 7 and Windows 10, the server is running Server 2012   One computer and the DC can get to the internet.  The computers that cannot get to the internet can see the server and the shared drives.   Any ideas how to bring all the computers to being able to access the internet without getting the message that it cannot reach the DNS  Server?
0
Hi All,

Looking for options for Redundant, Managed Public DNS.
Currently opened conversations with Azure, AWS and NoIP so am already aware of these options- looking for others.

Scenario:
(3) ISPs, all with numerous dedicated static IPs.
All ISPs provide a separate IP block.
Need a Public Reverse DNS failover solution so that when one ISP goes down the other immediately picks up for incoming connections to web servers and apps.

Currently:
- The primary ISP does not allow managed reverse dns resulting in the need to use the secondary ISP for all incoming traffic. (this isp is necessary as the primary due to band width issues).
- When the Primary ISP fails, the secondary kicks in for outgoing. This is fine except when the secondary fails all connections to web servers is lost until the tertiary ISP picks up.
- When the tertiary ISP picks up the traffic, the TTLs are not great so web server downtime can be an issue.
- Also, independent from the primary and tertiary ISPs, when ISP #2 goes down all public connections to internal servers goes down with a long TTl to roll over to #2.

Looking for a solution to manage the DNS to fail over to the other static IPs when the various ISPs go down.  

Any suggestions?
0
Hi,

I have a small environment within Azure and have extended the on prem DCs into Azure - I have two behind a load balancer with the FSMO role holder staying on prem (in the meantime).  Traditionally, I would setup the DCs DNS as the FSMO IP and the second one being the DC's IP but now with load balancers in place, should I change this traditional approach.

Cheers.
0
Hi,

I change the Plesk (windows) backup folder from C drive into our NAS drive. I map the NAS drive as P drive and run the "Change Plesk Backup Data location" under 'Plesk Reconfigurator' to change the path. Current backup data move into P drive (NAS) and path also changed.

Issue:
When client, re-seller and administrator (me) is not able to take the backup. We received an error:
Error: The backup process failed: (3, 'GetDiskFreeSpaceEx', 'The system cannot find the path specified.')

Please also review the logs. Please let me know whats actually i am missing? I need to assign permission on NAS drive. Currently only administrator have rights to access NAS drive (P) but i am not able to take backup via administrator account. Same error.  

Logs:

[2019-04-14 00:00:08.375|8528] DEBUG: LOG: custom log C:\Program Files (x86)\Plesk\PMM\logs\backup-2019-04-14-00-00-08-375\backup.log
[2019-04-14 00:00:08.375|8528] CRITICAL: Runtime error in pmmcli: 
<class 'pywintypes.error'> (3, 'GetDiskFreeSpaceEx', 'The system cannot find the path specified.')
Traceback (most recent call last):
  File "C:\Program Files (x86)\Plesk\admin\share\pmmcli\pmmcli.py", line 2560, in main
    data_action_response, errcode_response, error_message = actions.get(sys.argv[1][2:])(parameters)
  File "C:\Program Files (x86)\Plesk\admin\share\pmmcli\pmmcli.py", line 2455, in make_dump
    return ActionRunner(MakeDumpAction, backup_task_description, None).doActivity()
  File "C:\Program 

Open in new window

0
dcdiag /v /test:dns fails
rreg fails and it appears it says an "A" record is missing in the copy/paste below but I have put an A record in them locations. What can I do?
************************************************************
 Starting test: DNS

         DNS Tests are running and not hung. Please wait a few minutes...
         See DNS test in enterprise tests section for results
         ......................... BTSERVER passed test DNS

   Running partition tests on : ForestDnsZones
      Test omitted by user request: CheckSDRefDom
      Test omitted by user request: CrossRefValidation

   Running partition tests on : DomainDnsZones
      Test omitted by user request: CheckSDRefDom
      Test omitted by user request: CrossRefValidation

   Running partition tests on : Schema
      Test omitted by user request: CheckSDRefDom
      Test omitted by user request: CrossRefValidation

   Running partition tests on : Configuration
      Test omitted by user request: CheckSDRefDom
      Test omitted by user request: CrossRefValidation

   Running partition tests on : mbg
      Test omitted by user request: CheckSDRefDom
      Test omitted by user request: CrossRefValidation

   Running enterprise tests on : mbg.local
      Starting test: DNS
         Test results for domain controllers:

            DC: BTSERVER.mbg.local
            Domain: mbg.local


               TEST: Authentication (Auth)
                  Authentication test: Successfully completed

         

Open in new window

0
JavaScript Best Practices
LVL 13
JavaScript Best Practices

Save hours in development time and avoid common mistakes by learning the best practices to use for JavaScript.

We are trying to reduce our monthly overhead and are paying a host (similar to GoDaddy) an excessive monthly fee for doing nothing.

We have one domain that has mail DNS records going to Office 365 and web DNS records going to Wix.  

The other domain also have mail DNS records going to Office 365 and has no other function.  

It seems that we can't just transfer the domains into Office 365 (not supported) and don't want them parked (because we want to use them).  

So I am not sure what I am looking for, yet we have a home Ubuntu server available or are wiling to pay a provider a lower cost per month just to hold our domains?  

Any recommendations?
0
Hello,
how I can create my own smart dns proxy ?
thanks.
0
Hi  
Three ad sites on different subsets  

I want to be able to restore a backup of a server in to any of the sites change its ip to suit the subnet  
And have all the clients connected to it (av) instantly be able to find it

What can I do to help dns with going to client and flushing .  Alias? Extra ips? Extra nice  etc    Windows 2012   R2

Clients use netbios to locate the server   Or up  

Ttl is 8 hours  which I don’t want to reduce
0
I have a domain controller Windows 2012 R2 and Windows 2016 and I am trying to find out who added DNS A and CNAME records to the internal DNS zones.

Is there a way to accomplish that?

for example, user firstname.lastname added record "wrongdns" in zone "internal.company.com" ?
0
Trouble with accessing external hosted exchange, from new Windows Server 2019 Domain.

We've got a new Windows Server 2019 Standard install

We've configured the internal domain as "ourdomain.com" We've got external hosted exchange with a smaller company setup as "ourdomain.com"

We've configured internal mx records, autodiscover, and spf records to mirror the external records.

We have used the same setup in Windows Server 2012 R2 and in Windows Server 2016, but in those cases, Office365 is the external exchange host.

Somehow, even though we have not configured IIS, a self-signed certificate from the new server, is what Outlook 2016/2019 detects. Even at external sites, that are not connected to the domain.
Exchange-01.JPG
Exchange-02.JPG
Exchange-04.JPG
Exchange-05.JPG
Exchange-06.JPG
Exchange-07.JPG
Exchange-08.JPG
Exchange-09.JPG
Exchange-10.JPG
Exchange-11.JPG
Exchange-12.JPG
Exchange-13.JPG
Exchange-14.JPG
Exchange-15.JPG
0
Hello everyone,


I have a Cisco ASA 5516 with two inside interfaces. One is for customer LAN and another is for a few branch offices connected via a router that is connected to the 2nd Inside interface (All those offices are in the same building connected by a FO backbone. Customer is going to replace an old ASA 5510 where almost the same config already works.  

LAN network is 192.168.0.0/24 connected to 1/3 on ASA

Branch Offices are connected to 192.168.2.0/24 connected to 1/4 on ASA
 
I want to be able to ping and have unrestricted traffic between them.

Currently I have a laptop connected to int 1/3 and another one connected to Int 1/4 but no ping.

Someone please help!

Here's the configuration

ASA Version 9.8(2)17
!
hostname ASAFCHFW
domain-name mydomain.com
enable password $sha512$5000$pt2nRGQbSXA8K3vdow+Ztg==$kGNfDJREqQCQ+jO7m0bxmQ== pbkdf2
names
no mac-address auto

!
interface GigabitEthernet1/1
nameif Outside
security-level 0
ip address x.x.x.131 255.255.255.240
!
interface GigabitEthernet1/2
nameif DMZ
security-level 10
ip address 172.16.31.1 255.255.255.240
!
interface GigabitEthernet1/3
nameif Inside
security-level 100
ip address 192.168.0.2 255.255.255.0
!
interface GigabitEthernet1/4
nameif Branch_Office
security-level 100
ip address 192.168.2.1 255.255.255.0
!
interface GigabitEthernet1/5
shutdown
no nameif
no security-level
no ip address
!
interface GigabitEthernet1/6
shutdown
no nameif
no …
0
I need assistance with a DNS and MX Records issue.  I setup setup a new company I am hosting but the are not receiving any emails. They were using mailenable but they are now on my Exchange server.  I am using hosting controller as the front end.

One of the email addresses are receptionist@pyrosealant.com
0
All,
We are planning an upgrade from 2008 R2 domain/forest to 2012 R2. Deploying 2016 DC's but keeping it down a level due to 3rd party app limitations. Our network guy wants to break out DNS onto separate servers. We can't achieve this because our DNS is AD integrated and I don't want a secondary zone as RO. I've spun up 2 new DC's and would like to have the network team use them for DNS specifically. Has anyone, or advice, on how to deny authentication to these DC's so we can rely on them for DNS only? Remove from Sites and Services? Group Policy settings? Any help is greatly appreciated. Thanks!
0
Hello
We have a problem with our remote clients that are terminating across the cisco anyconnect VPN.  Currently we are unable to browse to the \\unc path of the said remote client, but not all machines.   The problem has been intermittent for a over a year now.  It has gotten worse since 1809 update to Win10.

We can browse from remote client to the LAN and UNC paths.
We can ping both ways i.e. 172 (local LAN) to the remote vpn client IP 10.255.255.*.
DNS is registering the 10.255.255.* IP in reversse lookup.
DNS is also registering local IPs on the forward lookup zone domain.local - this seems to be what is being resolved.

Im thinking its DNS wrongly configured but hesitant to make changes...

Any ideas?

Thanks
0
Become a CompTIA Certified Healthcare IT Tech
LVL 13
Become a CompTIA Certified Healthcare IT Tech

This course will help prep you to earn the CompTIA Healthcare IT Technician certification showing that you have the knowledge and skills needed to succeed in installing, managing, and troubleshooting IT systems in medical and clinical settings.

I am new to learning computers, but I needto learn as much as I can and one of the areas that's been most difficult has been networks. I have an HP DeskTop computer and a Lenovo ThinkPad, both of which I use and also two Android phones. All of these things live with me in my small room. The network is set up via wireless adapter from my desktop and the entire building is seriviced by a broadband internet connection. This is kind of a hotel with some guests like myself staying for a prolonged period of time, so I often see a lot of people online and sometimes on my network. I want to make my own safe network with VPN and Firewalls and DNS and proxy... as much as I can do to stay invisable to prying eyes.
0
I have an MVC 5 project where I have local processing RDLC reports using report viewer 14. For some reason I have a report that is called and after about 1 minute and 40 seconds and my site says that "No data was heard from..." in Chrome, and in IE it thinks there is a DNS problem after that 1 minute and 40 seconds. I have confirmed the SQL Query running in just a second. I am thinking that the biggest time factor is I am using a Matrix in my report.

I guess I would like to know how to extend my timeout. I have had other stored procedures that take a long time to run and I used the below reference and it fixed that. But I do not know how to fix this problem.

https://www.codeproject.com/Questions/238245/Dataset-xsd-Timeout-Problem
0
Hello -

I'm trying to figure out if our email delivery measures are set up correctly.

We use Office365. With that being said, is it necessary to add our public IP address into the SPF record? Would it help with anything or it's enough to add "v=spf1 include:spf.protection.outlook.com"

Second,

When emails are sent internally, analyzing the 'header', it says dkim=none (message not signed), dmarc=none. Is this normal? I do see the correct info when sending to external address, though.

Thank you for your help!
0
Recently we implemented proxy server and our domain joined workstations are configured to use the proxy through GPO.  We have disabled the option to change proxy for all.  There are laptops which are domain joined; when they connect outside our domain still the proxy option is checked.  We are looking for a solution to handle this situation automatically; without having the user to manually check/uncheck the option for the proxy.  I was looking at proxy.pac and seems there are some limitations to it and chrome does not work well with these settings in place.  can anyone suggest how can i overcome this.

Regards.
0
AD-tpology-converted-merged.pdfDear Experts,
Hope u are doing well, I need your suggestions, I am facing the issue of Exchange server losses the internet connection(Image is in attachment) and down time observed. Mr. Mahesh helped me and We found lookback IP was added as an alternative DNS in exchange server. So I removed it. And I assume the problem is solved. But again I have observed  exchange server down time same as before...Therefore I did troubleshoot and I found the same alternative DNS lookback ip as in Exchange server, 127.0.0.1 was added as an alternative DNS in my Domain controller, I dont understand what is the actually problem? Is the AD server alternative DNS and Exchange server alternative DNS was creating this problem together.
Can you please advice me on this issue?
Now I have removed lookback IP from both exchange and DC, So can I assume it will not looses its conenctivity with DC?

Please review the AD and Exchange pics.
MAny Thanks
0
Windows Server unable to resolve external DNS values until a reboot.
- Once rebooted it will resolve and act normal for several days; then stop resolving external values again.  Can get into the server via RDP from another machine locally and perform the following troubleshooting methods:

Reviewed the event logs for Critical, Errors, and Warnings.  No critical items; Errors related to DNS as follow:

- DNS Server Event ID: 4015 "The DNS server has encountered a critical error from the Active Directory. Check that the Active Directory is functioning properly. The extended error debug information (which may be empty) is "". The event data contains the error."
  * Have reviewed the DNS settings:
    *  Domain controller points to the PDC then to itself to resolve DNS.
    *  Perform a ping to "www.google.com" - RESPONSE: Ping request could not find host www.google.com. Please check the name and try again.  |  ping the IP: 172.217.5.68 get a response no problem, the IP is resolved by another machine that got the IP from a response to www.google.com

- Run from an elevated prompt: dcdiag /test:DNS /e /v >LOGFILE  the results are as follow on the effected Server DC01
  Domain          Auth   Basc   Forw   Del      Dyn     RReg   Ext
  DC00              PASS   WARN FAIL   FAIL     PASS   PASS   n/a
  DC01              PASS   WARN FAIL   FAIL     PASS   PASS   n/a

- Run the same from the server DC00 get the following results:
  Domain          Auth   Basc   Forw   …
0

DNS

26K

Solutions

26K

Contributors

The Domain Name System (DNS) is a hierarchical, globally distributed system responsible for associating the name of a computer, service or other resource into an IP address for connecting to the Internet or a private network. Most prominently, it translates domain names to the numerical IP addresses needed for the purpose of computer services and devices worldwide.