DNS

26K

Solutions

26K

Contributors

The Domain Name System (DNS) is a hierarchical, globally distributed system responsible for associating the name of a computer, service or other resource into an IP address for connecting to the Internet or a private network. Most prominently, it translates domain names to the numerical IP addresses needed for the purpose of computer services and devices worldwide.

Share tech news, updates, or what's on your mind.

Sign up to Post

Hi,

I want to give user write access to a specific dns zone (Not active directory integrated) in Windows 2012. How can I do that?
0
Exploring SharePoint 2016
LVL 19
Exploring SharePoint 2016

Explore SharePoint 2016, the web-based, collaborative platform that integrates with Microsoft Office to provide intranets, secure document management, and collaboration so you can develop your online and offline capabilities.

Corporate DNS A record needs updated so internal users will redirect to the new website.
0
Hi Drupal 8 experts,

The dns that I recently purchased is generating a 500 error by domain access module. The idea is to host multiple subdomains under one Drupal 8 installation. Could you suggest any good source of info. that could help me with this.
0
We have a website that is hosted on a dedicated windows server. The domain has a SSL certificate associated with it.

The website is a rental website and we have some clients who have created sub domains like shop.xyz.com. This domain is pointed to our IP address in their DNS. Our firewall also has an entry for these domains. This way these clients can have their customers access our website using their branding and url. So for example we have a page:
www.ourdomain.com/store.asp?storeid=1

The same page can be accessed via shop.xyz.com/store.asp?storeid=1 where storeid represents each unique client or store. The page would be displayed using store markings like logo and custom css.

Similarly some clients have pointed their domain to our IPs in which case the above example becomes www.customer2.com/store.asp?storeid=2, 2 being the store id for customer2 and www.customer2.com being the domain owned by customer2.

We now have to put SSL for these sub domains /domains which is creating a problem. The limitations are:
1. We cannot create sites for these sub domains as the site www.ourdomain.com uses some objects that can only be initialized once. So multiple copies of the website cannot work.
2. Since we cannot create these sites in IIS, the sites are virtual sites with mapping done in firewall.

Looking forward to your approach and solutions.

Question is how can we install SSL certificates for these sub domains.
0
Installing Exchange 2013 CU23. This a NEW install.  Domain name is:  fp.local. Single exchange server with the hostname of EXCHANGE. The external email domain name will be: mail.fp123.com.  Looks like we need to use the disjoint namespace, but I am not 100% of what is supposed to entered. In the GPO setup, the DNS SEARCH SUFFIX change requirement: Should i enter fp.local for this? Or should i enter fp123.com ?  Then when we goto the SCOPE, Security filtering, ADD:  What is supposed to be added here? The EXCHANGE server name itself, a user group, all the computers on the network? Thank you for clarification. Really appreciate it.
0
We have a Windows Sever 2016; AD, Domain Controller; DNS; DHCP handled by Meraki MX64; Server has a static IP Address; we have several remote desktop users.
Tried to implement (add role) Hyper V. When adding the role and after rebooting server the static IP address for the Server is changed to another address and is listed as receiving it via DHCP; DNS also shows the change.
Tried this on a test server prior to live production server and the static IP Address did not change so tried it on the production server and now we have this issue; on removal of the Hyper V role the original static IP address returns.
Anyone have any idea.
0
Greetings,

Newbie to VLANS here and I have a "lab" setup that I'm working with prior to an installation that will benefit from VLAN Topology.  Here's the basics of the test environment.

Internet--->ZyWALL USG20 Firewall--->Cisco 2960G Switch--->Computer

ZyWALL IP is 10.1.1.1/24 with DHCP Active
Switch IP is 10.1.1.254

Management of both devices work fine as does Internet access on Native VLAN1

Steps done to create VLANS:
On ZyWALL
-Create two Zones for VLANS
-Create VLAN10 and VLAN20, both using LAN1 as "base"
-VLAN10 ip is 10.10.1.1 with DHCP server active starting with 10.10.1.50
-VLAN20 ip is 10.20.1.1 with DHCP server active starting with 10.20.1.50
-Created Policy (rule) for VLAN10 and VLAN20 zones to access the WAN
-Connect LAN1 port on ZyWALL to Gi0/1 on switch.

On Switch
-Create VLAN10 and VLAN20 on switch; VLAN1 (default) exists as well
-Set Gi0/1 to 801.2Q Trunk with "ALL" VLANS included
-Set Gi0/9 to VLAN10/STATIC ACCESS
-Set Gi0/11 to VLAN20/STATIC ACCESS

Any connections on VLAN1 (default) work as expected.  DHCP, DNS, Internet all good

Connecting a computer to Gi0/9 (VLAN10) results in the computer using 169.X.X.X address on the nic, HOWEVER, in the ZyWALL DHCP logs there are entries reading
"DHCP offered 10.10.1.50 to <COMPUTERNAME(MACADDRESS)>"
Same result for Gi0/11 (VLAN20)

Obviously I'm missing something in the config on the server or swtich, because the computer is asking for an address, the DHCP server is handing …
0
SBS2008 running exchange > yes I know its old and is going to be EOL, we are in the process

Was working fine, then did a reboot, now DNS server wont start, Windows Event log, wont start (stuck starting), and a bunch of other services that rely on these wont start either.

Literally nothing has changed with the server, no updates in months, no new programs installed, was only rebooted because SQL server was using too much RAM.

Obviously I cant see the logs because the service wont start, but have copied the log files off the server and opened them up, but there is no info in them pertaining to what went wrong after the reboot because the eventlog service did not start.

When I try to start DNS server I get "Error 1722: The RPC server is unavailable.", getting similar RPC errors on a number of other services, but the RPC service is started and running...

I have tried deleting the logs, multiple reboots in safe mode and selective start, uninstall AV, messing around with network settings, SFC /scanow > found nothing

Please if anyone has any idea, this is very urgent and I am pretty desperate.
0
Users in One Site cannot resolve the Server "shares" in another Site unless an IP is used, so mapped drives are not connecting.  
So, an example would be, I can map a drive with the following unc \\10.10.20.11\sharename

Forest 2003 Functional level
Servers 2008 R2

No sure why the Forest Domain has not been upgraded to match the servers.

I can ping and resolve the server though, so it's not a DNS issue.

I inherited this challenge, and don't have a lot of history in terms of "why" this is happening or when it started, just it's "not" working.  Thanks for any feedback.

... running a dcdiag I get the following:
Directory Server Diagnosis


Performing initial setup:

   Trying to find home server...

   Home Server = ARIZONA

   * Identified AD Forest. 
   Done gathering initial info.


Doing initial required tests

   
   Testing server: ARIZONA-AZ\ARIZONA

      Starting test: Connectivity

         ......................... ARIZONA passed test Connectivity



Doing primary tests

   
   Testing server: ARIZONA-AZ\ARIZONA

      Starting test: Advertising

         ......................... ARIZONA passed test Advertising

      Starting test: FrsEvent

         There are warning or error events within the last 24 hours after the

         SYSVOL has been shared.  Failing SYSVOL replication problems may cause

         Group Policy problems. 
         ......................... ARIZONA passed test FrsEvent

      Starting test: DFSREvent

         

Open in new window

0
I purchased a EdgeRouter X  so that I can take advantage a 200 MEG connection. When I plug directly into the cable modem I get about 175. When I plug the router in, I get about 10 mbps down and 13 up. This router is brand new, replacing and old Netgear ac1200.

I did upgrade to the latest firmware with no change.

ubnt@ubnt# show
 firewall {
     all-ping enable
     broadcast-ping disable
     ipv6-receive-redirects disable
     ipv6-src-route disable
     ip-src-route disable
     log-martians enable
     name WAN_IN {
         default-action drop
         description "WAN to internal"
         rule 10 {
             action accept
             description "Allow established/related"
             state {
                 established enable
                 related enable
             }
         }
         rule 20 {
             action drop
             description "Drop invalid state"
             state {
                 invalid enable
             }
         }
     }
     name WAN_LOCAL {
         default-action drop
         description "WAN to router"
         rule 10 {
             action accept
             description "Allow established/related"
             state {
                 established enable
                 related enable
             }
         }
         rule 20 {
             action drop
             description "Drop invalid state"
             state {
                 invalid enable
             }
1
OWASP Proactive Controls
LVL 19
OWASP Proactive Controls

Learn the most important control and control categories that every architect and developer should include in their projects.

I have 3 domain controllers in my domain wich are windows server server 2003 and one is window server 2008 (all are DNS Servers) .

I want to get rid all the Windows server 2003 Domain controller and to keep them as DNS Servers , what is the best practive .

1- In Place upgrate to window server 2008

or
 
uninstall the active directory from them all (if that will that effect the DNS Server Role) ?
0
Getting this error on my windows 20012 r2 server.
I can mapped a drive by IP but cannot by hostame

This error I"m getting is:

\\servername is not accessible.  You might not have permission to use the network resource.  Contact the administrator of the server to find out if you have access permissions

See DCDIAG attached below.

Please help

Thanks
Drew
0
This is a "reopening" of another question I asked a week or so ago.  I thought the resolution was complete but am still having problems.
Attachment may be helpful in understanding my explanation below.

My home office's Linksys VPN router handles all traffic.  The Linksys sits behind an ISP supplied modem that is in full bridged mode.  I have a Public Static IP assigned by my ISP.  The Linksys has a Static IP of 192.168.3.1 assigned to it.  For DNS the Linksys is assigned the IP's supplied by my ISP, 12.223.xx.xxx.  The Linksys hands out IP's based on the 192.168.3.xx addressing scheme.  

There is an Access Point (bridged mode) connected to one of the ethernet ports of the Linksys and provides wireless connectivity throughout my home office.  Static IP address of this IP is 192.168.3.2.  So, all wireless devices are handed a 192.168.3.xx address.  This AP is also configured with Gateway and DNS IP's of 192.168.3.1 - thus pointing to the Linksys.

On one of the home office wireless clients, I have an outgoing VPN connection to my business network.  I use the Windows built in VPN Client for connectivity.  It connects to a Meraki firewall at the edge of the network.  This Meraki is configured to hand out IP's to VPN clients using the 192.168.25.xx addressing scheme.  In our domain we have our own Primary and Secondary DNS servers, 10.18.30.5 and 10.18.30.10, respectively.

As long as I don't use my VPN connection to my business network, all client PC's work extremely …
0
HI,

A client is moving from internal Exchange to O365.

I have used the following to kill the internal DNS at other clients and all works well - Set-ClientAccessServer -Identity <ServerName> -AutoDiscoverServiceInternalUri $null

however, this client has more than 1 internal email domain, due to internal politics not all email domain are moving to O365.

How can i modify the PowerShell command to only impact 1 of the internal domains?

Thanks
Gareth
0
Hi expert,

I'm planning migration to migrate mdaemon into exchange 2016.

My current email environment has a mail gateway that act as edge server and redirect email into mdaemon server, in Internal DNS they have a MX records point to mdaemon internal IP with mdaemon.company.com.

For my exchange 2016, in order to work properly, do i need to add MX records for exchange server as well? fyi, i have setup autodiscover in both internal and external DNS, using microsoft test analyzer they seem to be working properly... do i still need to setup the MX records?

FYI, in future the mdaemon ip will be used by exchange server..

any advise much appreciated!
0
Hi Guys,

We have a secondary DC which was successful restored offsite for an audit-recovery test.

Because this DC is unable to contact the PDC, we are now receiving the following errors:

Opening of Active Directory:

"Naming information cannot be located because"
"The specified domain either does not exist or could not be contacted"

I tried seizing the FSMO roles with Ntdsutil to the secondary DC, but running "netdom query fsmo" afterwards,
Produces the following error:

"The specified domain either does not exist or could not be contacted"


Any advise will be much appreciated.
0
Hi
we are planning to do domain controller migration from 2008 R2 to 2016
my question is before promoting the server to domain controller
what should be the primary DNS on NIC (DC02)?
point to itself? point to old DC? or 127.0.0.1?

after the migration we are planing decommission the old server (DC01)

DC01
IP:                   192.168.1.5
SM:                 255.255.255.0
GW:                192.168.1.1

PRi DNS:        192.168.1.5
ALT DNS:        192.168.1.6

DC02
IP:                   192.168.1.6
SM:                 255.255.255.0
GW:                192.168.1.1

PRi DNS:        192.168.1.5
ALT DNS:        192.168.1.6


Thanks!
0
Hello EE,

Please see attach some information about my computer for a quick idea.
What I am experiencing since a while is a "randomly" lost of my wireless adapter, sometimes my wireless keyboard stops working (battery is brand new..I have to unplug the little usb plug, replug and it starts to work again.

The wireless Adapter stops like I said, but in Network setting it's written something like : "you are not connected to internet but you can still see local network"
if I trouble shoot it says somehing like:  "windows can't communicate with the device or resource (primary dns server)"

My drivers seems to be updated.... (or thats why im thinking..!? maybe not?)

My question is : I suspect my USB ports to have a problem..is it possible there is a "lack of power" ? is it possible the computer kind of randomwly disable a port for x reason and re-enable ?

This is the feeling i have when im on the computer.

Any ideas before I throw the box out of the kitchen window?
cpu.png
0
We have a DNS server [BIND] in our environment, This was built for setting name resolution for our internal network.

All the VM's in our environment use this for name lookups.

We had added public forwarders in bind configuration, so if there is some name outside our environment they will be transferred to them for lookups.

Now there is a case where, I need to have our DNS server forward requests to other DNS based on domain name.

Example:

domain.local is the intial configuration
if the request comes to DNS for
internaldomain1.com it should query 192.188.10.10
if the request comes to DNS for internaldomain2.com then it should query 192.188.10.12


Please let me know how can we accomplish this
0
Announcing the Winners!
LVL 19
Announcing the Winners!

The results are in for the 15th Annual Expert Awards! Congratulations to the winners, and thank you to everyone who participated in the nominations. We are so grateful for the valuable contributions experts make on a daily basis. Click to read more about this year’s recipients!

hi,
got a website
abc.com - currently “A” record pointing to 1.1.1.1

and I recently got a new website developed like abcd.com- and it’s sitting in 2.2.2.2

now if I go into my abc.com domain console and change the “A” to point to 2.2.2.2
and if I browse abc.com- will it point to abcd.com automatically ?? am I doing it right ?

I just want to everyone to still use same old address abc.com but point to my new website
0
We cannot access our website from inside the LAN but outside. The windows domain that was setup is ptad.gov.ng and the website is https://www.ptad.gov.ng. Looks like the domain are clashing what do you thing could be responsible.
0
Reopening this question.  I thought the issue was fixed, but it persists.

I am seeing a strange issue with sssd on Ubuntu 16.04.  I am using sssd to authenticate to AD.  The logins work great and is almost instantaneous as long as you have recently logged in (within the last minute or two).  If you wait longer between logins, then it will login you into, but you do not get a prompt for up to 30 seconds.

Note that these systems are in Azure and our AD is also in Azure.

I am using offline caching and setting the site.  I am stumped as to how to correct this issue.

Below are my conf files (sanitized for security).

-----------------------------------------------------------------------------------------
/etc/sssd/sssd.conf

[sssd]
services = pam, nss
config_file_version = 2
domains = xxxx.COM
#debug_level = 7

[domain/XXXX.COM]
dyndns_update = False
id_provider = ad
auth_provider = ad
access_provider = ad
krb5_realm = xxxx.COM
#debug_level = 4
default_shell = /bin/bash
ad_site = AH
cache_credentials = True
ad_enable_gc = False

# Use this if users are being logged in at /.
# This example specifies /home/DOMAIN-FQDN/user as $HOME.  Use with pam_mkhomedir.so
override_homedir = /home/XXXX/%u

# Uncomment if the client machine hostname doesn't match the computer object on the DC.
# ad_hostname = mymachine.myubuntu.example.com

# Uncomment if DNS SRV resolution is not workin#g
# ad_server = _srv_

# Uncomment if the AD domain is …
0
our company active directory domain:  corpdomain.local

Our parent company active directory domain: portdgdomain.com

our domain users require connectivity to parent company servers with fqdn.

for example user: 'pnewman@corpdomain.local' requires to access the server 'srvpdb01.portdomain.com'

How to configure this?
0
I have a cloud server with a public IP address of 1.1.1.1 (not the real IP). There are over 100 users on standalone PC's over 12 sites across the south of the country who have a mapped drive on their devices using the UNC path \\1.1.1.1\data. The cloud provider can't upgrade the OS on the server (it's currently server 2008) and therefore a new one needs to be provisioned. I'm migrating the AD data over and replicating the domain name etc. I somehow need to map all users to the new UNC path \\2.2.2.2\data with ease. I can't use the hostfile mapping as DNS is not involved.

The question therefore is as follows: Is there an easy way using the command line or PowerShell to route the old IP address 1.1.1.1 to the new IP address 2.2.2.2 so I don't have to re-map over 100 devices or do I suck it up and remap from scratch?
1
Hello Experts,

this is first post for me,

I have:

3 DC's, the PDC is a remote one and other is local, win server 2016, I'm facing many issue with replication and DNS service,

the event ID: 4015 : the DNS server has encountered a critical error from active directory...

System 

  - Provider 

   [ Name]  Microsoft-Windows-DNS-Server-Service 
   [ Guid]  {71A551F5-C893-4849-886B-B5EC8502641E} 
 
   EventID 4015 
 
   Version 0 
 
   Level 2 
 
   Task 0 
 
   Opcode 0 
 
   Keywords 0x8000000000020000 
 
  - TimeCreated 

   [ SystemTime]  2019-11-12T01:02:26.217621900Z 
 
   EventRecordID 2946 
 
   Correlation 
 
  - Execution 

   [ ProcessID]  3060 
   [ ThreadID]  560 
 
   Channel DNS Server 
 
   Computer (my current DC)
 
  - Security 

   [ UserID]  S-1-5-18 
 

- EventData 

  param1  
   51000000 

-----------------------------------------------------------

Event ID: 4612 , DSFR 

System 

  - Provider 

   [ Name]  DFSR 
 
  - EventID 4612 

   [ Qualifiers]  49152 
 
   Level 2 
 
   Task 0 
 
   Keywords 0x80000000000000 
 
  - TimeCreated 

   [ SystemTime]  2019-11-11T23:51:36.267265500Z 
 
   EventRecordID 645 
 
   Channel DFS Replication 
 
   Computer (Computer name ) my current DC.
 
   Security 
 

- EventData 

   738FEA2C-9B3D-4E6A-9DE5-B43F5C5FB21C 
   C:\Windows\SYSVOL\domain 
   SYSVOL Share 
   Domain System Volume 
   1C9AD60F-6CD8-43EA-826F-06067D1D5D1B 
   FBB56F11-335C-4887-8F4C-FA9706F4842F 
   (My PDC ) 
   0 

Open in new window



any help?
DNS-and-DFSR.JPG
0

DNS

26K

Solutions

26K

Contributors

The Domain Name System (DNS) is a hierarchical, globally distributed system responsible for associating the name of a computer, service or other resource into an IP address for connecting to the Internet or a private network. Most prominently, it translates domain names to the numerical IP addresses needed for the purpose of computer services and devices worldwide.