DNS

26K

Solutions

26K

Contributors

The Domain Name System (DNS) is a hierarchical, globally distributed system responsible for associating the name of a computer, service or other resource into an IP address for connecting to the Internet or a private network. Most prominently, it translates domain names to the numerical IP addresses needed for the purpose of computer services and devices worldwide.

Share tech news, updates, or what's on your mind.

Sign up to Post

is it possible to get 100% fail over 100 % availablity using f5 to two IIS servers configured for load balancing in round robbin.

Each request to check if a server is active and route the call to the other server if one is down, without any downtime.

Also is it possible to queue a call if both servers are down and wait a certain period of time and make the call to the first available server?
0
I created a cluster with 2 vm's. I followed instructions listed below.This is on RHEL 7.3 This is after kubernetes was installed using yum. The version of kubernetes is 1.7

commands on Master01-only

sysctl net.bridge.bridge-nf-call-iptables=1
sysctl net.bridge.bridge-nf-call-ip6tables=1
systemctl stop firewall
systemctl disable firewall
systemctl status firewall
systemctl start iptables.service
systemctl enable iptables.service
iptables -F
service kubelet restart
kubeadm init --pod-network-cidr 10.244.0.0/16
make sure you copy the kubeadm join command that gets displayes after cluster creation"

mkdir -p $HOME/.kube
sudo cp -i /etc/kubernetes/admin.conf $HOME/.kube/config
sudo chown $(id -u):$(id -g) $HOME/.kube/config
kubectl get nodes
kubectl describe nodes
cd ~/Downloads
kubectl apply -f flannel.yml
kubectl apply -f flannel-rbac.yml
kubectl create -f rolebinding.yml
kubectl create -f role.yml
commands on node-only

sysctl net.bridge.bridge-nf-call-iptables=1
sysctl net.bridge.bridge-nf-call-ip6tables=1
systemctl stop firewall
systemctl disable firewall
systemctl status firewall
systemctl start iptables.service
systemctl enable iptables.service
iptables -F
kubeadm join --token xxxxxx.xxxxxxxxxxxxxx x.x.x.x:6443
The issue i am having is that the dns is not working as expected. Have been struggling with this for past two days. Would appreciate any help.
0
On one of our computers, we cannot open the fedex.com site in IE11.
This is a Win 7 Pro system.
She usually can open the site in Chrome.
She used to be able to open the fedex site in IE, but now it gets stuck seemingly trying to redirect to the site, to the proper address.
When she tries to connect, the address bar blinks a lot and shows signs of trying to redirect, maybe to Akamai, but it never fully resolves.
I have tried adding *.fedex.com to the Allowed Sites List in the IE Security settings.
I have cleared the DNS cache.
I have tried clearing her SSL State under the Content Tab in her IE Settings.
Other computers near her can connect to the site using IE 11, but she no longer can.
We have rebooted her computer.
We have uninstalled the security software, then rebooted.
We have cleared her Browsing History.
When I try to ping the site, it fails, but then it fails on the other computers as well, even though they can connect to the site using IE 11.
When I tracert, the result is always failure at the same distant point in the process.
I don't know if they allow Ping, so that might be the last step on the way, and it might for some reason block the protocol.

Tracing route to fedex.com [204.135.8.155]
over a maximum of 30 hops:

  1     *        *        *     Request timed out.
  2     1 ms     1 ms     1 ms  173-11-90-46-SFBA.hfc.comcastbusiness.net [173.11.90.46]
  3     *        *        *     Request timed out.
  4    13 ms    11 ms     9 ms  …
0
Good morning,
I asked my provider to create secondary zone for my dns, in order to be primary in the office.
Since done I can't access my exchange server from internet. And propagation of my dns seems stoped. My dns is " matpbnet.ma ", can you help me?
0
Hi, Need some help and not sure where to start. I have a server 2012RS essentials I would like to have client machines listed under computers. But whenever I try to use http://server/connect I get address not available. NSlookup resolves servername.domain.local and the correct IP.

http://servername/connect resolves fine on the server itself.

Could someone help.
0
Hi all

I want to setup vpn on my home computer but dont have static IP

Whats best and free dns solution so i can use that to overcome the static ip issue?

thanks
0
i have 1 default lan and 3 vlans.
setup on our watchgaurd firewall
vlan10 ip address 172.16.0.1/23 dhcp relay to the dns server
vlan 20 ip address 192.168.20.1/23 dhcp relay to the dns server
vlan 30 ip address 192.168.30.1/23 dhcp relay to the dns server

On the dns server i have the 3 vlans with thier own scope and in thier scope options i have the router set to
vlan 10 172.16.0.1
vlan 20 192.168.20.1
vlan 30 192.168.30.1
in the dns server routing and remote access i have the ipv4 dhcp relay agent set to 172.16.0.1, 192.168.10.1, 192.168.20.1, 192.168.30.1

all of our switches have the vlans setup also
any time i connect a pc to a switch that has its port set to any of the vlans it gives a bad ip address, 169....
anything on our defualt lan works

for a while i was getting this error on our dns server event viewer.
IPBOOTP was unable to receive an incoming message on the local interface with IP address 191.168.0.4. The data is the error code.

i restarted and also deleted and created the routing and remote acces dhcp relay agent
I dont get that error code any longer but the vlans still dont work
HELP
0
Today we changed the DNS and MX records for my company's website and I am not sure how to confirm if we did it correctly since we are getting the Bluehost holding page. I know it can take up to 72 hours but I want to just make sure it is all in working order. However, when I run the website through intodns.com it gives me a lot of information I do not know what to do with.

The website is www.beechtreetrading.com

We bought the domain through G Suite/GoDaddy and Wix originally, and now are hoping to have the website on Wordpress as a mapped domain with Bluehost. We changed the DNS on GoDaddy to point to Bluehost and then since we have our business email set up through G Suite, we deleted the old MX Records on Wix and added the new ones.

Wordpress still says DNS configuration required and now when I try to preview the site in Wordpress it gives me this message: The webpage at https://beechtreetrading.com/?iframe=true&theme_preview=true&frame-nonce=82ddc6aeee&cachebust=0&calypso_token=c7539680-e97e-4b53-a62b-155823a59520 might be temporarily down or it may have moved permanently to a new web address.

Is everything still in the process of updating? Or is there a step we missed? Thank you in advance!
0
Up to today, we've used 2008 R2 as our KMS server.  Today I setup another server (2012R2) as a KMS server

Install VAMT

Added several KMS keys from our MS VLSC site including

Server 2012 R2
Server 2016
Windows 10 LTSB 2016

Both KMS hosts are listed in DNS and both come up when I do an nslookup for KMS servers

When I'm at my LTSB2016 client, I ran slmgr.vbs /ato and it says

Error 0xC004F074
No KMS could be contacted

Not sure what to do now

Thanks
0
Can anyone guide me what to do.
I follow the instruction of this website - http://techgenix.com/dns-settings-for-the-forefront-threat-management-gateways-tmg-interfaces-587/

But still i cannot access internet but when i put DNS on external network i work but not perfect i could not access my email thru outlook using pop3 even i already created Policy rule.
0
I need to see the DNS resolution requests of my applications audited and if necessary modified before being sent. I suppose the easiest would be a local resolver that would review my requests before forwarding them to the resolver of my ISP? Another way would be to monitor and be able to override UDP/53 traffi (something I have no clue about). Is there an open source I could use?
Also, I would need this on all OS.
How would you do that? Or would there be a free solution that exists?
Need: support of iDNs as per RFC 5895 for the wole machine (transparent to applications), management of variants, parental control, typos correction. Etc.
Thank you!
0
Can someone give feedback if my NIC configuration is wrong.

Connection : Edge Network

                                  TMG Box                                                                                   Domain Box (AD, DHCP and DNS)
Internal Network                        External Network                                                                      Internal Network
IP - 10.0.0.1                                  IP - 192.168.137.222                                                                 IP - 10.0.0.2
SM - 255.255.255.0                     SM-255.255.255.0                                                                     SM-255.255.255.0
DF - None                                     DF - 192.168.137.1                                                                    DF - 10.0.0.1
DNS - 10.0.0.2                              DNS - 80.138.5.280                                                                   DNS - 10.0.0.2
                                                       DNS - 80.138.5.30  

Is this a correct configuration? If not please correct me.....
0
Oddly after all these, years it still remains unclear on what records I need to publish for a AD domain to be seen by AD domain joined clients from a public (forward facing) DNS server.
 We have our DNS servers for AD (on a public class c but behind a firewall, no NAT here), not accessible via public WANs or WiFi. We do have clients who need to attach or be aware of our Domain controllers when they are on local WiFi.
 So if our registered domain is allthingsdnsAD.com & we have a class C subnet BUT the DNS/AD Domain controllers are only open to a local class B subnet we want our clients on that class B subnet to be able to access local resources located within that class C subnet (yes in the scope of the class b subnet). Too do that we MUST push up AD DNS records for this domain yet I see no straight forward documentation or tool to make this happen. When we have domain joined clients that may be on WiFi (NAT or public) on this class b network they will see public DNS servers, they need to be able to query them to get to local AD resources (assuming they are on a subnet that is allowed through our firewall). Yes I understand these records would replicate, that is not an issue as the firewall would block that traffic anyways, just want those records available so when they are on the local class B network, they would be able to access resources located on that class c subnet (which is in same scope as class b). As a side note, we used to be able to "cheat" with the use of …
0
I have an IPv6 box that is supposed to be routing via HE. I have radvd configured, so it hands out a /64 subnet as follows:

interface enp2s0
{
      AdvSendAdvert on;
      AdvManagedFlag off;
      AdvOtherConfigFlag off;
      prefix 2001:470:1f17:204::/64 {
            AdvOnLink on;
            AdvAutonomous on;
      };
      # This is the DNS server on the internal interface
      RDNSS 2001:470:1f17:204:feaa:14ff:fe53:2eec {
      };
      route ::/0 {
      };
};

I have the interfaces up as follows: enp1s0 (enternal interface), enp2s0 (internal interface to LAN) and hurricane-ipv6 (interface to HE):

enp1s0: flags=4163<UP,BROADCAST,RUNNING,MULTICAST>  mtu 1500
        inet 184.71.193.90  netmask 255.255.255.252  broadcast 184.71.193.91
        inet6 fe80::219:5bff:fe2f:e30  prefixlen 64  scopeid 0x20<link>
        inet6 2001:470:1f16:204::2  prefixlen 64  scopeid 0x0<global> ...

enp2s0: flags=4163<UP,BROADCAST,RUNNING,MULTICAST>  mtu 1500
        inet 169.254.173.107  netmask 255.255.0.0  broadcast 169.254.255.255
        inet6 2001:470:1f17:204:21f:c6ff:fe5e:58b1  prefixlen 64  scopeid 0x0<global>
        inet6 fe80::21f:c6ff:fe5e:58b1  prefixlen 64  scopeid 0x20<link> ...

hurricane-ipv6: flags=209<UP,POINTOPOINT,RUNNING,NOARP>  mtu 1480
        inet6 fe80::b847:c15a  prefixlen 64  scopeid 0x20<link>
        inet6 2001:470:1f16:204::2  prefixlen 64  scopeid 0x0<global>...

lo: flags=73<UP,LOOPBACK,RUNNING>  mtu 65536
        inet 127.0.0.1  netmask 255.0.0.0
        inet6 ::1  prefixlen 128  …
0
We have internal & external dns servers but sometimes  internal dns doesn't resolve queries which had already done on external dns.External dns is also part of domain .Is it correct if we had join the external dns in domain?
0
I setup a forwardzone domain.com with www,domain.com forwarding to external IP and crm.domain.com forwarding to internal IP (same server/dc).  Browsing from the server resolves correctly, but browsing from local PCs in the domain do not. nslookup on PCs shows external ip of domain.com and crm.domain.com. It appears DNS on the DC is not being seen by client PCs; rebooting PCs doesn't help. Probably missing something simple... Thoughts?
0
Hello

I have come across a strange problem.  For years we have been using wpad via DNS to publish our proxy settings.  So we have an A record setup for wpad.domain.local pointing at an IP address.  On the machine with the the specified IP address we have IIS 7.5 running and in the root of the default website we have our wpad.dat file.  We have also configured the .dat mime type correctly.  As I have said this has been in place for a number of years without any problems.

Last week I removed our last Windows 2003 domain controller and replaced it with a 2012r2 server.  Not sure if this caused the problem but I thought I would mention it anyway.  Our firewall does not have an implicit block rule outbound so users can bypass the proxy by un-ticking the Automatically detect settings in IE to bypass the proxy if they need to.  (Which some of them do) We have a  Group Policy in place to re-enable the setting.

I have just noticed that users using Chrome or Firefox are correctly going through the proxy server.  However IE 11 users are not, they are going straight through the default gateway.  Chrome uses IE's settings correctly but it appears IE is totally ignoring the wpad setting.

Has anyone come across this before?

regards.
0
we have 3 vlans on one network. dhcp and dns are on a 2008 r2 server. the vlans are setup on watchguard firewall. if i put the device in the deny filter in dhcp, it wont get on any of the vlans. i would like to let them connect to one of the vlans. any way to do this?
0
When a user browses to "companysite.com"  it routes the user to a SERVER Application UI and I am not sure why.  When they type in "www.companysite.com" it goes toour company's website.  How do I enter a DNS record internally to force "companysite.com" to "www.companysite.com"
0
Running a physical server with AD, DHCP, DNS, and File server + Hyper V. (I know it supposed to be split but this is small company with only 5 users.) The VM is designed as Remote Desktop for the 5 users when they are traveling.

I setup the physical server then added the VM. The NIC1 was setup with the static address for the Domain Controller and DNS, Then I added the VM. I added the Virtual Adapter using the Physical NIC2. After I had it setup I was getting not connection back to the physical server until I checked the box to allow the host to share this adaper. That added a vEnternet on the physical machine and using DHCP to get the address.

Is this OK to have the vEthernet as dynamic? Most of the traffic to the physical machine seems to go through that adapter.
0
I cannot edit or create a new gpo in our single domain.

We recently changed our IP range and had a bit of an issue with DNS and since then if I try to edit and apply a setting to an existing GPO I get

The specified server cannot perform the requested operation

Interestingly, the details of a GPO are listed but when I edit one of them it says it is not configured.
0
I am using SMTP Virtual Server to send email in Windows Server 2000.  All emails are stuck in the Queue folder.  I turned off the firewall to make sure it's not a firewall port blocking issue.

I ran SMTPDiag and everything seems ok.  Results attached.

Why are mails still stuck in the Queue folder?
SMTPDiag-Results-Public_051217.jpg
0
I am using the following query to get the CNAME record to load my site properly. The issue: The code below works ... but only if refreshed a couple of times.

Query ::

$recsDNS = dns_get_record($_SERVER['HTTP_HOST'], DNS_CNAME );
print_r($recsDNS);

Not getting CNAME records Properly, SOme times coming and some times Not.

If I use DNS_ALL :: After refreshing 3 to 4 times i am getting CNAME records.
0
Hi, we currently have a website hosted internally (and NATted through the firewall for external access), example: domain.com....the root level of the website (domain.com) is public) but there is a domain.com/subpage which internal users access from anywhere simply by inputting their AD credentials.

What we want to do is make it more secure and bring the internal part off the internet....so people can continue visiting domain.com from outside for our company page but anything domain.com/subpage or domain.com/subpage2 should only be accessible from inside the company network.

If we do \\servername\subpage from internal (since the website is hosted there) it will work.....but how do we make it so that domain.com continues to work from external but domain/com/subpage only from internal? What do we need to do with IIS, DNS, firewall?

Thanks.
0
Hello,
i have an issue that the domain controller has domain.com and all  users have issues access the website that is hosted externally with godaddy.
I would like to know if possible to create a new dns zone domain.local in the existing server that the domain.com is on and then migrate all workstations to the new .local domain.
thanks
0

DNS

26K

Solutions

26K

Contributors

The Domain Name System (DNS) is a hierarchical, globally distributed system responsible for associating the name of a computer, service or other resource into an IP address for connecting to the Internet or a private network. Most prominently, it translates domain names to the numerical IP addresses needed for the purpose of computer services and devices worldwide.