DNS

26K

Solutions

26K

Contributors

The Domain Name System (DNS) is a hierarchical, globally distributed system responsible for associating the name of a computer, service or other resource into an IP address for connecting to the Internet or a private network. Most prominently, it translates domain names to the numerical IP addresses needed for the purpose of computer services and devices worldwide.

Share tech news, updates, or what's on your mind.

Sign up to Post

I am trying to get a device cert for our firewall to use the SSL VPN currently our DNS is registered with Godaddy.  you can achieve access to the VPN via the direct ip address or I set up a sub domain forwarder  for vpn.anydomain.com to forward to https://12.12.12.12:10443 goddady told me that they cant issue a cert for an ip address and I need to have my my firewall set up to use my domain name.  Which I cant seem to find out how to do that can someone please point some guidance my way.  Thanks
0
Is it possible to redirect a subdomain to a domain with a path like the example below?

http://fp.claimedt.com  >>>>>> http://claimedt/com/fp
0
I had this question after viewing Add static DNS entry to a SonicWALL?.

How were you able to get option 43 work on the sonic wall, I have failed.
0
on the 1/1/2017 we had a network fail (I think it came from our DNS servers), and for a short time (about 2 hours) we had no internet access
today I read something about Cloudflare servers that failed becuse of a second added to the clock
our internet problume solved itself by the time we got to the office
is it possible its related ?
0
Hi,

I'm trying to setup an old server as a backup firewall. I've installed pfSense on it and I'm able to configure it using the web interface.

So when the pfSense firewall is only connected via its LAN network card to the existing network (that uses the current Watchguard firewall) then hostnames resolves just fine (using 'DNS Lookup' under 'Diagnostics'), using localhost and my two internal DNS servers.

But when I connect the incoming 'Internet cable' to its WAN interface then hostnames doesn't resolve anymore ... seems like it doesn't see the internal DNS servers anymore? I can't figure out why though (no special rules defined, everything on default) ... any ideas?

The WAN interface has a public IP address (like 182.58.10.240) and its upstream gateway is like 182.58.10.1
The LAN interface has an internal IP address like 192.168.1.1

Any help is appreciated!
0
Hi,

I have setup a remote CCTV system at home and I'm having difficulty connecting remotley when I work away from home, I have checked my ports that are opened (see attached)
I have configured the CCTV software for http port: 80 and the media port for: 6871 also the static i.p. address I have setup for the CCTV is 192.168.3.30
Unfortunatley I can't connect remotley I have also setup my dns servers but still can't connect probably due to 6871 not being active.
I have a cisco asa 5505 firewall and I'm a little unsure how to configure this correctly Incase I screw It up.
I have a console cable to login and configure this at CLI and I also have the ASDM GUI interface software but this looks more daunting to be honest even though it looks good, On another point I also run a Cisco 800 router If you need to see the config for this then let me know as I can upload this as well if needed.

Any help would be greatly appreaciated with this

This is my firewall config below :-
----------------------------------------------
: Saved
:
ASA Version 8.2(1)
!
hostname ciscoasa
enable password 8Ry2YjIyt7RRXU24 encrypted
passwd 2KFQnbNIdI.2KYOU encrypted
names
!
interface Vlan1
 nameif inside
 security-level 100
 ip address 192.168.3.1 255.255.255.0
!
interface Vlan2
 nameif outside
 security-level 0
 ip address 192.168.1.2 255.255.255.0
!
interface Ethernet0/0
 switchport access vlan 2
!
interface Ethernet0/1
!
interface Ethernet0/2
!
interface …
0
Hi,

Trying to import a PKI generated https certificate to our Infoblox DNS Appliance
Converted a PFX to PEM...
Receiving the error "could not find a CSR matching the piblic key"
We cannot create the CSR from the Appliance because need alternative names
Ideas ?

Thanks
0
Hi experts,
Im planning a multi-location Webserver cluster. I test how the browsers are handling multiple A records.

Test configuration was:
four A records to different IP addresses, only one was IP of a working webserver.

I used a Wireshark to see what is going on and there are the results from Windows 10 machine:
IE and Edge takes 7 seconds timeout for each A record. in the worse case when the A record of working webserver is on the last tried IP opening of page takes 21 seconds.

In Chrome and FireFox, each try takes 21 seconds, so worst case takes 63 seconds to open a page.

Once the page was opened, all browsers are holding the working IP so after initial connection it is fast, as usual.

Is there any other method that is faster on failover?
0
Getting this error relating to newly created zones. The Zones are gray. Not sure what tha means as I am new to DNS
TEST: Delegations (Del)
                  Error: DNS server: test.isilon.test.com. IP:10.100.x.x
0
I have a few applications that are running off of IIS. I can access the applications via a very long web address. For example:

https://internalapplication.domain.com:4343/Folder/console/html/cgi/cgi.exe

What I am trying to do is make it simple to access. So I can go into a browser and type in: internalapplication and it takes me directly to that link. I already have my browsers setup to auto add the .domain.com.

Otherwise the only way to access the link is by having the whole URL. I am unsure how to set this up in either DNS or IIS or a combo of the 2.
0
Hello,

We are currently in the process of setting up 3 plesk servers located in 3 different countries. We were wondering how we should setup our DNS servers so that customers can point their domain names at a hosting account on one of the servers.

Should each location have a primary and secondary DNS for redundancy? or would it be possible to cluster the 3 DNS into an anycast network somehow.

Thanks
0
I am looking for a way to search DNS from the command prompt or power shell.  This is for our service desk to search for a computer name with only partial information, for example they would search for all DNS entries that begin with nbcolaa when the full hostname is nbcolaapatel.  It would be OK if there was a way to do it from a web portal as well.  My service desk only needs to search and view the info, so they wont be changing anything.  

Today I have a script that does exactly what i am asking.  They launch a command prompt and type "ip nbcolaa" and it lists all hostnames that match that along with the address of those.  However we just implemented OpenDNS which uses their own virtual appliance for DNS.  They do not support dns zone transfers so my script is broken now.  So I am looking to see if anyone else does this differently or better.

I attached my existing script if that is helpful.  Thanks in advance.
0
Can someone show me an output of nsquery on hpux?

nsquery hosts <any fqdn>
0
My objective is to resolve FQDNs using host file. I removed resolv.conf and my nsswitch.conf reads "files dns". Somehow, my applications still resolved to the old DNS entries instead of picking up entries in the host file.
Are the DNS records cache somewhere within weblogic?

weblogic 8.1 on Hpux 10.x
0
I have 2 servers which run Dante. On one of them dante was crashing. Initially I thought it's the kernel being too (maybe) old so I re-installed with ubuntu 16.04 LTS. The machines are not identical and I can't seem to figure out what's the cause and what's the difference that might be behind this.

The errors are as follows:

    dante    | Starting dante...
    dante    | *** buffer overflow detected ***: /usr/local/sbin/sockd terminated
    dante    | Sep 27 15:53:28 (1474991608.686063) sockd[2403]: info: Dante/server[1/1] v1.4.1 running
    dante    | ======= Backtrace: =========
    dante    | /lib/x86_64-linux-gnu/libc.so.6(+0x731af)[0x7fa0e27801af]
    dante    | /lib/x86_64-linux-gnu/libc.so.6(__fortify_fail+0x37)[0x7fa0e2805aa7]
    dante    | /lib/x86_64-linux-gnu/libc.so.6(+0xf6cc0)[0x7fa0e2803cc0]
    dante    | /lib/x86_64-linux-gnu/libc.so.6(+0xf8a17)[0x7fa0e2805a17]
    dante    | /usr/local/sbin/sockd[0x46450c]
    dante    | /usr/local/sbin/sockd[0x4048ce]
    dante    | /lib/x86_64-linux-gnu/libc.so.6(__libc_start_main+0xf5)[0x7fa0e272eb45]
    dante    | /usr/local/sbin/sockd[0x407d30]
    dante    | ======= Memory map: ========
    dante    | 00400000-004c9000 r-xp 00000000 00:2b 64                                 /usr/local/sbin/sockd
    dante    | 006c8000-006ca000 rw-p 000c8000 00:2b 64                                 /usr/local/sbin/sockd
    dante    | 006ca000-01a3f000 rw-p 00000000 00:00 0 
    dante    | 02167000-021ba000 rw-p 00000000 

Open in new window

0
I can increase the date but I can't decrease it.

The zone can be scavenged after:
     Date and Time:         9/30/2016 3:00 PM
0
I cannot find any document about Enterprise Mode for Internet Explorer (EMIE) for DNS suffix.

For example, I have a domain (i.e. domain.com) listed in SearchList under Hkey_Local_machine\System\currentcontrolset\services\tcpip\parameters

When I type http://exmaple in the address bar, it becomes example.domain.com

I do have example.domain.com in the EMIE list, but adding just example does not seem to work.
0
i have wordpress with domain name blog.test.com which i want to redirect to www.test.com/blog.
I know it can be done via htaccess but issue is that wordpress is on cdn as it gets lots of hit and www.test.com is on normal server which can't bear such load.
What steps has to be taken and on which level if given step by step it would be great.

Server : Linux
Framework for test.com is laravel
0
We are experiencing intermittent and significant delays in receiving emails from various 3rd parties from various domains (no rhyme or reason as to which sending domains).  The issue is intermittent.  Sometime no problem, sometimes up to a 33 hour delay receiving an email.  The issue is being experienced from private domains, gmail, Comcast.net, etc.  We checked the route trace on several emails and the delays appear to consistently be in the step where the mail is received by our server.  See attached screen shot for a google app report of the route trace.  We have not been able to pinpoint any external reasons, the mail domain is not on a blacklist and we are able to reach the email server from offsite locations (since the issue is intermittent, but we have not identified any external reasons for it).  Internally once the mail hits the server it routes immediately, so we know that once the mail hits our server it is on the users desktop in a matter of seconds.  Any assistance or direction on this issue is appreciated.

Google Apps route trace
0
I have successfully blocked domains, but i need to be able to block access to subdomains as well

i have tried adding a entry in the hosts file using both .domain and *.domain pointing to the local ip and it didnt work.

Thanks
0
Hi -

I recently moved some small web portals internally from a Colo and now I'm having some issues pointing to the right website from the outside. I'm able to bring the websites up internally(private IP) but externally, I'm having issues accessing them. How do I point to different websites on the same IP? Can it be done with NAT translation on the firewall or does it have to be done with DNS records(godaddy)?

thank you for your help!
0
Hello,

I have a question concerning HSRP with a redundant ISP providers.
We host an application and are researching the possibilities of adding additional ISP for redundancy.

If CISCO HSRP  ( routing protocol )becomes active, and the outbound traffic  is tagged with a different  WAN IP, that session should continue to remain connected.

My question is, what happens when a user resolves domain xyz.com on the net and the ISP who assigned the APP server its IP, is offline?

A new session inbound, How will traffic inbound how to reach  the APP server on the redundant circuit? I would assume this would have to be a layer 2 technology to point to a mac address?

 
Maybe my illustration will help explain better ( please see attachment)

I appreciate any help on this
domain.jpg
0
I manage a Magento store. We recently launched a corporate version, and moved the domain from the Magento Store to a Wordpress site. Wordpress works great.

Magento has two environments, a live and a stage site. We created TWO new URLs and changed the live store URL from the base (non sub) to a sub, and also changed the staging to another sub.

The issue is the live sub is redirecting back to the staging sub. Here are the links:
Corporate (Wordpress): apothecaryproducts.com
Live store: https://store.apothecaryproducts.com (ONLY works when https:// is in front, otherwise http://store.apothecaryproducts.com redirects to...
Stage store: zstagestore.apothecaryproducts.com

I'm at a loss for whats going on. I think it might be resolvable by setting up another "store" for staging, but I'm confused why its resolving to stage. Also the IP address resolves to stage: 162.209.57.148
0
We have Sophos UTM 9 that is providing dhcp. There are maybe 50 laptops in use.  There are access points through out the two buildings. The two building are connected with hp filber switches. The access points are meraki but there are a couple of older cisco access points.  I keeping getting calls about users not being able to connect to the internet. I find that they are connected to the wireless but the connection has a yellow bang symbol over it.  I release the address, flush the dns, disconnect and reconnect to the wireless but nothing fixes the issue.  The only thing that works in these instances is to set a static ip and dns.  Does anyone have a suggestion on fixing this or an idea of what is causing this?
0
Hello,

 We have 2 x 2008R2 DCs in a site A which are caching some DNS records but not caching other DNS records. This seems to be affecting DNS performance.

 We have 2 x 2008R2 DCs in site B which are caching all records as expected.

 All servers are using Root Hints.

 Example:

 Site A DCs: ft.com in DNS cache shows 4 NS records

 ns1.p23.dynect.com
 ns2.p23.dynect.com
 ns3.p23.dynect.com
 ns4.p23.dynect.com

 When I do:

 NSLookup www.ft.com.

 I get this response:

 Non-authoritative answer:
 Name:    e.global-ssl.fastly.net
 Address:  185.31.17.230
 Aliases:  www.ft.com

 But the record for www.ft.com is not cached.

 Site A DCs: ft.com in DNS cache shows 4 NS records

 ns1.p23.dynect.com
 ns2.p23.dynect.com
 ns3.p23.dynect.com
 ns4.p23.dynect.com

 When I do:

 NSLookup www.ft.com.

 I get this response:

 Non-authoritative answer:
 Name:    e.global-ssl.fastly.net
 Address:  185.31.17.230
 Aliases:  www.ft.com

 But the record for www.ft.com is not cached.

 In SIte B, the same nslookup command results in the caching of:

 ns1.p23.dynect.com
 ns2.p23.dynect.com
 ns3.p23.dynect.com
 ns4.p23.dynect.com

 and the caching of CNAME for www => e.global-ssl.fastly.net

 Has anyone ever seen this behaviour?

 Any idea why DC in one site is caching the www record and DC in other site is not?

 Thanks.
0

DNS

26K

Solutions

26K

Contributors

The Domain Name System (DNS) is a hierarchical, globally distributed system responsible for associating the name of a computer, service or other resource into an IP address for connecting to the Internet or a private network. Most prominently, it translates domain names to the numerical IP addresses needed for the purpose of computer services and devices worldwide.