DNS

26K

Solutions

26K

Contributors

The Domain Name System (DNS) is a hierarchical, globally distributed system responsible for associating the name of a computer, service or other resource into an IP address for connecting to the Internet or a private network. Most prominently, it translates domain names to the numerical IP addresses needed for the purpose of computer services and devices worldwide.

Share tech news, updates, or what's on your mind.

Sign up to Post

We have deployed SQL Always-on which is consist of two MS-SQL 2017 servers. When we try to connect through always-on listener IP, the connection takes time.

However, its connecting fine using listener DNS name.
0
Restored this DC from a snapshot backup.
Good idea because the server is up and running.
Bad idea because it broke Active Directory.
I had to seize the schema master and naming master from this server.
I forced the demotion of the server.
I uninstalled Active Directory and DNS.
Now i am trying to add this server back to the domain and i am getting this error.
Domain-error.jpg
We use Office365 so i looked in the Azure Active Directory but this server is not in there.
0
I have a Server 2016 file server whose shared folders are randomly becoming unresponsive.  This had happened 3 times since walking into the office this morning.

The only way to fix it so far has been to reboot he server.  Interestingly, when I reboot it gets stuck 'restarting' and I have to power it off/on in order for it to restart.

The first time I did this today, it was OK for about 3 hours.  Then the drives were no longer accessible (some users could browse them but as soon as you tried to open a file it would hang).

I rebooted, but this time it only last 30mins or so before it went again.

The server performance appears to be fine, no issues with CPU/RAM etc.  There are no obvious error messages in event viewer etc.

My sneaky feeling is this might be DNS alias related.  The only odd thing I have found in event viewer is this warning (event id 8008):

The system failed to register network adapter with settings:

           Adapter Name : {7826F803-15EE-48EA-A37C-D7549BDCBC21}
           Host Name : XXXX
           Adapter-specific Domain Suffix : alias.mydomain.com
           DNS server list :
                   172.xxxxx 172.xxxxxx, 172.xxxxxxx
           Sent update to server : <?>
           IP Address(es) :
             172.xxxxxx

The reason the DNS update request could not be completed was because of a system problem. You can manually retry DNS registration of the network adapter and its settings by typing 'ipconfig /registerdns' at the command…
0
Thanks in advance,  I have one domain with one exchange 2010 server and one 2008 r2 server plus one 2016 standard server.  I am trying to upgrade my domain/forest to 2016.  I have transferred all the roles to new 2016 server and verified this, however, every time I do anything in exchange, it appears to still be connecting to old 2008 r2 server for validation.  I have changed all dns settings and the global catalog servers show both servers.  In global catalog section of exchange, it shows 2016 server first, but I don't want exchange to connect to 2008 server anymore.  Will it stop when I fully demote 2008 server or should I be concerned?  I don't understand why when I make settings changes in exchange it references old server.  Thanks
0
We have a single Microsoft Small Business Server 2011 running exchange.

We have been running for some time without problem. We have recently had several clients that are receiving an NDR stating that the account is unknown.

We noticed that the mail never arrives at our mail server, and that the NDR was issued from a google name server.

On checking our MX records, we see :-

mx records via mxtoolbox.com

We can see that the correct MX record is shown as our preferred MX record, and we can see several google MX records with higher preferences.

We are currently unaware of where the google MX records have come from. We did have someone develop our website, who may have added these, but currently unsure as to why.

Will these affect our main MX record as it seems that some of our clients are hitting the google mx rather than our correct mx.

Should there be so many MX records, and do you think this is the root of our problem?

Any advice much appreciated.
0
I am trying to get my email server to send direct instead of send connectors.

I can send some emails but some are being blocked. I want to know what dns records i need to add at the domain level to make sure they dont get blocked as spam.

Exchange 2016 running as a hosted solution so multiple tennents from different domains
0
I think I have a problem with autodiscover with a clients emails service. They use a hosted exchange service. When I try to connect Outlook 2016 to a known working email account it fails.

When I check their domain dns record there are 2 entries which mention auto discover

One that is correct and there is also one that starts _autodiscover._tcp pointing to cpanelmaildiscovery. This is something they use.

Would this cause a problem and should I delete the _autodiscover._tcp entry?
0
Hello Experts

I have a Curious Issue I am tryning to migrate AD from win 2008 to Win 2016
I had one DC that was in shortage of space in the C drive

A guy Lucnh an operation to virtualize the server and i think the Operation did not go well but now when i type repadmin /replsummary

I have errors of RPC server not available on this DC that was restarted and now replication reporting errors

Nothing change in the configuration Except the DC hang and was restarted

And something else during the nigth the command reported the DSA Source and DSA Destination

Now it is reporting only DSA Source
0
We are moving into the cloud our architecture which also consist of Cassandra database. For security reason the access to
the db is restricted and now my team is not able to access it from outside. One solution proposed was to use static ip and provide access only to those ip but our network address are dynamic ; what more firewall rule can’t be configured based on dns. Do you know any proxy that can be configured or if there one solution already out there for Cassandra database? Do you know any other solution/workaround to this problem alternative to proxy? Is there any specific solution to this kind of issue for Cassandra?

Thank you.
0
Hi Experts,

I am having issues setting up an ADFS farm that will be accessible both internally and externally and use a third party SSL for the public side.

We currently have the below set up.
2 Windows 2019 servers on our internal network
1 Windows 2019 server on our DMZ with a public IP nat & a dns name set with our external DNS provider.
The server in DMZ has routing to both the internal servers.
We want to use our third party Wildcard SSL if possible for the public side to ease accessibility issues.

When trying to run the configuration wizard I get the below error:
ADFS-Error-2.PNG
0
DHCP reservations and DNS on 2012 server for windows 7 hosts not working properly. 2 separate domains, 1 legacy that hands out all ip's via reservations. No usable pool of addresses. 2 DNS servers. one newer domain on 2012. There is no trust between domains. newer domain also uses only reservations for ip's, no usable pool of addresses. Everything works fine for windows 10 hosts on the newer domain. Windows 7 hosts originally get their reservation from the 2012 server and all is well. But after some time on the network they all of the sudden have their dns settings changed to the legacy domain settings. There is no reservation on the old dhcp server for this to occur and their ip address and setting for the dhcp server remain as the dhcp reservation on the newer domain. The dns on the newer domain does not get records created or deleted from the reverse zone for windows 7 hosts. All windows 10 hosts work properly with both dhcp and dns on the newer domain. Any help would be greatly appreciated.
0
Hi
I have built my first DC in azure IaaS with help of Petri guide: https://www.petri.com/deploy-domain-controllers-azure-virtual-machines
I had issues connecting from new DC to on premise for when adding the AD/DNS roles, so added the static IP of the Ops master to the DNS entries of the VM NIC within the OS.
I also added all 4x on premise DNS server to the VMs DNS settings blade within ARM.

Now that everything looks ok and before i add a second DC can you help clarify the following:

Should the DNS entry on the VMs NIC (OS level) be removed or add the other 4x as i would on premise?
Leave the static DNS entries on the VMs DNS settings within ARM or use dynamic?
The new DC is within the new site (ADS&S) - should i add on prem servers here (like i have done in the past for remote sites)?
Should the public IP be removed or not?  
I think i read that the ops master roles stay on premise (seems logical for hybrid and where our resources lye currently) - is this correct?
Azure want me to replicate and back it up.  Should i as they are DCs?

Thanks
0
hi,

got  server 2012 R2. it acts as DC/DNS/DHCP server

in event viewer, in system logs- i keep on getting netlogon error related to dns 5774. "the dynamic registration of dns record failed on the following dns server"
The dns record name keep changes in all errors 5774

got the network adaptetr config as :  ip- 192.168.0.1
sm-24
gw-192.168.0.254
dns-192.168.0.1

if i go to dns- properties- these are the forwarders i have.: 8.8.8.8/8.8.8.4.4/ 208.67.220.220/208.67.222.222/139.130.4.4

any ideas why this error occurs and how do i solve it ? ? ?  
note:  this error never caused any issues. no one complained so far and its going on for few months.
0
We have an issue after standing up a hybrid solution. Only on-prem users can see online users and send messages. Does not matter if they are local to network or coming through Edge server on guest network. Online users can only see other online users, cannot send or reply to on-prem users. Both sides are open federation. Federation partner test passes. All users are synced with AADC with Skype attributes enabled. All local, tenant configuration settings, DNS entries doubled checked by multiple people. Edge server running in DMZ with dual NICs with F5 acting as reverse proxy. Wondering if someone could point us to where we need to go next for testing, troubleshooting to get this resolved.
Thanks!!
0
I've fixed this problem art other locations years ago but this has me stumped. A small LAN with Windows Server 2012R2 - the only one on a domain... "thisdomain.local" as set in DNS.

Until a few days ago everyone could reach their website hosted externally. "www.thisdomain.com"

The site is reachable from their router if I plug my laptop into it.

I can ping the external website's IP address from any machine in the building. And, I can ping www.thisplace.com which tells me DNS is resolving properly.

But if I point a browser at the site it times out and says:

"There was a temporary DNS error. Try refreshing the page. Error code: INET_E_RESOURCE_NOT_FOUND"

I've disabled the Server's Windows firewall but no change. Any ideas? Thank you.
0
Need a tutorial or pointer to create self-signed certificate which does not show "not secure" message in the browser tab for my local system which has a dns name(hostname)  as004.  Lets encrypt with certbot not able to do it. any ideas ?
0
I believe I have problems with DNS and Active Directory so I'm trying to run "Microsoft IT Environment Health Scanner Report" from my Admin PC and I can't run the report as I'm receiving the error The Specified Domain Controller doesn't appear in ServerTable.  The Limited information I could google indicated there might be a null listing however  >dsquery * domainroot -filter "(&(&(sAMAccountType=805306369)(objectCategory=computer)(objectClass=computer)(operatingSystem=*Server*)))" -attr cn DNSHostname show all NETBOIS names with their  DNSHostname
0
I'm setting up a network for a small business.  One server 2016 Essentials (DC, AD, DNS and file server)  5 workstations.  It's a brand new setup.  I've run the cables, set the dataports, installed the switch, patch panel, server, power UPS, etc.   Everything that a new LAN needs......except.  They are using a Linksys router.  Like the home version bought from the store.   That's all fine and good.   Everything works.   Now they want to incorporate two other locations into the domain.   Each is a couple hundred miles away.   There is a database on this LAN that they will need access to.  What are my options without breaking the bank?  Ideally, I would like the computers to be able to log into the domain from anywhere.
0
Domain Controller moved to new location - No connection to Hyper-V Virtual Servers from office computers.

Server moved to new location - Company sold

3 Virtual Servers

Cannot ping them - they are setup as Flash1 - Main Server - Flash2 - Data Flash3 - Exchange Server (not used now) Flash4 - Public folders

This site for this new company has everything plugged into switch going to Comcast Box. Before - We had a VPN Router and Server gave out IP Addresses. 192.168.1.19, etc.
 
Addresses were given out by the Flash2 (DHCP) and DNS for internet access and Flash4 as backup.

Need instruction to access Flash2 192.168.1.19 - and confusing they can access 192.168.1.17.

Do we need to order a Router like before or is there a way to best access this Server 192.168.1.19 from local computers.

I am not onsite and been sick for a month so wondering best way to have local computers able to access Flash2 Virtual Server at 192.168.1.19 and confused how 192.168.1.17 is able to be accessed even though address scheme not the same Computers are getting a 10.1.10.x address coming from Comcast.

Do they need a Router with VPN like we had before?

Strange - cannot ping 192.168.1.17 but they can access that drive.

They cannot access 192.168.1.19 Virtual Server.

Thank You and let me know if more clarification is needed.
0
Hello,
We're migrating our website www.tiedemannglobe.com from one server to another. The last provider suspended our account and on entering the site through the browser, I got a page that said "Account suspended".
I changed the DNS in Godaddy, specifically, the Name Server to the DNS I have in WHM for the new server, and the host names to the new IP.
The DNS changes seem to have deployed already, because when I enter the website now, I can see, with the IP check plugin of my browser, that the IP for the site is that of our new server, but I still get the "Account suspended" error instead of the content I uploaded to the server via FTP. What am I missing?
0
We want to configure our scanners to relay off of Exchange servers for scan-2-email, but multiple servers just in case one is down.

I'm looking for Microsoft documents on how to configure and recommendations on configuring DNS Failover and Round Robin.

I also want to know in a Round Robin scenario, if a node is down and it's next in line, does email fail?
0
Hello, we have three DCs:
DC01 -which was the primary DC but had hardware issues and demoted and we tried repromoting it with the error message attached.
DC02 - was in existence with DC01 but as a secondary DC only to be made primary before DC01 was demoted and the fsmo roles were transferred
DC03 is active as a secondary domain controller

The problem statement is that we want to repromote the DC01 but we are getting the error message in the screenshot attached, as well as DNS and GPO issues.

dc-installation-failed.jpg
0
I have a huge dilemma and I was wondering if someone had a suggestion to help me out.

Printers in one active directory were published by short name (NetBIOS name) and the short name has DNS record in active directory.  The problem is when I exported all the printers from one print server in one active directory to another in a completely separate active directory, having those short name / NetBios for defined ports names were not working on the target print server.  For a short term workaround, I pointed the print server back to an active DNS server in the old domain and added the old DNS suffix in the DNS search order of the new print server.

There are literally 500+ printers on this one server so this is kind of a huge undertaking.

I was able to query DNS from the source directory to get a short name to IP address mappings.  I have renamed the printers on the source system utilizing the help from one of the gurus on this site by concatenating the variable.

The question is:  Is there a way, utilizing the csv file that I have pulled from the old domain with the printer to IP address mappings, to search for a variable and replace the information based on display name variables in the registry, on the new printer server?

I am manually doing this on the new print server by changing the registry at HKLM\System\CurrentControlSet\Control\Print\Printers\"Printer name". Once in that key, I am looking for REG_SZ value Share Name of the printer, and once found, changing …
0
Hi Experts

Our email service is hosted by a cloud based hosting vendor and recently its IP address was blacklisted by Barracuda.
After requesting for de-listing, the IP is no longer black listed but whenever we send email to Gmail, it gets rejected saying due to low IP reputation.

Due to emergency, we subscribed to SMTP2 go relay service and it is able to deliver to Gmail now but it always goes to "Spam" folder of Gmail.

After some more troubleshooting, I notice public email verifying service always fail to verify the email address which is saying "INVALID" when I check from this. https://hunter.io/email-verifier   

I checked from other web based email verifying service also results the same which make me suspect the reason of going to Spam folder is due to email verification fail and it was sent out as unauthenticated or something but I'm not very sure.

When I check the domain reputation from Google webmaster tool, its state is Medium.

What could be the reason of email verification fail which MX record is correct and server is always reachable via telnet on port 25?

What could be the reason of email sent to Gmail always going to Spam folder?

Thanks
Regarrds
BMT
0
LiteTouch USB boots fine into the deployment environment, but will not connect to the deployment share.  It worked without issue then I had to change my password due to the 6mon password change policy and I had to re-IP the MDT server that houses the images due to a network change.  I applied the new IP the old IP record was removed from DNS, and I'm able to ping the new IP via the IP and the hostname.  Mapping a drive to the deploymentshare folder via UNC path and IP both work from my workstation.  When I'm in the bootable environment, i can hit F8 to launch a cmd window and both ping the hostname and the IP of the deployment server, yet I'm getting "access denied" when I try to map to it.


The initial error I get is: "A conneciton to the deployment share (\\servername\share) could not be made.  Connection Ok.  Possible invalid credentials."

The thing is I've gone into the deployment share and changed my creds to my current creds in the bootstrap.ini -- that's the only play I can think of that I have my credentials.  I then completely updated the share with new boot images, then copied the litetouch iso file over to my desktop and used Rufus to make a bootable USB -- it boots fine, but then I get the above error.  Thoughts?  I feel like somehow the share still has my old creds somewhere.
0

DNS

26K

Solutions

26K

Contributors

The Domain Name System (DNS) is a hierarchical, globally distributed system responsible for associating the name of a computer, service or other resource into an IP address for connecting to the Internet or a private network. Most prominently, it translates domain names to the numerical IP addresses needed for the purpose of computer services and devices worldwide.