DNS

26K

Solutions

26K

Contributors

The Domain Name System (DNS) is a hierarchical, globally distributed system responsible for associating the name of a computer, service or other resource into an IP address for connecting to the Internet or a private network. Most prominently, it translates domain names to the numerical IP addresses needed for the purpose of computer services and devices worldwide.

Share tech news, updates, or what's on your mind.

Sign up to Post

Hey Experts,

Some users are experiencing performance issues when performing searches within Project Explorer of the Vault Professional 2016 client.  Searches for projects, part files and documents are slow to return results and are slow to retrieve full property details of the files.   This poor performance is experienced when the user logs into the Vault server using the FQDN of the server, from the Vault client on their machines.

When the user logs into the Vault client using the IP address of the Vault server, the performance issues are not present.  Results returned from searches within the Project Explorer are snappy and all property details are quickly returned.  

Both forward and reverse DNS resolution for the FQDN / IP are present and lookups complete successfully.

Can anyone offer suggestions on where I should start looking.

Thank you,
Anthony
0
I have a strange issue happening with a web site redirection. I have a HTTP Redirection Record added to my dns and it works for me and many other people. It is not working for everyone and every device. I have one that has an iphone and it works in Safari but does not work in Chrome. Uninstalled the app, reinstalled, cleared the cache etc. We are getting constant calls from people saying they cannot reach the site. Any ideas?
0
Our third-party web developer just changed the website so it now redirects from www.domain.com to  https:\\domain.com without the www. After this change, no one on the LAN can access our website anymore, because “domain.com” points to an internal IP address. Previously everyone could get to the website because www points to the outside public IP address of our website. Now that the www is dropped that no longer works. We can change DNS to a public site (8.8.8.8) and can of course then get website access, but then Outlook disconnects from our on premise Exchange server. Please help. We have numerous portable laptops, so the solution needs to work both inside and outside LAN.
0
Im wondering can someone help,
I recently installed a new domain controller and moved dhcp, dns services onto it and thats all working fine. I also migrated the old domain controller onto it. It says it has all the fsmo roles. However when i shutdown the old domain controller i cant connect to any active directory services on the server.

I see this error in the logs but i cant seem to resolve it. Any active directory wizards that can help me ? Windows 2012 is the new server


This server is the owner of the following FSMO role, but does not consider it valid. For the partition which contains the FSMO, this server has not replicated successfully with any of its partners since this server has been restarted. Replication errors are preventing validation of this role.
 
Operations which require contacting a FSMO operation master will fail until this condition is corrected.
 
FSMO Role: DC=mycompanyDC=local
 
User Action:
 
1. Initial synchronization is the first early replications done by a system as it is starting. A failure to initially synchronize may explain why a FSMO role cannot be validated. This process is explained in KB article 305476.
2. This server has one or more replication partners, and replication is failing for all of these partners. Use the command repadmin /showrepl to display the replication errors.  Correct the error in question. For example there maybe problems with IP connectivity, DNS name resolution, or security authentication that…
0
Hi all,

I have a brand new DC (it's the only domain controller as it's a small business) running on Server 2016 Standard.  I am running the DNS Best Practices Advisor and keep getting lots of error messages saying DNS: The DNS server :: on Ethernet must resolve...

I can't work out what DNS Server :: is relating to.  Can anyone please shed some light on this as nothing is coming up on Google.

Many thanks

Adam
0
Let's say you reserved a domain at one of the reputable registrars.  You don't link it with the hosting account yet, just own it.  The registrar automatically creates nice landing page for it.  This means that they created a valid DNS zone file for your domain name, which includes an A record pointing at the web server hosting the landing page, bunch of CNAME records pointing at their www., pop., imap., etc. servers.  However, this is only a zone file for a landing page, so MX record may or may not be there and SPF record typically is not there.  Now, a company like Security Scorecard scans registrar's records and finds that this specific domain name belonging to your company.  The domain name doesn't have SPF record - negative points, has associated IMAP service - negative points, the landing page doesn't enforce HTTPS protocol - negative points.  All you did was reserved yourself a domain name, but that scored negatively against your company cyber security or, as they call it,  digital footprint reputation.

This leads me to the question directed to people familiar with Security Scorecard, or such like, services  - what is the best way to avoid owned parked domain having adverse effect on the Security Scorecard report?  Is the private registration the way to go?  Or, perhaps, setting invalid address for the DNS server authoritative to that domain, e.g 1.2.3.4?  That way the scanner will not get any response at all.  Or, maybe it is better to set the authoritative DNS …
0
Website not accessible. I have a website hosted on Godaddy.com and working, but the site is not accessible from Internally. nslookup find ip of the server and resolved the name and I am able to ping the server. No problem externally. I checked DNS and seems working.  Refreshed the DNS server and clear the cache on DNS. local domain is domain.local and the website is domain.com. DNS forwarder set to ISP and resolved it correctly.  Any idea?
0
We currently use domain1.com AD and O365 (sync)  All users are created in domain1 AD but we also use domain2.com (added in AD DNS and the same Office 365 account)  as an email alias for some users.  

But this domain2.com will now have it's own AD and Office 365 account.  It will be completely separated from domain1 AD and Office 365.  

About half users of domain1.com are not migrated on Exchange online so their mailbox is on Exchange On Premise.  

All users of domain2.com are already migrated to Exchange Online on Office 365.

In the past we often had issues when a user left but had a new email somewhere else, emails sent to him sometimes bounced back because Exchange keeps trying to send it to the old address
X500
IMCEAEX-_O=SRMAILOU_OU=EXCHANGE+20ADMINISTRATIVE+20GROUP+20+28FYDIBOHF23SPDLT+29_CN=RECIPIENTS_CN=UK+20Accounts@domain.com

Besides, all the users of the new domain2.com will still have a user@domain1.com email address along a new user@domain2.com email address.  

I'd like to know if there is something we could do instead of creating many X500 entries to avoid any issue?

Note: we use Office small business premium and E3

Thanks
0
My domain a 2008 R2 server on a 192.168.0.X.
I can nearly view all webpages but there are a few that have recently started to give errors when I try to access them.
I get the error in firefox or similar on other browsers:
We can’t connect to the server at www.facebook.com.
If that address is correct, here are three other things you can try:

    Try again later.
    Check your network connection.
    If you are connected but behind a firewall, check that Firefox has permission to access the Web.

I suspect it may be a DNS issues bu tsince I can view any other webpage just a few specific how can I tell?
0
Hi, I have a brand new 2016 Server Standard installation running as a Hyper V VM on a standalone server providing. This VM is providing DC, DNS, DCHP and File Share to a small group of domain users and has replaced an old SBS server which has been correctly retired with the FSMO roles moved on to the new DC.

I've set up a few of these single 2016 servers for different clients and it's always been plane sailing but this one is really odd in that I just can't get RRAS to start which I need to provide PPTP VPN for occasional access,  I get the error: The Remote Access and Routing service did not start because of the following error: The system cannot find the file specified.

I've removed the RRAS role a few times, restarted and added again and not worked. I've run SFC /Scannow and that did find an issue and fixed it but not helped.  I did at one point try to set up Direct Access and installed a trusted SSL cert but then realised Direct Access wasn't going to give me what I needed and want to get PPTP VPN working.  So I removed Direct Access and deleted the certificate in IIS, I mention this in case it's relevant.  Would really appreciate any help on this issue as it's causing me issues!

Many thanks
0
Our local domain is the same as our web site domain. However when we try to access http://ourdomain.com I get 403 forbidden access is denied. I think its pointing a local iis server or something like that. Do I need to create a DNS A record on our local DNS server to resolve this? If so what kind of record?
0
The DFS Replication service encountered an error communicating with partner domainServer for replication group Domain System Volume.
 
Partner DNS address: DomainServerDomain
 
Optional data if available:
Partner WINS Address: DomainServer
Partner IP Address: 192.168.1.220
 
The service will retry the connection periodically.
 
Additional Information:
Error: 1753 (There are no more endpoints available from the endpoint mapper.)
Connection ID: 664B7FC3-5194-4B24-AD9D-E02F44270F08
0
I had this question after viewing DNS not resolving for specific website.

I have a same Issue like. Our DNS server not responding to the certain address
0
Hi, I am trying to join my computer to our domain but I unable to do so due to issues with discovering the name server. when i run nslookup it returns with a server unknown with an IP V6 address. I have a slight inclination as to the issue is but could not know how to troubleshoot it. On the DNS server someone as crated both multiple host records with different names pointing to the same IP address in both IPV4 and IPV6. However the IPV4 records in  SBS Server 2011 can have reverse lookup records where as IPV6 do not. I know IPV6 should have the capability to do a reverse lookup. Please help.
1
Setup of DNS - 1 in my DMZ and I in ISP location - public DNS servers
Hi,

I'm receiving feedback from some external experienced engineers that the above setup is weird. I sense there my be something wrong - but from what ive researched this is good practice.
They are both primary authoritative name servers for our public domain. - there is no zone transfer between them.

The ISP controlled DNS is frustrating to a degree as we need to ring them frequently to get unusual entries completed. EG SPF records. Then I need to place the same record in my DMZ on-prem hosted DNS server (which i can do myself easily). So there is double entry required.
The question I'm asking is is this an unusual setup for public DNS for an organization?. Whats wrong with it ? Thanks
0
I have a hyper V lab environment setup. I originally had it setup to a internal switch but wanted to change it to a external switch so I can get out to the internet.
 I can get out to the internet if I set that machines to automatically get a ip address but I need to be able to communicate between the machine in the lab.

At my work place they have it setup so all the machines use the DC for DNS resolution and they set forwarders on the DNS server to get out to the internet. This doesnt seem to work in my lab envir. Is there a way to get the machines to see each other and get out to the internet as well?
0
we have configured a new Server 2016 DC and and new Exchange 2016 sever (on separate hardware).

We are not able to get our iPhone's to setup an Exchange account. The account on the phone will all 'green tick' but when trying to collect email is comes up 'account error' - 'unable to connect'.

This is a summary of what DOES work.
DC is working fine
Exchange is working fine
We have configured various DNS settings on our DC to reflect out external URL, Autodiscover, OWA and remote - they point to Exchange
We have a WIldcard SSL that gives us a secure SSL connection from outside our organisation to the DC's RWW and Exchange OWA
Internally Outlook clients can connect fine
Externally - NON DOMAIN joined PC's can configure a Exchange account and CAN send and receive email.
We have configured AUTODISCOVERY (URL 'A' and 'Cname' records) - and according to Microsoft's Remote Connectivity Analyser all tests pass - EXCEPT IMAP and POP which is due to the Wildcard SSL NOT being bound to those two protocols (but shouldn't be an issue- i don't think)

I have tried setting up the Exchange account on iPhone 6, 7, X iPad 2 and iPad Pro - none work and all show the same connectivity issue with Exchange.

We seem to have setup everything correctly - but clearly there is something missing.

Can anyone offer any support please
Thank you
0
Windows DNS issue.  Customer added on-premise Exchange server.  Since doing so, their is a problem accessing their public website from within the network.  The website is designed to strip the www prefix. When accessing the website www.domain.com it strips it to domain.com.  The AD domain is also domain.com so when the website tries to redirect to domain.com it goes to the internal DNS which is the Exchange server.  Need assistance in configuring DNS so it continues to route to the public website when the www is stripped and not effecting any Exchange 2016 functionality.
0
We currently have 2 DCs onsite and 1 DC in Azure. There are more times than not, our building has a planned power outage and we have to shut down our servers. However, our Cisco ASA is still up and we want the DC in Azure to pick up DHCP/DNS. I'm not sure how to go about this or where to look.
0
hi all ,

we have exchange server 2013 running DAG , we have issue with cluster services due to the Cluster name is not being online and checking the event log of the cluster we see the below error
" Cluster network name resource 'Cluster Name' cannot be brought online. Ensure that the network adapters for dependent IP address resources have access to at least one DNS server. Alternatively, enable NetBIOS for dependent IP addresses "

what we have tried is  remove the A record of the cluster from the DNS and create again with all permission and  set the option allow any authenticated user to update DNS .

the ComputerName CNO for the Cluster is now online .

any suggestion people .
0
I recently transferred a domain to my Registrar using the domain key.

After the transfer, I checked the whois database. All the information has been updated except Registrant and Registrant ID

I have contacted my registrar(Godaddy), they said these records will be updated in a couple of days automatically . I am not sure they are right. my understanding is the domain still belongs to previous company, we only have control of it. I need to transfer the ownership as well.

Does anyone have know to update these records to my company details?
0
Regarding the issue is that PTR record is not updating properly and if we can go ahead and untick and then tick again the option called "update assiocated ptr record" in A record it is working.


We are using DHCP in our environment to recieve the ip address from client systems, In DHCP we have the enabled option called Dynamically update the A record and PTR record for your referecne.

In DNS we have properly have the reverse zone and configured the dynamic updates to "secure only"

reverse zone like we have 10.30.

if we ping the ipaddress such ping -a 10.30.53.101 then it is not resolving with hostname and if do nslookup we are getting the same hostname not resolving..


Please help us to fix. Please do the needful.
0
Windows 2012r2 , I followed this thread to rename domain name :http://www.rebeladmin.com/2015/05/step-by-step-guide-to-rename-active-directory-domain-name/

However, after the domain renamed. my DNS appears to a problem.

 All my AD dns record changed to just hostname. but it should be FQDN: hostname.domainname. including the name server also been changed to just host name.

Even I manual changed to FQDN, it will create another record with just hostname automatic.  

Can anyone tell me why?

0
I have 2 test servers running 2012r2 that I am using to study for my certifications. Both machines are clean installations.

This is my setup:

Server 1
Configured as a domain controller
Roles installed:
Active directory users and computers
DNS
DHCP


Server2
Configured as a member server and is connected to the domain. I have hyper v role installed and I have a virtual machine created. I have installed  exchange 2013 on the virtual machine.

After the installation was successful, I was able to connect to ECP, and I could access the administrator account. When I rebooted the domain controller, it died.(it was a used sever) I then reconfigured another machine as a domain controller with the exact same settings as before. When I try to log into exchange ecp, I get this error.


Server Error in '/ecp' Application.

An error occurred during forest discovery (photonics.org).
  Description: An unhandled exception occurred during the execution of the current web request. Please review the stack trace for more information about the error and where it originated in the code.

 Exception Details: System.ServiceModel.FaultException`1[[Microsoft.Exchange.Data.Directory.TopologyDiscovery.TopologyServiceFault, Microsoft.Exchange.Data.Directory, Version=15.0.0.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35]]: An error occurred during forest discovery (photonics.org).

Source Error:


 An unhandled exception was generated during the execution of the …
0
I have an environment that included both wireless and lan connections
When a users comes into the office with a laptop and connects to their docking station they get DHCP from our "wired" scope (10.15.2.10-10.15.3.250)
When they come into the office and don't dock they get DHCP from our "wireless" scope (10.15.22.10-10.15.22.250)

Our issue
If the user has a dhcp assignment from either or and then connects to the other, our DNS records DONT get updated
Example
Laptop user was on wireless and had an IP address of 10.15.22.165
User went to her desk. Our laptops are configured to disable wireless when docked
After docking she got a "wired" IP of 10.15.3.125
DNS record was NOT updated. The only way I can connect to the user is by going into DNS and deleting the record
DHCP is configured to always dynamically update DNS

I'm not responsible for our DNS or DHCP and I'm always told there is nothing that can be done. I find it hard to believe

TIA
0

DNS

26K

Solutions

26K

Contributors

The Domain Name System (DNS) is a hierarchical, globally distributed system responsible for associating the name of a computer, service or other resource into an IP address for connecting to the Internet or a private network. Most prominently, it translates domain names to the numerical IP addresses needed for the purpose of computer services and devices worldwide.