Editors IDEs

24K

Solutions

19K

Contributors

Development in most programming languages is frequently done with an editor or integrated development environment (IDE). An IDE is a software application that provide comprehensive facilities to computer programmers for software development. An IDE normally consists of a source code editor, build automation tools and a debugger. XCode, Visual Studio, Adobe Dreamweaver and Eclipse are some of the more popular development tools, but an editor or IDE can be anything from simple text editors to sophisticated programs. Related topics: All programming and development language, database and web based content management systems topics

Share tech news, updates, or what's on your mind.

Sign up to Post

I have my code like below
      response = orch.process(request);

when i mover on to process method and click control and left mouse click it supposed to go to process method implementation but it is not doing in eclipse mars.

it used to work earlier not sure suddenly what happened stops working.

i restarted my laptop still not working.

please advise
0
VIDEO: THE CONCERTO CLOUD FOR HEALTHCARE
LVL 4
VIDEO: THE CONCERTO CLOUD FOR HEALTHCARE

Modern healthcare requires a modern cloud. View this brief video to understand how the Concerto Cloud for Healthcare can help your organization.

I'm new to, and using Git. I have my remotes/origin branch of "master" that contains all production-ready code.

From "master", I create a new local branch called "Bug Fixes".

When I try to push code changes in Bug Fixes back to "master", I get this error every time:

Error encountered while pushing to the remote repository: Not a valid reference 'origin/master'

Maybe I'm not using this correctly? Can someone please advise?
0
Many web pages get some crummy, unreadable, text.

Attached is PhpMyAdmin.

I have been told it's my default font that's broken.

Can anyone tell me how to change that?

Thanks
0
Hi Experts,

I am getting the below error msg while installing maven plugiin.
Is there any to solve this issue

Error Messages:

    From: m2e - Maven Integration for Eclipse (includes Incubating components) 1.8.0.20170516-2043 (org.eclipse.m2e.feature.feature.group 1.8.0.20170516-2043)
    To: org.eclipse.m2e.refactoring [1.8.0.20170516-2043]

i tried the below link,no luck
http://ourerrorcodes.blogspot.in/2015/05/error-javaee-solved-m2e-maven-dependency-plugin-install-eclipse.html

Thanks
0
I'm using Visual Studio Team Services for my source code respository.

I have a project AA that has it's own visualstudio.com location, but when I went to add another project BB on the same PC with a different location, it said it was already loaded under the other project AA's TFS location. Of course, I have never published my other project BB to that project AA, that would really mess things up.

I tried using Team > Disconnect from TFS to remove this project BB, but it says that will close all solutions that use TFS. So I said no.

I am able to go to Team Explorer > Manage Connections and add my other project BB's visualstudio.com repository,  I added the path to this project BB's directory and it shows on the HOME.

If I go to visualstudio.com  for BB there is no code there, just a BuildProcessTemplates folder.

When I go to Connect, it shows a Local Git Respository with my other project AA. When I try to ADD and use the Path to this Websolution BB,  it has "No new repositories were found."

When I go to NEW and try to create one with this path to BB it says:
The folder *** already exists and is not empty. Choose a new folder or an empty folder for the cloned repository.

How do I take an existing project BB, and add it to TFS? It's the one that contains existing source code.

thanks!
0
I want to keep all the lines that start with a + or a - but delete all other
lines in a file. I see a ready receipe for ^[+-]. that I could use to delete those
lines. But I want to keep them and delete all the ones. What's the mojo?
Thank you.
0
We are trying to migrate from 2010 to o-365 and we have SSRS reports in 2010, so we to have establish the connection between  Visual Studio and o-365,  so that we put the output of the report in O-365.
0
Hello,
I have submitted Selenium and Eclipse questions and they were never answered.  
There are many topics that are "Proposed."
My assumption is that EE does not have Experts for these topics.  Is my assumption correct?
0
Visual Studio 2015 is not letting me set breakpoint in javascript in code in front.

I am clicking on the left furiously and nothing happens. It just won't create the break point.

Any ideas what I'm doing wrong? I have done this in the past, but it just hasn't worked lately.

thanks!
0
Hi,
I am trying to use an SDK that is developed as a .NET DLL in Visual C/C++ in a Java development environment using Netbeans.

I want to use JNA and have been using the JNAerator to generate the java classes using the .h file of the library that I have received with the SDK. I think I have overcome the compile errors in the library and am now trying to get a sample program running. But when I call the functions it gives me all kind of errors. First of all the functions need to be called with pointers to structures that are being filled. I am not able to get java compiled without warnings/errors.

Is there anybody that has experience with using JNA and C/C++ dlls in Netbeans?
0
Free Tool: Port Scanner
LVL 9
Free Tool: Port Scanner

Check which ports are open to the outside world. Helps make sure that your firewall rules are working as intended.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

I am using the visual debugger in PythonWin on a Windows 7 platform with Python 2.7.  I am not using pdb.  I'm trying to debug code written by someone else.  I have set some breakpoints and am stepping through the code.  There are some for-loop variables in the code.  As I go through the code I would like to see the changes to these values.  However, they don't seem to change.  If I execute a print in the Interactive Window I see the correct value.  But all I see in the list of values in the visual debugger is the initial value.

Is there something I need to do to get the variables to refresh every time they are updated?

Any help would be much appreciated.  There is not a lot of documentation on the PythonWin visual debugger which is easier/quicker to use than pdb ... if I knew how to use it!  ;-)

Thanks.
0
Hi

I have created a new JavaFX project.

There is JavaFXApplication1.java that has been created initially, and I have added a JFrame which is now called NewJFrame.java.

How can I open and show NewJFrame.java when I run the project?

Instead of showing the standard form from the JavaFXApplikaction1:

public void start(Stage primaryStage) {
        Button btn = new Button();
        btn.setText("Say 'Hello World'");
        btn.setOnAction(new EventHandler<ActionEvent>() {
            
            @Override
            public void handle(ActionEvent event) {
                System.out.println("Hello World!");
            }
        });
        
        StackPane root = new StackPane();
        root.getChildren().add(btn);
        
        Scene scene = new Scene(root, 300, 250);
        
        primaryStage.setTitle("Hello World!");
        primaryStage.setScene(scene);
        primaryStage.show();
    }

Open in new window


Or would it also be possible to convert JavaFXApplication1 into a form that I can edit using the netbeans form editor gui?

Thanks
0
Hi

I have created a simple app just showing a JFrame with a button.

But when starting it I get an error that I can not run the self signed app ("Security Settings block execution of self signed app")

I have added the path to the jarjnlp file to the java control panel exception list (various versions with forward, backward slashes etc) but no success.

How can I run that application?

Thanks
0
I open my visual studio 2010 load a website and all toolbox controls are grayed out..

How can I enable them?

Or how do I start a new project with the controls enabled?

Any ideas?
0
Hello,
I had/have Eclipse Neon 2 installed.  I then "had" to install IntelliJ.  When I installed IntelliJ I gave it a separate workspace path.
I installed IntelliJ because I want to learn it, yet at the moment I need to do my work on Eclipse Neon2.
It appears that Intellij has invaded the workspace of Eclipse Neon2.
I do not want to uninstall IntelliJ.  So what might be an easy fix?
Or do I need to uninstall IntelliJ?
0
Hi everybody.
I'm new to Java and I'm playing with a small project, just to start. Using Netbeans IDE, I wanted to import org.apache.commons.lang3.StringUtils, so I followed following steps:

1) right click on Libraries node in Projects panel
2) choosen Add JAR/Folder
3) added commons-lang3-3.5.jar file downloaded from Apache site
4) run the project (everything's fine)
5) Clean & build to create my small jar file

Then I used jSmooth to convert the jar file to a Windows executable and after some test I activated the debug option and there I saw that  I had this error:
Exception in thread "AWT-EventQueue-0" java.lang.NoClassDefFoundError: org/apache/commons/lang3/StringUtils

Open in new window


Netbeans doesn't raise any error at all but conversion makes the exe raise that error and the code after the line where StringUtils is used is not executed...

Any idea?
Thank you for any help :)
0
Hi,
what are eclipse shortcuts for


how to extract some code to separate metod
how to put in a loop sysout

how to move whole method up and down

how to find call hierarchy and how it is different from type hierarchy and find references

please advise
0
hi,

while importing as existing maven project i see some projects have single pom.xml some other projects have top level pom and also sub level pom.xml as well. why we need like parent pom and child pom kind of structure for some projects?
please advise
0
If i am to choose between Visual Studio Pro of Microsoft and KOMODO IDE of ActiveState.  which is one would be a better IDE based on your experience. price should not be a factor.
0
Independent Software Vendors: We Want Your Opinion
Independent Software Vendors: We Want Your Opinion

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

I had this question after viewing Open a file from Powerbuilder using Windows default associated program.


I have used ShellExecuteW in my powerbuilder application to open any type of files on double click. The function/application works absolutely fine while running through powerbuilder, but terminates when i run thro PBD and EXE  with 0007 termination error-Unresolvable external linking reference to ShellExecutew .

Please let me know if i am missing anything..


below is my code

 li_rtn =GetFileOpenName("Select File",docpath, docname ,"DOC", &
                  + "All Files (*.*), *.*" )
string ls_filename, ls_null
SetNull(ls_null)
ls_filename=docname

//declared this external function-so calling it here
//ShellExecuteW( handle( THIS ), "open", ls_filename, ls_Null, ls_Null, 1)

In global external functions of userobject,have declared it as below
FUNCTION long ShellExecuteW( ulong hWnd, string Operation, string lpFile, string  lpParameters, string lpDirectory, int nShowCmd ) LIBRARY "shell32.dll" Alias For "ShellExecuteW"
0
I'm used to building any C++ projects in Visual Studio, but I'm taking an online course and I need a generic gcc compiler, so I'm using Eclipse.

I added the C++ add-on to Eclipse (Kepler for Java), and I now have C++ projects in my projects menu.  However, the standard header files for C++ are not automatically in my path.  I found iostream, and so I manually added the include path:

D:\Program Files (x86)\Microsoft Visual Studio 12.0\VC\crt\src

Should these be in the Visual Studio path?  Doesn't Eclipse have it's own version of the files?  The problem is that 'std' is not recognized by Eclipse.  Is that in an include file?  I expected that to be part of the compiler, but I can't find any files that fit.  While I found iostream, vector and many others cannot be found.  Eclipse doesn't recognize 'vector', the std namespace and size_t.  And the whole project only has 44 lines of code so far!

Where are all the standard header/other files supposed to be for Eclipse to finish building my C++ project?

Thanks!
0
My Outlook vbaproject.Otm file has dozens of modules and classes. I want to export them periodically for a another project I am working on.

I found bunches of code that will automate export for Excel modules, but no luck for Outlook.

I even found a 2004 post from the famous Sue Mosher saying she did it manually when needed.

I have a solution but it requires several manual steps, but I hope somebody has an easier way.


My solution is to use Outlook IDE control P then selected Code and "Current Project". Setup used "Microsoft Print to PDF" with 11x15 landscape (long lines of code won't split).  

I also tried "print to file" but that did not seem to work.

After creating the 298 page PDF, I opened it with Foxit Reader and Saved as TXT.

The resulting TXT looks pretty good and a simple program could create multiple BAS modules. But before I do that I want to see if anybody here has already done something similar.

Each of my TXT pages start with 4 lines that look like this:

----------------------- Page 148-----------------------  top line has the PDF's page number
                                                                          2nd line is always blank.
mdlMicrosecondTimer - 8                                  3rd line has the module's name and page number
                                                                         4th line is always blank.
                                                                    …
0
Hi,

i wonder what are differences between sorce folder and folder in eclipse. When to use which one. please advise
0
I am trying to learn JavaFX, and one of the very important controls, TableView is not displaying correctly, even though it compiles and runs without errors:
TableView not displaying correctly
I am expecting the DATA to show up in the rows and columns of the table.


My code:
1. Main class: (Also setting values for the properties of Product class here)
package tableviewdemo;

import javafx.application.Application;
import javafx.collections.FXCollections;
import javafx.collections.ObservableList;
import javafx.scene.Scene;
import javafx.scene.control.TableColumn;
import javafx.scene.control.TableView;
import javafx.scene.control.cell.PropertyValueFactory;
import javafx.scene.layout.VBox;
import javafx.stage.Stage;


public class TableViewDemo extends Application {
    
    // You need to make a list of objects for the tables, and then convert them into ObservableList
    // (Objects -> ObservableList -> Table)
    
  
    public void start(Stage primaryStage) {
        
        // This is the entire table:
        TableView table;
        
        // (At least one column defined)
        // Name column:
        TableColumn<Product, String> nameColumn = new TableColumn<>("Name");  // Name column header is passed in constructor
        nameColumn.setMinWidth(200);  // If not specified all the columns are bunched together
        nameColumn.setCellValueFactory(new PropertyValueFactory<Product, String>("name"));  
                // It has to be the EXACT NAME as your property 

Open in new window

0
I have seen a lot of wannabe's out there, and each one fails in some fundamental way.

I am looking for an IDE, set of libraries, and whatever else is needed to allow for cross platform and cross browser application design and development for an app that will run on the desktop (Windows/iOS) in the form of a web browser app, and on mobile (Android)  in the form of a hybrid app such that:

  • UI design is WYSIWYG (as much as possible)
  • Core code base is shareable across the board
  • Minimizes the need to manually code HTML5 and CSS3
  • Gracefully handles the organization, design, debugging and management of Javascript
  • Lends itself well to team development

Has anyone found such a magical thing?  Please advise.  Thanks!
0

Editors IDEs

24K

Solutions

19K

Contributors

Development in most programming languages is frequently done with an editor or integrated development environment (IDE). An IDE is a software application that provide comprehensive facilities to computer programmers for software development. An IDE normally consists of a source code editor, build automation tools and a debugger. XCode, Visual Studio, Adobe Dreamweaver and Eclipse are some of the more popular development tools, but an editor or IDE can be anything from simple text editors to sophisticated programs. Related topics: All programming and development language, database and web based content management systems topics