Email Servers

24K

Solutions

21K

Contributors

Within Internet message handling services (MHS), a message transfer agent or mail transfer agent (MTA) or mail relay is software that transfers electronic mail messages from one computer to another using a client–server application architecture. A MTA implements both the client (sending) and server (receiving) portions of the Simple Mail Transfer Protocol (SMTP). The terms mail server, mail exchanger, and MX host may also refer to a computer performing the MTA function. The Domain Name System (DNS) associates a mail server to a domain with mail exchanger (MX) resource records containing the domain name of a host providing MTA services.

Share tech news, updates, or what's on your mind.

Sign up to Post

I need to find the log that contains all the connections and inbound email that was delivered for exchange 2016.  I've been unsuccessful so far finding this log.  It is possible it is not enabled.
0
Why Diversity in Tech Matters
LVL 13
Why Diversity in Tech Matters

Kesha Williams, certified professional and software developer, explores the imbalance of diversity in the world of technology -- especially when it comes to hiring women. She showcases ways she's making a difference through the Colors of STEM program.

Can someone please help with the folowing request:

User1, 2 and 3 need to share the same assistant. She needs to get all the meeting requests forwarded to her since she will be managing the calendars.

How can we get that done with Exchange?

Thanks
0
Can not install or remove exchange 2016. I was installing CU12 and the update crashed. I tried to rerun the update but got errors. I followed the suggestions (https://exchangemaster.wordpress.com/2010/08/11/cannot-install-or-uninstall-an-exchange-role-after-a-failed-disaster-recovery-install/)
The server was in a DAG. I removed it from the DAG. Exchange powershell doesn't work on the server.  the error message I get when I run the recover/setup is:

 Error:
The following error was generated when "$error.Clear();
          & $RoleBinPath\ServiceControl.ps1 -Operation:DisableServices -Roles:($RoleRoles.Replace('Role','').Split(',')) -SetupScriptsDirectory:$RoleBinPath;
          & $RoleBinPath\ServiceControl.ps1 -Operation:Stop -Roles:($RoleRoles.Replace('Role','').Split(',')) -IsDatacenter:([bool]$RoleIsDatacenter)
        " was run: "System.Management.Automation.PSInvalidOperationException: Cannot find the Windows PowerShell data file 'ManageScheduledTask.Strings.psd1' in directory 'C:\Program Files\Microsoft\Exchange Server\V15\Bin\en-US\', or in any parent culture directories.".

The en-US directory doen't exist. I scanned the V15 and sub directories for the missing file. I doesn't exist.

Thanks for the help
0
We have a problem with some users sending emails to an external email address and CC'ing an internal group (AddDev). The external user receives the email with the CC containing "AppDev"  I know an internet address will replace the "AppDev" if the group document contains an internet address (appdev@domain.com). In this case "AppDev" does not contain an internet address.

I know, if the user remembers, can click on "More - Expand Public Groups" will replace "AppDev" in the CC with the user names within that group.

Is there a way to eliminate the user having to click "More - Expand Public Groups" and have the server automatically do it if the is being externally sent?
0
I have some Win XP machines that are used for connection to an older ERP. They use Outlook 2010 with all the latest updates. We were on an Exchange 2013 email platform and it was working. Our email provider recently migrated to Exchange 2016 and now the Windows XP computers cannot connect. When adding a new profile and connecting as an Exchange over https client, an error is received that 'must be connected or online'. We have run the commands on the server to specify the certificate used for connection, but this has not resolved the issue. Is there any other options for settings on the computer or the server that may help?
Thank you
0
We have to be PCI compliant and on the PCI comliance report, I have an issue with port 465 and my exchange cert.  Not sure why it's throwing an error, but
it's complaining about a self signed cert.  I'm running exchange 2016, and in my certs section, there are 4 certs, one is invalid, expired.

The multiple names certificate is my good, or real, valid cert, from Godaddy. The report is complaining about either the  wmsvc-sha2 cert or the other,
my question is, can I delete every cert here except my multiple name certificate?   Will that cause any issues to mailflow, or OWA?

Not sure how to resolve this issue?  Any thoughts?

elisha is the name of my exchange server.

Exchange certs
cert

PCI error
PCI error
0
Dear Experts, which ports do we need to open in an Exchange servers?

Attachment is the results of "netstat -aon" commands in our servers. Can you check and suggest some abnormal ports?

Many thanks in advance!
Desktop.zip
0
Hello can someone please help me to get a report of the active users and their mailboxes. I am looking for something like this

Name lastname username mailbox

I am using powershell and exchange cmdlets

Thanks
0
We are trying to reduce our monthly overhead and are paying a host (similar to GoDaddy) an excessive monthly fee for doing nothing.

We have one domain that has mail DNS records going to Office 365 and web DNS records going to Wix.  

The other domain also have mail DNS records going to Office 365 and has no other function.  

It seems that we can't just transfer the domains into Office 365 (not supported) and don't want them parked (because we want to use them).  

So I am not sure what I am looking for, yet we have a home Ubuntu server available or are wiling to pay a provider a lower cost per month just to hold our domains?  

Any recommendations?
0
<?php
require("class.phpmailer.php");
$mail = new PHPMailer();$mail = new PHPMailer();
$mail->IsSMTP();
$mail->Host = "smtp1.example.com;smtp2.example.com";
$mail->SMTPAuth = true;
$mail->Username = 'smtpusername';
$mail->Password = 'smtppassword';

$mail->From="mailer@example.com";
$mail->FromName="My site's mailer";
$mail->Sender="mailer@example.com";
$mail->AddReplyTo("replies@example.com", "Replies for my site");

$mail->AddAddress("email@example.com");
$mail->Subject = "Test 1";

$mail->IsHTML(true);
$mail->AddEmbeddedImage('logo.jpg', 'logoimg', 'logo.jpg'); // attach file logo.jpg, and later link to it using identfier logoimg
$mail->Body = "<h1>Test 1 of PHPMailer html</h1>
    <p>This is a test picture: <img src=\"cid:logoimg\" /></p>";
$mail->AltBody="This is text only alternative body.";

if(!$mail->Send())
{
   echo "Error sending: " . $mail->ErrorInfo;;
}
else
{
   echo "Letter is sent";
}
?>

Open in new window



im looking at this example,

how can i use this for inline images copied into the email body and how can i even tell if their is a img in the body ?

cause not all users will embed a image inline on email ?
0
Ensure Business Longevity with As-A-Service
Ensure Business Longevity with As-A-Service

Using the as-a-service approach for your business model allows you to grow your revenue stream with new practice areas, without forcing you to part ways with existing clients just because they don’t fit the mold of your new service offerings.

I have a request to replace existing Primary SMTP in exchange environment with name.surname@domain.com

I am trying to build a powershell script that will pass by every user, check their existing Primary smtp if it's SMTP:name.surname@domain.com

If it's like this it'll write-host User has name.surname format and will show the user's primary SMTP address

If not then the script will change Primary SMTP to secondary and add Primary SMTP name.surname@domain.com

I would appreciate if anyone could help me with this .

Thank you
0
Hi,

I'm trying to setup a printer to use scan to email, but I need it to be able to email external email accounts - It can scan internally ok but not externally, any know what I'm missing here?  Exchange Server is on premise 2010.

Cheers
0
Is there a way to access exchange 2013 EAC or powershell after certificate was revoked? My SSL certificate was revoked and I have to install the new one, but when I tried to open EAC, i get certificate revoked error, and when I try to open powershell, I get access denied error.
0
I have been blessed with the task of learning and troubleshooting evault enterprise server 12. So far things are going well but I have a few issues that I have been asked for assistance.

In our environment we have several users at any given point whose local vault cache we have to reset, because the Outlook client stops connecting to the server. In some of those cases building a new outlook profile works also.

I have searched the event viewer logs and cannot find anything really consistent with what is occurring (mind you I am not there when this occurs). All I hear is the last time the Outlook client (version varies 2010, 2013 and 2016) was such in such date and now it's not syncing. Consequentially, we copy all the items out of the "to archive" folder up to the exchange mailbox and reset the vault cache.

One last thing, the Exchange portion works in cached mode or in online mode. Any leads on how to attack this issue
0
I am facing issue with cyrus-imap roundcube. Round cube is taking long time to login and loading very slow. I am using kolab-community server. can any one help me in this regards?

Thanks
0
I have a client that is using Mailenable 3.61.  I noticed today that there are emails stuck in the inbound and outbound queues.  Seems no matter what i do, I cannot get this to resolve.

I have restarted the server and the services  multiple times and still nothing.

Does anyone have any suggestions?
0
Hi

Can some one tell me the procedure of cutting over from Message Labs to Mimecast please
0
Office 365 Exchange Online Transport rules: I am attempting to prepend incoming emails with warning to our users. I am able to see plain text warning but html formatting is not coming through on emails. I am using code below..

<html>
<body>
<p><div style=""background-color:#FFEB9C; width:100%; border-style: solid; border-color:#9C6500; border-width:1pt; padding:2pt; font-size:10pt; line-height:12pt; font-family:'Calibri'; color:Black; text-align: left;""><span style=""color:#9C6500; font-weight:bold;"">CAUTION:</span> This email originated from outside of the organization.  Do not click links or open attachments unless you recognize the sender and know the content is safe.</div><br></p>
</body>
</html>


Any ideas on how to get this to show up correctly in Outlook?


Example of formatting referred to in question
external.png
0
We have a Send Connector that sends all email for a specific domain to a sharepoint smtp server. This configuration has been in place for some time now but it only has one HUB Server configured as the Source Server. We would like to replace this server and add more for redundancy.

Steps taken so far:
Sharepoint Team confirmed they added the new HUB server IPs to the allow list
Tested telnet from HUB servers. works ok
Added the new servers to the Source Server tab and removed the old one.

Issue is we noticed emails were starting to queue up on all HUB servers for this Send Connector in this site with the below error message. Some of the servers it queued on were not added to the source server tab for the connector.

451 4.4.0 Primary target IP address responded with: “451 5.7.3 Cannot achieve Exchange Server authentication.” Attempted failover to alternate host , but that did not succeed. Either there are no alternative hosts, or delivery failed to all alternative hosts.
0
Python 3 Fundamentals
LVL 13
Python 3 Fundamentals

This course will teach participants about installing and configuring Python, syntax, importing, statements, types, strings, booleans, files, lists, tuples, comprehensions, functions, and classes.

I have a 2010 exchange with clients running outlook 2010, when I try to use the out of office in outlooks it tells me that it is no available but it work in owa, what is wrong?
0
We are trying to create two generic ID files in Domino admin for registering person docs (Registering New users) and re-certify user certificates which are expired. Current issue is we when we create a new person document with ID file and grant access to Admin server and try creating a new lotus domino account, we are unable to view list of certifiers to select.

When we try to modify recovery authorities but it fails and does not resolve the current issue, When we try to Modify certifiers and try to remove administrators its giving an error  “Cannot locate user certificate. Make sure server contains your certificate for encryption”. I also tried copying the person document of that administrator back into their directory and followed the same steps which did not help me.

Can any one help me at the earliest as its very important to us?2019-03-28-09_35_36-2019-02-10-10_46.png
0
Hello Team,

I am trying to setup a weekly reporting for the below. Can someone please help me in getting the below items in one script?
Its for Exchange 2016 environment.

Top Mailboxes by size
Top Senders by quantity - Would like to list top 10 senders by quantity. Sender Name and Quantity
Top Receivers by quantity - Would like to list top 10 receivers by quantity. Receiver Name and Quantity
SPAM statistics
Total Mail statistics

Thanks
Krish
1
How to decide to set dmarc to quarantine or reject? I am reviewing the dmarc reports but don't know what to set. Right now is set to none for collecting dmarc reports. What to do?
0
Hello -

I'm trying to figure out if our email delivery measures are set up correctly.

We use Office365. With that being said, is it necessary to add our public IP address into the SPF record? Would it help with anything or it's enough to add "v=spf1 include:spf.protection.outlook.com"

Second,

When emails are sent internally, analyzing the 'header', it says dkim=none (message not signed), dmarc=none. Is this normal? I do see the correct info when sending to external address, though.

Thank you for your help!
0
We have a 3 server Exchange 2013 CU 18 DAG, running on MS Server 2012 R2. We require our users request their devices be allowed after connecting them to active sync. The last couple of weeks I have noticed a major delay between approving the device and the approval being effective in exchange. I have checked the resource utilization and nothing has changed up or down. However, the delay seems to be getting worse as time goes. I have also reviewed the network settings on the server and our bandwidth has not changed either.

Troubleshooting I have done:
I have updated and rebooted all 3 servers, and reviewed logs and cannot find any errors. Other than the extreme delay between granting access to the devices and it being effective.
0

Email Servers

24K

Solutions

21K

Contributors

Within Internet message handling services (MHS), a message transfer agent or mail transfer agent (MTA) or mail relay is software that transfers electronic mail messages from one computer to another using a client–server application architecture. A MTA implements both the client (sending) and server (receiving) portions of the Simple Mail Transfer Protocol (SMTP). The terms mail server, mail exchanger, and MX host may also refer to a computer performing the MTA function. The Domain Name System (DNS) associates a mail server to a domain with mail exchanger (MX) resource records containing the domain name of a host providing MTA services.