Exchange

202K

Solutions

72K

Contributors

Exchange is the server side of a collaborative application product that is part of the Microsoft Server infrastructure. Exchange's major features include email, calendaring, contacts and tasks, support for mobile and web-based access to information, and support for data storage.

Share tech news, updates, or what's on your mind.

Sign up to Post

I have a 2 node DAG Exchange 2013 CU19.
I am trying to delete any email older than 1/1/2016 for a specific user, but no matter what I do, I get nothing from searchquery filtering.
I Have confirmed Roll group Membership for Discovery Management and Mailbox Import Export.
I tried every format of double and single quotes for the date, and could not find anything.
I then tried to remove something from my mailbox, and get the same thing.
I sent me an email with subject test, and can not find it either.

I have tried:
search-mailbox -identity ttaylor -searchquery subject:test -estimatresulteonly
search-mailbox ttaylor -searcquery subject:test -estiamateresultonly
search-mailbox -identity ttaylor -searchquery "subject:test" -estimatresulteonly
search-mailbox ttaylor -searcquery "subject:test" -estiamateresultonly

I always get the same output
RunspaceId       : 304008d0-fa23-40d9-8867-d6ea567d5b9c
Identity         : Domain/ou/Tim Taylor
TargetMailbox    :
Success          : False
TargetFolder     :
ResultItemsCount : 0
ResultItemsSize  : 0 B (0 bytes)

Any suggestions
0
I have 2 exchange servers in a DAG.

Today the primary server we use died due to a Hyper-V error.

The other server kicked in as it should do, except nobody could use activesync.

I have checked all firewall rules and everything is set up as it should be.

I have ran Get-ActiveSyncVirtualDirectory | fl on both servers and they look pretty much identical. The only thing i noticed that at the bottom there is an "ISVALID" on the primary server it is set to true, and on our failover member it is set to False.

I have looked at MS documentation and it says "A Boolean value that indicates whether the user's Active Directory account is valid or not valid." I am logged in to the same user on boht machines and they both run app pools as local system with the WW service running local system.

What could cause this? Is it the isvalid command? Thanks in advance for any help.
0
Hi All
I need some help please.
I have 5 Exchange 2010 SP3 RU 21 servers running on Windows 2008 R2.
On 2 of my servers mail all of a sudden stops flowing to them.
There’s enough free space across all drives.
The servers are virtualized running on top of Hyper-V Server 2012.
Certificates are valid.
Server time is correct.
When I attempt to restart the transport service on the affected server it fails to stop and then you can’t start it again.
Even going via task manager and ended the exe relating to the transport service doesn’t seem to help.
The only thing that restores mail to and from this server is a reboot.
Any ideas?
0
I need to migrate my file server, sharepoint to office 365. I want to run a hybrid system, of users either connecting to 365 or on premise. i have a .local for my AD i need to know the steps on how to do it. secondly i need to know if there will be downtime during migration.
0
Exchange 2013, 3 Server DAG with 4 Databases. We are having an issue with being unable to move DB copies to certain servers. I have troubleshot the issue for months and cant seem to come up with a solution. I get the error below when attempting to move databases. The odd part is the issue goes away after a few days. I can get it to go away occasionally by moving the databases to Exchange3 then rebooting 2 and moving them to 1, but if I try to move them back to 2 at that point I get the RPC error. It hits all 3 servers occasionally and I have to either reboot all of them or just wait a few days and it goes away. I cant find anything in the event viewer related and I have verified the RPC services are functioning normally.  

error
EXCHANGE1
An Active Manager operation failed. Error: The database action failed. Error: An error occurred while trying to validate the specified database copy for possible activation. Error: EXCHANGE1:
A server-side administrative operation has failed. The Microsoft Exchange Replication service may not be running on server (MYDOMAIN). Specific RPC error message: Error 0x6ba (The RPC server is unavailable) from cli_RpcsGetCopyStatusWithHealthState
[Database: DBNAME, Server: EXCHANGE2]
0
Hi,

We have an Exchange hybrid deployment with office 365. Each user has a mailbox held on our local exchange server and then an online archive in office 365. We have a retention policy configured with:

Default Retention Policy - 30 Day Retention Tag (Default) Period 30 days, 1 Week Archive (Personal) 7 days, 2 Week Archive (Personal) 14 days, 3 Week Archive (Personal) 21 days.

So the only default is to archive the mailbox every 30 days unless specified otherwise with a personal tag.

We have had reports that some user mailboxes have started to become full and when investigating the the policy is applied to the mailbox, checked with Get-Mailbox "username" | Select RetentionPolicy. However the last time the archive successfully ran was 18/06/18, we checked this using  Export-MailboxDiagnosticLogs -Identity username -ExtendedPropertie
s | export-csv "C:\export.csv". The ECLLastSuccessTimestamp is 18/06/18. Compared with archiving mailbox this is the same day so today for a successful user is 15/08/18. Other mailboxes affected are around the same time 18/06 19/06. We have tried running the MFA manually on a few of the mailboxes Start-ManagedFolderAssistant -Identity "Chris", this will won't make any difference, but will work on currently archiving mailboxes. For any mailbox that we run in the logs we get Cmdlet suceeded. Cmdlet Start-ManagedFolderAssistant, parameters -Identity "chirs".


We have removed the policy for 24 hours from an affected mailbox, re-added …
0
Hi all,

we have one Exchange 2010 SP3 on Server 2012 on which Update Rollup 23 (KB430733) cannot be installed.

In windowsupdate.log i see:

2018-08-15 09:26:15:494   808 a90 AU   # WARNING: Install failed, error = 0x80070643 / 0x80070643
2018-08-15 09:26:15:494   352 9c8 Handler   : WARNING: Operation failed at update 0, Exit code = 0x8024200B

Can anyone help?
0
Dear Support Experts,

We have roll back some of the users mailboxes from O365 to on premise exchange 2013.
After moving those users to on premise whenever they are replying any old emails to internal user email are bouncing back with Undelivered with below mentioned error.
 Please advice

Mailboxes name
The email address you entered couldn't be found. Please check the recipient's email address and try to resend the message. If the problem continues, please contact your helpdesk.
Diagnostic information for administrators:
Generating server: MAIL2.domain.com
IMCEAEX-_o=ExchangeLabs_ou=Exchange+20Administrative+20Group+20+28FYDIBOTH23SPDLT+29_cn=Recipients_cn=d3988943315e84b678bbef4c80d42b65a-Komalkar@domain.com
Remote Server returned '550 5.1.1 RESOLVER.ADR.ExRecipNotFound; not found'
Original message headers:
Received: from MAIL01.domain.com (191.16.10.21) by mail2.domain.com
 (172.16.10.53) with Microsoft SMTP Server (TLS) id 15.0.1365.1; Wed, 15 Aug
 2018 10:50:35 +0400


Thanks
0
Hi All,

I need some help in performing Exchange mailbox export as Username@emaildomain.com for each member of the .CSV file as the input?

The input CSV file content from the HR department only contains one column with First Last name format:

user
John Herschel
Mark Sunderland
Cory Jones
Alex Ho
Sue Chen
Lin Fang
....

Open in new window


So any help to modify the below PowerShell script would be greatly appreciated.

Issue 1: How to make sure the input.CSV can match the Display Name of the Exchange mailbox?
Issue 2: How to export the mailbox that failed to process as .CSV file list so I can manually export the .PST?

#Import remote session with exchange on my laptop where Outlook is installed
$Session = New-PSSession -ConfigurationName Microsoft.Exchange -ConnectionUri http://PRODEX02-VM/Powershell/ -Authentication Kerberos
Import-PSSession $Session

$ServerBackupUNCPath = "\\BACKUP\OST\"
$CSVPath = "\\computername\c$\users\user\desktop\users.csv"

try{
	$AllMailboxes = Import-CSV $CSVPath
	foreach ($mbx in $AllMailboxes) { New-MailboxExportRequest -Mailbox $mbx -FilePath "$ServerBackupUNCPath$($mbx.Alias).pst" -baditemlimit 50 -acceptlargedataloss; while ((Get-MailboxExportRequest -mailbox $i | Where-Object { $_.Status -eq "Queued" -or $_.Status -eq "InProgress" })) { Start-Sleep 120 } }
	
	Write-Host "Processing...........$mbx.Alias................" -ForegroundColor Green
}
catch{
	Write-Host "Exception has occured processing....$mbx.Alias...." 

Open in new window

0
Environment

Off Ver     : Office 2013
Exch Ver  : Exchange 2013


This is not a new or odd request, but I haven't seen any workarounds to achieve it.

Scenario
An employee calls their manager to report they aren't coming in due to illness.
The Manager wants to be able to set an Out Of Office reply for that subordinates mailbox.  
The Manager doesn't have (and doesn't want) delegated access to the employee's mailbox.

For obvious reasons the manager doesn't have the employees credentials to be able to log in as the employee and set the Out Of Office Reply on behalf of the employee, but would like to be able to without the need of the employee login.

Has anyone seen /developed a method or workaround to achieve this?
1
Hello everyone,

can someone help me with this request ? I'm look for a script how to get all folders permission on all mailboxes  of exchange 2010?
0
OWA receives an email with a valid link, but it is not hyperlinked.
When forwarding message the hyperlink lights up and is clickable, but not on the original message.
Would like to know how to get OWA to see the link as accessible the first time around and simply click on it to access.
0
Hi Guys, I need help!

Have a Microsoft Exchange Exchange environment with Hybrid with Microsoft Exchange Online.

The client has multiple e-mail address policies, we installed a new Exchange Server 2013 in a new DataCenter through an attempt to create a new policy for a new domain, the problem that is not displaying to the Domain Controller OU.

In the old CAS I can see normal as OR.
0
In the process of migrating a SBS 2011 domain to Servre 2016, Exchange and SharePoint were removed to clean up AD.  However, a short time later several SP users cried ouch that some of their data had not been moved.  By then, the backups for the server had been aged off.  SharePoint was re-installed, but it also crashed all of the web services on the server.  Certainly getting those going would be great, but after a whole lot of time and energy, we tried a different tack: created a new, fresh SBS and am attempting to attach the content database from the original server.

The obvious way to do this, I believe, would be to back up the database, create a new instance on the new SBS, and import the data.  Well, that didn't go so well.  The attempt to back up the database on the old server keeps failing.  So plan B -> copy the data base to the new SBS, attach it as content database, but of course it has no usable credentials on the new server.

Here are my questions:

1. How do I take ownership of the database with credentials from the new server?
    I looked at some of the PowerShell commands but they require -identity and I can't come up with that from IE where I am supposed to see it I think.

2. How can I get it to backup on the old server, and would import then solve the problem?
    I have no idea why I am getting an error on backing this up; the newer content database backs up just fine.

3. How can I fix the web services on the old computer?
    Well this …
0
I need to create a shared calendar in Exchange 2013 that people can share specific events in their personal outlook calendar with.  What is the best way to do this?  Can a shared mailbox accept meeting requests?
0
I am using Veritas BackupExec 20, running on a SAS-connected tape library drive currently in trial mode and trying to run an Exchange backup. I have 3 Exchange servers in a DAG and all databases are mounted, healthy and have no failed replicas. We are using Exchange 2013, updated within a month of the most current CU. Two of the servers are running Enterprise and the third runs SE. The three servers are "MD" and "MT" (The enterprise ones) and "PM" is running SE. I currently have the databases running on the "MT" and the "PM" servers because the backup wants to use the passive copy, which is on the "MD" server and is in the same room with the tape drive, so will have the shortest backup time (There would be network congestion issues trying to back up 6TB over the links to the other servers!). When I run the backup, it gets the first two and a half TB then quits with this error:

Completed status: Failed
Final error: 0xe0008516 - The database specified for the snapshot was not backed up because the database was not mounted.
Final error category: System Errors

For additional information regarding this error refer to link V-79-57344-34070

and that error leads to this error in the job log:
V-79-57344-34070 - Snapshot Technology: Initialization failure on: "Microsoft Information Store". Snapshot technology used: Microsoft Volume Shadow Copy Service (VSS).

Snapshot technology error (0xE0008516): The database specified for the snapshot was not
0
I have a particular problem I'm trying to troubleshoot. I am looking for a powershell script to search a particular mailbox to figure out how many messages are in the inbox that were received on a particular day. I know I can get some info from the transport log powershell scripts but I would like the data directly from the user's inbox vs the transport logs. Any help is appreciated! We are running exchange 2010.
0
I'm trying to search for eamils that contain a specific attachment. When I ran the script below, I believe it grabbed any emails that contain attachments that contain any words in the name of the attachment in the script, not the entire phrase "This is a test*"


How do search for the exact phrase?

get-mailbox -ResultSize unlimited | search-mailbox -SearchQuery 'Attachment:"This is a test*"' -TargetMailbox mailbox -TargetFolder foldername -LogLevel full
0
Hi

We have exchange 2017 and we have built exchange 2013 and doing a Hybrid migration.
Please see the attached snapshot and the errors  on this batch with  2 failed migration to 0365.
Please let me know how to troubleshoot an migrate this mailbox to 0365 successfully
Thanks and any help will be great.
User1-MB-Migration.jpg
0
Hi there,

On my Exchange 2016 environment, I have to set the user mailbox maximum outgoing message size as 0 (EAC>Mail Flow Settings > Message Size Restrictions > Sending message size). At the same time, the auto-reply message could not send out. Is there a way to make the OOF(auto-reply) happened?

Thanks!
0
Hello Experts, I have Exchange 2013 CU20, with AD2012 R2. I have setup AAD Connect with pass-through authentication, enabled Modern Auth, Single Sign on, and enabled Password hash synchronization aswell on the AAD connect servers. I have also ran the Exchange hybrid configuration wizard, with centralized mailflow. We have a few authoritative primary domains in on-prem which user accounts are stamped with. I have added and verified these domains in our Office 365 tenant. and the user objects/ identities are being replicated to Azure AD just fine. since the users will be doing pass-through authentication and will not be leveraging our on-prem ADFS, i believe leaving the domains as managed in Office365 will be fine?

i assume this will be fine? My question is, i know if a domain is federated, and if it is added in Office365 tenant as a federated domain, it needs to become federated with the switch  -SupportMultipleDomain. Does anything similar to that need to be done for the domains that are showing as managed in Office365 portal, if we have multiple domains added in Office 365 as managed? I could not find any Microsoft article that talks about this, and wanted to make sure.

Please let me know, thank you in advance
0
Hello Experts. I have Exchange 2013 CU20 with AD2012R2 in my environment. I would like to go to CU21 for Exchange 2013. I have a few questions:

1. Although I see that /PrepareSchema is not required according to this article: https://blogs.technet.microsoft.com/rmilne/2018/06/19/exchange-2013-cu21-released/
    is there any harm in running /prepareSchema?

2. I tried to do a /prepareSchema in my staging env DC, and received an error stating that i need to install 'Visual C++ Redistributable Packages for Visual Studio 2013' before running the command. Do i really need to install this on my DC aswell if i would like to do a /PrepareSchema? I will do a /PrepareAD prior to installing CU21, i believe that /PrepareAD will through the same error that it needs 'Visual C++ Redistributable Packages for Visual Studio 2013' before running the command. I am not a big fan of installing extra piece of software on DC's, is there any other way of going about this?

3. According to this kb: https://support.microsoft.com/en-us/help/4099855/cumulative-update-21-for-exchange-server-2013  i see that .Net Framework 4.7.1 is now required. we are currently on .Net Framework 4.6.2 . Do I need to install 4.7.1 myself first prior to running CU21, or will CU21 install the required .Net Framework 4.7.1 itself during the update?

4. According to the above kb, it also mentions that 'Visual C++ Redistributable Packages for Visual Studio 2013', is required. will CU21 update install this component …
0
With Skype for Business/Exchange Online, and a conference room that has a Polycom group Series, how do you logistically use that for Skype Meetings?
Is the Polycom supposed to “be the room” and this you name it the name of the room?  
Or do you create a room for the “room” and create a second “resource” for the Polycom Skype device?  
Further, when you schedule Skype meetings, would there ever be a need to send FROM the top or FROM the Polycom Skype Calendar, as in manually creating the event on the calendar. Or does a Meeting Organizer always simply add the Room and/or Skype enabled Polycom device AS an additional “recipient” in the meeting invite?
0
Get-Mailbox -ResultSize Unlimited | Where {$_.EmailAddresses -like "*@domain_name.local"} | Get-MailboxStatistics | FT DisplayName,TotalItemSize

Two issues:
1.) Only pulls up the first 4 names out of more than 20.
2.) How to export to text?
0
I want to make sure my SSL is configured correctly for my environment.  checklist.com says I do not have TLS or certs setup correctly.  I have attached a PDF of my Exchange config.  Where do I start?

looking up MX hosts on domain "sfmx.org"
•exchange.sfmx.org (preference:10)
•smtp.sfmx.org (preference:20)

Trying TLS on exchange.sfmx.org[207.242.48.212] (10):

test stage and result

[000.080]  Connected to server
[000.158] <--  220 exchange.sfmx.org ESMTP Service ready
[000.163]  We are allowed to connect
[000.163]  --> EHLO www6.CheckTLS.com
[000.249] <--  250-Requested mail action okay, completed
250-SIZE 20000000
250-AUTH NTLM
250 OK
[000.250]  We can use this server
[000.250]  TLS is not an option on this server
[000.251]  --> MAIL FROM:<test@checktls.com>
[000.335] <--  250 Requested mail action okay, completed
[000.335]  Sender is OK
[000.335]  --> QUIT
[000.409] <--  221 Service closing transmission channel
 
Trying TLS on smtp.sfmx.org[207.242.48.212] (20):

test stage and result

[000.071]  Connected to server
[000.150] <--  220 exchange.sfmx.org ESMTP Service ready
[000.151]  We are allowed to connect
[000.151]  --> EHLO www6.CheckTLS.com
[000.224] <--  250-Requested mail action okay, completed
250-SIZE 20000000
250-AUTH NTLM
250 OK
[000.224]  We can use this server
[000.225]  TLS is not an option on this server
[000.225]  --> MAIL FROM:<test@checktls.com>
[000.298] <--  250 Requested mail action okay, …
0

Exchange

202K

Solutions

72K

Contributors

Exchange is the server side of a collaborative application product that is part of the Microsoft Server infrastructure. Exchange's major features include email, calendaring, contacts and tasks, support for mobile and web-based access to information, and support for data storage.