FreeBSD is a free Unix-like operating system that is a direct descendant of BSD. FreeBSD contains a significant collection of server-related software in the base system and the ports collection, it is possible to configure and use FreeBSD as a mail server, web server, Firewall, FTP server, DNS server and a router, among other applications. Although FreeBSD does not install the X Window System by default, it is available in the FreeBSD ports collection. A number of Desktop environments such as GNOME, KDE and Xfce, and lightweight window managers such as Openbox, Fluxbox and dwm are also available to FreeBSD.

Share tech news, updates, or what's on your mind.

Sign up to Post

Running BIND9 on FreeBSD. rndc status says server is running. However, after a rndc freeze, I edited a zone file and removed some no longer needed entries. I updated the serial number so it would update the secondary server. I received an out of range error when I tried to reload the zone....and even if I try to rndc thaw the zone...I get the same out of range error.  After research on the web, It was recommended to delete the jnl file associated to the zone. Again even after that step, the reload returned an out of range error. Very cautious with updating the DNS as it's the primary for our network....

Please help. Also...It does NOT seem that my DNS is updating the secondary server.

Thank you
CompTIA Network+
LVL 13
CompTIA Network+

Prepare for the CompTIA Network+ exam by learning how to troubleshoot, configure, and manage both wired and wireless networks.

I am trying to install FreeNAS from a USB on a server and am running into all sorts of problems. I have used UNetBootIn, Universal USB Installer, and ISO to USB to try to get the ISO on the stick, but they don't boot because there is a missing boot loader.  So I did a search and discovered that the only way to install from a Windows computer was to use Win32 Disk Imager.  However, that required an .img file and all I had was an ,ISO file.  So, I used PowerISO to make a .img file from the ,ISO file.  This resulted in:

No /boot/loader
FreeBSD/i386 boot
BTX halted

Can anyone provide any insights into how I am supposed to be doing this?
How to create a md (memory disk) file in freeBSD,

basically I want to keep / ( root ) in memory and hence I want to use memory disk ( md ). Also I want to ensure that it's like that boot over boot

I created a few different zpool configs on ZFS using FreeNAS and I'm trying to figure out a way to reliably benchmark the performance.

I first tried it from a remote host connecting to an SMB share. In Windows I can't get any higher than 60 MBps. Both using a normal file copy (big file) and using various benchmarking tools. On linux I tried filling up a file using
to a smb mapped drive using a simple dd if=/dev/zero of=/mnt/cifs-share1/test1.img bs=1G count=5 There I get up to 106 MBps and then I guess I'm hitting the 1 Gbps Ethernet connection speed limit.

On to the host itself: So far I tried the default way using iozone which ships with FreeNAS. But the results seem to be high to be true so the question is how do I do it reliably and how to interpete the results?

The result I'm getting is:

    sudo iozone -i 0 -R -l 5 -u 5 -r 4k -s 10G | tee -a /tmp/iozone_results.txt
Excel chart generation enabled
        Record Size 4 kB
        File size set to 10485760 kB
        Command line used: iozone -i 0 -R -l 5 -u 5 -r 4k -s 10G
        Output is in kBytes/sec
        Time Resolution = 0.000001 seconds.
        Processor cache size set to 1024 kBytes.
        Processor cache line size set to 32 bytes.
        File stride size set to 17 * record size.
        Min process = 5
        Max process = 5
        Throughput test with 5 processes
        Each process writes a 10485760 kByte file in 4 kByte records

        Children see throughput 

Open in new window

Interestingly enough I have no problem using let's encrypt on Windows platform and figured it was going to be a breeze on *nix... Running into a slew of issues.  For one I am trying to use certbot to facilitate this.  When I issue the correct commands and webroot I see it builds the .well-known folder but it does not build the acme-challenge folder.  If I try to manually create the acme-challenge folder it deletes it after the sudo certbot certonly --webroot -w /var/www/example -d -d command (with my domain info substituted of course) with the following error:

Detail: Invalid response from
   <title>403 Forbidden</title>
Super frustrated as everything in *nix is always easier, right?  Well not this time LOL.   Any suggestions would be appreciated!


  I would like to know if there is a way to create a Symlink-like file but with the difference that the file it points to gets executed when the link is read and the output is what I get from reading it.
  It should work on freebsd/linux.


Best regards
I heard iOS is tailored from FreeBSD so I'm hoping to be able to do something like
"ps -ef |grep email_client_process"
if it's not there, then restart it.

Reason is our MobileIron email+ client kept getting killed by iOS as iOS sees it
as a 3rd party/foreign process.

any chance of doing this on an MDM controlled device?
I inherited a FreeBSD box that is forwarding email using Postfix through various JLS (jails).

Two days ago I switched the MX record(s) to point to a third party service that is going to replace this FreeBSD server.

When I log into the FreeBSD machine and look at the logs (specifically to see if mail is flowing), I see two or three messages in a handful of jails.

A week ago before the MX record change there would have been 20 emails every few minutes, so something obviously changed, which was expected.

What was NOT expected was to see ANY mail flow through the FreeBSD machine.

My question is: Should I expect to see some mail for an extended amount of time? I'm asking because I thought that once I changed the MX record - with a TTL of 300 for all 5 priorities - that it would handle all the mail.

Thanks for your help!
No matter what NTP server address i put in it says "server could not be reached". I tried setting it to force and rebooting it but that didnt do anything either. I'm not understanding why this wont work because i can clearly ping from FreeNAS to my other servers that i want to use as a reference.

I also tried doing it through shell but I don't know if I have the commands correct...
Hi everyone. I'm going crazy trying to join my FREENAS server to windows 2008 AD service. I've tried almost everything with no luck. I always get this message:
Unable to find domain controllers for innovateperu.local.
and the log shows:  
FreeNAS_ActiveDirectory_Base.get_SRV_records: no SRV records for _ldap._tcp.dc._msdcs.innovateperu.local found, fail!
I have attached some screenshots of my FREENAS configuration

My local domain is: innovateperu.local
Exploring SharePoint 2016
LVL 13
Exploring SharePoint 2016

Explore SharePoint 2016, the web-based, collaborative platform that integrates with Microsoft Office to provide intranets, secure document management, and collaboration so you can develop your online and offline capabilities.

I know that I can organize a single directory listing with:


Open in new window

How would I look for all .php files on the whole drive, with the latest being at the bottom?

Any ideas?
Can I delete /root/authorized_keys in FreeBSD.  I've had some break-ins and want to cover all bases.
I'm trying to figure out what the very top (dot) directory is, and why it shows that it was created today.

dot directory
I'm having trouble getting FTP to work on our server.

When I check auth.log it contains:

Jul  5 13:06:29 216-55-xxx-xxx sshd[57421]: Accepted password for ftpuser from port 58996 ssh2
Jul  5 13:06:29 216-55-xxx-xxx sshd[57423]: subsystem request for sftp by user ftpuser failed, subsystem not found

Any ideas?  It's been a LONG time since I configured this server.
We have a FreeBSD Pfsense appliance on a physical Dell PE1950 in a remote office. It becomes essential for the appliance to send out an alert if its hard drive(s) got bad. How to accomplish that?
I'm wondering if a NUC of type DCCP847DYE would be a good basis for a home-made NAS and basic web server? I would like to run FreeBSD on it with ZFS for expanding storage. And how would i be able to add more storage, physically, as i went along?
Hi there, i need to extract from a FreeBSD server running Qmail the list of all domains and mailboxes, and for each mailbox in the domain the space used.

Example format needed:
Domain1   user1  120MB
Domain1   user2  200MB

Domain2  user1  50MB
Domain2  user2  30MB

and so on...

I wrote the following script that does a partial job:

du -h /usr/local/vpopmail/domains/ |sort -n|grep Maildir$ |tail -15000 |awk -F'/' '{print "Space Used: "$1"\t Domain: "$6,"\t\t\tMailbox:"$7}'

Open in new window

This mainly works, however the main problem is that in the /usr/local/vpopmail/domains/ folder there are also folders "0", "1", "2" containing domains inside (something like postfix does i guess) that i cannot count. So the above command counts correctly only the domains inside /usr/local/vpopmail/domains/$domain_name but not the /usr/local/vpopmail/domains/0/$domain_name.

Anyone can help me please?

Thank you all in advance
We are running the latest VMWare VSphere Essentials 6.0.1 environment where we have three hosts and a couple of SANs shared via iSCSI.  One of the hosts is a Dell PE630 with a rather big local storage volume.
Can this local volume be exposed to other hosts and VMs via iSCSI just like our SANs volumes are..?
If yes, how do I do that?
Thanks for comments
regards Tor
I have to manually migrate our DNS servers from the FreeBSD to Microsoft DNS.  We tried the run zone transfers from the Microsoft DNS servers to FreeBSD but had no luck so the next best option is to manually create all the entries.  Just curious if anyone has any suggestions on what we need to do to successfully migrate all those entries over.  What all are those records that we need to copy over to the Microsoft Active Directory servers (A records..NS records)?  The reverse  zone files and records should be created automatically on the new servers when clients start joining and accessing the networks?

CompTIA Cloud+
LVL 13
CompTIA Cloud+

The CompTIA Cloud+ Basic training course will teach you about cloud concepts and models, data storage, networking, and network infrastructure.

What is wrong with by shell script?


while [ $numberFirst -le $max ]
 numberLast=$(( numberFirst+$jump-1 ))
 curl ''$numberFirst'&numberLast='$numberLast   -o '/data/x'$numberFirst'_'$numberLast'.txt'

/usr/local/bin/mysql --defaults-file=/conf/m.conf << EOF
use mydb;
LOAD DATA LOCAL INFILE '/data/x'$numberFirst'_'$numberLast'.txt' 
INTO TABLE Contacts  

numberFirst=$(( numberFirst+$jump ))

Open in new window

I get an error:
Syntax error: end of file unexpected
Does anyone know how to disable the firewall configuration on a Free BSD server?  DNS service is hosted on it and I need to do a zone transfer but it doesn't seem to allow it as there are some kind of firewall settings that is preventing it.  I am trying to avoid having create the records manually as we need to migrate it to a Windows DNS server.
My file system is full and I'm having a hard time trying to find space.  I don't know how to get to that first drive:

I'm using FreeBSD.
I am running a apache web server and then doing reverse proxy to confluence server. when I try to upload some files to confluence server (less than 100MB) it woks fine (it takes around 3 minute to upload)

but I have one big file close to 300MB which takes more than 10 minute to upload and upload gets failed and I get below error:

Proxy Error 502 : The proxy server received an invalid response from an upstream server

Open in new window

Here is my proxy configuration.

#Rewrite rule for Confluence
RewriteCond     %{HTTP_HOST}    ^     [NC]
RewriteRule     ^/(.*)$$1        [P]
ProxyPassReverse /

I believe issue would be related to timeout setting somewhere. Appreciate if someone can help me in fixing it.
We use McAfee's SaaS Email Protection as a anti-spam gateway. Our MX records are properly set up so all mail to the domain goes through the gateway. However, we have found that some spammers are able to bypass the service entirely by sending mail directly to the IP address instead of the MX record.

McAfee says this:
Lock Down
Prevent attackers from bypassing the SaaS Email Protection by configuring your email server or firewall to only allow SMTP connections from the IP space used by the service.
Here are the IPs in various notation types. If you provide these to your e-mail provider, they should be able to lock down your e-mail connection to only accept inbound mail from McAfee EPS and prevent this type of message from reaching your firm in the future.

I have the IP list from McAffee in CIDR/21 and CIDR/24 formats as well as individual IP addresses. I manage the email server myself, but not sure where or how to enable this. Perhaps in /usr/etc/access ?

I do not believe the configuration is specific to FreeBSD platform, probably any Linux or other server running Sendmail.

Looking for some instructions on exactly how to configure this. Thanks in advance!
Good day, dear colleagues!
I have several NASes based on - Nayla (revision 1349)
My goal is to be able to mount and unmount encrypted ufs partitions (mnt1 & mnt2) via SSH
Now I’m able to connect to SSH via root account, so what should I do next?
Thanx in advance :)






FreeBSD is a free Unix-like operating system that is a direct descendant of BSD. FreeBSD contains a significant collection of server-related software in the base system and the ports collection, it is possible to configure and use FreeBSD as a mail server, web server, Firewall, FTP server, DNS server and a router, among other applications. Although FreeBSD does not install the X Window System by default, it is available in the FreeBSD ports collection. A number of Desktop environments such as GNOME, KDE and Xfce, and lightweight window managers such as Openbox, Fluxbox and dwm are also available to FreeBSD.

Top Experts In

No Top Experts for this time period. Answer questions to earn the title!