FTP

224

Solutions

409

Contributors

The File Transfer Program (FTP) is a standard network protocol used to transfer computer files between a client and server on a computer network. Built on a client-server model architecture, it separates control and data connections between the client and the server. Users may access the server through a sign-in protocol, typically in the form of a username and password.

Share tech news, updates, or what's on your mind.

Sign up to Post

Hello Experts,

I work for Company A who has recently entered a partnership with Company B to provide outsourced services.

Both Company A and Company B have completely separate AD Domains/Forests but have recently had dedicated WAN links deployed to provide "non-public" connectivity.

We have a requirement to share specific data folders, but there's a hesitancy to expose SMB/CIFS shares to mitigate the potential propagation of malware and limit other compliance considerations.

I was thinking that some kind of Managed File Transfer solution that would work in a similar fashion to DFS-R (and provide near real time replication) may be a suitable route forward, and would only require the use of port 22.

Do you agree that this is a reasonable approach?

Can you suggest any potential solutions that would fulfil the requirements?

Or, I'm open to suggestions for alternative solutions.

Any advice gratefully received.

Regards

A
0
Expert Spotlight: Joe Anderson (DatabaseMX)
LVL 13
Expert Spotlight: Joe Anderson (DatabaseMX)

We’ve posted a new Expert Spotlight!  Joe Anderson (DatabaseMX) has been on Experts Exchange since 2006. Learn more about this database architect, guitar aficionado, and Microsoft MVP.

hi am not able to connect to my via ftp but i can ping my vm am using winscp my vm is in linux ubuntu my host is window 10
host
0
Need to create an ability to transfer files via a web browser.

Can do FTP in the background. But must be a web front end that we can skin up.

Currently use Joomla for most web projects. Installed eDocMan and JDownloads etc..
Set.

Server is running Windows and Plesk. This is not changeable. Could be pure IIS if we use another box.. However, want to use the PLESK box as Nirvana.

Can upload ZIP as 1.99GB successfully now as eDocMan. Cannot do larger ISOs. Can do 700MB not 2GB.

Need a solution to do 15GB+.

Please advise what I can use to achieve a customisable front web interface that can take single large files.

Have changed UPLOAD_MAX_FILESIZE, POST_MAX_SIZE(bigger than UPLOAD_MAX SIZE), MAX_EXECUTION_TIME, MAX_INPUT_TIME, MEMORY LIMIT.

So as far as I can see all should be fine.
I know browser upload on big files historically are hard. But using Chrome which exceeds 2GB limit.
I know IIS can have an issue bc the max size is 4GB something. However, need to know how hard a limit this is.

Need some guidance please.

Cannot just use FTP or FTP in windows address bar. Needs to be a "delivered solution"

Please advise.

Many thanks in advance.
R
0
Setup FTP server in Windows 2012 R2 and completed the configuration successfully. But when I type ftp://192.168.1.10 from a workstation on the same network, I get an error "This page cannot be displayed" Please help!!!
0
Hello,
We're migrating our website www.tiedemannglobe.com from one server to another. The last provider suspended our account and on entering the site through the browser, I got a page that said "Account suspended".
I changed the DNS in Godaddy, specifically, the Name Server to the DNS I have in WHM for the new server, and the host names to the new IP.
The DNS changes seem to have deployed already, because when I enter the website now, I can see, with the IP check plugin of my browser, that the IP for the site is that of our new server, but I still get the "Account suspended" error instead of the content I uploaded to the server via FTP. What am I missing?
0
Hi,
I have a file I'm retrieving via ftp in laravel from a 3rd party who provides it as pipe-delimited. I can get and store the file fine.. but I need to open it and convert the pipes to a comma-delimited file and save the changes.

Any idea how to accomplish this?

Small sample chunk of the file is:

ADID |CompanyID|CompanyName|Category |StockNumber|Vin |Status |Year |Make | Model |Trim |KMS |Exterior Color |Mfg Exterior Color | Interior Color | FuelType |Drive |Engine Size |Transmission |Doors |Passenger |Cylinder |Body |Price |HidePrice |Options |AdDescription | FinancingIsAvailable | FinancingPayment |FinancingPaymentType | FinancingNumberOfPayment |FinancingDownPayment | FinancingSource |FinancingType | FinancingOdometer |FinancingDescription |ManufactureProgram |Warranty |WarrantyDescription | MainPhoto |OtherPhoto|ModifiedDate|CreatedDate
43686979|20046119910706|Johns Volkswagen|"Sport Utility"|V59201PC...... 

Open in new window

0
Hello,
 I have two ASA 5525-X firewalls (in HA configuration) with Firepower. I'm asking for help on whether we'd be able to establish Traffic Shaping to guarantee bandwidth for FTP traffic.  We have a 1Gb connection recently added and would like to guarantee 900Mbs for FTP when needed, but allow other traffic to utilize the connection otherwise.
0
Hello there,

I am missing features in IIS for FTP and I'm not sure why. I installed the FTP Server role and restarted the server. I can create FTP sites but in the features pane, all I can see is FTP Directory Browsing under FTP. There's supposed to be way more features. I'm running IIS 10 on Server 2016.

My actual goal is to create an SFTP that people can access externally but I need these features in order to do this right.
0
I'm using ftps for the file transfer. I'm not able to access the ftp. Here is the log

#Software: Microsoft Internet Information Services 10.0
#Version: 1.0
#Date: 2019-06-25 13:15:48
#Fields: date time c-ip cs-username s-ip s-port cs-method cs-uri-stem sc-status sc-win32-status sc-substatus x-session x-fullpath
2019-06-25 13:19:12 192.168.1.1 - 192.168.1.1 1980 ControlChannelOpened - - 0 0 122e06a0-da11-411e-b840-d5de6952e357 -
2019-06-25 13:19:12 192.168.1.1 - 192.168.1.1 1980 USER sr 534 5 25 122e06a0-da11-411e-b840-d5de6952e357 -
2019-06-25 13:19:12 192.168.1.1 - 192.168.1.1 1980 QUIT - 221 0 0 122e06a0-da11-411e-b840-d5de6952e357 -
2019-06-25 13:19:12 192.168.1.1 - 192.168.1.1 1980 ControlChannelClosed - - 0 0 122e06a0-da11-411e-b840-d5de6952e357 -

Here is the screenshot of the settings:
authauthorizfirewallssluser-info
0
I am working on a Windows Server 2012 R2 machine (virtual) that has a need to upload FTP files (ASCII) to a site as part of a backend system; this occurs as part of a batch file. What we are finding is happening is that the ftp connection gets established but when it tries to upload the file, it hangs and times out. If I turn off the Windows firewall, it works fine.

So I added exceptions in the firewall for the FTP program (inbound and outbound) and it still hangs. Can anyone help me figure out what the right path is to figure this out? Thanks!
0
Ensure you’re charging the right price for your IT
Ensure you’re charging the right price for your IT

Do you wonder if your IT business is truly profitable or if you should raise your prices? Learn how to calculate your overhead burden using our free interactive tool and use it to determine the right price for your IT services. Start calculating Now!

Hi,

Hope somebody could help us with this issue..

We recently purchased a 5506-X firewall to add to our existing network. We work in a shared office environment and the IT department provided us with a Static IP for (outside) configuration of the firewall. In order to have access to the internet in our network environment we must authorize devices by MAC address. I have tested the outside IP on my laptop and was able to connect to the internet from the uplink provided to me.

We have followed all the steps necessary to setup the 5506-x firewall but cannot seem to get internet access. Also, we have allowed the mac address of each interface on the 5506-x to have access to the network.

Maybe we missed something and someone could help guide us in the right direction. We followed the instructions here but still know luck.

Below is the show configuration log...

 Saved

:
: Serial Number: JAD22310EK4
: Hardware:   ASA5506, 4096 MB RAM, CPU Atom C2000 series 1250 MHz, 1 CPU (4 cores)
: Written by enable_15 at 18:30:29.659 UTC Tue Jun 11 2019
!
ASA Version 9.8(2)
!
hostname AI-Firewall
enable password $sha512$5000$oN0ERX19wEcf1sA20aNprA==$h4DD3XDf1aAxawHyqyjPYQ== pbkdf2
names
ip local pool AI-Pool 10.222.222.100-10.222.222.120 mask 255.255.255.0

!
interface GigabitEthernet1/1
 nameif outside
 security-level 0
 ip address 67.71.213.166 255.255.255.252
!
interface GigabitEthernet1/2
 bridge-group 1
 nameif inside_1
 security-level 100
!
0
I am trying to establish an FTP connection between client and server.  I am able to run FTP between the client and server within local network behind NAT router as shown in config A in attached file(FTP config). I have problem establishing the data connection when running the client and server in two different networks as shown in config B.

The error message displayed in the client window and the FileZilla network configuration result is shown in the attached file(ftp problem).
The client is connected through a mobile hotspot and the server is connected to a wifi network.
I have control over the wifi router where I have configured the port forwarding.
FTP-Config.pptx
FTP-problem.PNG
0
HI,
I have a following piece of code :
import com.google.inject.Inject;
import com.google.inject.Singleton;
import com.google.inject.name.Named;
import com.jcraft.jsch.ChannelSftp;
import com.jcraft.jsch.SftpException;
import in.zeta.sftp.client.SftpCommandService;
import in.zeta.sftp.client.SftpSessionManager;
import in.zeta.spectra.capture.SpectraLogger;
import io.netty.channel.ChannelException;
import olympus.trace.OlympusSpectra;

import java.io.InputStream;
import java.util.concurrent.CompletableFuture;
import java.util.concurrent.CompletionException;
import java.util.concurrent.CompletionStage;

import static java.util.concurrent.CompletableFuture.completedFuture;
import static olympus.message.util.CompletableFutures.unwrapCompletionStateException;

@Singleton
public class UserDocsSftpHelper {
  private static final int timeoutMillis = 20000;

  private final SftpSessionManager sessionManager;
  private final CompletionStage<Void> sessionManagerInit;
  private final SftpCommandService sftpCommandService;
  private final SpectraLogger logger = OlympusSpectra.getLogger(this.getClass());

  @Inject
  public UserDocsSftpHelper(@Named("rbl.docs.sftp.manager") SftpSessionManager sessionManager) {
    this.sessionManager = sessionManager;
    this.sessionManagerInit = sessionManager.init();
    this.sftpCommandService = new SftpCommandService(20);
  }

  public CompletionStage<Void> createDirectoryIfNotPresent(String directoryPath) {
    CompletableFuture<ChannelSftp> 

Open in new window

0
Hi,
What is the best way to create a secure FTP for a company ?
0
Hi,
I am trying to connect to an SFTP server and here is the output :

sftp -o KexAlgorithms=diffie-hellman-group16-sha512 -o MACs=hmac-sha2-512 -P 22
40 -i portalKey user@safar.xyz.com

EFT Login - %DATE% %TIME% - Please enter valid credentials to continueConnected to safar.xyz.com
sftp>
sftp> ls
ZETA

I am able to connect but once i entered credentials it just hangs in "EFT Login - %DATE% %TIME% - Please enter valid credentials to continue" this and had to press enter move forward
Now here i am connecting with a key and there is no need for valid credentials. Also i dont enter anything...just pressing enter does the job.
Why could this be happening ?

Thanks
0
Hello everyone,


I have a Cisco ASA 5516 with two inside interfaces. One is for customer LAN and another is for a few branch offices connected via a router that is connected to the 2nd Inside interface (All those offices are in the same building connected by a FO backbone. Customer is going to replace an old ASA 5510 where almost the same config already works.  

LAN network is 192.168.0.0/24 connected to 1/3 on ASA

Branch Offices are connected to 192.168.2.0/24 connected to 1/4 on ASA
 
I want to be able to ping and have unrestricted traffic between them.

Currently I have a laptop connected to int 1/3 and another one connected to Int 1/4 but no ping.

Someone please help!

Here's the configuration

ASA Version 9.8(2)17
!
hostname ASAFCHFW
domain-name mydomain.com
enable password $sha512$5000$pt2nRGQbSXA8K3vdow+Ztg==$kGNfDJREqQCQ+jO7m0bxmQ== pbkdf2
names
no mac-address auto

!
interface GigabitEthernet1/1
nameif Outside
security-level 0
ip address x.x.x.131 255.255.255.240
!
interface GigabitEthernet1/2
nameif DMZ
security-level 10
ip address 172.16.31.1 255.255.255.240
!
interface GigabitEthernet1/3
nameif Inside
security-level 100
ip address 192.168.0.2 255.255.255.0
!
interface GigabitEthernet1/4
nameif Branch_Office
security-level 100
ip address 192.168.2.1 255.255.255.0
!
interface GigabitEthernet1/5
shutdown
no nameif
no security-level
no ip address
!
interface GigabitEthernet1/6
shutdown
no nameif
no …
0
Hi, we have a Server 2012 R2 Server, and using FileZilla, what is the best way to secure this as we want to allow 3rd parties to upload files/folders to the server?
0
We have an SFTP Server with user accounts worldwide. When working with US sites, users are emailed their account information and instructed to call us for their password. We have an SOP stating we don't send passwords via email, and FAX is not an option. Now that we work with international sites, we're constantly running into language/time zone barriers.  We email new users the account username and tried using encrypted zip files but this has been problematic for many reasons. We are wondering how to securely get passwords to our international users. Any help/suggestions/best practices are greatly appreciated.
0
Hi - I'm having an issue with FTP using Filezilla server. For some reason I cannot get it to successfully connect in passive mode. Initially, and i have no idea why, when using Filezilla client, we set that to passive mode (with the setting to "fall back to active mode" enabled) and it worked, but it doesn't seem to be truly connecting in passive mode based on the connection logs. Does anyone have any ideas on how to get this to work?
0
OWASP: Forgery and Phishing
LVL 13
OWASP: Forgery and Phishing

Learn the techniques to avoid forgery and phishing attacks and the types of attacks an application or network may face.

I was given public keys by vender , Im trying to connect to server through  WS _FTP utility .  I genertaed a set of keys using putty.  Im trying to import the private key that I created through Putty and receiving an error invalid format when trying to import  as my private keys through WS_FTP.

Thanks
Aron
0
Hi, I am trying to set up a secure file  transfer on windows server 2016. I need a practical and simple documentation. Any ideas ?
0
My Joomla!  website is hosted at OVH since a couple of years.
Now since a couple of days (or weeks ?) I get OVH feedback (automatic email from them) that some outgoing emails (mainly to addresses @gmx.de and gmx.at) are not delivered (names not known etc...)
A dozen of such emails every day, but a total of sometimes more than 40 emails sent ...
My website has RSForm! Pro and a form that sends email to exactly one specific address (that I manage) outside the OVH server.
I wonder how my website has been hacked : the OVH admin password, the Joomla! admin password and ftp password are almost ... random ! (I have them at home written on a paper in my desk, nobody has access to it)
What shell I do to take that hacking away ?
Thanks
0
How to gain root access to a vulnerable Red hat Linux server?

I only have the following details.
1) There are 3 services running. (SSH, FTP and HTTP)
2) I managed to get some user username and password, however when i tried to login into the server, i recieved the error permission denied.
0
I'm using WinSCP in the scripting mode with an MS Access 2K application.

My goal is to use the shell command that runs a batch file that ftp's a file.


THe MS Access application needs to know when the FTP has completed, so I use a batch file to copy a flag into the directory.
The Access Application then loops, checking every second to see with the flag exists, before it continues...


The problem is that while the batch file works as expected when executed from the command mode, it does not perform as expected when I use the Shell command.
I'm pretty sure the problem is the use of the term "exit" in the WinSCP script, but I don't know what to do to solve the problem.

Here is my batch file... StartFTP.bat (again... batch file creates Finished_FTP_Flag.txt as expected)

DEL "\\<myServer>\Database\XMIT-files\Finished_FTP_Flag.txt"
"C:\Program Files\WinSCP\WinSCP.com" /ini=nul /command "open ftp://<myFTP_Site>/" "put \\<myServer>\database\xmit-files\<myFileName.zip>" "exit"  
COPY "\\<myServer>\Database\DistiTools\FinishedConvertingFlag.txt" "\\<myServer>\Database\XMIT-files\Finished_FTP_Flag.txt"

Here is my MS Access (VBA) command (again... batch file never creates Finished_FTP_Flag.txt
 Call Shell("c:\<MyPath>\StartFTP.bat")

Any suggestions???
0
I would like to use a powershell/vbs script to run the following commands currently found in a .bat file:


@echo off
setlocal 

set password=xxxxxxxx
set /p password=<%~nx0:password
if not "%password%"=="" goto OK
set /p password=Enter password: 
echo %password%>%~nx0:password
:OK

set localdir=\\srv\folder\NewInbound\folder
set remotedir=/out_folder
set ftpserver=ftp.server.com
set username=xxxxxxxx

::del "%localdir%\*.*" /q

call :GetFtpFiles
call :ClearFTPFiles

exit /b

:GetFTPFiles
    (echo open %ftpserver%
    echo user %username% %password%
    echo bin
    echo cd %remotedir%
    echo lcd "%localdir%"
    echo mget *.*
    echo quit
    ) | ftp -n -i
    exit /b

:ClearfTPFiles
    (echo open %ftpserver%
    echo user %username% %password%
    echo cd %remotedir%
    (for /f "tokens=*" %%a in ('dir /b /a-d "%localdir%\*.*"') do @echo dele "%%~a")
    echo quit
    ) | ftp -n -i -d

Open in new window

0

FTP

224

Solutions

409

Contributors

The File Transfer Program (FTP) is a standard network protocol used to transfer computer files between a client and server on a computer network. Built on a client-server model architecture, it separates control and data connections between the client and the server. Users may access the server through a sign-in protocol, typically in the form of a username and password.