The File Transfer Program (FTP) is a standard network protocol used to transfer computer files between a client and server on a computer network. Built on a client-server model architecture, it separates control and data connections between the client and the server. Users may access the server through a sign-in protocol, typically in the form of a username and password.

Share tech news, updates, or what's on your mind.

Sign up to Post


I'm having an issue with setting up an IIS FTP server (on a 2008R2 box). I have succeeded in setting up the server, users, publish the directory, setup NAT on the firewall. Things are looking pretty much ok but I am struggling at this point:

 220 Microsoft FTP Service
234 AUTH command ok. Expecting TLS Negotiation.
USER username
331 Password required for username.
PASS *****************
230 User logged in.
200 PBSZ command successful.
200 PROT command successful.
211-Extended features supported:
211 END
200 OPTS UTF8 command successful - UTF8 encoding now ON.
215 Windows_NT
257 "/" is current directory.
250 CWD command successful.
200 Type set to A.
PORT 172,16,101,102,208,219
501 Server cannot accept argument.
250 CWD command successful.
200 Type set to A.
PORT 172,16,101,102,208,222
501 Server cannot accept argument.

Open in new window

I guess this is somehow linked to passive FTP mode but
  • it happens even if I explicitly request active mode only
  • I have defined the passive ports in the "FTP firewall support" tab and NAT-ed them to the correct internal IP
  • this works fine if connecting locally (localhost) but not from LAN no WAN

I'm sure it is a "classic" one (seeing lots of post googling this) but can't really figure it out.

Any advice most appreciated
Managing Security Policy in a Changing Environment
Managing Security Policy in a Changing Environment

The enterprise network environment is evolving rapidly as companies extend their physical data centers to embrace cloud computing and software-defined networking. This new reality means that the challenge of managing the security policy is much more dynamic and complex.

linux shared server
want to have one version (non www) of small one page website

I have ftp access.

is this something I can do in root folder
I'm having trouble with an Expect script on Red Hat Enterprise Server 6.10.  I would think that the script below would spawn SFTP, then send the password.  I'm getting a Password error, which I am guessing is due to lots of escapable characters.

The script below gets me a "permission denied" error.  My password ( I changed some characters) is something like  r10@4g@$^#a&r*a^^$%  .  I have tried escaping the 'special' characters with \ and also tried escaping every character (so it looks like \r\1\0\@\4\g\@\$\^\#\a\&\r\*\a\^\^\$\%).  When I manually connect to the site and manually enter a password it works fine.

Can someone tell me what I might be missing?

Thanks for any advice you can provide,


spawn sftp username@ftpprd.host.com
expect "username\@ftpprd.host.com\'s password: "
send "r10@4g@$^#a&r*a^^$%\n"

Similar to Guilt FTP…Looking for another Server

We have used GuiltFTP which is a very tiny exe to act as FTP server locally...

Currently it is not working in our machine..

Is any free open FTP servers which is very small to be installed and run in local machine for FTP testing?

I need to run the scheduler (Built in)
Copy file from my source
My local folder
Ever 60 minutes

AFTER that process...
I need to delete the file off the source folder

When IPSWITCH ws-ftp does a scheduler transfer
Is that a COPY
or a MOVE?
Dear Experts,

I am having trouble with an FTP site that we need.

We have a Meraki firewall that is port forwarding to an internet FTP server.  

The remote sessions for the clients need to be done in an active mode, not passive mode.

I m testing with a client FileZilla:

Status:      Logged in
Status:      Retrieving directory listing...
Status:      Server sent passive reply with unroutable address. Using server address instead.
Command:      MLSD
Error:      Connection timed out after 20 seconds of inactivity
Error:      Failed to retrieve directory listing
Status:      Disconnected from server
Status:      Connecting to 75.xxx.yyy.57:21...
Status:      Connection established, waiting for welcome message...
Status:      Insecure server, it does not support FTP over TLS.
Status:      Logged in
Status:      Retrieving directory listing...
Status:      Server sent passive reply with unroutable address. Using server address instead.
Command:      MLSD
Error:      Connection timed out after 20 seconds of inactivity
Error:      Failed to retrieve directory listing

Is there a way to tell the client that the session needs to be active only? An output from a testing site

Warning: Plaintext FTP is insecure. You should use explicit FTP over TLS.

Status: Resolving address of us-net-cisco.dynamic-m.com

Status: Connecting to 75.xxx.yyy.57                                                                      <------------------------------ External ISP dynamic address

Warning: The entered address does not resolve to …
What is the best way to share a folder on my server (about 30G) with external users via Internet. We need extra users to have access to only that folder.
Windows 212 R2

Installed FTP So I can backup my Vcenter Appliance over FTP on my Windows 2012 R2 server.
Is not working.
So I went to FileZilla on my Window 10 Computer it gets this error

Status:      Connecting to
Status:      Connection established, waiting for welcome message...
Response:      220 Microsoft FTP Service
Command:      AUTH TLS
Response:      234 AUTH command ok. Expecting TLS Negotiation.
Status:      Initializing TLS...
Error:      GnuTLS error -48: Key usage violation in certificate has been detected.
Error:      Could not connect to server

I created a local user on the Server vcsauser    and added it to the permissions tab of the FTP Site with full control

The windows Firewall is enabled and the only firewall on my internal network
The built in FTP rules were I created when I installed FTP service

I even tried ftps://   same error

I am thinking firewall problem

How about the experts ?

Thanks in advance

Dear Experts

Please can someone assist me with the follow issue.

I have FileZilla setup on a Windows 2016 Server in my data centre. It's behind a firewall.

It’s secured using TLS.

Please see attached sceen shots for all my settings.

Inbound, I have the following ports opened:
20, 21, 50000-50100

Outbound, all ports are opened.

I can connect to my ftp server from external fine using explicit FTP. It connects in passive mode to a random port between 50000 – 50100.

Problem is there is a system that does not support FTPS and must use plain FTP.

I setup another account on the server for this system and specified that its not forced to use TLS.

However when I attempt to connect to the FTP server using this account via plain FTP it enters passive mode however it’s not using the port range specified, 50000 – 50100. So I can login but cannot do the directory listing.
Hello Experts,

I am not having success with a Meraki FTP configuration.

A client needs an anonymous FTP connection for a text file upload every ten minutes.

Is a primitive way to monitor a job.

Anyways, I have the FTP working well internally.

I need it to be accessed from the web.

I m not sure if I need to just port forward to port 21.

Also, do I need a NAT rule as well?

Will I need to use the IP address or the dynamic link address of the Meraki: ftp://ipaddress  or ftp://merakilinkaddress.com 

Do I need to specify a port range in the Meraki NAT rule or Port Forwarding?  

Thank you for your help.
Do You Have a Trusted Wireless Environment?
Do You Have a Trusted Wireless Environment?

A Trusted Wireless Environment is a framework for building a complete Wi-Fi network that is fast, easy to manage, and secure.


I have a Model 9406-170 with OS: V4R4M0

I can login to this system via FTP and navigate to the AS400 library (MFG.PMS) that I want to download files from. I have verified through green screen that the files PMCR06.PGM and PMCR06CL.PGM exist in this library.

My FTP "pwd" command output:
257 "MFG.PMS" is current library

My FTP "ascii" command output:
200 Representation type is ASCII nonprint.

My FTP "get PMCR06.PGM" OR "get PMCR06" command output:
550 File PMCR06 in library MFG.PMS not found.  
550 File PMCR06.PGM in library MFG.PMS not found.

So I attempted FTP command "dir" and get this output:
200 PORT subcommand request successful.
126 Member *ALL not found in file *ALL in library MFG.PMS.
250 List Completed.

NOTE: I ultimately want to do the following via FTP...
1) Start FTP session.
2) Set FTP session to ASCII.
3) Set FTP session to not prompt.
4) Navigate to an AS400 library.
5) Download all files in the library via FTP command mget *
Repeat starting at step 4.

I'm new to the AS400 but not FTP.  Anyone have any tips?  


I need help setting up SFTP on Server 2016 STD.

Can anyone assist me?
I have a Red Hat 7.1 server.  I cannot FTP into the RH7.1 server I get a message 530 Login incorrect.
I can receive files if I use FTP from the RH7.1 server but I cannot SEND files from the RH7.1 server.
When attempting to send files from the RH7.1 server a zero length file is put on the receiving server but no data is ever copied to the receiving server and the FTP process on the RH7.1 server hangs.

This is on an internal network with no outside connections so security is not a concern here.
I also tried sftp with no success.

Any suggestions would be greatly appreciated.

Dan Kaib
Server: Windows Server 2012 R2 Standard
Function: Running Windows FTP Server

I have an FTP server and one of the accounts keeps getting locked out. I'm trying to determine HOW it's getting locked out.  It's obvious that it's coming from too many incorrect password attempts, but is there anyway to determine what IP address it is coming from on the WINDOWS side?

Thank you!
I need to connect to FTP server through Command Prompt.

When I am trying to connect to it, it says Connection Timed Out.

ftp> open
To xyz.test.com
ftp: connect :Connection timed out

What must be the reason behind it? Please help

I can connect to it through Filezilla.
Hi Experts,

I'm looking for code or a package that can be called from Access 2016 VBA code to upload a file to a FTP server.


Hello Experts,

I have an errors everytime i try to transfert a file from my filezilla, The server's firewall is disabled, the server is not behind an ASA, so I don''t really understand why I can't transfert files. The FTp was working perfectly a month ago. Can you please help me?

Hello, FTP site connection problem with data connection, I have opened and forwarded the port 2121 in my router to local windows 10 pc I have also disabled firewall on windows 10 machine where the FTP site is in iis manager, every time i try to connect using WinSCP or Filezilla it shows message of "connected waiting for welcome messege and then says retriving directory  listings"  and get disconnet, I have setup FTP to no encryption just to test it first but i cannot connect at all from outside even my public ip is static, i have included the logs for refrence.
I converted the FTP SERVER to use SFTP. I am able to connect using winSCP but it always put me into the root directory. How i view my my virtual directories int he FTP.
I install solarwinds free sftp the server.
I need my ftp users to be able to reach their proper directories. what i can do now?
Powerful Yet Easy-to-Use Network Monitoring
Powerful Yet Easy-to-Use Network Monitoring

Identify excessive bandwidth utilization or unexpected application traffic with SolarWinds Bandwidth Analyzer Pack.

Dear expert

I would like to know how FTP works with file modification time.

When you get something from ftp the windows is showing the file is created by yesterday, not today when you received, I mean when you write something to the disk, OS should write the create time is today right? But it doesn't why is that?

I would like to modify this portion of an FTP script so that it does try to look at the LOCAL folder to compare files with the REMOTE folder - and then try to delete those files on the REMOTE FOLDER.
I simply want the script to download the files found in the REMOTE folder to the LOCAL folder, Delete the files in the Remote folder - but not to delete anything in the LOCAL folder..

    (echo open %ftpserver%
    echo user %username% %password%
    echo bin
    echo cd %remotedir%
    echo lcd "%localdir%"
    echo mget *.*
    echo quit
    ) | ftp -n -i
    exit /b

    (echo open %ftpserver%
    echo user %username% %password%
    echo cd %remotedir%
    (for /f "tokens=*" %%a in ('dir /b /a-d "%localdir%\*.*"') do @echo dele "%%~a")
    echo quit
    ) | ftp -n -i -d
Working with an existing internal FTP server with (3) FTP sites where all traffic is behind my internal firewall. I now need to add a connection from an external source that is behind their own firewall. When building the FTP on the existing server I want to use a custom port, for example, of 11000. Both firewalls were modified for that connection and FTP clients can connect. BUT! No information is listed for the connection, such as file names, folders etc. I identified this as related to needing to specify a custom, active Data Port on the FTP server to allow this visibility. Ok, no issues there, I can make that happen and know how.

However, when I edit this setting on the server it looks very much to me that it would be a global effect on the entire server for all FTP sites. My concern is that if I make this change the existing connections for my internal sites will stop, even though they are using the standard port for connections.  I also have a custom FTP port (not 21 or 22) on one of my INTERNAL sites that is working fine.

Question:  Does making this change for the data port affect anything on the standard FTP port of 21? I need to make sure I won;t break my current connections by enabling this setting and specifying a port. If so, I will build another server for the external (trusted) connection.

Please advise.
DOS FTP access script

I am using this command:
ftp -s:ftp.txt
ftp.txt is this:
lcd c:\_A
put TR.bak

I get this response:
ftp> Connected to
220 Microsoft FTP Service
User (
331 Password required for MyUser.

530 User MyUser cannot log in.
ftp> Local directory now C:\_A.
ftp> lcd c:\_A
put TR.bak
530 Please login with USER and PASS.
530 Please login with USER and PASS.
ftp> quit

the password is correct. What am I doing wrong here?
do you know any ftp that allow for schedule that more important it is free and easy to use? In window
All i have to do is

send 100 files m to f at 7:30 pm.
Have a series of files on local windows server that I want to ftp to a web server host. the location of these files, source and target change on each use. the files are essentially the same wildcards (*.pdf, *.htm,  etc...) the transfer variables are the same (client,subclient,date) which dictate the location of the folders on both ends. I currently do this locally with a home grown filecopy program that is drivn from an xml file. Now moving to cloud hosting it must be ftp. I'm looking for an ftp package with scripting so that this is an automatic action. would love to find an ftp/xml solution but doubt that is in the cards. I'm going from a win10 desktop to a win 2012 server running wamp. Any thoughts greatly appreciated.






The File Transfer Program (FTP) is a standard network protocol used to transfer computer files between a client and server on a computer network. Built on a client-server model architecture, it separates control and data connections between the client and the server. Users may access the server through a sign-in protocol, typically in the form of a username and password.