We help IT Professionals succeed at work.






Git is a version control system for software development. It is a distributed revision control system with an emphasis on speed, data integrity, and support for distributed, non-linear workflows. Git was initially designed and developed for Linux kernel development. As with most other distributed version control systems, every Git working directory is a full-fledged repository with complete history and full version-tracking capabilities, independent of network access or a central server.

I'm new enough to GIT where I want to be certain that when I type "push," I'm pushing my changes to the correct remote repository.

When I do "git branch -avv," I get this:

So, based on that, I'm thinking that when I type "git push," I'm pushing my changes to the remote branch of the same name, "BRUCE-code-cleanup."

I'm pretty certain that's the case, but to risk overwriting somebody else's work is a risk I'm not willing to take, so...

If I hit "git push," I'm just updating my own branch, correct?
Bitbucket is showing my test and dev branches are "2 commits behind master".  When I do a diff it shows no differences between the dev/test branches and master.

Can someone help be understand what "2 commits behind master" means and how do I resolve this if there is no apparent difference?

I can not install SourceTree 2 on my MacBook (macOS Catalina)

I download the latest version of the file from https://www.sourcetreeapp.com/

as a Zip file. Then, when I click the program, I get the fatal message:

Can I change my security setting on Catalina?


Recently, I fielded a call from a recruiter and we had conversed about 10 minutes about the things the client was looking for. Then we got to, what they insisted needed to be in place, which was someone who was certified in SCRUM?

Here's what I understand:

SCRUM is all about being tactical and efficient in the way you approach a project that needs to be done. It takes is philosophical / organization cues from Agile - specifically the Agile Manifesto.

When I read down the 12 points of the manifesto, I see a lot of great organizational content.

But I also see things that should pretty intuitive from the standpoint of a forward thinking IT Leader.

I don't doubt that there's a great deal to gain, as far as the managerial chops that one would receive by being a Certified SCRUM professional, but should that represent a red flag if I'm conversing with a client that insists on it?

I've had the opportunity to work with some truly talented IT leaders who broke down a project based on the specs, assigned various tasks to those who had the corresponding strengths, met frequently to ensure a forward thinking and expandable design, organized it using GIT and whatever other tools facilitated a well organized work flow and delivered a quality app on time and in a way that exceeded the client's expectations.

We were an AGILE environment without being preoccupied with the terminology.

Is BitBucket the best choice?

I am starting a project which will involve various developers, some offshore. I need a GIT Repo I can use for source code management and have good memories of BitBucket.

Is it still a great choice?

I saw a difference between Free/Standard/Premium that I dis not understand...

"Build Minutes"...

I do not recall using BitBucket to Build anything. What does this mean? To Build on BitBucket??

This site will have a EJS front end with a JAVA back-end. Does this mean on JAVA code commits, an auto-compilation can be configured? That is probably an option, I presume...it may be a very good option, but I'd like to understand it.

Some projects migrated from TFS to GIT repos.

The project in and of itself is set to use NuGet feeds (public and private) for some of the DLL's. So, the projects haves the packages.config and all.

In TFS, when we built the project it restored the Nuget items from the feeds and the build was no problem.

However, after we migrated to GIT and clone the repo. When we try to build it fails. It even says it restores the NuGet items from the feeds.

We do to the NuGet Packager Manager and it shows they are all installed yet the build still fails.

The only solution that we have found uninstalling the Nuget feed package items and then reinstall. Once we do all of them in the package then it will build and work.

Again, when it was in TFS we had no problem.  The NuGet Feed was still the same one as what we have in the GIT repo (which of course it should be.)

We shouldn't have to uninstall and reinstall ever time we clone.

Anybody have any ideas on this?

VS 2017 15.9.20. C# is used in the Projects.
I'm working on a Laravel project and I'm attempting to "add" and "commit" a number of files simultaneously and I've run into something I've never seen before.

Rather than plow ahead with solutions that seem intuitive on the web, I wanted to run this by some folks who I'm sure have seen this.

When I go to do a

"git commit -m "my message"

I get this error:

[code]error: invalid object 100644 6a247fefd088bae6baae483aa27872517393f5fe for 'app/Http/Controllers/Auth/ForgotPasswordController.php'
error: invalid object 100644 6a247fefd088bae6baae483aa27872517393f5fe for 'app/Http/Controllers/Auth/ForgotPasswordController.php'
error: Error building trees[/code\

When I went out to Google in an attempt to remedy the situation, I saw this:

https://medium.com/@panjeh/git-error-invalid-object-error-building-trees-44b582769457 (see also https://git-scm.com/book/en/v2/Git-Internals-Git-Objects)

Sha-1 looks as though it's just a way of telling GIT to overlook what would otherwise be a snag. Is that right?

Then I found this: https://stackoverflow.com/questions/17628305/windows-git-warning-lf-will-be-replaced-by-crlf-is-that-warning-tail-backwar

From what I can gather, depending on your OS, Windows is going to interpret LF differently than a Linux system, hence GIT looks at LF and wants to replace it with CRLF.


I'm getting to share this with another developer and I want to make sure that I'm not just blowing through something I need to be …
Please help me with GIT.

I have github and I share with a fellow dev.

We have a repository in GITHUB which we both are owners to.

I have an old copy of this repo on my local hardrive.

I want to delete this and do a fresh pull from GIT without affecting the repo or affecting him.

I am looking for the commands to do this.

Also he uses visual studio to do all his commits and pushes and then uses the UI in GITHUB to merge the feature branch to master.

How would I do that using GIT only.

I am trying to force myself to using GIT commands only and get away from learning every UI's way of doing it.

Hi Experts

Could you point if it's possible to clone a repository  (Bitbucket  on my case) from master with a named way ?

What I mean is something like:

git pull origin master  (name)

Or the name is only possible to link a name when commiting (f.e.).

Thanks in advance!
I've found a GitHub Javascript example that I'd like to work with.
It is called hextris, and is a tetris like thing with hexagons. The touch and mouse handling code spots are very simple to find.

Is it indistinguishable if I pull it in to my visual Studio code project using their importing system, or copy the files myself? Obviously their project importing is just quicker?
The project page is here
I think I'd like to set up the files myself, to better learn the IDE?

I'm unable to clone u-boot from my linux laptop?
I also cannot login into github.com

Is there a problem with github?  Few weeks ago I was able to login to github and clone source code from there.
I was hoping to have some strategy for my GitHub profile. I am a 32 year old Computer Science student and I am interested in web development. My goal is to get hired.

Right now my GitHub profile has every Udemy course I have completed as a public repository. Should I make those repositories private and only have a few repositories of projects I have created?
Hi experts

Since I'm part of new team managing cloud projects (AWS)

As part of DevOps, would like to introduce few automation which will streamline CICD

My request is, could you please help me with some pointers, essential process, best practices, house keeping, monitoring automation (I know, its a wide topic) but even a link to a third-party would be very helpful.

Basically below are the areas would like to get some help.

1. github on commit deployment to DEV or QA?. (we already have basic branching and release strategy)
2. Housekeeping, deleting old branches
3. Automated git commit report (generate release note from git code commit).

Atlasian JIRA:
1. Automation around JIRA
2. Integration with github, confluence
3. Essential alerts and report.

1. On commit, reports etc.

please let me know, if you want me to create individual question for each topic

are there any good tutorials on using git on windows? I know one can use command line version or GUI .
do I need to set up a GitHub or some repository account first?
can i set up multiple repository accounts , and commit to different code bases from the same machine, say one is in gitlab another in GitHub ? how do i set that up and how I have read we have to create Ssh key, how does that work?
I am trying to send http requests to the API provided by HelloSign.com........To test what I was doing, I used Git BASH, and the following command completed correctly (I have changed the key and some of the user / document information, but the syntax is exactly as I sent it):

curl -u "9Ca9C0972a4e1ae439Cee8e5d54CCa881031ba247e085807a847aa86Ca080d6a:" "https://api.hellosign.com/v3/signature_request/send" -F "title=rjr.docx" -F "subject=Rick's Test Document" -F "message=Please sign this contract" -F "signers[0][email_address]=rrudolph@test.com" -F "signers[0][name]=Rick Rudolph" -F "file[0]=@c:/docpath/rjr.docx" -F "test_mode=1"

I opened up a VBA module, and set a reference to the Microsoft XML 6.0 library. Then I tried the following:

Public Function TestAPI()

Dim StrAPI As String
Dim request As MSXML2.ServerXMLHTTP60
StrAPI = " -u '9Ca9C0972a4e1ae439Cee8e5d54CCa881031ba247e085807a847aa86Ca080d6a:' 'https://api.hellosign.com/v3/signature_request/send' -F 'title=rjr.docx' -F 'subject=Rick's Test Document' -F 'message=Please sign this contract' -F 'signers[0][email_address]=rrudolph@test.com' -F 'signers[0][name]=Rick Rudolph' -F 'file[0]=@c:/docpath/rjr.docx' -F 'test_mode=1'"
Set request = New ServerXMLHTTP60
request.Open "Post", StrAPI, False
Debug.Print request.StatusText

End Function

This code created an error at :  request.Open "Post", StrAPI, False

The error was:
runtime error '-2147012890 (80072ee6)
System error: -2147012890

I'm ready to install git for my MacBook 10.14.6 and command line, for my Javascript game project's source code needs.
I downloaded an install from source forge and my OS claimed it was from an unidentified dev, thus invalid, or something like that.
What is the correct way to acquire the correct version of git? will my OS recognize it as legitimate?


Can anybody explain to me the difference between the Master and Origin/Master?

From what I understand the Master is the a local branch but if you do a pull request and all there is that not going into the Master?

Why is it necessary to approve the pull request and all on the Azure DevOps site using a browser? Why are not all the aspect contained and functional is Visual Studio 2019? Or is it?

Everything I have read or seen shows a browser for with Azure DEV ops and nothing explains the difference between the Master and Origin/Master. Which is use when? When I create a feature branch which Master do I create that off of?

Any info on this to help with clarity would be greatly appreciated.
error pushing app to heroku
git push heroku master
Enumerating objects: 954, done.
Counting objects: 100% (954/954), done.
Delta compression using up to 4 threads
Compressing objects: 100% (939/939), done.
Writing objects: 100% (954/954), 8.52 MiB | 543.00 KiB/s, done.
Total 954 (delta 122), reused 0 (delta 0)
remote: Compressing source files... done.
remote: Building source:
remote: -----> Python app detected
remote:  !     Requested runtime (python-3.5.1) is not available for this stack (heroku-18).
remote:  !     Aborting.  More info: https://devcenter.heroku.com/articles/python-support
remote:  !     Push rejected, failed to compile Python app.
remote:  !     Push failed
remote: Verifying deploy...
remote: !       Push rejected to appname.
I need to install git 2.22.0 on Oracle Enterprise Linux 6 and can't find an install that works.  I've installed the epel repository, but no go.  Any help would be greatly appreciated.

Is it necessary to do a Git snapshot when we want to have a copy of our code base for our stable website? I had posted a question here about *how* best to create a Git snapshot, but I didnt ask *why*. I got to thinking after that... our web host has daily backups on the server of our entire site, and if anything goes wrong or we push some code from Github to our live site and it breaks something, couldnt we just have our web host restore all the files from the server backup to a date before we screwed things up? I know there would then be an issue of how to get our Github repo reverted back to that date and not lose all our subsequent changes, but maybe thats a better approach then trying to schedule snapshots of our stable site. I'm not sure, though, so Im looking for opinions here.

In Git, how do I:
-sync only certain files
-sync from different repos but in 1 folder, f.e.

Sync full folder 1 to repo1 but only subfolder 3 to repo2
-auto sync = autopull, is it only possible via scheduled task (Windows, Powershell)?

I have list of files on my local branch. I see one extra file.  I want to remove that file but not able to remove it

I have 4 files.

when I submit the review in rbt commons, I see Test1.js.

Tried to remove the file in GitHub ui interface, it does not let me remove

Used the below to checkout the file from master

Git checkout master Test1.js

i still see the file as one of the changed file in my local repo.

Need help removing it
I did a git fetch and was perusing the different branches and I went to checkout a branch and got this:

$ git checkout unitTest
error: cannot stat 'bin/development.sh': Permission denied
error: cannot stat 'start.sh': Permission denied

I can't get to any other branch now and I don't know how to solve "cannot stat..."

Any ideas?
I've set up a git dynamic on my computer and I'm successfully interacting with my remote repository, but I was wondering...

If I wanted to confirm the URL of the repository that constitutes my "origin," how do I access that?

I tried "git config --global --list" and I got "unable to read config file."

How do I access that information?
I'm working with a co-worker who created a new branch on a project that we're both working on. I want to retrieve the code that he put on that branch and put it on my computer.

I'm going through what I can find online and the command would seem to be:

git fetch origin <branch name>

"<branch name> is the new branch that my coworker just created. So if the new branch he just created is "new-master," then all I need to do is:

git fetch origin new-master


It's not working. What am I missing?






Git is a version control system for software development. It is a distributed revision control system with an emphasis on speed, data integrity, and support for distributed, non-linear workflows. Git was initially designed and developed for Linux kernel development. As with most other distributed version control systems, every Git working directory is a full-fledged repository with complete history and full version-tracking capabilities, independent of network access or a central server.