[Product update] Infrastructure Analysis Tool is now available with Business Accounts.Learn More

x

Git

174

Solutions

259

Contributors

Git is a version control system for software development. It is a distributed revision control system with an emphasis on speed, data integrity, and support for distributed, non-linear workflows. Git was initially designed and developed for Linux kernel development. As with most other distributed version control systems, every Git working directory is a full-fledged repository with complete history and full version-tracking capabilities, independent of network access or a central server.

Share tech news, updates, or what's on your mind.

Sign up to Post

hi friends,

i have been trying to send email via localhost using phpmailer and base on research, i was ask to first install composer and set the environment variable. i downloaded and composer from https://laravel.com/docs/5.4  and set the environment variable. the problem is when i try to run (composer require phpmailer/phpmailer) again,

i am still getting this error

[RuntimeException]
  Failed to clone https://github.com/PHPMailer/PHPMailer.git via https, ssh protocols, aborting.

  - https://github.com/PHPMailer/PHPMailer.git
    Cloning into 'C:\xampp\htdocs\vendor\phpmailer\phpmailer'...
    fatal: unable to access 'https://github.com/PHPMailer/PHPMailer.git/': Could not resolve host: github.com

  - git@github.com:PHPMailer/PHPMailer.git
    Cloning into 'C:\xampp\htdocs\vendor\phpmailer\phpmailer'...
    ssh: Could not resolve hostname github.com: Name or service not known
    fatal: Could not read from remote repository.

    Please make sure you have the correct access rights
    and the repository exists.


require [--dev] [--prefer-source] [--prefer-dist] [--no-progress] [--no-suggest] [--no-update] [--no-scripts] [--update-no-dev] [--update-with-dependencies] [--update-with-all-dependencies] [--ignore-platform-reqs] [--prefer-stable] [--prefer-lowest] [--sort-packages] [-o|--optimize-autoloader] [-a|--classmap-authoritative] [--apcu-autoloader] [--] [<packages>]...

i have install git but it still not working. please help! i am new to …
0
Become a Certified Penetration Testing Engineer
LVL 12
Become a Certified Penetration Testing Engineer

This CPTE Certified Penetration Testing Engineer course covers everything you need to know about becoming a Certified Penetration Testing Engineer. Career Path: Professional roles include Ethical Hackers, Security Consultants, System Administrators, and Chief Security Officers.

Looking for a GUI Github software that will download all repositories from a user, without having to do each repository separately.

I have done some searching and couldn't find this in any GUI software, only with CLI.

Thanks in advance for your help,
Future Developer
0
Any Zurb Foundation users on here? I am getting the below errors when opening Foundation.

Version info:

Git = v2.13.2

Node = v7.1.0

NPM = v3.10.10

Foundation-CLI = v2.2.5

----------------------------------------------------

1)      I open the console/CMD Prompt
2)      Try to run:
-      foundation –v (to check Foundation CLI version)
-      -or -
-      foundation new (to start a new project)
3)      Get the error


SyntaxError: Unexpected token function

    at Object.exports.runInThisContext(vm.js:78:16)

    at Module._compile (module.js:545:28)

    at Object.Module._extensions..js(module.js:582:10)

    at Module.load (module.js:490:32)

    at tryModuleLoad (module.js:449:12)

    at Function.Module._load(module.js:441:3)

    at Module.require (module.js:500:17)

    at require (internal/module.js:20:19)

    at Object.<anonymous>(C:\Users\*****\AppData\Roaming\npm\node_modules\foundation-cli\node_modules\terminal-kit\lib\termkit.js:53:26)

    at Module._compile (module.js:573:32)

---------------------------------------

In PATH = Git then NPM then Nodejs

‘foundation –v’  -or- ‘foundation new’ resultsin:

C:\Users\*****\AppData\Roaming\npm\node_modules\foundation-cli\node_modules\terminal-kit\lib\detectTerminal.js:179

exports.getParentTerminalInfo = async functiongetParentTerminalInfo( callback ) {

                                                                     ^^^^^^^^
0
I'm using visual studio code version 1.26.1 for angular projects. Right now I'm using source control GIT. But I would like to change this to Team Foundation Server.
So that I have installed the Visual Studio Team Services. Once after that, I have done the following things.

Open File -> Preferences -> Settings

Add the following lines to your user settings
{
  "tfvc.location": "C:\\Program Files (x86)\\Microsoft Visual Studio\\2017\\Enterprise\\Common7\\IDE\\CommonExtensions\\Microsoft\\TeamFoundation\\Team Explorer\\tf.exe",
    "tfvc.restrictWorkspace": true
}

Open a local folder (repository), From View -> Command Pallette ..., type team signin

when I select the sign in from command palette I got the following error

"(team) No Team Services or Team Foundation Server repository configuration was found. Ensure you've opened a folder that contains a repository.

Please let me know how to set up the Team Foundation Server repository. Do I need to uninstall the GIT for use the TFS? Please let me know?
0
Does anybody know how to solve this Git Issue?
 1.pngI'm using Vs 2017 under windows 10, thank you.

The problem is that I've changed the username in the Bitbucket now I don't know how to tell that to vs.
Thank you in Advance
0
Hello, I'm using GitLab (git), and I want to be able to create a single tag that captures all of the commits for that branch in the past week.
For example, let's say I have 5 different commits to the master branch. I want to create a consolidated tag of all of those commits.

How do I do this? I'm using command line language.

Thanks
Jeff
0
I am trying to push a project I am working on to GitHub, but when I do I am getting the error invalid username or password. I'm entering the correct password.

I have two step verification turned on and I added my public SSH key to my GitHub profile.

I'm running Ubuntu 17.10.
0
We have two concepts in GIT Rebase and Merge

Rebase Overrides the history of commits

Merge keep track of history of commit.

Merge would be cluttered if many people works and commits on the same feature branch.

Rebase would be time consuming when multiple people commits on the same branch eventhough we just changed a few lines in the same committed file.

When to use Rebase and when to use merge in real time is not clear?

Please advise.
0
I would like to Migrate/Port source code in Clearcase to Github without loosing version history.(Complete repository porting without loosing version history information)
 
After google, I followed
https://therub.org/2013/07/19/clearcase-to-git/ and
https://github.com/charleso/git-cc.
and able to  fetch the history. However it takes only  the first version of the VOB from ClearCase to Git.

If anyone have already done this activity please suggest. It would be a big help!!!
If there is any paid tool to do this activity quickly, is also appreciated.


Thanks in Advance.
0
I'm using sourcetree and there is an unstaged file stuck.

The file has actually been removed a long time ago, I don't want it anymore, however, no matter what I do, I can't remove the line from unstaged files.

I've tried remove, ignore, stop tracking etc.. and I get the same error:

git -c diff.mnemonicprefix=false -c core.quotepath=false checkout -- lib/addins/imagemagick/pclip.png
error: pathspec 'lib/addins/imagemagick/pclip.png' did not match any file(s) known to git.
Completed with errors, see above.

Open in new window


I'm sure a git command will fix this, just not sure what to try
0
Starting with Angular 5
LVL 12
Starting with Angular 5

Learn the essential features and functions of the popular JavaScript framework for building mobile, desktop and web applications.

Hello Experts,

I'm trying to share my Visual Studio solution in a new VSTS or Team Foundation Server Git repo.

I have a VSTS account. I'm essentially trying to create a local Git repo for my project using the guide at the following link:

https://docs.microsoft.com/en-us/vsts/git/share-your-code-in-git-vs-2017

I'm trying to 'Add to Source Control' from my VS2017 as shown in the following image:
git
However, I'm not given that option in my VS2017. I also can't see the option when I select my solution in Solution Explorer

Can someone let me know how to select the option?

Thanks

Carlton
0
when running Jenkins build getting the above error.

Jenkins fetch data from bitbucket. in Jenkins scm section I gave bitbucket url and credentials .

how to fix this error ?
0
Hi Experts,

My team have a Github repository and I would like to fetch following data of all the pull requests merged by my developers :

1) Get list of all pull requests merged in repository
2) create date of every PR
3) date when PR is assigned to reviewer
4) merge date of every PR
5) name of developer who has created the PR

I would like to have final output to be either in xml or csv or excel format.

Thank you
0
When Pull Requests are merged in Bitbucket stash, post commit hook of stash is triggering the jenkins jobs. We have multiple jobs for each service and have configured "Polling igores commits in certain paths" with "Included Regions" and "Excluded Regions".

When a merge commit is made to Project A, both Project A and Project B jobs are getting triggered in Jenkins.
But expected should be only to trigger Project A Job.

Project A Job is having below settings:
Included Regions: A/.*
Exclude Regions: B/.*

Project B Job is having below settings:
Included Regions: B/.*
Exclude Regions: A/.*

And with Poll SCM enabled and without any Schedule.

On further analysis, we found there is an unresolved bug in Jenkins Git plugin not supporting merge commits -
https://issues.jenkins-ci.org/browse/JENKINS-32386
https://issues.jenkins-ci.org/browse/JENKINS-20389

We had Git plugin version 3.5.1 installed originally and tried with latest version 3.6.4 as well but no luck.
In JENKINS-20389 ticket, there is a first comment where an user has mentioned "I'm having the exact same issue in the 2.0 git plugin. I have to downgrade to 1.4.0 because of this bug."

So we tried to install this 1.4.0 plugin as well but this has some features missing like Credentials options, Git Parameter options.. So Jenkins was not able to connect to our GIT respository. So unfortunately we couldn't check with this plugin version.

Now, we are stuck with this issue and need help to tackle …
0
I am trying to install Magento2.2 on my iMac. The Installer gets to Success - as per attached BUT the admin directory is not there!!

I have the correct version of php; Apache etc... and am installing the version for my imac.
I have tried loads of other suggestions on the web with git & composer but getting nowhere.

I've assumed it was a permissions problem so set all to 777 to avoid any directory creation issues in the script.
I've tried to work through the install scripts but cannot see where it is creating the admin directory anywhere!

Any ideas or suggestions are very welcome!

Stephen
ee-1.png
0
What is the connection between a Netbeans 8.2 (php) project and a remote git repository? There is no git information in the project properties. I understand using Team menu as described in the docs. The confusion is how is a project logically linked to a remote repo? When I use the Team menu, does that operate on the current project only? What if there are two projects open at the same time?

I have one large project that encompasses an entire server and all its inter-related sub-domains, and one smaller project that is a single sub-domain of the large project. I need to have the larger project connected to one remote repo (on bitbucket), and the smaller project connected to a different remote repo (also on bitbucket). The whole project-to-repo connection is unclear.

Assuming I have to open one project at a time to have different repo's -
when I use Team -> Remote -> Clone the dialog displayed is confusing (see attached image file). This is supposed to be a remote repository (right?), so why are the examples and the Browse button all assuming a local file on my hard drive? Shouldn't it be a url like https://bitbucket.org/.../file.git ?
Image1.png
0
Hello

Let's say i narrow the language in github search. I further want to specify a string to search for in all the repos available. Possible? How?

thanks
0
can we  run a script automatically when a developer commits a change into GIT
best way to run this script. kindly help.
0
I want to know how to edit a comment in git after commit has been pushed , the exact commit number is available with me, I am using "ubuntu 16.04"   and git version is "GitLab Community Edition 8.14.0"
There are few more users who have done a commit after me on the same project.
I do not want other commit messages to be altered.
0
Build an E-Commerce Site with Angular 5
LVL 12
Build an E-Commerce Site with Angular 5

Learn how to build an E-Commerce site with Angular 5, a JavaScript framework used by developers to build web, desktop, and mobile applications.

I have been trying to install GIT 2.8.1 on my AIX server running 7100-03-04-1441, and receiving following error:

# rpm -ihv git-2.8.1-1.aix6.1.ppc.rpm
error: failed dependencies:
        libcrypto.a(libcrypto.so) is needed by git-2.8.1-1
        libssl.a(libssl.so) is needed by git-2.8.1-1

I have verified that both of these files are on the system in /opt/freeware/lib.
 Per my  research findings, I ran the updtvpkg command, and also  exported my  LIBPATH to include /usr/lib/ and /opt/freeware/lib. Also tried the -nodep option, which allowed git to be installed, but then receive the message:
Could not load program git:
        Dependent module /usr/lib/libcrypto.a(libcrypto.so) could not be loaded.
        Member libcrypto.so is not found in archive

Any ideas would be greatly appreciated!
0
Hi Experts,

I've only just started using GitHub - via the latest version of Github Desktop (Windows GUI).

I created a repository via the web interface - and added files to it via the web interface.

Now I'm trying to Sync using the Sync button in Github Desktop.

This gives this error:  GitHub Error: "Failed To Sync This Branch. you might need to open a shell and debug the state of this repo.

I've opened the Github shell and typed git status.

Here's the output:

D:\GitHub test [master ? +1 ~0 -0 !]> git status
On branch master
Your branch is behind 'origin/master' by 1 commit, and can be fast-forwarded.
  (use "git pull" to update your local branch)
Untracked files:
  (use "git add <file>..." to include in what will be committed)

        APSDS50/

nothing added to commit but untracked files present (use "git add" to track)
D:\GitHub test [master ? +1 ~0 -0 !]>

Open in new window


That's all goobledegook to me.

I was hoping to fix this by Github Desktop commands - I really don't want to use the Shell if I can avoid it.

Regards,
Leigh
0
I'm having an issue upon merging to master in git.
A file that I was working on in my local branch (old.file) has been moved and renamed in master (to new.file).
After merging master into my branch I now have the new file and working changes on the old file.

How do I move changed contents of old.file into new.file?
I only want to move the 20-something changed lines of old.file into new.file and then delete old.file.
0
I have a website that I need to commit system generated files and folders to an existing git repository via linux command line. I've pulled the repo to my server, and am writing files within a sub folder of the repo, but when I run 'git add [FOLDER]/*' , its giving me an error that the folder is outside the repository. I'm at a loss as to how to get past this. I'm brand new to git, please help!
0
This is Chef cookbook question.

Question: I need to dynamically reference an index.html file located on github.com within the recipe.

Apache2:

template '/var/www/html/index.html' do
   source index.html.erb
end

In the above code, /var/www/html/index.html file is being replaced with index.html.erb located in <cookbook>/template/default/index.html.erb file. What I want is instead of index.html.erb, I need to use https://github.com/<repository>/myIndex.html

If there is any change in myIndex.html, it should reflect in /var/www/html/index.html realtime.

I appreciate your help.
0
Hi Expert,

I just got installed Git on my server  running on CentOS 6.7. However, I can't access to my repository via public key, actually my laptop can access my server using ssh key which I already added to server, I would like to know is there any configuration I should take on my linux server in order to get access to my repository?

Thanks
0

Git

174

Solutions

259

Contributors

Git is a version control system for software development. It is a distributed revision control system with an emphasis on speed, data integrity, and support for distributed, non-linear workflows. Git was initially designed and developed for Linux kernel development. As with most other distributed version control systems, every Git working directory is a full-fledged repository with complete history and full version-tracking capabilities, independent of network access or a central server.

Top Experts In
Git
<
Monthly
>