We help IT Professionals succeed at work.

Golang

641

Solutions

1K

Contributors

Golang, also called Go, is an open source programming language that is a statically-typed language with syntax loosely derived from C, adding automatic memory management, type safety, some dynamic-typing capabilities, additional built-in types such as variable-length arrays and key-value maps, and a large standard library. Go is a general-purpose systems programming language that aims to be efficient both for development and execution with a focus on fast compilation and increased maintainability of large projects. Go was originally targeted at systems programming tasks such as building server/web applications, high throughput middleware and databases.

I have a new in the box Philips SIC4750/27 Webcam.  I want to install it on a Windows 10 laptop.  The CD it came with does not have a Win 10 driver.  The Philips website does not have one.  I found a few places online that said they do, but did a search and was told they were malware sites.  Is there a safe place to get a new driver for an old Webcam, or just go buy a new one?
0
Hi Experts!

How would I go about setting an Out of Office on a shared mailbox that does not have an O365 license and have the emails direct to the two staff's email address's who monitor this mailbox?

Thanks!

M
0
I am being bombarded with robocallers on both my present voip  phone service through my local fiber ISP which is Elevate Fiber. I also have a second "landline" service through Magicjack. Both are working, but both are victims of incessant robocalls. I have a cell number that WAS experiencing the same difficulties. I signed up for NOMOROBO.COM service for my cell. I have not received a single robocall in four days! Amazing! I wanted to avail myself of the same service for my two voip numbers but both Magicjack and Elevate Fiber do not support that app. How might I go about finding another voip provider?
0
Hello,
I have a wordpress site going and was wondering if there is a way via wordpress or something else to make item's on an image clickable.  See attached, each round circle I have a doc for. I'd like to link the circle to the doc's but not sure how to go about this. Thank you!A.M-HW-SOLUTIONS-Healthy-Lifestyle-M.png
0
I am currently writing a Crystal Report in CR 13 SP 12.   I have several rows that look like this:

Name           Service         Quantity         Time Spent
Jeff                Lawn                   1                    3 hours
Jeff                Lawn                   1                    4 hours 
Rick               Floors                  1                    2 Hours    
Rick               Floors                  1                    1 Hour   
Rick               Floors                  1                    3 Hours

Open in new window

     

What I need to do is combine the rows for each name, adding together the "Quantity" and "Time Spent" columns, so the output would look something like this:

Name            Services            Quantity           Time Spent
Jeff                 Lawn                   2                      7 Hours
Rick               Floors                  3                       6 Hours 

Open in new window


How would I go about combining the rows and getting sums in this way?  So far I've created grops for the names and for the Services, but can't break through that next wall.
0
I am creating windows services using C# , and configurator for the service using windows form app in C#. So, I want to include start, stop and know the state of the service( Running/Stopped) functionality on my configurator, how would I do this using C# ? So if I click start button it is going to start the service and if I click the Stop button it would stop the service, and text field should display the status of the service (running, or stopped).

 All I want to make my configurator user friendly, so that user don't have to go to Task Manger and manually stop or start the service. Not only for the service I created, but this would allow me to write any service name on the text field, and should give me service status, and if it is already running, and  I click stop button it should stop, if it is stopped, and I click start button it should run.
0
I have this excel sheet filled with data. The setup is like the original and enables my to see at a glance if the sheet is still like the source data.
Therefore I decided to bilinear interpolate the data to get the value I want by inserting the x and y value.

I managed the bilinear interpolation judging bij de average of the 4 zvalues given at the bottom of the sheet and the the answer in cell N7.

My question is how to calculate the values at the edges of the table. For example. How to get the value of x 1000 y 10. To interpolate I need 4 zvalues and in this instance I have only Q_11 and Q_12.
How to go about the value x 6000 y 42 which gives me 4 zvalues where I only need Q_11.

My first idea was to figure out if the bilinear interpolation is always needed for example the x 0 y 42 value since its value is on the chart. Maybe a combination af bilinear interpolation and ...
900W-CFM56-7B26.xlsx
0
Hello,
        I have a Asus RT-Acrh13 router that I am trying to tether to a Verizon Hotspot. The Hotspot has USB 3.0 so there no USB version conflicts should be causing this.

 What happens is this:
1:  I power on the Asus and let it get to ready.
2:  I plug in a ethernet cord to the 4th port on the system and connect it to my laptop.
3:  I then connect the Hotspot to the Asus. the Hotspot detects that a device has connected
4:  I start the Quick setup (for some reason I can't get to the setting otherwise ) and set the device as USB Modem and finish the quick setup.
5: I then go to the network map and see that the Hotspot is there but I have no internet connection.

Unplugging and reconnecting the Hotspot shows that it is dis/connected on the hotspot and on the router but nothing happens. I can set the Hotspot to USB and Wifi but that still does not let the USB connection work. Thinking that it could be the Hotspot that is the problem I tried my cell and it was the same result except that it says that the cable is unplugged ( which it is but that is not the point ) I did some research on it and as luck has it I have a phone that is just incompatible with this router: a Samsung S7. I borrowed a 10S from a co-worker and hers "worked" as in it gets a IP but I still can't get online from our systems.. I updated firmware and tried 4 different cables. the results are t he same. Any tips on this?
0
I am trying to push a custom made screensaver file *.scr to several machines in my network via registry keys.  After doing research on which keys to add and where I settled on these:

HKEY_CURRENT_USER\Control Panel\Desktop  ScreenSaveTimeOut=300

HKEY_CURRENT_USER\Control Panel\Desktop  ScreenSaverIsSecure=1

HKEY_CURRENT_USER\Control Panel\Desktop  ScreenSaveActive=1

HKEY_CURRENT_USER\Control Panel\Desktop SCRNSAVE.EXE =maint.scr

I have tried other locations like "HKEY_CURRENT_USER\Software\Policies\Microsoft\Windows\Control Panel\Desktop" with same results.

The .scr file is in the system32 and/or sysWOW64 (either place causes same issue)

Now for the issue.  The above edits apply via policy just like they are suppose to but when I or any user log in and wait the 300 seconds for the screensaver to turn on nothing happens.  I go look at the "Screen Saver Settings" and the maint.scr is chosen with 5 minutes on the wait time.  If I change the wait time to anything lower or higher in time and the screen saver will work, I also changed it back to 5 minutes and it works then as well. Although when a new user logs on the settings are overridden by the policies and I have to go through the changing of the wait time to get it to work again.

Oh, this is happening on Windows 10 Pro machines up-to-date on all drivers, window updates, and software updates.

Any ideas?
0
- client is using an RDS server (VM) for roughly 7 users
- we recently moved them from a Windows 2016 server to a new 2019 server (also a VM)
- some of the users are also running Datto Workplace sync & share on their remote desktops
- one of these users swears that on the Windows 2016 server, items they deleted from the Workplace folder would bypass the Recycle Bin, but that items deleted from the Desktop would go into the Recycle Bin by default
- user would like to see this behaviour on the new server
- Datto confirmed that this is not a feature that their software has
- from what I can see, there is no option for changing the default Recycle Bin behaviour from within a specific folder (settings to bypass recycle bin will apply to the entire drive), but the client insists that this was set up before

Is there a practical way to make items bypass the Recycle Bin from a specific folder only (similar to how items on different network drives will bypass the Recycle Bin)?
0
I'm modifying a HUGE ppt deck and want to more quickly modify two settings in each slide. There's gotta be a faster way than to manually go into the paragraph dialog box and manually changing the spacing to 6 PT (before) and the Line spacing to SINGLE.
bad
0
I have a program that uploads a folder that a user selects, but I want to make sure the folder does not contain sub folders (otherwise they might upload their entire hard drive!). I have the path to the folder and just need to know if there are sub folders. I'm thinking there should be a way to do this with just a couple lines of code, but I can't find anything.  I found the below code, but it's in C# and I can't figure out how to get it to work in VB.  I don't need to use this code... if there is a better way to do this, I rather go with the better solution.

Please do not post links... I'm looking for code. Thanks!

DirectoryInfo directory = new DirectoryInfo(SubFolderFullPath);
DirectoryInfo[] subdirs = directory.GetDirectories();
                       
if (subdirs.Length == 0) hasSubfolders = false;

Open in new window

0
What can we use to better avoid complications from lightning strikes?  All our equipment is on UPS and surge protection, but the lightning strike this morning that made the power go off and back on over a couple of seconds seems to have fried one of our routers and one of our switches. I thought having the router and the switch on UPS and surge protection would protect them, but that clearly wasn't enough.  What else can we use or install to guard against large spikes like that?  Both the router and the switch were on two different APC UPS units in different areas of the office.  There were also devices on those UPS's, but only the router and the switch fried. The other devices are fine.
0
I wish to create a secure verification system for a php based website.

I am using password_hash to save the password securely in a MySQLi database

$hashed_password = password_hash($_POST["password"],PASSWORD_DEFAULT);

Open in new window


The $hashed_password is then saved in the database. Then during login check the password in the database using.

       /* $hashed_password is retrieved from the database */
 
	if (password_verify($_POST['password'], $hashed_password)) {

		session_regenerate_id();
		$_SESSION['loggedin'] = TRUE;
		$_SESSION['name'] = $_POST['username'];
		$_SESSION['id'] = $id;
	

		// go straight to the provider admin area as we've logged in
		header ("Location: ../accm1.php");
		exit();
	} 

Open in new window



My question arises in the next step, I am aware at the top of 'accm1.php' I can use the following:

<b>accm1.php</b>
<?php session_start(); ?>
<?php // If the user is not logged in redirect to the index page...
if (!isset($_SESSION['loggedin'])) {
  header('Location: index.php');
  exit();
}?>

Open in new window


So if the user isn't logged in, the user is sent to index.php and doesn't see the contents of  'accm1.php'.

This does work,  and I'm no expert on security, but have read about stealing keys from sessions and the like, which I understand little about to be honest. I have also seen various solutions that focus on taking an ID of the computer that logged in, but read this may cause users to be logged out sporadically if the server changes it's IP.

Given that

<?php // If the user is not logged in redirect to the index page...
if (!isset($_SESSION['loggedin'])) {
  header('Location: index.php');
  exit();
}?>

Open in new window


Isn't a very secure way of ensuring that the logged in user, is in fact the user that logged in, I am looking for help to improve my code so that it's very secure, but won't in any way cause interference to the 'real' users experience.

Please help and enlighten me,

Thank you
James
0
Hello, I am in the process of changing a mail server to google and website to Wix, and the domain is with Go Daddy. In the past, I have done something like this before and I setup Cloudflare to manage the DNS setting but I didn't put in my notes why I did this so my question is if my domain is with go-daddy and website is with Wix but email is with google should I just set up the DNS on go daddy or setup Cloudflare? Its been a while since I have done this.
0
I have an old (not that old NAS. IOMEGA StorCenter PX4-300D. It's a 4 bay and I have 4 4-TB drives in it.
I bought it a few years back (actually like 8 years) and never used it. I initially initialized and formatted the drives when I bought it but as I said never used it. It's in perfect working condition. The issue is it's obsolete on their website and I can't find the latest firmware update. My question is do I use it as is or can I wipe out the OS on it and use something like Open Media Vault, FreeNas, etc? If so how do I go about doing that? and how do I get any compatible firm ware updates?

Any help is appreciated.

I'm not sure if I want to use it for home (personal) or business use.
0
We are currently have a large amount of data we want to back up to a safe location. All of our IT infrastructure including servers and storage (Dell EMC) are located on premise. We have a gateway server that allows our servers to connect to the Internet. The data doesn't need to be accessible constantly. We only need to retrieve the data when there is a catastrophic event on premise. We are looking into AWS Glacier as our solution; however, we have couple concerns:

. Can we just use the AWS Glacier service without using any other AWS services to upload and to retrieve our data?
. Our data is currently located on an Isilon that doesn't have direct access to the outside Internet? Can we set up so that we can upload/retrieve data from the Isilon to AWS Glacier?
. The files and folders we want to back up to AWS contain very large graphic files. The files can go up to couple hundred Gibs. Will speed be an issue?
0
Hi,
There are File Servers:
FS#1 is bad.
FS#2 is the replacement.

Here is the hierarchy of the folder:
FS#2> Marketing > Proposal > many folders here
The permitted users to Read, write or modify every folders under the “proposal” folder are
User#1
User#2

I want to give permission to User#1 to be able to modify any folders under the “proposal” folder.
The things that I do:
I go to the Proposal folder > right-click, select properties > go to the Security tab > click Edit > then, I add the “user#1” and give him “Full Control” permission > then, click OK or Apply

My question: Is there anything else that I have to do?

tjie
0
This one is really getting to me. I would like to run most of my docker containers by connecting them to a vlan on my Ubiquiti network but cant seem to get it working. although admittedly I don't know much about docker and I'm still very new to it.

I have tried creating a macvlan for one of the networks and that seems to be alright but I cant seem to get my containers connected to it.

I would like to connect to my vlan at 192.168.20.0/24 just doing that with an nginx container or something would be a great example for me to go by.

Thanks in advance for your help.

Stuart
0
We would like to use Biztalk to do some EDI transforms, and I am standing up a new 2019 server with Biztalk 2020 in the lab to see if it will do the job we need. After a lengthy round of double checking all the prerequisits, I finaly have an install.....almost.  When running the configuration manager I get an error on the one part I will need!  The section labeled 'Biztalk EDI/AS2 Runtime' flags an error "Host (BizTalkServerApplication) is an invalid Recieve Handler for SQL AdaptEr.  Please go to BizTalk Administration Console to add BizTalkApplication as a new Receive Handler."
Seems pretty straight forward... but the administration console does not have a SQL Adapter.  More digging into Biztalk documents reveals the SQL adapter has been removed in version 2020.  Links guide me to documentation that tell me it is available in the 'adapter pack' which has 5 adapters included.  However the adapter pack that came with the distribution only has 4, the SQL adapter is not included. With much Google-fu I am still unable to find a download for the holy SQL adapter.  Just lots of places that tell me that is what I need.

Does anyone have a link to this adapter download package?

and WTH does a fresh out of the box install fail to set up a component for lack of a adapter that has been removed from the distribution?
0
I have a client that is running Windows Server 2016. They have two FTP sites (behind a VPN firewall) on Ports 21 and 21000. The reason they have 2 FTP sites to to accommodate different aspects of their business.

These FTP sites recently stopped working for no obvious reason and I've set-up SFTP for them.

Following an online set of directions I found [1], I am able to have certain users land in a given folder (e.g. ~\ProgramData\ssh\sshd_config) with the directive:

ChrootDirectory D:\FTPSites\Site

Open in new window


Otherwise it defaults to C:\Users\UserName, which is not acceptable to them long-term.

Is there a way to have SFTP go to a different directory based on the local user accessing the server? Or is SFTP limited to only one folder a user can "Chroot" to?

Thanks!

[1] https://tech.xenit.se/installing-and-configuring-sftp-server-on-windows-server-2016/
0
I've downloaded the latest MS Edge because it seems quite good.  I had previously been using Chrome.

I'm able to set my home page to google.com, which I want because I use gmail and my contacts and calendar are all also at google.

Edge will go to this, but only when I have one instance and only with my initial page.  All other times it goes to some MS page (not specified in the address bar, but certainly the bing home page).

Is there anyway to get all tabs in all sessions to go to something besides bing.com?
0
Over the last two weeks, I've had a number of Windows 10 computers go into a looping restart.  Upon system power up, a Windows logo appears for a short bit with a dotted whirligig... the screen clears and is followed by a second dotted whirligig... after another short bit, the screen clears and the system drive activity light flashes for some 20 - 30 seconds before the system restarts and the sequence begins again.  This looping restart continues until power is removed from the system.

I've tried booting from a Windows 10 installation CD and running Repair.  Startup Repair does nothing.  System Restore does not remedy the looping restart.  Chkdsk with /r does nothing.  The one time I was able to get the option to start in Safe Mode, the looping restart prevailed.  On earlier systems, I simply restored from backups.  On this particular system, it has no backup to recover to.  Yes... I've created a full image backup of the drive so I can recover data.  But I'd like to think that I made every possible recovery attempt before I perform a clean Windows install, return the client's data and inform them that they'll need to reinstall programs, printers, email, settings, etc. that are now lost for good.

Any ideas?  I have a stinking suspicion that this won't be the last of these symptom computers that I see.

Thanks for reading and giving thought to this!!

Jim
0
Hello All,

So we have a database where each client have their own schema.  I need to implement a backup and restore process.  So far I've been able to backup a specific schema but I'm getting errors when I try to restore that backup.

Here are the steps I've done so far:

Step 1 Create schema:
ALTER DATABASE [TestSchemaRestore] ADD FILE ( NAME = N'TestSchemaRestoreHost_Data',
FILENAME = N'C:\Program Files\Microsoft SQL Server\MSSQL14.SQLEXPRESS\MSSQL\DATA\TestSchemaRestoreHost_Data.ndf' , SIZE = 8192KB , FILEGROWTH = 65536KB )
TO FILEGROUP [HOST_FILEGROUP]
GO
ALTER DATABASE [TestSchemaRestore] ADD FILE ( NAME = N'TestSchemaRestoreTenantOne_Data',
FILENAME = N'C:\Program Files\Microsoft SQL Server\MSSQL14.SQLEXPRESS\MSSQL\DATA\TestSchemaRestoreTenantOne_Data.ndf' , SIZE = 8192KB , FILEGROWTH = 65536KB )
TO FILEGROUP [TENANTONE_FILEGROUP]
GO

--sp_help EventHistory

USE [TestSchemaRestore]
GO
/****** Object:  Table [host].[EventHistory]    Script Date: 1/13/2020 1:18:47 PM ******/
SET ANSI_NULLS ON
GO
SET QUOTED_IDENTIFIER ON
GO
CREATE TABLE [host].[EventHistory](
      [EventHistoryID] [int] IDENTITY(1,1) NOT NULL,
      [WhenOccurred] [datetime] NULL,
      [Category] [nvarchar](50) NULL,
      [Description] [nvarchar](200) NULL,
      [UserID] [int] NULL,
      [Value1] [int] NULL,
      [Value2] [nvarchar](max) NULL,
      [Value3] [datetime] NULL,
      [Value4] [bit] NULL,
      [Value5] [decimal](18, 2) NULL,
      [SubTenantID] [int] NULL,
      [TenantID] [int] NULL,
      …
0
Hello Experts

I have a client who is translating some documents using Word 2010.  One document is over 45 pages long.  He needs to insert footnotes, but it stopped inserting them on page 33.  Once he got to Page 34, the function quit.  He can go back to earlier pages and enter them, but not past Page 33.  

I imported the document to test it and it does the same thing on my computer, also using Word 2010.

I copied and pasted pages 34 to the end to a new Word Document and it enters footnotes just fine.  He is on footnote 16 and in what I copied and pasted, it starts with number 1.  But I think I can make that work so it starts with the correct number.  So I've found a potential work-around, but I'd like to fix this.

Anyone have any ideas?

Thanks

thedslguy
0

Golang

641

Solutions

1K

Contributors

Golang, also called Go, is an open source programming language that is a statically-typed language with syntax loosely derived from C, adding automatic memory management, type safety, some dynamic-typing capabilities, additional built-in types such as variable-length arrays and key-value maps, and a large standard library. Go is a general-purpose systems programming language that aims to be efficient both for development and execution with a focus on fast compilation and increased maintainability of large projects. Go was originally targeted at systems programming tasks such as building server/web applications, high throughput middleware and databases.