We help IT Professionals succeed at work.

Golang

640

Solutions

1K

Contributors

Golang, also called Go, is an open source programming language that is a statically-typed language with syntax loosely derived from C, adding automatic memory management, type safety, some dynamic-typing capabilities, additional built-in types such as variable-length arrays and key-value maps, and a large standard library. Go is a general-purpose systems programming language that aims to be efficient both for development and execution with a focus on fast compilation and increased maintainability of large projects. Go was originally targeted at systems programming tasks such as building server/web applications, high throughput middleware and databases.

The previous exchange admin previously tried to install Exchange 2016 in a (2) DAG Exchange 2010 environment and caused some serious issues.  I went ahead and cleaned it up when I was tasked with the role but after decommissioning the Exchange 2016 server I am seeing a lot of health monitoring mailboxes and system mailboxes in our AD under CN=Microsoft Exchange System Objects.  

I want to know what is the best way to remove these identities to clean things up but without causing any issues?   Let me know if further detail needs to be provided.

I am trying to clean these up before I go into upgrading our Exchange environment to 2016.
0
I recently installed SharePoint Server 2019 (and all pre-requisites) on a Windows 2016 Server OS with no errors; however, when the Product Configuration Wizard finished and attempted to automatically open Farm Configuration Wizard under Central Administration web page (//_admin/adminconfigintro.aspx?scenarioid=adminconfig&welcomestringid=farmconfigurationwizard_welcome), it will not accept any login combination, i.e. the SPAdmin, SPFarm, nor my Enterprise Admin account which I used to install SharePoint.  I've verified the passwords for all, none are locked and they are all in the "Farm Administrator's" group (which I found thru searches on a very similar issue).  I'm able to go in to SharePoint Central Admin thru the Start menu and accepts my login; however, when I click on "Configuration Wizards", it displays "Farm Configuration" and an icon, but neither are an actual link to click on.  Any assistance is appreciated!!
0
Hi and thanks for reading.
We have always-on VPN sat up in our Network.
Some users complain that they can only connect to local recourses for a very short time. After that it shows as connected on Win 10 pc, but no traffic can go over until they disconnect and connect again.
If we test by running a continuous ping it stays up. Until we stop ping. and then VPN tunnel close after 5 sec... (but still shows as connected)

During testing, we also found that connecting over hotspot (via iPhone) it works fine.
Also some users repport they have no problems. So ISP is a factor. But strange that as they can connect and that as long as a ping is running the tunnel is up!!

Please help
0
PLEASE HELP ME. No one in IT for my company can help me figure out why I am getting this error.
This is the code in the file of the database I am trying to run, everything else in the application works just fine,
IF  EXISTS (SELECT * FROM sys.objects WHERE object_id = OBJECT_ID(N'[dbo].[db_RoundsOrderSeq]') AND type in (N'P', N'PC'))
DROP PROCEDURE [dbo].[db_RoundsOrderSeq]
GO

CREATE Procedure [dbo].[db_RoundsOrderSeq]
      @Action char(3),
      @HospitalCode char(1) = '',
      @RoundsKey varchar(8) = '',
      @Sequence smallint = 0,
      @Location varchar(10) = '',
      @Room varchar(8) = '',
      @Bed varchar(4) = '',
      @ReturnErrorDescription varchar (200) = '' OUTPUT

AS
BEGIN
-- db_RoundsOrderSeq: Insert, Update, Delete
-- (C) Copyright 2013 Universal Hospital Services, Inc.
-- Created by SMH 04/24/2013
-- Version 8.00
-- Changed by SMH 02/27/2014 Right Justify Room and Bed
-- Version 8.01

-- Return Version only
If @Action = 'VER'
   BEGIN
   Select Version = '8.01'
   RETURN
   END

Set @ReturnErrorDescription = ''
DECLARE
      @ROS_RoundsKey varchar(8)
      
-- Right Justify Room and Bed (already done in table class)
SET @Room = RIGHT('        ' + RTRIM(@Room), 8)
SET @Bed = RIGHT('    ' + RTRIM(@Bed), 4)
 
-- Import Record
IF @Action = 'IMP'
      BEGIN
      Set @ROS_RoundsKey = ''
      Select @ROS_RoundsKey = RoundsKey
            From RoundsOrderSeq
            Where HospitalCode = @HospitalCode And RoundsKey = @RoundsKey And Sequence = @Sequence
      IF @ROS_RoundsKey = ''
            Set …
0
Hello all,

We have recently migrated to Azure and have found that powering off one of our two session hosts during off-peak hours has significantly reduced our costs. The process is automated and works well. All servers in the RDS farm are Server 2012 R2.

The issue is that every few weeks or so, the host that was powered off will boot up and come back online at its specified time, however, it for some reason will not accept new connections. We then very quickly max out the capacity of the first host and new connections to the RDS farm are dropped.

When this happens, the broker shows that the server is connected and does not seem to report any issues. That being said, the broker shows the server is connected even after it has been powered off for ~8 hours so we can't really rely on that. Using Get-RDSSessionHost to try and detect when the server is having issues is of no help as it always shows connected.

The solution is to reboot the host and on the next reboot it starts accepting connections and the issue is resolved. The problem is that we need a way to detect this issue before it gets to the point where users are not able to connect. So we are looking for a way to monitor this and alert when users are not able to connect to the second host. Hoping someone here has some ideas on how to go about this.

Thanks!
0
The communication code VBA for RS 232 has failed, it cannot transmit any data to the Rs 232 gadget kindly help me to locate where the problem is. There are no errors whatsoever during transmit ion but the data does not go or written to the com port 4. The json part is okay and confirmed by the users I’m also able to see the results by using text file instead of on an Immediate window. The requirement here is to write data, send and receive data from rs 232 gadget.

VBA CODE RS 232

Dim json As String
    Dim intPortID As Integer ' Ex. 1, 2, 3, 4 for COM1 - COM4
    Dim lngStatus As Long
    Dim strError  As String
    Dim strData   As String
    Dim lngSize As Long
    intPortID = 4
    ' Initialize Communications
    lngStatus = CommOpen(intPortID, "COM" & CStr(intPortID), _
        "baud=115200 parity=N data=8 stop=1")
    
    If lngStatus <> 0 Then
    ' Handle error.
        lngStatus = CommGetError(strError)
    MsgBox "COM Error: " & strError
    End If
    

    ' Set modem control lines.
    lngStatus = CommSetLine(intPortID, LINE_RTS, True)
    lngStatus = CommSetLine(intPortID, LINE_DTR, True)

    ' Write data to serial port.
    strData = JsonConverter.ConvertToJson(transaction, Whitespace:=3)
    lngSize = Len(strData)
    lngStatus = CommWrite(intPortID, strData)
    If lngStatus <> lngSize Then
    ' Handle error.
    End If
Exit_CmdConertJson_Click:
Exit Sub
Err_Handler:
Resume Exit_CmdConertJson_Click

' Read maximum of 64 bytes from serial 

Open in new window

0
We have setup where we have a main site and a warm DR site. Both sites are connected via a site-2-site vpn and both sites have 2 domain controllers.

All DC are 2016 and we are a vmware shop.

Recently, we started to noticed major time drifts. We thought this was due to time.nist.a being deprecated.

We updated the peers on all the DCs to go to new time servers


I feel the problem is we have peers set on all the domain controllers and that we need to do the following

PDC - set primary and secondary NIST server

all other DC, Set Primary as the PDC with time.nist.giv as a fall back encase the server is down.


Please let me know your feedback or if you have a similar setup.


Thanks!
0
I do work for a municipality and have run into an issue.  The building is run on a domain with a domain controller that runs the DNS and DHCP.   The Internet provider owns the firewall so they control it and we cannot even have the admin password.   There is also a DSL line that is used to go directly to the state.   Up until two moths ago the two computers that use the DSL line to the state would also be on the domain for the building.   Then there was an issue where the state said their site was down over the whole state.   Then when the state brought the site back up, those two computers had to be detached from the building network and be directly plugged into the DSL router only.   Again, before this happened the two computers were able to get to the state site via the DSL line, but then the users could also print to the building network printers even is they downloaded from the state site and needed that file printed.   If I do a trace route, the first thing it hits is the ISP network firewall then it hits the DSL router, then it goes out into the cloud to the states server.      Any ideas how this could have been setup or why it might not be working now?  Any ideas?
0
We are supporting multiple separate sites, not on the same domain network, nor server and across the board multiple computers are experiencing the same issue, when they are turning on, while loading Windows, they go to a "Fixing (C:) Stage (numbers from 1 to 5)" and a percentage with an ETA of hours (could be 4 to 20 hours), once stage 1 gets to 100% is goes to stage 2 and so on.

All computers are Windows 10, so we are assuming a Windows Update. Does anyone have more information about it?
0
Hello, I'm trying to jump into the programming side of things and I have a course I need to finish.  I have been going through the course material, challenge exercises, and coding sections and find that reading isn't helping it stick.  Maybe it's the course, but probably me.

Looking for a Python one-on-one type instructor for virtual sessions to go through the programming portion with me.  I have limited time access to the course and would need to complete the material in a couple weeks.

Thank you
0
My home page in sharepoint online is reporting as 900GB when I go to the metrics page  
https://tenant.sharepoint.com/_layouts/15/storman.aspx and add up all the sites it only comes to 220GB. Can anyone tell me what the additional space is or how I locate it, thanks.
0
We are trying to have our old website redirected / resolve to a new domain name which is now hosting the companies current and active website

so users/clients currently trying to access "www.Domain1.com" and getting a 404 page not found error,  as the site is no longer active. We have our new domain available at "www.Domain2.com"

If i go to our domain host management page for Domain1.com, its showing that domain is pointed to the DNS servers our ISP manages. If i then go to our ISP's DNS zone management page, it previously had A records for www.Domain1.com, which have since been removed, and in its place a new CNAME record

the CNAME record is as follows

www.Domain1.com 300 IN CNAME domain2.com

My understanding is that when users try to access www.Domain1.com, it hits our ISP DNS zone, should see the CNAME record and then send back the IP address for www.domain2.com and the user will get the new website

This is not currently working, what am I missing?

Thank you!
0
In Google Photos, my photos are uploaded as original, because I don't want complression. My Google Drive is steadily filling up, but a big chunk of the space is taken up with motion photos (or Live Photos as Apple call them). I have now disabled motion photos in my phone's camera, because I don't use it anyway, but now I have tens of thousands of photos with motion enabled, taking valuable space in my Google Drive. I know that cropping a motion photo removes the motion from it, so is there a way to do this for all photos, without cropping?

This isn't something that Google will provide a feature for, because they don't want people to keep a lean Google Drive. But is there a script that can be utilised to recursively go through all photos and strip out the motion from all of them?

Thanks.
0
I have an organization with Exchange 2013 servers at three sites running a DAG. Latency between sites 1 and 2 is about 1-2ms, and latency between either site and site 3 is 25-35 ms. get-exchangeserver shows all three servers using the DC at site 2. we have been noticing serious delays in replication when settings change- for example, 2 weeks ago we removed a delegation setting from a mailbox, and one of the users still has the access while the other does not. Sometimes settings take a few days to go through. Any idea where I should look for the cause of this? I haven't noticed anything abnormal in the event logs. The only change I made recently was this morning where I removed Hyper-V time sync from the guest services for the DC, which was causing a 3-minute time difference between sites- well within the 5 minute SSL/Kerberos 'skew' limit. Let me know- I appreciate any suggestions!
0
I currently have Magic Mirror installed as well as both the MMM-Facial-Recognition and MMM-Facial-Recognition-Tools modules.  I captured training images and ran the necessary scripts.  However, I am having a problem setting up the config.js file and making my mirror selectively display contents on the screen by who is looking at it.  I am not sure how exactly to go about this because everything I have found online so far has provided no guidance.
0
Hi expert,

For connection between outlook 2010 client connect exchange, which authentication is more recommended? negotiation authentication or NTLM authentication?

In our internal network environment, all PC need to go through proxy to access internet.


With proxy connection, during setup do i still need to tick and enable msstd:exchange.contonso.com?

Thanks.
0
I am helping a client of mine with some AV issues. They have two desktops that are pushing out Powerpoint presentations to large flatscreens in a lobby area. But the problem here is the way they have the connections going to the large screens. If you notice in the photos they basically have pieced connections together to get something going on the Screens. I want to get a device that will take the display port coming off the desktops and go to a device that will connect the flatscreens and eliminate all this clutter. The client is reporting that the presentations tend to stop running and freeze up. I checked everything on the machine in relation to any hibernation or powering down etc etc. unless there is something Im missing i dont know what else can be done about it
 


IMG_0439.jpgIMG_0440.jpgIMG_0441.jpg
0
I have 3 Backup Exec 20.5 servers. 2 are on identical hardware and identical tape libraries. One of the servers runs as normal as Backup Exec can run. The other one finishes a job, puts it in the job history as completed, but it remains as an active job for almost 30 minutes before it finishes. This is causing major delay's in our backups and is causing a high volume of missed backup jobs. I have an active ticket open with Veritas. Their conclusion is because there are hard read/write errors on some of the drives, it is causing the issue. However, the server that is working fine on the identical hardware also has tape drives with hard read/write errors. I let the tech know this, but he would not budge on on fixing the read/write errors first, then we will go to the next step.

We write directly to tape. I am currently in the process of creating a disk storage on this server to see if a disk to disk backup does the same thing. In the meantime, has anyone else seen this? Or have any ideas I can try while waiting on Veritas support to try and repeat this same issue in their test lab?

Thnak you in advance for any ideas I get from this post.
0
Exported SSRS reporting  data in Chrome  now exporting to separate tabs in Excel.  I there a setting in Excel  or Chrome to only have the data go to one tab?
0
Hello All,

We have a trading server (an ec2 instance in London) and 3 data centers that feed information to the trading server. of the 3 DC's, 1 is hosted on AWS in HK, 2 others hosted outside AWS in HK as well.

How can I go about setting up a direct connection between all 4 sites in order to reduce network latency. Happy to offer further clarifications.

Thanks!
0
In the toast pop ups, the firewall being disabled notification will keep popping up despite every effort to disable it - via policy, via registry hack.....anyone have any insight to this?
0
hi got server 2016 as Active directory.
i want to know about a particular user"Ä", in which computer he has lastly logged on to or which computer he was using ? how do i find it out from active directory ? ?


got more than 100 computers in domain, cannot go into each computer and search for his user profile. so is there any way to find out which particular computer the user "ä" has used lastly ?
0
Hi

 

current setup.

1. login to 3rd party web app using ADFS

2. WIA works from domain joined clients on LAN

3. all external clients login using forms based og login page on ADFS

4. internal non-domain joined clients and iPads/Macs won't fallback to username/password on internal LAN, and will somehow go directly to 3rd parties web app showing Accecss Denied

5. 3rd party web app is configured to use WIA when auth request comes from our LAN public IPs, and password protect when it comes from any other public IPs

 

Problem.

1. having non-domain joined clients, and non windows systems fallback to username/password auth when on LAN

 

Troubleshooting steps taken

1. get-AdfsGlobalAuthenticationPolicy

PrimaryIntranetAuthenticationProvider - (FormsAuthentication, WindowsAuthentication)

WindowsIntegratedFallbackEnabled - True

2. added Chrome iOS agent to supported agents (Mozilla/5.0 (Macintosh; Intel Mac OSX)

 

Will this have to be tweaked at 3rd party web app aswell?
We have other 3rd party systems configured and they work with WIA fallback
0
Here is a weird one for account lockouts.

We have a GPO (Server 2012 R2) that sets a user's SSID with RADIUS (EAP), it all works and the user connects with a W10 endpoint via a Meraki WAP (MR42). For about 10/475 endpoints/users constant lockouts happen. We have domain controller logging enabled (nltest /dbflag:0x2080ffff) on the DCs and it tells us its coming from our NPS server that handles the RADIUS authentications. I also see these EAP failures on the WAP logs for the specific workstation so I know its coming from the endpoints.

We've cleared out all the credentials on the workstations but we still find that NPS if locking it out.

We also go to the endpoint and test connecting via WiFI/SSID and it works just fine.

This happens for a few times in a row and then stops for hours.
We've even tried to turn off WiFi and still see these events happen.

I see the repeated log entry until it locks out:
11/07 14:40:32 [LOGON] [8732] -DOMAIN HERE-: SamLogon: Transitive Network logon of DOMAIN\nvega from  (via NPS01) Entered
11/07 14:40:32 [CRITICAL] [8732] NlPrintRpcDebug: Couldn't get EEInfo for I_NetLogonSamLogonEx: 1761 (may be legitimate for 0xc000006a)
11/07 14:40:32 [LOGON] [8732] -DOMAIN HERE-: SamLogon: Transitive Network logon of DOMAIN\nvega from  (via NPS01) Returns 0xC000006A

Open in new window


The lockout event:
11/07 12:51:47 [LOGON] [8388] -DOMAIN HERE-: SamLogon: Transitive Network logon of DOMAIN\nvega from  (via NPS01) Entered
11/07 12:51:47 [CRITICAL] [8388] NlPrintRpcDebug: Couldn't get EEInfo for I_NetLogonSamLogonEx: 1761 (may be legitimate for 0xc0000234)
11/07 12:51:47 [LOGON] [8388] -DOMAIN HERE-: SamLogon: Transitive Network logon of DOMAIN\nvega from  (via NPS01) Returns 0xC0000234

Open in new window


These log entries match-up with the DC's Event Viewer's security section.
0
Hi

We have been given Cisco Firepower 1010 firewall to use at a site and we need help with configuring site to site VPN.

Here is the current status

1. We don't have what's called the FMC, we only use FTD which is the built-in management web interface for the device. I know there is command line also available via terminal but I have no clue about how to use it. I am more of a GUI person.
2. I have managed to configure the basic settings so I can get on the Internet from behind the firewall.
3. I have also configured site to site VPN with the remote site. Remote site is using a Draytek Router and Draytek side it is showing that the VPN has been established. On Firepower side, I can't see the status in the GUI but command line (show crypto isakmp sa) is showing VPN to be up. I googled that command I don't know CLI commands for cisco.
4. So VPN is up but can't route traffic between the two sites either ways.

I am aware that in Cisco firewalls, just doing VPN isn't enough, you have to do firewall rules or policies etc. I don't know where to do it from GUI and I have a feeling it might not even be possible via GUI in this device. That's fine as long as someone can help me create those rules and policies using command line.

Need to go live next week so any urgent help will be greatly appreciated.
0

Golang

640

Solutions

1K

Contributors

Golang, also called Go, is an open source programming language that is a statically-typed language with syntax loosely derived from C, adding automatic memory management, type safety, some dynamic-typing capabilities, additional built-in types such as variable-length arrays and key-value maps, and a large standard library. Go is a general-purpose systems programming language that aims to be efficient both for development and execution with a focus on fast compilation and increased maintainability of large projects. Go was originally targeted at systems programming tasks such as building server/web applications, high throughput middleware and databases.