We help IT Professionals succeed at work.

Golang

640

Solutions

1K

Contributors

Golang, also called Go, is an open source programming language that is a statically-typed language with syntax loosely derived from C, adding automatic memory management, type safety, some dynamic-typing capabilities, additional built-in types such as variable-length arrays and key-value maps, and a large standard library. Go is a general-purpose systems programming language that aims to be efficient both for development and execution with a focus on fast compilation and increased maintainability of large projects. Go was originally targeted at systems programming tasks such as building server/web applications, high throughput middleware and databases.

Emails from sender on Allow List continue to go to Quarantine.  Messages are typically in the 20 Mb range.  Email header attached.
0
Hi all,

We are switching to using the Windows Firewall for clients after using Sophos for many years.  At the moment I am configuring a GPO and have a couple of queries.

1.) How can I stop or restart the Windows Firewall service?

I have noticed that when I go to services and look at Windows Defender Firewall, everything is greyed out and I have no option to stop or restart it (yes, I am running services with admin credentials).  If I run Task Manager as administrator and access services this way, when I attempt to stop with Windows Defender Firewall service I get:

The operation could not be completed.  Access denied.

2.) Problems with logging.

a.) I have enabled logging in the GPO.  I left it with the default  %windir%\system32\logfiles\firewall\pfirewall.log location.  However, the log fails to be created.  I have read about the requirement to add "NT Service\MpsSvc" with full permissions to the location but the log file still fails to be created even when I add this permission.  Even if I could get it work, how would I replicate this permission change to all my PC's when I deploy this business wide?

b.) I quite like the idea of changing the path where the log file saves to a central shared location.  I was thinking of using a %computername% variable in the file name to save a different file for each computer.

is this possible?

Thanks in advance
0
We have an issue after standing up a hybrid solution. Only on-prem users can see online users and send messages. Does not matter if they are local to network or coming through Edge server on guest network. Online users can only see other online users, cannot send or reply to on-prem users. Both sides are open federation. Federation partner test passes. All users are synced with AADC with Skype attributes enabled. All local, tenant configuration settings, DNS entries doubled checked by multiple people. Edge server running in DMZ with dual NICs with F5 acting as reverse proxy. Wondering if someone could point us to where we need to go next for testing, troubleshooting to get this resolved.
Thanks!!
0
After rebuilding on prem server (rest in Azure), users at the location randomly get the errors when saving or opening a recent file, "location is not available". More rare, a user may not be able to access a specific share with the error "element not found" (reboots resolve this). The first error will go away if they open Explorer, navigate to the folder, then return to the application and hit save/open. If a user is using explorer (file, not IE) and go many folders deep, and click on the address bar to go up a few folders, they sometimes get "location not available". But, if they  click on the root of the drive, they can immediately go back to where they wanted.

Our environment is Windows 2012R2. The server is also a DC. We are running DFS to a single Namespace, mapped to a single drive letter (z:) to all users via GPO. Our DFS replicates to 3 other servers in other sites, none which exhibit the same issues. All clients are Windows 10 May update.

What I have done so far...

Updated and verified all firmware, drivers, and OS updates.
Ran DCDIAG tests. (no errors)
Ran REPADMIN tests. (no errors)
Checked client and server for relevant errors in system logs (no relevant errors)
Verified all file and share permissions (all shares use "authenticated users", perms set at file level
Had users manually disconnect drive and rerun gpupdate to remap drive

When a user accesses the share via the namespace (wii.local\cloud), they will still randomly get the error.  I have …
0
I have 10 reports that I pull out of dynamics and need to reformat the date/time cell, add a week and month column based on the date in the date cell. All 10 reports have the same column structure but number of rows vary. After the columns are reformatted and two additional columns added, I need to copy and paste everything from row A2:Fend of data in another workbook (compiled scorecard data_Dev2.xlsm) on worksheet 6 (changes based on the report pulled from dynamics). Once I paste the data onto the "compiled scorecard" report I do not have to go back to the sample report. I will attach a copy of a sample report that comes out of dynamics (sample report.xlsm), a sample of how the data should look after reformatted (sample report after reformatted.xlsm) and the workbook it needs to be pasted on (compiled scorecard data_Dev2.xlsm). I have completed these steps using the macro recorder however I am now running into a "out of memory" issue and unable to run these macros. If you could give me an idea of how to properly structure this VBA as to avoid running into the "out of memory" issue.
sample-report-after-reformatted.xlsm
sample-report.xlsm
compiled-scorecard-data_Dev2.xlsm
0
Hi all
 
We are having problems pasting into Quick Edit. It just... doesn't work? If I try to paste more than say 10 rows, the screen whites out with the 'Loading' wheel going and no matter how long we wait, it simply hangs.
 
This is across two tenants and several users. Anyone got any ideas? It's really getting in the way of things.
 
I can paste one row at a time, but even that can be patchy, sometimes it only picks up the first one or two fields and then we get the little blue loading wheel in the first cell in the row.
 
Whenever either of these things happens, the Exit Quick Edit link is unresponsive and we have to exit all the way out to another page, go back in and try again.
 
Screen grab:Loading-Hang-Snip.PNG
Thanks!
0
I have just purchased a license for several Remote desktops for Windows 2016.
I am not interested in doing any anything complicated I just want 5 users to be able to access a desktop session on a server. No WAN access involved, just the same feature as the admin RDP but with several licenses.
How can I do that without having to go through the whole setup of gateways and certificates  that seems to be required by this version of RDP ?
0
I'm trying to write a powershell script which will go through all computers in Active Directory and get a list of local accounts and their descriptions.

The problem that I'm having is that it was hitting the domain controllers and then getting all the domain user accounts as well.  So I tried to filter those out, but it's not working correct.

Get-ADComputer -LDAPfilter "(&(objectCategory=Computer)(!userAccountControl:1.2.840.113556.1.4.803:=8192))" -Property * |  select -expandproperty name -first 1 | foreach-object {
    $Comp = $_
      if (test-connection -computername $Comp -count 1 -quiet)
{
                    ([ADSI]"WinNT://$comp").Children | ?{$_.SchemaClassName -eq 'user'} | %{
                    $groups = $_.Groups() | %{$_.GetType().InvokeMember("Name", 'GetProperty', $null, $_, $null)}
                    $_ | Select @{n='Server';e={$comp}},
                    @{n='UserName';e={$_.Name}},
                    @{n='LastLogin';e={$_.LastLogin}},
                    @{n='Groups';e={$groups -join ';'}},
                    @{n='Description';e={$_.Description}}
 
                 }
           }
     }|Export-Csv -NoTypeInformation LocalUsers.csv
0
Hi Experts,

I have a Site to Site VPN between a ASA 5506-X and ASA 5512-X. The VPN is working fine all traffic is flowing in both directions through the tunnel. The problem I have is, on the remote site if I want the server to access the internet directly, it can't as I think all requests are being sent through the tunnel. I suspect it is to do with NAT, I have tried a few things to divert traffic not destined for the head office to not be sent through the tunnel but so far I have had no luck. I have attached the configuration for the remote site ASA config.

In summary, I need the server on the DMZ interface (192.168.35.0/24) to pass traffic through the tunnel to the remote network 192.168.1.0/24, all other traffic to not go through the tunnel. At the moment the VPN is working, but internet requests are failing,

Thanks in advance!!

Paul
Config.txt
0
I have a Parent Table Called Clients and a Child Table Called Insertion. Since Ms-Access 2007 does not support Transaction VB.Net I am looking for the best way to delete a child then a parent, but I want a method in case any error happens that prevent the 2 Queries to execute.

If we are using Transaction we can ROLLBACK but as I told you access 2007 doesn't support that

DELETE * From Child Table WHERE Condition

If Query 1 Execute with no error then go to query 2 otherwise abort the operation

DELETE * From Parent Table WHERE Condition

if Query 2 Execute with no error display a message otherwise abort the 2 execution
0
got a ransomware and it took out my system. I want to find out if there is anyway i can get system restore up and running to go back before I even had this issue.
0
Every now and then we go to install a refurbished mitel 5330, 5340 or 5360, the phone works but none of the keys show on the screen.  They will function but they don't appear. We will then swap to another phone and the keys all show up. Cant find a reason for this, It seems to be the phone as if we try it somewhere else, the keys wont show.  Anyone have any ideas?
0
Hello all, and Happy Friday!!  
I've been trying to build a useful spreadsheet for a client in Google Sheets that requires three functions I am having difficulty with, and they are so linked together, I am afraid to post them as separate questions.  Here goes:
1) I would like to automatically export data from only one tab (Tab D) of a multi-tabbed daily spreadsheet into one separate new monthly summary spreadsheet. (Outcome: all data from tab 'D' from all (m-f) daily reports appears in a new single summary of that tab for the entire month. So my daily reports have tabs a, b, c, and D, but we get to see a whole months worth of 'tab D' in its own separate monthly report.)
2) In a separate tab in this new monthly summary report, rather than listing the litany of measurements we've made that month and have a clunky, crowded spreadsheet,   I would like to include a drop-down menu that indicates different criteria, and when that items is selected, that function is executed.  I've attached a small sample of what I mean. And lastly,
3) I would like a chart accompanying that selection to appear when selected, if possible.  So in the example I attached, when I click on 'Brand New Member - Did Not Work Out' my desired outcome is that the number of members who signed up for the gym but did not work out would be displayed (that data lives on another tab in this same report) AND that the chart/visual for that data ALSO appears when that item is selected from that drop-down menu...

0
We're having issues regarding patching and reporting via SCCM.  This seems to stem from two sources, DNS and SCCM.  Some of the issues originate from multiple sources...

1.  When help desk would reimage the same machines, they did not go into AD to delete the "old" machine name or clean up the process on the backend.

2.  We migrated from one SCCM server (site) over to another.

3.  Some machines on the current SCCM are still pointing to the "old" site.

4.  On our DNS server, there are multiple IPs showing for the same machine name.

We need to do the best possible way as far as time and man power...while at the same time, with the least possible downfall should anything occur (uptime for our users).  

Please let me know your recommendations.
0
I have a excel file in a folder on a server. This file is essentially a template, I make a copy of the file and then go to save it in the same directory as the other one. But, when I go to save the copy, the Excel uses the C:\Users\<Username>\Documents location as the default save path.
Is there any way to get Excel to look at where the original file is, then automatically point to that location when i go to make a copy of the file.
0
I have the Faststone slideshow maker to arrange the order of images.  However, Faststone has at least one major flaw.

My question what slideshow editor has the full screen for thumbnail which is great for editing/arranging images.

Lifetime license for the software is preferable.  I have tried over two dozen software titles, so far none meet my ideal.
0
I'm following this tutorial: https://medium.com/swift2go/building-grpc-client-ios-swift-note-taking-app-6133c7d74644
The problem is I can't understand what exactly is happening in the following code:

func listNotes(completion: @escaping([Note]?, CallResult?) -> Void) {
        _ = try? client.list(Empty(), completion: { (notes, result) in
            DispatchQueue.main.async {
                completion(notes?.notes, result)
            }
        })
   }

Open in new window


I need someone to explain me the above piece of code in detail.
Can anyone please help?
0
We have a client that needs a fax server setup for them.
We just purchased a new ProLiant DL325 Gen10 server running server 2016.

We tried installing a Fax modem on one of the PCI slots on the server but did not like it. Server would crash.

We now want to go with a USB fax modem and found a business class USB fax modem. It is a Multi-tech USB Modem MT9234ZBA-USB-CDC-XR.

Does anyone know if this will work on Server 2016?

Or would anyone know of a USB modem that will work?
0
My 10-year old boy is driving me crazy and making me look bad.  I don't normally do pre-algebra and thinking math problems such as the area, perimeter how much volume and such questions and need help explaining math problems.  What's available for me to learn at the same time explain.  I know the internet is out there, but since I work a regular 9-5pm job, I don't have the luxury of asking the teacher and knowing what's for homework.  I also know the internet is out there, but don't know where to go to look for how to's for math and school subjects.  Can you point me in the correct direction?
0
We have had an issue that started a few months back where after a reboot, we will have random databases go (Recovery Pending) .  
- Servers are both 2016 and 2012R2 running SQL server 2014 SP3CU3 / SP3CU2
- We are running CB Defense and have exemptions listed for any .ldf and .mdf file types
- Event viewer shows no errors in system or application

I am able to fix the issue by running a tsql script but when the server gets rebooted it is a 50/50 that the issue happens again.

After looking on line I found a post about looking into logs under mssql
- When digging into the mssql\logs I have the following entries

2019-04-23 19:22:13.78 spid17s     Error: 17204, Severity: 16, State: 1.
2019-04-23 19:22:13.78 spid17s     FCB::Open failed: Could not open file D:\SQL\DB\XXXX.mdf for file number 1.  OS error: 32(The process cannot access the file because it is being used by another process.).
2019-04-23 19:22:13.95 spid17s     Error: 5120, Severity: 16, State: 101.
2019-04-23 19:22:13.95 spid17s     Unable to open the physical file "D:\SQL\DB\XXXXX.mdf". Operating system error 32: "32(The process cannot access the file because it is being used by another process.)".


2019-04-30 08:16:05.86 spid18s     FCB::Open failed: Could not open file D:\SQL\DB\XXXXX.mdf for file number 1.  OS error: 32(The process cannot access the file because it is being used by another process.).
2019-04-30 08:16:05.88 spid18s     Error: 5120, Severity: 16, State: 101.
2019-04-30 …
0
I have a number of 2014 SQL servers each with a number of databases.  We have one SQL2014 server that is dealing with all the transaction log restoring for all the servers.  The disks are getting hammered every 15 mins, but after about 8 minutes are just fine.  SQL logs show that the SQL doing the restoring is having a hard time keeping up (Write latency, etc)  While waiting on a second TL restoring machine, is there any way to stagger my restores so they do not hit all at once?  I have the restore jobs set to go every 15 mins - Daily but that does not give me a chance to change the start time from 1:00 to 1:05 for example for some of these database restores - all within the 15 minute copy window.

Thanks!
0
We have a Windows 2016 Standard Server running on VMWare ESX 6.7.  
There is a data drive on this server that we have encrypted with bitlocker.
It's set to automatically unlock the drive, however, this auto unlock doesn't happen until a user has logged back into the server.
So what's been happening, is our client will have a power outage, the server will shutdown, and boot back up when the power is restored.
They go to access this drive on their PC's because it's locked.  It become's available when the administrator logs into the server.

Is there a way to set bit locker to automatically unlock when the server boots and doesn't require an administrator logon?
0
Domain naming master and PDC FSMO at random switches back to the secondary DC rather than staying with the assigned PDC. So i have to go back and change it to point to the PDC. Any reason why this happens?
0
Hi,
I am importing data from a CSV file into SQL Server Express and one of the columns contains data format  £5,420 or  €5,420
Can the SQL table column be modified to accommodate data ? I would prefer it to be converted to format  5420 or  5420 if possible.
How can I go about it.
Thanks
Ian
0
One of our client's server went down yesterday at 6:00pm sharp. No one in the office knows why. No one did anything. in the morning It was powered back on and everything seems to be ok.

All other computers in the office and on the network stayed up and running. no issues.

I'm looking for evidence on why the server went down and I'm not finding anything. The event logs show that everything seems to be fine up until 6:00pm then no more log entries until the server is powered back on at 7:23am this morning.

In my experience this indication suggests that the server lost power. It that safe to assume?

Where else should I look for evidence?

THANKS in advance!
0

Golang

640

Solutions

1K

Contributors

Golang, also called Go, is an open source programming language that is a statically-typed language with syntax loosely derived from C, adding automatic memory management, type safety, some dynamic-typing capabilities, additional built-in types such as variable-length arrays and key-value maps, and a large standard library. Go is a general-purpose systems programming language that aims to be efficient both for development and execution with a focus on fast compilation and increased maintainability of large projects. Go was originally targeted at systems programming tasks such as building server/web applications, high throughput middleware and databases.