We help IT Professionals succeed at work.

Golang

640

Solutions

1K

Contributors

Golang, also called Go, is an open source programming language that is a statically-typed language with syntax loosely derived from C, adding automatic memory management, type safety, some dynamic-typing capabilities, additional built-in types such as variable-length arrays and key-value maps, and a large standard library. Go is a general-purpose systems programming language that aims to be efficient both for development and execution with a focus on fast compilation and increased maintainability of large projects. Go was originally targeted at systems programming tasks such as building server/web applications, high throughput middleware and databases.

We have a Sharepoint 2007 farm and 1 of the site collections stopped working all of a sudden. When trying to go to a site we get "File Not Found". Turned on more detailed errors and getting "Resource cannot be found" HTTP 404 The resource you are looking for could have been removed, had it's name change, or is temporarily unavailable. Also getting a bunch or this error in Application Even Viewer. "Console Configuration File Error: File Not Found. The system cannot find the file specified.
We have rebooted the server and have also moved the site collection to a different WFE and it will work for a little bit and then back to getting these errors.
0
Hi There

I have a client who sells time slots for his his business in many different locations. Up until now there has never been any issues because the customer would have to go to their website to start booking an appointment. It is a WordPress site using the Bookings extension with WooCommerce.

However, they are now going to be working with a Hotel that will be sending them some clients, and we will need to monitor the bookings being made.

Is there software/plugins/scripts that will allow a code to be added to the URL which will follow a button clicked on their website through to a booking being made???

We need some way of tracking any bookings being made which originate from the Hotel website.

regards
0
I have a customer running peachtree Complete Accounting 2012. They have several computers running Win 7. Which has to go. They are using it on an office network and do not want to go cloud.

Question 1 - I have not had success getting it to run on win 10. Is there a solution?

Question 2 - They are willing to upgrade. Is there a comparable upgraded version? I am only finding cloud and single user.

Thank you
0
Dear All


           i have an issue with WSUS server, i checked that some client computers showing with "no status", and i try to go to the problem client computer and click "check for update" but i received the error code, any way i can get the problem client computer receive windows update by wusu ?


1
2
0
Upgrade to Server 2012 R2 failing with LSI Logic LSI Adapter, Ultra320 SCSI 2000 series, w/1020/1030 driver.  I have a VM machine running Server 2008 R2 and trying to upgrade to Server 2012 R2.  I am being asked to update the driver, but am having issues finding it.  Most sources say go to LSI website, but its appears to have gone away.  I think the only reason this server has the Ultra SCSI adapter is because the server was originally a Physical  that we did a P to V on.  Advice please?
0
I have one of my users that is having an issue in Excel.  It seems that any excel file he has, complex or simple calculations has this same issue.  If he leaves the file open, and does other things on his pc, or steps a way for a while, Excel is very slow to respond when he clicks a cell on the spreadsheet.  He has several spreadsheets he updates every day.  He is so used to this issue, that he knows to click on a cell and go work on other things for a minute or so, then comes back and works in spreadsheet.  It acts like excel is hung, but always comes  back and stats working.  You just have to wait.  Everything else on his pc responds great.  He said many other co-workers have told him they have the same issue.  We run Microsoft Office 365 ProPlus, and we do use cloud storage such as Microsoft's OneDrive.  I think most of his files are stored on SharePoint, and this also has cloud storage back to Microsoft.  Almost seems like Excel has its own hibernation mode.
0
New to solar winds patch manager. I have deployed updates to test group. updates arrive to all machines but don't get installed. I have to manually go to updates and install them. not able to figure out why?
0
Hello
I am trying to authenticate my API calls using JWT with nodejs and javascript using qeuelize and mysql . I was able to get the token and send it in the headers using postman, but if i want to send it from the html form once the user sign in and then the token will be send or go through to authenticate the user. how will I store the token so the user can send it with the middle ware to be reauthorized to access the index page.
signin function:

exports.signIn = (req, res) => {
	console.log("Sign-In");
	console.log(req.body.username);

	User.findOne({

		where: {
            username: req.body.username,
		}
	}).then(user => {
	    console.log(user.password);
		if (!user) {
			return res.status(404).send('User Not Found.');
		}
        let passwordIsValid = bcrypt.compareSync(req.body.password, user.password);
        if (!passwordIsValid) {
			return res.status(401).send({ auth: false, accessToken: null, reason: "Invalid Password!" });
		}

        const token = jwt.sign({id: user.id}, config.secret, {
            expiresIn: 86400 // expires in 24 hours
        });


       // res.status(200).send({ auth: true, accessToken: token });
       res.sendFile(path.resolve(__dirname,'../public/index.html'));


    }).catch(err => {
		res.status(500).send('Error -> ' + err);
	});
};
/************************************** verifyToken function****************/
verifyToken = (req, res,next) => {
  const token = req.headers ['x-access-token'] || 

Open in new window

0
Dear all,

I have a dynamic picker in xamarin forms where I have an entry before I realize then when entering data in the entry and go to the picker, picker data is opened twice.
How to solve this issue?

Thank you
0
Hi,

Am trying to create a solution to convert spring boot microservices to AWS Lambda. Am getting mixed opinions on if spring boots should even be considered suitable for aws lambda.
Under what circumstances would it make sense for me to go ahead with the conversion?
What type of assessment checks should I do before I try to re-write a Java based microservice to a serverless function?
0
I had been trying to find a solution to setting up the shared calendar, contact, and hopefully files using our office 365 account.
Instructions from Go Daddy and Microsoft itself don't provide much clarity. It's an important project that I need to get off it's feet.
We have a corporate 365 email plan that I need to share a public calendar and an internal calendar so public (external and internal email accounts) AND private (Internal email accounts) events can be separately accessed.

I'd like to be able to have everyone contribute OR post to the calendars, but I'm not sure how to set it up.

Also, I'd like to be able to have ALL contacts from ALL emails sent/received to the corporate address be available to ALL users...OF Course APPROVAL will be required prior to making the contact available to all. This would be necessary to establish a FULL directory of Customers, Vendors, Distributors, etc. for corporate communications.

I'm the IT Director and Office Administrator with hope of putting in a more complete solution in the near future. Currently we have 15 key email users.

Thank you in advance for your suggestions and potential solutions.
0
Exchange 2013 Installed Go Daddy SSL Certifcate that was rekeyed after renewing.  OWA and Email is working fine.  Can no longer access ECP (internally from the server and externally - both worked properly before the new certificate was installed two days agao.  In IIS Default Site has new Certificate listed under HTTPS correctly.  Certificate names did not change.  How to regain access?
0
Customer called, they are having an issue after a Synology DS1515+ system had a power failure.
The customer moved the drives to the new Synology NAS.
Once they did this they powered up and had to check consistency.
The consistency scan ran for 5 or 6 hours. From there when that ended, we could see the iSCSI information on the Synology.

We went into the ESXi console, Tried adding a storage adapter and connection that would target the NAS and see the datastores.

When we add the host name of the iSCSI target, we don't see anything populate. But if we go in and add the IP address of the Synology in question under the Dynamic Discovery, we see 3 disks come up under static. It shows the .25 IP address and an IPv6 address for each of the LUNS.   But even with the LUNS showing up in the discovery area, we still can't target the storage and see it under the Storage Adapter as noted in the image attached. How can I get the Synology NAS to show the iSCSI Target so the system will boot again?
2019-01-10_22h46_09.png
2019-01-11_01h07_13.png
0
I use different netsh commands to run individual back ups of DHCP servers.
For example:
netsh dhcp server dump > \\10.0.0.1\dhcp$\Area1\dhcpcfg.txt
netsh dhcp server export \\10.0.0.1\dhcp$\Area1dhcpdb all
pause
netsh dhcp server dump > \\10.0.0.2\dhcp$\Area1\dhcpcfg.txt
netsh dhcp server export \\10.0.0.2\dhcp$\Area2\dhcpdb all
pause
I have to go on each server to run this
Please indicate a power shell command I could use to run once and back up all my dhcp servers
0
Hello Experts.

I'm looking for some creative ideas on how I might go about adding drill-down capability to my databound forms. Allow me to explain...

Let's say that my hypothetical project is for managing a local sports league, and includes three databound tables and corresponding forms for entering / updating records:
  • Players
  • Teams
  • Schedule

As you can imagine, some of the data in these tables are related. So, the Players table would have a field to specify which team they are on. The Teams table would have a field to specify the Captain and their Player ID. The Schedule table would have the two Team IDs that are competing each week.

I would like to be able to make the TextBoxes which have a direct relationship clickable, with the action being to display the correct Form and record. So, if I'm working within my Players Form, and I want to have a look at the details about their Team, I could just click that field and the Teams form would be shown for that player's team.

Hopefully, that's fairly clear. Any thoughts how I might go about making this a reality?

Tony
0
Hi,
Can someone please help me understand how a certificate works on a firewall. The concept and how the firewalls authenticate certs.
The scenario is a Fortigate 100d with a cisco ASA (3rd party) Certificate based VPN.

We have setup a tunnel however i don't see many logs due to firewall in shared datacentre managed external. However they do not support certificate based VPN tunnels.
We initially setup on pre shared key and was fine. So we know all the other settings are correct.

We have created a CSR on the fortigate and completed this with a CA "Digicert" we have loaded the cert into the firewall (Fortigate using web gui) We have received the Certificate Authority (Go Daddy from external 3rd party and installed these. Now remote_Cert1 2 etc.
We have setup the VPN tunnel to use the Peer certificate and pointed to 1 of the Go Daddy Remote-Certs. No option on a Fortigate to use 2 certs.

The info we are getting from the Cisco side debug is as follows

IPSEC An inbound LAN to LAN SA xxx between IP and IP (user==IP has been created
same and outbound LAN to LAN created
AAA retrieved default group policy IP for user =IP
local remote connection established. then it say an IPSEC inbound/outbound LAN to LAN has been deleted.

The CIsco (3rd party side have no experience on Fortigate( they are seeing a message saying our certificate has been successfully validated SN x subject name CN = company etc.

The tunnel won't come up on the fortigate. So any info on …
0
We are setting up Log Analytics in Azure and are trying to monitor for specified services if they go into a stopped state.  My issue is that I'm not seeing all of the EventID records for event 7036 in Log Analytics.  If I use the following query:

Event
| where (EventID ==7036)
| where Computer == "xxxx.yyy.com"


I see entries for some services but not all.  Example I see entries for "The WMI Performance Adapter service entered the running state. "  but none for "The Print Spooler service entered the stopped state." when the following entry is in the Event log on the actual VM.


Log Name:      System
Source:        Service Control Manager
Date:          12/7/2018 2:28:39 PM
Event ID:      7036
Task Category: None
Level:         Information
Keywords:      Classic
User:          N/A
Computer:      xxxx.yyyy.com
Description:
The Print Spooler service entered the stopped state.
Event Xml:
<Event xmlns="http://schemas.microsoft.com/win/2004/08/events/event">
  <System>
    <Provider Name="Service Control Manager" Guid="{555908d1-a6d7-4695-8e1e-26931d2012f4}" EventSourceName="Service Control Manager" />
    <EventID Qualifiers="16384">7036</EventID>
    <Version>0</Version>
    <Level>4</Level>
    <Task>0</Task>
    <Opcode>0</Opcode>
    <Keywords>0x8080000000000000</Keywords>
    <TimeCreated SystemTime="2018-12-07T20:28:39.267645100Z" />
    <EventRecordID>122417</EventRecordID>
    <Correlation />
    <Execution ProcessID="664" …
0
I am having a real problem trying to get an Office 365 label published. I have created the label and linked it to a policy and applied it to my test account. When I go into my word online the label does not appear. I have an E1 and an AIP license assigned. Any ideas why this is not working
0
Search results appear to have no file associations . it shows a blank page and you cannot click on it to open the files.  These are word documents.  you then can go into the directory and open the file ok.  Only the search results is missing the file associations.   The os is 2016 server with remote desktop.
0
if (stripos($anwer['infomation'], trim($propThree['value'])) !== false && $anwer['infomation'] != ""){
                                $html .= "<div style = 'margin-top:5px; padding-left: 0.10rem !important ;'  class='form-check form-check-inline'><input style='width: auto !important;' class='form-check-inline' type='checkbox' name='property" . $cusData['propertyId'] ."[]' id='property" . $cusData['propertyId'] . $c . "' value='{$propThree['value']}' checked='checked'/>";
                            } else {

Open in new window




database
why is this not working ? suspose to go in split this string and if it checked than output the checked option else non checked option but they not checking.
1
Hi,

i have receive an SonicWall SonicPoint N2,

i have plugged it on my poe switch, i dont have the poe injector who come with the package. i just have the access point device only

i have access to the firmware and i dont see any way to enable the 2.4 and 5 ghz radio, if im go to the status page i see the 2 radio is disabled right now.

is there a way to edit that and enable the radio and change wifi settingsscreenshot of firmware page
0
I have installed Outlook 365 and is Version 1089 (Build 10827.20181) when I open outlook, outlook keeps asking for my password even though is correct. Any ideas how I can fix this since I have over 100 employees that I need to do the update but im afraid of it since I have this issue that will not go away.

Thank you
0
We're noticing that more and more of our users are having problems with appointments actively syncing between each other when using Outlook. We need a scheduled appointment to show up immediately, so duplicates are not created. We've taken it to disabling Outlook email caching on each computer so they are all actively syncing updates with the server. Since we've started this there hasn't been any issues until now, but now more and more users are starting to complain about things not showing up fast enough or right away.

We need to find a way to solve or implement a change to fix this problem. It’s odd that it is all of a sudden happening to numerous people. Is the only solution really for me to go to all computers and turn off cache mode? Or is there a bigger issue that could solve this?
0
Hi Technical Gurus ,

I need your worthy advice and guidance . Actually we are building our data center and for server virtualization , I need expert suggestion . Either we should go for KVM or VMWARE . As of course , KVM is an open source , the management would prefer to go with KVM to reduce the cost but  I need solid reasons if I refuse to go with KVM and instead opt for VMWARE . In any case I need you guys expert opinion to choose either one for our data center servers virtualization .  The brief summary of our network requirement is that we need 150 cores and 350 GB RAM ,,, we plan to purchase 6 servers with 28 cores each and plus six more for high availability. I need your worthy guidance regarding the selection for virtualization.

Best Regards

Masud
0
SSRS- Created a blank report and used a DB dataset to just drag and drop a text field onto it.  It only shows one row.  This was a limitation of SSRS and that field.  
Solution was to create a Tablix and go through the following to display a separate row per page:
https://www.mssqltips.com/sqlservertip/3493/display-a-fixed-number-of-rows-per-page-for-an-ssrs-report/
The problem is that when I place the Tablix field in my report it is in the position I want.  But due to the page breaks I lose my position and the field ends up on the top of my report with my report being broken up.  Is there a way or how do I get the position of the Tablix field to not move when traversing through my data?
0

Golang

640

Solutions

1K

Contributors

Golang, also called Go, is an open source programming language that is a statically-typed language with syntax loosely derived from C, adding automatic memory management, type safety, some dynamic-typing capabilities, additional built-in types such as variable-length arrays and key-value maps, and a large standard library. Go is a general-purpose systems programming language that aims to be efficient both for development and execution with a focus on fast compilation and increased maintainability of large projects. Go was originally targeted at systems programming tasks such as building server/web applications, high throughput middleware and databases.