Golang

547

Solutions

1K

Contributors

Golang, also called Go, is an open source programming language that is a statically-typed language with syntax loosely derived from C, adding automatic memory management, type safety, some dynamic-typing capabilities, additional built-in types such as variable-length arrays and key-value maps, and a large standard library. Go is a general-purpose systems programming language that aims to be efficient both for development and execution with a focus on fast compilation and increased maintainability of large projects. Go was originally targeted at systems programming tasks such as building server/web applications, high throughput middleware and databases.

Share tech news, updates, or what's on your mind.

Sign up to Post

Can someone look at the code at http://www.gtraxc.com/ and tell me my the "Create Account" link doesn't open?  Note that it works when you go to http://www.gtraxc.com/login.asp and click the "Create Account" link.  Note that this framework was written for me and I am not completely familiar with all of the syntax...but working on it.

Thanks in advance!
0
I know how to create a certain trace on the SQL Profiler but I have to....set up a SQL Server Profile trace on our prod server (SQL Server 2008) to capture execute times for a specific stored procedure, and to capture events where a query been delayed more than 2 seconds due to locks which I haven t done before.


Database: testdb
Stored proc: (sp_ex)
Elapsed: more than 300ms
Login: login\test

How would I go about this?
0
Server is R810 with four MD1200's attached.  Oracle db on it.  System had been running fine until last Thursday when it signaled a bad drive on the first md1200. We hot swapped it out and the rebuild appeared to go normally.  However, enen though its led light is normal green and the system states that it's online, performance is noticeably slower.  Also, I noticed that the led's on the hot spare of that md1200 are BOTH solid green while the other three md1200's only have the top led green (and the bottom led is off).  Does this suggest that it's still in some kind of rebuild almost a week later? CPU, RAM and network all seem to check out.  Also, non Oracle jobs are slow, so probably not Oracle.
0
Hi
I'm trying to perfect my streams chess client server.
I've had some bad luck doing a board out of an 8x8 of characters, and I'm backing away from that, because chess servers out there prefer an 8x8 of piece objects. I still make the mistake of early 80's (4/5 years old) non-object-oriented thinking, occasionally. Some short-cuts are long-cuts.
I have no problems with move generation. In fact, I find that enjoyable. I want this to be all my own code, in case I move it to Python, - it will be totally smooth 4 me.
So,
I can maintain the state on my server and send legalMove objects to the clients.
For protection from hackers, if I go mobile with this project. - I'd like the clients to respond w the index of the legal move they choose to make. Hacking is a concern 4 if I go towards prizes and such.
Do I send the legal moves objects (and board) as an objectOutputStream, or a self-made block of legal move data? - maybe a DataOutputStream byte array
That I re-assemble on the client? I could do a thing where I send only object-to-move -and-destination data, and never the pieces, as they should always be correct on the client.
Would the clients need to know all the squares of the path of the move? Some examples do an 8x8 of square objects, where each square can hold a color and a piece.
?

Thanks
0
After doing a lot of research we decided to go with Hikvision for our CCTV security system. It seems like they are one of the major players. We kind of hit a snag with the computers we monitor the cameras on. We can view maybe 6 cameras simultaneously but the CPU usage at that point runs a constant 80% and is very, very taxing on the computer. Is that normal at the 6 camera mark?

   We were told by their support early on (about 8 months ago) to alleviate this issue by running all the cameras in sub-stream. That solved the issue for 8 months until the other day. I added a camera and everything went to pieces. Half the cameras would not reconnect. Don't know what changed but when I called Hikvision support they determined that the Lorex cameras we started out with couldn't be ran in sub-stream and needed to run them in main-stream. It seemed to work but why, after running fine for 8 months in sub-stream, would the Lorex camera no longer be able to connect when in sub-stream?

   So we changed the Lorex cameras back to main stream and the CPU usage re-reared its ugly head. I called their support and was told that more memory would drastically improve the situation. I called a second time and was told a Video card would drastically improve the situation. Alas on a third call I was told neither would really help. Well I double the memory from 8 to 16GB and put in a nice little Radeon HD6450 with 1GB and unfortunately my third call in was correct. Neither really helped.

 …
0
I am desiring to utilize the new Office 2019 in a cloned environment using Clonezilla.  The installer Microsoft sends requires you to put the activation key during installation.  I would like to have the product installed on the cloned machines with other desired applications, sysprep,  then go back and add the product key later.  Is there a way to modify the setup configuration file that Microsoft has recently sent out to install Office 2019 and/or Office 365 to allow this or is there another way?
0
I am looking to roll out a FreePBX phone system for one of my clients. I have experience setting up FreePBX itself, though I'm not sure which SIP provider I should go with to host my phone services and numbers.

Do any of you have SIP providers you would recommend, or have any other tips I should keep in mind while rolling out VOIP services for business?

Thank you!
0
I am attempting to create a bootable image of an iso file to a flash drive with Rufus 3.5 and am getting a error message saying "This image is either non-bootable, or it uses a boot or compression method that is not supported by Rufus."  So how do I go about getting the iso to be bootable?
0
Outlook Templates in File System. I'm trying to recover a user template files in Outlook 2013. I went to new items then choose forms and User Templates in File System. However, I can't find the folder it's in at all?  Where would I go next thanks
0
Error message:
An administrator has blocked you from running this app. For more information, contact the administrator, mmc.exe
Publisher: Unknown
File origin: Hard drive on this computer
Program location: "C:\WINDOWS\system32\mmc.exe" C: \WINDOWS\system32\eventvwr.mscError message
I have to go into a tedious work around to do administrative work.

Many thanks.
0
Long question made short: If CASH is 100% as good as CASH and if one assumes that PayPal is 90% as good as Cash, where does Bitcoin fall on a 1% to 100% scale in your opinion. The only variable to eliminate for my question is for you to assume that ALL intentions of mine, a private user, are completely honest and above board. I know virtually nothing about Bitcoin and am looking for straightforward, honest and blunt opinions of this "product". I do not want to find myself in a situation that I perhaps funded a proposed new bitcoin account with a few thousand dollars only to have someone say to me "You mean to say that you never heard that bitcoin had this or that problem or potential pitfall in the works that I had not heard of. You need not go into great depth on your answer and I request that not more than EIGHT Experts give their opinion so that I can be able to award a decent amount of points to each of the eight respondents with a decent amount of points. Thanks Experts!
0
Help!  I'm new to the Macbook.  Editing a Google Docs document on my Macbook, how do I quickly go to the top of the document (for example).  Thanks
0
Trying to update ao  Local Server Database from a Linked Database and keep getting multi-part identifier errors.
MSSQL Servers
Local Server: SQL3
Linked: ILL-SSQL

USE sagedata
Update [SQL3].sagedata.dbo.transactions
Set [SQL3].sagedata.dbo.transactions.illnumber = [ILL-SQL].sagedata.dbo.transactions.illnumber
FROM [ILL-SQL].sagedata.dbo.transactions
INNER JOIN ILL-SQL ON [SQL3].sagedata.dbo.transactions.transactionnumber = [ILL-SQL].sagedata.dbo.transactions.transactionnumber
Go
0
We are moving from Novell to Synology for our main "server". I need to remove our current Novell clients from our Windows 7 and 10 workstations. I have one particular workstation that won't let me uninstall the client. As this is the first Windows 7 Pro machine I have tried to do this on, I am concerned there may be more like this.
Anyway, what happens is when I go to "Add and remove programs" and uninstall, I get an error that says "There was a problem starting C:\Program Files\Novell\Clinet\ncsetup.dll".
I have gone into that location and the Novell folder is there but empty. The client version is 2 SP1 (IR9a). Is there an uninstaller I can run on these?
0
I had this question after viewing Master Formula Sheet Excel.

Hi folks - I have a similar question to above but somehow didn't understand the final solution shared. This was "If the formulas are identical, and they always go into the same cells, then you should be able to select all the applicable sheets, and then the edits you make should propagate to all of the selected sheets." How do I select all the applicable sheets and then how do formulae magically propagate to cells which are also magically selected? I like the sound of the solution but can't understand what sounds to be an elegantly simple solution! Looking forward to your reply.
0
Hello,

Looking for guidance on creating an Excel chart based on projected age.  I have a basic employee table where each row represents an employee.  In one column I have employee age as of today.

What I'm looking for is a line chart with one line showing a total count of employees under the age of 60 and another line showing employees age 60+.  The two axis would be employee count and year.  The chart would start today and then project to 2028.  So what you should see over time is the age 60+ go up as employees get older while the below 60 will decrease (see image sample).

Thanks!Age Sample
0
MS Access -  How can I test the results when using the TOGGLE on the Home - VBA CODE .
I display a form frmDEBrowse, then use the toggle from the home menu to find text equal to 1111. If found then all is ok, if not found I get a blank screen and I have to close the form and re-open then form frmDEBrowse.

The filter contains the criteria that I entered in the TEXT,  Need help with VBA Code to test the toggle for no records found , display a message and then re-open the form, OR , display a message then go to the first record of form.
0
I have a subscription to Office 365 on my PC.  Now I just bought a new MacBook.  Where do I go to install Office on my Macbook?  Thanks
0
I have large building that is really 3 old building tied together.  Wiring from one building to another is difficult, not impossible, but very difficult.
The goal is to have the background music in all building playing the same thing (from one source).   Currently there are speakers in each building and each "building's speakers" go to an old stereo tuner of some sort amplifying the signal.  

We have a "Music on Hold" device that allows music and "ads" to be loaded onto a USB and this device has a simply RCA Out jack that feeds into one of the tuners.
We have standard 14ga SPEAKER WIRE running from the center-most tuner to the other 2 tuners.  If looking at the attached PDF, we have speaker wire running from A to B, and from A to C.
If that wire can be used to connect them together that would be AWESOME.  If I need to run a different kind of wire because of new equipment needed, so be it.
I have attached a rough diagram that hopefully will make clearer my situation.

My question is what device(s) can I get to make all these speakers play from one source?   Either new amplifiers, or something that could go from an output of one amplifier to an input of another.   AND.... of course I'm trying to do this as inexpensively as possible.  
Thans for any help.AudioDiagram.pdf
0
The computer is connected and has access to the Internet, but the Network icon in the taskbar shows the warning sign and says No Internet access.

I've tried:
1)     restart Network Location Awareness.

     2)     Check IPV4 and make sure it has default settings.
     Ipconfig /release
     Ipconfig /renew
     right click on the desktop and click refresh
     

     3)     netsh int ip reset in cmd window and reboot

     4)Go to the Properties of your NIC's then go to  Configure of all your NIC's and make sure if you have it, a Power management tab, go under this tab and  turn off all power management stuff  Like Respond to ARP Requs, Respond to NS Requs, Ect. turn  off All Power saving options also turn off all wake on lan I own a Netgear WNDR4500 as a WAP. This fixed the probmel  WIn10 has been doing some fishy stuff when it comes to updates turning porwer and privcy options back on after a update.. Thinks Windowns. Hopefully this fixs your problem. this is for win 10/8.1 os

     5)Finally if none of that worked check your anti-virus and make sure you have allowed the following URLS:
     dns.msftncsi.com
     http://www.msftncsi.com/*
    if that still doesn't do the trick stop scanning port 80 network traffic at %SystemRoot%\system32\svchost.exe - path may be off.

All with no luck.  Any other ideas?
0
Recently upgraded to Win 10 OS, I have been utilizing Omniforms 5.0 for several years and have several older forms that I had in sequence with data. For some reason now when I go to open the form they are blank. I have these copied forms on a shared drive and can open them fine on a Win 7 pc, data still visible, but not on the Win 10 pc, any suggestions? Thank you
0
It is a VM under Server 2019. It was activated. I then had to move it to a temporary server and now it is back to the original server but it is no longer activated. I still have the product key but when I go to "Change Product Key" I get the attached screenshot. It started out being a fresh, clean install of Windows 10 so I don't know why it thinks it wasnot activated prior to upgrading. It has to be a false error. Any ideas on how I can reactivate?

Error Message
0
Excel 365

I am trying to take the attached sample file and go through the 'Rating' column and count the number of instances of 'A', 'S', and 'NI'. I need it to count the number of times it sees each one and then return in cell B2 which one had the most instances.

For example in this column 'A' occurred most often so it would return 'A'
Sample.xlsx
0
When trying to get Bitlocker key saved to the Azure AD, I sometimes get this:

Can't sign in to your Microsoft Account
You need to be signed in to Windows with a Microsoft
account to save your recovery key. Sign out and then
sign in with a Microsoft account or go to
Settings and choose Accounts to change your
existing account.

This doesn't make sense to me. The user is signed in to his "Work or School" account which appears to register him with not only the Microsoft 365 apps etc. but also registers him and the laptop on the Azure Active Directory for the organisation. Under "Devices" in the AD his device appears with correct name.

It's only when attempting to save the BL key to the AD that we have this issue.

Is there perhaps another way to get the user signed in to the domain account but without having to tell Windows that the laptop is an organisation's laptop?

Confused of Berkshire!
0
The strange thing here is that I have the two table as follows:

(1) Table Inventory (Primary ) with primary key called InventID
(2) Table Productiondetails (Child) with primary key PRID

The two table are supposed to be linked in sql server , but each time I try to use server management studio to directly link these tables , they look like below:

Primary table                                                             Secondary table
 Inventory                                                                    Productiondetails
 InventID                                                                      InventID


But after saving the above relationship , then I try to go and check whether the relationship remain the same as above to my surprise I find that the following is showing:

Primary table                                                             Secondary table
 Productiondetails                                                     Productiondetails
 PRID                                                                                PRID

As a result when the data is posted to this the parent primary key (InventID) will update PRID instead of InventID as foreign key

I'm still new in the SQL server I can't on this!

So what do I do fix this situation, any help will be appreciated.

Regards

Chris
0

Golang

547

Solutions

1K

Contributors

Golang, also called Go, is an open source programming language that is a statically-typed language with syntax loosely derived from C, adding automatic memory management, type safety, some dynamic-typing capabilities, additional built-in types such as variable-length arrays and key-value maps, and a large standard library. Go is a general-purpose systems programming language that aims to be efficient both for development and execution with a focus on fast compilation and increased maintainability of large projects. Go was originally targeted at systems programming tasks such as building server/web applications, high throughput middleware and databases.