We help IT Professionals succeed at work.

Google

1K

Solutions

1K

Contributors

Google is an American multinational technology company specializing in Internet-related services and products that include online advertising technologies, search, cloud computing, software, and hardware.

I am just a beginner in Android. I have to call a web service which I have develop in .NET from Android Studio.  I found lots of code from google but still unable to figure out an issue
Here is my code I don't know if it's correct
public class MainActivity extends AppCompatActivity {

    EditText LoginText;

    String SOAP_ACTION = "https://mywebsite.com/ReadLogin";
    String METHOD_NAME = "ReadLogin";
    String namespace = "https://mywebsite.com/";
    String url = "https://mywebsite/login.asmx";

public void checkLogin(View view) {
        String login = LoginText.getText().toString();
        RequestParams params = new RequestParams();
        if (isNotNull(login)) {
            //params.put("username", login);
            call();
            //invokeWS(params);
        }
        else {
            Toast.makeText(getApplicationContext(), "Please enter valid email", Toast.LENGTH_LONG).show();
        }
    }


public void call()
    {
        try {

            SoapObject request = new SoapObject(namespace, METHOD_NAME);

            request.addProperty("username", "abc");

            SoapSerializationEnvelope envelope = new SoapSerializationEnvelope(SoapEnvelope.VER11);
            //envelope.dotNet=true;
            envelope.setOutputSoapObject(request);

            HttpTransportSE androidHttpTransport = new HttpTransportSE(url);
            androidHttpTransport.debug = true;

            androidHttpTransport.call(SOAP_ACTION, envelope);

            

Open in new window

0
Hi
I'm coding my JavaScript phone games in Brackets. It claims Google Chrome browser must be used for test/preview.
But if I refresh in Safari, it seems to be fine.


I'm using a local XAMPP server for my project web-file-space.
Is there a good/convenient way to publish the files to a real web_space? How do I connect the (lightning) preview button in Brackets IDE properly?



It insists Google Chrome must be installed as a browser. Does this in any way complicate my install of Safari?


Thanks
0
I'm working on a Nodejs application. At one, a twig is rendered via the "companies? route. Part of that twig looks like this:

 <table id="main-dt" class="table custom make-datatable table-bordered table-striped dataTable no-footer" data-route="/companies/datatable" data-layout="tlipr" data-callback="initHeatMap();">
      <thead>
        <tr>
          <th scope="col" data-field=":checkbox" data-searchable="0" data-sortable="0">
            <div class="pretty p-default">
                <input type="checkbox" class="table-all" />
                <div class="state p-primary">
                  <label>All</label>
                </div>
            </div>
          </th>
          <th scope="col" data-field="name" data-searchable="0" data-sortable="1">Company</th>
          <th scope="col" data-field="owner" data-searchable="0" data-sortable="1">Lead Owner</th>
            <th scope="col" data-field="contacts" data-searchable="0" data-sortable="1">Contacts</th>
          <th scope="col" data-field="addresses" data-searchable="0" data-sortable="1">Location</th>
          <th scope="col" data-field="meta.ftes" data-searchable="0" data-sortable="1">FTE's</th>
          <th scope="col" data-field="meta.premium" data-searchable="0" data-sortable="1">Premium</th>
          <!-- th scope="col" data-field=":actions">&nbsp;</th -->
        </tr>
      </thead>
      <tbody></tbody>
    </table>

Open in new window


Notice the "data-route="/companies/datatable" piece. That route is what's feeding the info the table is displaying.

That route looks like this:

router.post('/companies/datatable', async (req, res) => {
    let resp = await Company.datatable(req.body, { pipeline: { $ne: '' } });
	//console.log(resp);
    res.send(resp);
});

Open in new window


If you do a 'console.log', you get an array which corresponds to what you see on the page:

screenshot of page
When you click on the name of any of the companies that you see listed and inspect that link, you see this:

<a href="javascript:void(0);" class="open-company-details" data-company-id="5e67f4287774fd397082de8b" data-route="companies">brucegust.com</a>

Open in new window


"open-company-details" is what will will open up a popup that has several tabs that you can scroll through and view the "details" that correspond to that company name.

Easy enough.

But when you look at the "company.html.twig" file, the one where the above table is housed, there's no mention of that link / class:


Open in new window

0
My background is in Oracle development but currently I'm trying to learn and maintain a web app.  We are using the google geocoder location thingy to "find stores" based on the entered zipcode or address.  We have error messages that are initially hidden, but then go through logic to display the correct error message if the search is not successful.  

Initially we use something like
<li><div id="geocoder-error-zero-results" class="d-none">@Global.GeocoderErrorZeroResults</div></li>

Open in new window

to, I'm guessing, set up the page but leave the messages hidden.

Once the user enters a zipcode, such as 00000, the status is set to ZERO-RESULTS and goes through logic in a javascript file, but the error message is never displayed:
$('#geocoder-error-zero-results').css("display", "block");

Open in new window


I have tried the following:
Changing d-none to another class that we have defined as display: none (without !important)
Changing the above javascript to
("display", "block !important")

Open in new window

Changing the above javascript to
$('#geocoder-error-zero-results').removeClass("d-none");

Open in new window


None of these have worked.  Any ideas?  

Thank you!
0
I am trying to import the table data shown here into this Google Sheet complete with pictures.

https://www.vercalendario.info/en/what/utc-offset-by-country.html

The fields needed are
UTC
Country Flag
Country
City
Date and Time Link

I have started a sheet here complete with the field names, and a link to the table data in a separate tab.
https://docs.google.com/spreadsheets/d/1U3kMIOyXCIbkbjE70OMQBtJCJv_vCkCQZtW8F35_7C0/edit#gid=0

Assistance is greatly appreciated.
0
I have a client with a "bricked" Motorola G6 Phone (e.g. MotoG6). The client can't remember the PIN code and doesn't recall the Google Account associated with the phone.

The phone number is long gone.

Is there a way to reformat this so that it's reset to the factory standards? I've done a half-dozen or so YouTube tutorials, but all rely on the previous Google account to be known.

Is there a way to put the Android OS on an SD card and, for all intent and purpose, "start over"? I've seen the term "root"... is that the same as reinstalling the operating system for Windows (e.g. "nuke and pave")?

Thanks!
0
Windows 11 all the updates, Outlook keeps asking for my password, I use gmail, and have outlook download and delete from google. for some reason it is now asking for the "password" that I just changed Saturday, it's been working just fine till this morning, I use Nord Vpn. any suggestions?
0
hi,

want to install google hangouts meet on windows 10 PC, seems can't !

seems only for Android host, any idea on how to fix it for PC ?
0
I just created a new free Gmail account.  I have to email about 100 people. When I’m trying to do it it won’t go through. No one has received any of my messages. Is there a reason why? I would think it’s under the limit.
0
I have a database that generates an excel file. I have to copy to my desktop then upload to my google drive shared folder. Is there a way to upload the file right to my google drive shared folder. I dont see an option save to google drive or something simialar
Thanks
0
I currently have a Citrix NetScaler VPX 200 and I would like to enable 2 factor authentication. I'm new to setting up 2FA and any advice would greatly be appreciated.

The goal is to have the user sign into the Netscaler web portal and authenticate with their domain (LDAP) credentials. Upon successful login, the user is required to enter a passcode/one time password that they would receive from an SMS message or ideally a code using an authenticator app (Microsoft or Google authentication app for example.) Once the user enters the one time password, the user can access the VPN or ICA portal.

When researching what is evolved to enable this, it looks like a RADIUS server is required. I do have a Windows Server 2016 RADIUS server, but it doesn't seem to support what I'm looking for, unless Microsoft's terminology is different. I've opened a case with Citrix, but the only thing provide is links to setup RADIUS on the gateway, which I already found before opening the case.

Has anyone been able to accomplish this? Thank you for your time.
0
Hi

I want to find out what keywords a website uses for it's Google SEO. How do I do that?
Are there tools that I can use?

Thanks
0
I am having this problem with Google Chrome Apps{GCA}. Whenever I create a desktop shortcut using Google Chrome it places the short under the specified path in the screen capture under chrome apps. I don't know why is it called apps when in act it is a shortcut first of all. Can someone first answer this question-Question Number 1.

I was able to click on any of these chrome apps and it opens up no problem till lately when I noticed that all of these apps icons had turned to a blank generic icon and when I click on it it does not open up that particular web site instead it opens a tab page  in Chrome with the Google home page the one with search bar and most commonly visited web sites under the search bar. The Address bar is blank. Can someone tell me why is this happening all of the sudden?-This is Question Number 2.

I just added a shortcut to my desktop just right now, it is Texas.gov and it was correctly placed on my desktop with the correct icon however in the Chrome Apps folder that you can see in the screen capture the icon was not correctly displayed but I was able to click on it and it opened up no problem in Chrome. Why the icon did not display completely and if this shortcut was left alone for sometime will it become like the other shortcuts unusable and could not be open?-This is Question Number 3.

Lastly, When I was uploading these screen captures I saw that the Normal …
0
I am in the throws of organising a group dinner. I have collated all of the attendants menu choices using Google Forms and now have the data in Google Sheets. From Google sheets I can copy into Excel if so required.

I am looking to produce Table Place Name Cards with each attendant name and their menu choice. Hoping to have a folded card in tent format with Name of attendant on front and their menu choices on the rear. I am planning on using a pre-perforated sheet of business cards so that I can print and easily separate the cards before then folding in half to create the tent.

I was hoping to use a Mail Merge into a suitable sized sheet of "cards" but the difficulty I have is getting the text so that it is the right way up on both sides; printing the name first it has to be printed upside down so that when the card is folded it is then the right way up in relation to the menu choices on the rear.

In Word I can create the table to match the business cards and use mail merge fields or in Excel, I can just create a sheet that mirrors the table for business cards in Word by adjusting column and row heights, with interval columns/rows as required and then do some lookup formulas to get the data.

So the question is whether Google Docs/Word or Google Sheets/Excel have an option to rotate text through 180 degrees.

I have found a way to do it in Excel (and can presumably do same in Sheets) by aligning the text vertically and rotating through 90 degrees for one side and…
0
Hi experts,

What simple formula is there in Excel to list multiple values based on multiple criteria's?
The result should be like the Filter formula from Google Sheets.

I used this formula so far but it only shows the last found value instead of all.
=IFERROR(INDEX(STOCK!$D:$D,SMALL(IF($A$2=STOCK!$Q:$Q,ROW(STOCK!$D:$D)),ROW(1:1))-1,1),””)

The formula came from article
https://www.excel-bytes.com/how-to-extract-a-dynamic-list-with-multiple-criteria-in-excel/
0
I would like to output (for curiosity/debugging) the data values in the JSON object returned by Google ReCaptcha v3 verification. The ReCaptcha doc's show the object's format to be:
{
  "success": true|false,      
  "score": number,             
  "action": string,           
  "challenge_ts": timestamp,
  "hostname": string,        
  "error-codes": [...]        
}

Open in new window


Here is code snippet:
<?php
.
.
.
 // post request to verify token with Google reCaptcha server
      //
      $url = "https://www.google.com/recaptcha/api/siteverify";
      $data = array (
        'secret' => $secretKey, 
        'response' => $captcha,
      );
         
      // use key 'http' even if request is to https://...
      //
      $options = array (
        'http' => array (
          'header'  => "Content-type: application/x-www-form-urlencoded\r\n",
          'method'  => 'POST',
          'content' => http_build_query($data)
        )
      );

      $context  = stream_context_create($options);
      $response = file_get_contents($url, false, $context);

      $responseKeys = json_decode($response, true);

     // echo $responseKeys[success];
     // echo $responseKeys[action];
      //echo $responseKeys[score];
 
      if($responseKeys["success"] == true && $responseKeys["action"] == $action && $responseKeys["score"] >= 0.5) {
        echo ("reCaptcha.php thinks you are human");
        header ("location: ./sent-success.htm");
        } else {
          echo ("reCaptcha.php thinks you are a bot");
          header ("location: ./spam-block.htm");
        } 
    ?>

Open in new window


Tried echo $responseKeys[success]; and var_dump($responseKeys. They don't appear to work.
0
Hi All,

I have set up SSSD in a CentOS and RHEL, authentication with AD users is succeeding as expected and without any issues.

So when an AD logs in to any of this Linux distributions is receiving a shell in this format:

- [username@domain@linuxhostname ~]

I'd like to know if it is or not possible to set up the shell to this format after successful authentication with an AD account:

- [username@linuxhostname ~]


The users are mentioning that is a little bit confusing to have the shell in this format

- [username@domain@linuxhostname ~].

I already google it, made some changes to the sssd.conf file but none seems to work.

I already tried the following:
- use_fully_qualified_names = False
- full_name_format = %1$s
- re_expression = (?P<name>.+)
- Change default shell

Unfortunately, none as worked, probably I'm missing something.

Logs:
> realm list
  mydomain
  type: kerberos
  realm-name: mydomain
  domain-name: mydomain
  configured: kerberos-member
  server-software: active-directory
  client-software: sssd
  required-package: oddjob
  required-package: oddjob-mkhomedir
  required-package: sssd
  required-package: adcli
  required-package: samba-common-tools
  login-formats: %U
  login-policy: allow-realm-logins

[sssd]
default_domain_suffix = mydomain
domains = mydomain
config_file_version = 2
services = nss, pam

[domain/mydomain]
ad_domain = mydomain
krb5_realm = MYDOMAIN
realmd_tags = manages-system …
0
When I right click on a file then select send to Google Drive. Google Drive opens up but the file does not get downloaded into the Drive nor I get any prompt asking me where I need to save it? Can someone help me please?
Thank you,
Basem Khawaja
0
Interesting challenge for everyone this is actually a difficult one.   Has anyone worked with google phones lately?  They have added a feature that prevents phones from getting factory'ed without forcing a new factory restore to continue without entering googles old account information that was previously associated with the phone.   I guess its a new security feature that allows users to setup their account (personal or business related) using a password or pattern swipe to continue to login.  

Having said that we have a bunch of google phones that are "bricked" because even after the phone is factory'ed it still remembers the last account that was setup and will not let the phone setup be complete without entering the credentials of the last user.  

The impossible question is there any way to get around this so the phone can be recycled for someone else?
0
Are there any alternatives to the above groups? It seems like the "big brand name" groups are either dead or dying.  Also seems like all the online user groups/forums that are very topic-specific are winning.
0
Hello Experts,

in plain English...

if "yes" is selected, move row to a different sheet.
also add the current date into the Col. and
now calculate the total days between col A & G and display results in H

for some reason it doing the calctulation for the row above, not the current row that has just been populated.

any ideas please?

function onEdit(event) {
  var ss = SpreadsheetApp.getActiveSpreadsheet();
  var s = event.source.getActiveSheet();
  var r = event.source.getActiveRange();

  if(s.getName() == "Active Jobs" && r.getColumn() == 7 && r.getValue() == "yes") {
    var row = r.getRow();
    var numColumns = s.getLastColumn();
    var targetSheet = ss.getSheetByName("Completed Jobs");
    var target = targetSheet.getRange(targetSheet.getLastRow() + 1, 1);
    //This puts the completion date into the last column of data currently col G
    targetSheet.getRange(targetSheet.getLastRow(),numColumns  + 0).setValue(new Date());
    //Calculates the turn around time in days for column I on the Completed sheet
    targetSheet.getRange(targetSheet.getLastRow(),numColumns  + 1).setFormula("=DATEDIF(R[0]C[-7],R[0]C[-1],\"D\")+1");
    s.getRange(row, 1, 1, numColumns).moveTo(target);
    s.deleteRow(row);
  }
}

Open in new window



https://docs.google.com/spreadsheets/d/1X4M2G0f7MEpDETrVIZ2kU9MJAFC8K9jR9ZqKOijYDN0/edit?usp=sharing
0
I have a Gmail mailbox attached to an user in G-Suite that's in the name of an organisation, not a person's name, so the "FirstName LastName" format doesn't apply. Google doesn't allow for one of these fields to be blank either, so just to get around this, I've had to put the first half the org name in First Name, and other other half in Last Name. But is there a way around this? I can't imagine I'm the only one faced with this problem.

I can change from "First Last" to "Last, First", but this doesn't help because I cannot have the First or Last fields blank.
0
Hi Experts!

How can I have my iPhone google page always in English? I’m using an iPhone and alway when “clearing” the safari, it sets my google to Spanish; I need it always English.  How can I do that?
0
My Google Chrome browser keeps closing randomly on it's own. I would be working on it and have a few tabs open and I go to sleep the next morning I see it closed and when I click on the task bar icon to open it asks me to restore pages from last session or just open the tabs that I have it set to open with. Can someone help me please?

Thank you,
Basem Khawaja
0
hello i have this script which i would like to use on my google sheet so that if a data in column A is over 6 days then it will colour the cell as red.
Unfortunately its not throwing any errors so i don't know what it wrong with it but its not working.

function checkDate() {
  var ss = SpreadsheetApp.getActiveSpreadsheet();
  var sheet = ss.getSheetByName("Active Jobs");
  var dates = sheet.getRange("A:A").getValues();
  for(var i=0;i<dates.length;i++) {
    var d = dates[i][0];
    var isNotString = typeof d != "string";
    if(isNotString) {
      var today = new Date();
      d.setHours(0,0,0,0);
      today.setHours(0,0,0,0);
      var diff = (today - d)/(24*60*60*1000);
      var cell = sheet.getRange("A" + (i+1) + ":A" + (i+1));
      if(diff>=6)
        cell.setBackgroundRGB(255,0,0);
      else
        cell.setBackground("white");
    }
  }
}

Open in new window


can anyone see what might be wrong here please?
0