HTTP Protocol

The Hypertext Transfer Protocol (HTTP) is an application protocol for distributed, collaborative, hypermedia information systems. Hypertext is structured text that uses logical links (hyperlinks) between nodes containing text. HTTP is the protocol to exchange or transfer hypertext. HTTP functions as a request-response protocol in the client-server computing model. HTTP is designed to permit intermediate network elements to improve or enable communications between clients and servers. HTTP is an application layer protocol designed within the framework of the Internet Protocol Suite; it presumes an underlying and reliable transport layer protocol.

Share tech news, updates, or what's on your mind.

Sign up to Post

On a webpage "http://portal.viewpoint.com/sso/aha?portal=procontractor" that I access frequently, when I click on any of the hyperlinks the "http://" is removed from the url in the address and then the resulting page is just blank. If I add the "http://" back in, I get the expected page in its entirety. This was working just fine yesterday. Any ideas why this would be happening?
I contacted the website owner and they tell me they are having no problem accessing the pages
0
https://www.experts-exchange.com/questions/27177513/Shell-Perl-script-to-test-a-Tcp-port-using-nc-netcat-in-RHES-4-x.html

I refer to the above link (EE article# 36120990 & 36129509) .

I need a similar Windows script to test all the IP addresses in our corporate for Canon, HP & Ricoh printers.

So if I manually issue from my PC's command prompt below:
c:\> telnet 10.x.y.z 80

GET /index.htm / HTTP/1.1 <hit_ENTER>


HTTP/1.1 400 Bad Request
Date: Thu, 07 Jul 2016 10:35:10 GMT
Server: CANON HTTP Server  <== this tells me it's CANON
Content-Type: text/html
Content-Length: 109

<BODY><H1>400 Bad Request
</H1>
Your browser sent a request that this server could not understand.</BODY>
Connection to host lost.
C:\>



However, I simply just did not manage to capture the above output despite trying:
  start telnet 10.x.y.z 80 < input.txt > tel.out 2> tel.err   (this command is no good as the spawned windows just hang there)
   OR
  cmd telnet 10.x.y.z 80 < input.txt > tel.out 2> tel.err

where input.txt contains:
GET /index.htm / HTTP/1.1
(with 2 empty lines that follow)


type tel.out gives:
==============
Microsoft Windows [Version 6.1.7601]
Copyright (c) 2009 Microsoft Corporation.  All rights reserved.

type tel.err gives:
==============
'GET' is not recognized as an internal or external command,
operable program or batch file.


What did I miss?   What I need is an output file that captures the "Server: CANON ..." line
& I'll be …
0
Hi,

I need a little help with some DNS please.

We have an test website (http://testwebsite1.ourcompany.com) which is only accessed internally.  In DNS we have a HOST (A) record for testwebsite1 to point to the IP address of the server.

I have had a request to point a second domain name (http://testwebsite2.ourcompany.com) to the same server.

I believe that best practise in this scenario is to use an Alias (CNAME), to point http://testwebsite2.ourcompany.com to http://testwebsite1.ourcompany.com so this is what I have done.

However, when I use my browser to go to http://testwebsite2.ourcompany.com I just get an HTTP 404 not found page.

If I do an "nslookup http://testwebsite2.ourcompany.com" it tells me that it is correctly pointing to http://testwebsite1.ourcompany.com so I am not sure why the page is not loading.

Can you help please?

Thanks
0
I have been getting a lot of emails following the pattern below. I wonder if anyone can
1) Figure out what information might be captured by the __VIEWSTATE / __VIEWSTATEGENERATOR gambit
2) Decode the strings passed to __VIEWSTATEGENERATOR and __VIEWSTATE (What is the process? I can write Java code for this if I need to)
3) Comment on the vulnerability of my Windows 7 machine to this approach. It seems that any online security discussions about VIEWSTATE start with the assumption that the server needs to be protected. However unless I am mistaken, this turns it around and threatens to compromise the user machine. Am I correct in thinking that this is likely a preliminary step towards a later infection attempt? Your comments are appreciated!

I know next to nothing about asp, though I have an extensive background in software generally.

Thanks

**********************************************************************************
Email subject : "Cooperation with a large firm" Received 2016-06-12

We are looking for employees working remotely.

My name is Dominick, am the personnel manager of a large International company.
Most of the work you can do from home, that is, at a distance.
Salary is $2500-$5000.

If you are interested in this offer, please visit Our Site<--A LINK
**********************************************************************************

****************** This is the link given in the initial email
******************
0
When I open my WCF service locally on the server using http://localhost/AppName/MyService.svc?wsdl it works fine, but when i access it remotely using http://ServerName/AppName/MyService.svc?wsdl it does not work. What am I missing?
0
Hello:


Please if anyone knows of this issue: how Use  URLDownloadToFile to download snapshot from ipcam using http://ipcam:port/snapshot.cgi? instead http://ipcam:port/snapshot.jpg? can i use or any other function or libraie?

I explain:

I have a surveillance program in Excel 2000 vbasic. I using a intellinet  camera, I can download  a spanshot from a url and namefile.jpg  Using the following code:

Declare Function Beep Lib "kernel32" (ByVal dwFreq As Long, ByVal dwDuration As Long) As Long
Private Declare Function URLDownloadToFile Lib "urlmon" Alias "URLDownloadToFileA" _
     (PCaller ByVal As Long, ByVal szURL As String, ByVal szFileName As String, ByVal dwReserved As Long, _
  LpfnCB ByVal As Long) As Long

Private Declare Function DeleteUrlCacheEntry Lib "WinINet.dll" _
    Alias "DeleteUrlCacheEntryA" _
   (LpszUrlName ByVal As String) As Long

pathrep=”c:\reportes\”
nfile= “mm-dd-aa_hh-mm-ss.jpg”
image = http://192.168.1.221:81/jpg/image.jpg 
URLDownloadToFile RetVal = (0, image, pathrep & nfile, 0, 0)
Call DeleteUrlCacheEntry (image)

Note:
In the intellinet cam, snapshot was fixed in the filename image.jpg and locatable on the path shown. The last line (call delete…) erased the image cache so that it does not "freeze" snapshot at a particular time.

New other cams usin severals ways, for example:

The  foscam f9821w v2  use:
http://192.168.1.67:88/cgi-bin/CGIProxy.fcgi?usr=admin&pwd=&cmd=snapPicture
but not work with…
0
I have 2 domain names: users.newsite.com and users.oldsite.com. I have users.newsite.com hosted on Mac OS X 10.10.5 using Server version 5.0.15. I have A records setup in DNS so that both domain names (users.newsite.com and users.oldsite.com) point to the same IP address for the OS X Server machine.

We have a wildcard SSL cert of *.newsite.com installed on the OS X Server machine. I have a redirect configured in OS X Server (I believe this uses Apache) so all traffic for the http version of users.newsite.com is going to the https version of users.newsite.com. This is working properly.

The problem is if anyone uses http version of users.oldsite.com. They get a warning that the connection is not secure because their browser is trying to redirect to https version of users.oldsite.com. We do not have an SSL cert for oldsite.com.

Is there a way to setup a redirect so that any traffic coming from http://users.* (newsite or oldsite) gets redirected to https version of users.newsite.com?

I can enter a URL matching a regular expression and direct that in the Server app, but I don't know what to enter to get the redirect to work properly so that the http versions of users.newsite.com AND users.oldsite.com both redirect to the https version of users.newsite.com.

I have attached a screen shot of the redirect I have setup for http to https.  I only have one site hosted on this OS X Server machine.

Thanks!
redirect.png
0
I had this question after viewing problems installing a ssl certificate on a mac that is a local machine with no domain.

very simply how do i generate a csr that contains my organization name to send to verisign or whoever and get an intermediate ca from them?  right now when i do it, i get an error because the organization name is empty.  dont see even remotely where to put this in.  dont want a self signed certificate and dont have the osx server app installed.  there has got to be a way to generate this csr so that it actually works

os x is yosemite
0
All of our network traffic is routed through a proxy server, including https traffic. We have a digitally signed security certificate which enables routing https traffic too.
We're looking for a solution where if the security certificate is untrusted by the browser (i.e. our security certificate hasn't been installed yet) prompt the user to download our security certificate.
0
I am posting the result when I was testing active sync. through test exchange connectivity.com

how can I solve the problem.
The Microsoft Connectivity Analyzer is testing Exchange ActiveSync.
Testing HTTP Authentication Methods for URL https://mail2.mydomain.com/Microsoft-Server-ActiveSync/.
The HTTP authentication test failed.

we have existing url mail.mydomain.com/Microsoft-Server-ActiveSync which is working fine
we developed new squid 3.3 and are trying to use mail2.mydomain.com for active sync which is failing.
Additional Details
A Web exception occurred because an HTTP 503 - ServiceUnavailable response was received from Unknown. HTTP Response Headers: Mime-Version: 1.0 X-Squid-Error: ERR_SECURE_CONNECT_FAIL 71 Vary: Accept-Language Content-Language: en X-Cache: MISS from mail2.mydomain.com X-Cache-Lookup: MISS from mail2.mydomain.com:5080 Connection: keep-alive Content-Length: 3860 Content-Type: text/html Date: Fri, 20 May 2016 11:16:17 GMT Server: squid
Elapsed Time: 307 ms.

I am getting below error on squid proxy logs

In the cache.log “fwdNegotiateSSL: Error negotiate SSL connection on FD 14: error:14090086:SSL routine:SSL3 routines: SSL3_GET_SERVER_CERTIFICATE: certificate verify (1/-1/0)”
0
I want to use an encrypted string in an email as a type of token for a reset, so I generate the string as:-
aDhJ1XIgO/grKdsv/pM7Wkq2E0UWLW1ZcInfFz/2Mp2P0cFAbL76iz7evIxGQMuy1m5i9Q9/L/VQQm+OnixzTAgKskIilH2wknQRRFK2skVHf9XLKqT+xuHLOpdM16KZ3yPkZ/p8oUlVKen5lXLFfUdJogROoNQmxHqV6UiuPIFkiI/UJaE8RFL8EEB4Muo8e++xy4jWEIBugVlt46q1UYwgwZOvNZl9yfN8K+KTd9ka2q4xgZN9hDi4IVmjMWXfFriViloRIMceQfofgkKdIuL59jjhZKBphISQcH2AOVOkrnET60RpmmHAxFiT4fT9SG7YXzYZ0fKj4T1eB1df6wjw43Ju31OMTH6lDUxkwlG8jZj+XmUrch1hoVw1h0mXB/AlstXv0Ej2u4XZ096EK0ZOeDZU2yfPaCiYc5GJIA0=

It arrives in my inbox fine, and shows the as:-
http://localhost:85/?resetPassword=aDhJ1XIgO/grKdsv/pM7Wkq2E0UWLW1ZcInfFz/2Mp2P0cFAbL76iz7evIxGQMuy1m5i9Q9/L/VQQm+OnixzTAgKskIilH2wknQRRFK2skVHf9XLKqT+xuHLOpdM16KZ3yPkZ/p8oUlVKen5lXLFfUdJogROoNQmxHqV6UiuPIFkiI/UJaE8RFL8EEB4Muo8e++xy4jWEIBugVlt46q1UYwgwZOvNZl9yfN8K+KTd9ka2q4xgZN9hDi4IVmjMWXfFriViloRIMceQfofgkKdIuL59jjhZKBphISQcH2AOVOkrnET60RpmmHAxFiT4fT9SG7YXzYZ0fKj4T1eB1df6wjw43Ju31OMTH6lDUxkwlG8jZj+XmUrch1hoVw1h0mXB/AlstXv0Ej2u4XZ096EK0ZOeDZU2yfPaCiYc5GJIA0=

When I click on the link, again works fine:-
1
The first code block returns a good request.  The second returns a fault.  Please advise.
  using System;
    using System.Collections.Generic;
    using System.Linq;
    using System.Net;
    using System.ServiceModel;
    using System.ServiceModel.Channels;
    using System.Text;
    using System.Threading.Tasks;

    namespace Ahcccs.Isd.Aes.Breaz.Core.WCF.SOAP
    {
        public class ConsumeGetVendorLookup
        {
            public void Consume(string wso2token)
            {
                Header header = new Header();
                header.Type = "?";
                header.ReturnCode = "?";
                header.Requestor = "?";
                header.Recipient = "?";
                header.Date = "?";
                Requestor requestor = new Requestor();
                requestor.UserID = "";
                requestor.Password = "";

                header.Subject = requestor;

                Payload payload = new Payload();
                GetVendorCustomerIn getVendorCustomer = new GetVendorCustomerIn();
                getVendorCustomer.IncludeGeneralInfo = true;
                getVendorCustomer.IncludeHeadquarters = true;
                getVendorCustomer.IncludePrenote_EFT = true;
                getVendorCustomer.IncludePrenote_EFTSpecified = true;
                getVendorCustomer.Vendor_Customer = "{our customer number}";

                payload.GetVendorCustomerIn = getVendorCustomer;

                AdvMessage advMessage = new 

Open in new window

0
I have a field that I am displaying in my ASP which contains ASP code (nvarchar field).
The problem I have is that it is displaying the HTML code, instead of the text within the HTML code.

here is what I get

&nbsp;USCIS has published an updated <a href="http://www.uscis.gov/tools/green-card-resources/welcome-united-states">Welcome to the United States: A Guide for New Immigrants</a>. The guide contains practical information to help new immigrants settle into everyday life in the United States, including how to find a place to live, how to get a Social Security number and how the U.S. system of government works. | &nbsp;Beginning with the November 2015 Department of State (DOS) Visa Bulletin, if USCIS determines that there are more immigrant visas available for a fiscal year than there are known applicants for such visas, we will state on <a href="http://www.uscis.gov/visabulletininfo">www.uscis.gov/visabulletininfo</a> that applicants may use the <em>Dates for Filing Visa Applications</em> chart. Unless otherwise stated on our website, the <em>Application Final Action Date</em> chart will be used to determine when individuals may file their adjustment of status applications. | 

Open in new window


I display it as:  
<%=(report_results.Fields.Item("casenotes").Value)%>

Open in new window

0
Being an "Assembly Language Developer from way back",  I am used to looking at a program and following the code sequentially: You execute Line 1, then line 2, etc (unless of course something like an IF statement redirects that flow)
NOW I am having trouble understanding how to follow the flow of execution in an HTML Page that has a lot of snipets of PHP code in it.
SO as a human trying to follow along to see what the code is doing, here's my questions:
1.  I hear that a Script can go anywhere in a web page. I presume that is true for PHP in an HTML page also. So if I am following along the flow of execution, do I "ignore" anything in between the <?php and the ?> tags ... until another part of the code "calls" that section, like a subroutine?
2. Or do those sets of PHP code get executes first, immediately?
3. Or ?? I am asking specifically about PHP, but also wondering if all scripting languages handle this contol flow the same way in an HTML page (Javascript, VB Script?)
Thanks for any help wrapping my brain around this!
- B
0
Hi All,
A company we use to host our websites recently retired some old servers, which in turn force me to change to new name server in my Go Daddy account. No big deal I have done this before.
Website in question is a public website, no logging in etc... From outside our network the website in question http://www.examplewebsite.com/ is totally accessible with no issues. Type into your browser, and away it goes, can ping the website as well no problem,
Inside my network is a different story: I can ping the website in question by DNS name with no problem, but if I go to the website and I get the 403 forbidden.
I have in house Server 2012 R2 that doubles as DC, and DNS server. I have always in my DNS had the website in question set with a static IP, because the website and my local domain are the same except the external is .com and internal is .local
I am not the greatest by any means no a lot about DNS, but I just opened DNS from the Server Manager, and found every instance I could that had the .com website address, and I modified the IP address with with the new IP address.
And now I get the 403 Forbidden when any PC inside my network tries to access the .com website.
I went back to double check my work, and I noticed that I think the Fully Qualified Domain Name for this website had changed to the website.com website.com website.com. 3 instances, Others ones had combination of website.com and website.local as the FQDN. All other websites come up fine.
Any help would…
0
I need to setup a URL redirection for my website.  I need to redirect http://www.mysite.com/* to https://www.mysite.com/*.  I am using Joomla 2.5 and downloaded the ReDj extension but I am getting an error on the install.  Looking for a good solution.

Thanks, Jon
0
Not being a web person, i have to ask this seemingly easy question.  Random guides found on a google search are complicated because we already have a url-rewrite in place

we want to make it so anyone who goes to our site at http://www.example.com by http, are on-the-fly and blindly redirected to https://www.example.com while maintaining our existing url-rewrite

Our existing rewrites are handled by web.config it the root of the site and is in the code block below.

<?xml version="1.0" encoding="UTF-8"?>
<configuration>
    <system.webServer>
        <rewrite>
            <rules>
                <clear />
                <rule name="Rewrite rule1 for CRMsoftwareTest" enabled="true" stopProcessing="true">
                    <match url="(CRMsoftware|api)(.*)" negate="true" />
                    <conditions logicalGrouping="MatchAll" trackAllCaptures="false" />
                    <action type="Redirect" url="CRMsoftware/portals{REQUEST_URI}" appendQueryString="false" redirectType="Found" />
                </rule>
            </rules>
            <rewriteMaps>
                <rewriteMap name="CRMsoftwareTest" />
            </rewriteMaps>
        </rewrite>
    </system.webServer>
</configuration>

Open in new window

0
I setup https on tomcat 7 by editing my server.xml and web.xml
Some of the webapps are not working, and I need to revert to http to test.
I removed the changes I made to server.xml and web.xml, and restarted tomcat,
it keeps resolving the address to https, and keeps stating page can not be displayed.
Here is my current server.xml

<!--
  Licensed to the Apache Software Foundation (ASF) under one or more
  contributor license agreements.  See the NOTICE file distributed with
  this work for additional information regarding copyright ownership.
  The ASF licenses this file to You under the Apache License, Version 2.0
  (the "License"); you may not use this file except in compliance with
  the License.  You may obtain a copy of the License at

      http://www.apache.org/licenses/LICENSE-2.0

  Unless required by applicable law or agreed to in writing, software
  distributed under the License is distributed on an "AS IS" BASIS,
  WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
  See the License for the specific language governing permissions and
  limitations under the License.
-->
<!-- Note:  A "Server" is not itself a "Container", so you may not
     define subcomponents such as "Valves" at this level.
     Documentation at /docs/config/server.html
 -->
<Server port="8005" shutdown="SHUTDOWN">
      <!-- Security listener. Documentation at /docs/config/listeners.html
  <Listener …
0
I have Python 2.7.9 running on a linux box. Now I need to sending http post request with body and headers. However, due to some restrictions, I cannot use pip to install some third party modules, and I cannot use Python to execute "curl" command either. Can I achieve this with Python out of the box?
0
I have Python 2.7.9 running on a linux box. Now I need to start a http server to accept post requests with payloads (post body). However, due to some restriction, I cannot use pip to install some third party modules. Can I achieve this with Python out of the box?
0
If I send a text document from location A to location B over the internet via HTTP and there was someone in between sniffing the traffic with wireshark, would they be able to see inside the text document? I do not believe the wireshark capture would be able to see inside a file or can it?
0
Good Morning,

My Boss is asking for a monitoring tool so that we can verify that some of our traffic is flowing through HTTPS and not HTTP.   I know that fiddler exists, but we are having a hard time figuring it out.

Is there some monitoring tool that we can use/purchase that can be used to monitor traffic coming from a server?

Thanks,
0
Dear Experts,

We receive traffic on one of our sites that is from a url redirect, so there is no referrer information, which, of course, is not reliable in itself.

My question is - with JavaScript - is there any way, are there any methods, that can read/detect any information that the user arrived as a url redirect to our site - without passing values with the url?

I've exhausted everything I can think of, but wanted to get expert thoughts before we ask our redirecting partners to add params to their urls.

Thank you in advance.

Best,
--Mike
0
i have 2 public facing websites

1) http://company.com/
2) http://blog.company.com/

we want to use our main website as proxy of the second one.

http://company.com/blog  --> http://blog.company.com/

installed arr
installed url rewrite module

created a virtual directory in the main site and added reverse proxy rule, the below is my web config for that virtual directory

<?xml version="1.0" encoding="UTF-8"?>
<configuration>
    <system.webServer>
        <rewrite>
            <rules>
                <rule name="ReverseProxyInboundRule1" stopProcessing="true">
                    <match url="(.*)" />
                    <action type="Rewrite" url="http://blog.company.com/{R:1}" />
                    <serverVariables>
                        <set name="HTTP_ACCEPT_ENCODING" value="" />
                    </serverVariables>
                </rule>
            </rules>
            <outboundRules>
                <rule name="ReverseProxyOutboundRule1" preCondition="ResponseIsHtml1">
                    <match filterByTags="A, Form, Img" pattern="^http(s)?://blog.company.com/(.*)" />
                    <action type="Rewrite" value="/blog/{R:2}" />
               </rule>
            </outboundRules>
        </rewrite>
    </system.webServer>
</configuration>

Now, http://company.com/blog works fine.
http://company.com/blog/something is returning 404 error.

any help is much appreciated. i have very slim time lines for to finish this task…
0
Is it possible using client side only PHP code alone, to devise a secure login procedure?

If so, I would like to find a simplified example where a person would have to enter a password to bring up the page.
0

HTTP Protocol

The Hypertext Transfer Protocol (HTTP) is an application protocol for distributed, collaborative, hypermedia information systems. Hypertext is structured text that uses logical links (hyperlinks) between nodes containing text. HTTP is the protocol to exchange or transfer hypertext. HTTP functions as a request-response protocol in the client-server computing model. HTTP is designed to permit intermediate network elements to improve or enable communications between clients and servers. HTTP is an application layer protocol designed within the framework of the Internet Protocol Suite; it presumes an underlying and reliable transport layer protocol.

Top Experts In
HTTP Protocol
<
Monthly
>