HTTP Protocol

The Hypertext Transfer Protocol (HTTP) is an application protocol for distributed, collaborative, hypermedia information systems. Hypertext is structured text that uses logical links (hyperlinks) between nodes containing text. HTTP is the protocol to exchange or transfer hypertext. HTTP functions as a request-response protocol in the client-server computing model. HTTP is designed to permit intermediate network elements to improve or enable communications between clients and servers. HTTP is an application layer protocol designed within the framework of the Internet Protocol Suite; it presumes an underlying and reliable transport layer protocol.

Share tech news, updates, or what's on your mind.

Sign up to Post

Greetings.

I am converting an Applet into a Desktop Application, and one of the internal program's services includes a SOAP client, designed to send information to a remote server. Here is a piece of the code in charge of this process:

package my.package.app.utils;

import my.package.app.main.MainClass;
import my.package.app.org.json.JSONObject;
import org.w3c.dom.Document;
import org.w3c.dom.NodeList;

import javax.xml.parsers.DocumentBuilder;
import javax.xml.parsers.DocumentBuilderFactory;
import javax.xml.transform.*;
import javax.xml.transform.dom.DOMSource;
import javax.xml.transform.stream.StreamResult;
import java.io.*;
import java.net.HttpURLConnection;
import java.net.URL;
import java.net.URLConnection;
import java.util.logging.Level;
import java.util.logging.Logger;

public class SoapClient {
    
    public static JSONObject callMethod(String path, String method, Object... args) {
        HttpURLConnection connection = null;
        String            data       = null;
        try {
            data = parseXML(method, args);
            
            MainClass.debug("Making http POST connections to : " + path);
            
            URL           u  = new URL(path);
            URLConnection uc = u.openConnection();
            connection = (HttpURLConnection) uc;
            
            connection.setDoOutput(true);
            connection.setDoInput(true);
            connection.setRequestMethod("POST");
            

Open in new window

0
Hello Experts.

    Websocket-client connects to websocket-server through haproxy.
    Sometimes transmission works, sometimes not.
    Websocket-client is based on python2.6/site-packages/websocket_client-0.7.0-py2.6.egg/websocket.py
    Websocket-server based on c++ library.
    Haproxy version is 1.5.x

    As you can see, websocket client reuses connection when python-script is reentered.
    Note, if not to reuse the connection, there are no errors.

    How get rid of this error?
    #must we put here something to "flush" the "mysterios" ws "buffer"? ( See this comment in script )

    Script, error-trace, haproxy.cfg and log are attached.

Thank you.
script-and-error.txt
haproxy-cfg-and-log.txt
0
I have a web site hosted on Server2012 R2 and every page served has an HTTP Response header of "no-cache". I have set the "Common http response headers" in IIS to expire after 7 days and added a "Cache-Control max-age = 604800" NV pair to the http response headers, but I still see "no-cache" on every page.
Any clues ?
0
Hi,
I am setting the following header in response of my spring web application :
         response.setHeader("Strict-Transport-Security","max-age=31536000");


I load my web application using https://localhost:4430/notes
4430 is the https port i have specified for my embedded jetty server...

I also see this header when my application page is loaded...
Now when i remove the s from this url i was expecting that it would auto hit https url But instead the url was aborted by the firefox browser :
All i see in the net panel is :
Screen-Shot-2016-10-05-at-7.06.50-PM.png
These are the response headers when the url is loaded with https://
Screen-Shot-2016-10-05-at-7.10.14-PM.pngWhat could be the reason for this ?

Thanks
0
Is there a guide or reference some place that will interpret the HTTP accept header?

Here are two examples

application/json, text/javascript, */*; q=0.01
*/*;q=0.5, text/javascript, application/javascript, application/ecmascript, application/x-ecmascript

Thanks
0
HI,
In the RFC: https://tools.ietf.org/html/rfc7230#page-22
There is a line : obs-text       = %x80-FF
What does this mean ?

Thanks
0
My site has been using HTTP for most of our product links.  We will send out emails to our customers about a special and point the link in the email to the product link on our website.  I have recently changed our site to use HTTPS for more security.  However the old links that use HTTP are now redirecting back to the home page and I'm not sure how to make the system find the product page using HTTP or HTTPS?
Our site is built using a magento platform, so i can use the magneto admin feature to point to HTTP or HTTPS and or I can change the HTACCESS file, I tried both and it seems that any old link just keep defaulting back to our home page, I believe that is coming from the HTACCESS file.
Any advice or suggestion would be help full.
0
I need to config a squid server  between L3-switch and router without change configuration .  L3--->squid--->router
I installed a transparent squid  between the switch and the router in bridge mode, the switch has several vlans that speaks with a route.
All vlans can reach the router so bridging seems ok, but  i cant't see any log in squid's access.log  
my config as follows:
/usr/sbin/brctl addbr br0
/usr/sbin/brctl addif br0 eth0
/usr/sbin/brctl addif br0 eth1
/sbin/ifconfig eth0 0.0.0.0 promisc
/sbin/ifconfig eth1 0.0.0.0 promisc
/sbin/ifconfig br0 192.168.100.5 255.255.255.0 up
route add default gw 192.168.100.1 dev br0
ebtables -t broute -A BROUTING -p IPv4 --ip-protocol 6  --ip-destination-port 80 -j redirect  --redirect-target ACCEPT --log --log-level=info --log-prefix="EBTAB" --log-ip
/sbin/iptables -t nat -A PREROUTING  -i br0 -p tcp --dport 80  -j REDIRECT --to-port 3128

after i did this,no log come and no packets in iptables's nat table
sorry for my bad english
Anyone have a suggestion on how to manage the transparent proxy mode inside the vlans?
0
We have a custom mobile browser developed by a third party. When viewing one website in particular, we see a page not displayed error.

The vendor states that the web server is responding with a Connection:Close when it should be using Connection:Keep-Alive.

Wanted to get some background information before we proceeded from any web server experts.

Thanks in advance!
0
I found this in another question and tried it. However, I'm not sure how accurate it is and I also need a Mbps output.
Can someone edit this for me for the output I am needing.

#!/bin/bash

        BAND_TIME="$(date +"%F %T")"

        CSTATS=`curl -m 30 -w '%{speed_download}\t%{time_namelookup}\t%{time_total}\n' -o /dev/null -s https://example.com/50mbfile`
        BITSPS=`echo $CSTATS | awk '{print $1}' | sed 's/\..*//'`
        DNS_TIME=`echo $CSTATS | awk '{print $2}'`
        TOTAL_TIME=`echo $CSTATS | awk '{print $3}'`

        echo Time="$BAND_TIME"
        echo Bitsps="$BITSPS"
        echo Dns_time="$DNS_TIME"
        echo Total_time="$TOTAL_TIME"

Open in new window

0
Using command line bash on Linux, trying to find a solution which allows sending a file and it's contents, intact with newlines, etc, to another host.  Am finding countless examples and suggestions but not one that works for me at least, so far.

I won't bother posting all of the variations I've tried but here is the last I've tried.

curl -s --cacert /etc/ssl/certs/ca-certificates.crt -u "1234:4321" --data "@/tmp/testfile" https://domain.com/
> POST / HTTP/1.1
> Authorization: Basic MDgfYhfsDBfgfvfgOSgTssU0wam12V245b1daeGFrYVRBbmpSeW1EN2tNcVlXVXZrbUU=
> User-Agent: curl/7.38.0
> Host: domain.com
> Accept: */*
> Content-Length: 5603
> Content-Type: application/x-www-form-urlencoded
> Expect: 100-continue
>
< HTTP/1.1 100 Continue
< HTTP/1.1 204 No Content
< Date: Tue, 20 Sep 2016 17:53:50 GMT
< Server: Apache
< Cache-Control: no-cache
< Content-Length: 0
< Content-Type: text/html; charset=UTF-8

I've also read that you need to use -o for output which I've tried, etc etc. There must be way of doing this.

The resulting file on the remote host should contain the user name being used to send it.
So, in this case, 1234-testfile
0
I had this question after viewing Going from HTTPS to HTTP.

I have basically the same problem as the question above. But I think we have scattered links through out the site that have https in them, so https links are staying in the searches. We don't want to scour through the site for them because we're not really working actively with it anymore.

It's on Debian GNU/Linux server. I tried using the below code and it doesn't work. I assume it's because it's checking for ssl to be on and since it isn't it skips the rule? I couldn't find any examples searching that were different than this.

RewriteEngine On
RewriteCond %{HTTPS} ^on$
RewriteRule ^(.*)$ http://www.seoautomatic.com/$1 [NC,L,R]

Open in new window


Thanks for any help.
0
This must be the 5th question I have asked in september, versus an average of 2 questions a year previously.  I have just changed the url settings in my wordpress site to https from http and now have lost access (can still ftp).  Is there an easy way to change the url back using ftp?

Some things I have already tried:

I turned wp_debug on
I can't find http settings in the wp--config.php file
I don't see an https setting in the functions.php or vars.php files
0
Hi,

I want to redirect and then rewrite my URL (internal forwarding) so that it doesn't show the php extension as well it doesn't show the ?, = and & in the URL.

This is the example of what I want to achieve, my actual URL passed to header is http://localhost/portal/error.php?error=runtime-error which I want to show in the address bar http://localhost/portal/error.php/error/runtime-error and internally this URL is forwarded to the actual URL http://localhost/portal/error.php?error=runtime-error.

Also, what I want to achieve is here is single redirect and single rewrite rule(for internal forwarding) which applies to all the scripts instead of adding individual redirect and rewrite rules for each script page.

Below is the code that is present in my .htaccess file.
ErrorDocument 404 /portal/error.php
ErrorDocument 500 /portal/error.php

RewriteEngine On
RewriteBase /
RewriteRule ^include/(.*)$ /portal/error.php [L,R=404]

Open in new window


Kindly let me know if any more information is required.

Thanks in advance
0
We just finish purchasing a SSL for a site.  Yet when we log to the site without "Https", it displays the regular "Http:".  However, when typing "Https://domain.name", it display the "S" and the Lock, otherwise it doesn't.  

Is the site secure? Does it have SSL? How can we determine that the SSSLl is in effect even without seeing the Lock or "Https"?

Please advice.
0
I am developing a Phonegap application that not only runs on the phone but also on the desktop's browser.  The application needs to access the resources in the www directory and a few js files that reside on external sites.  So far my meta tag looks like this:

<meta http-equiv="Content-Security-Policy" content="default-src 'unsafe-inline' localhost:*/*  'self' *.shlepz.com  *.googleapis.com   https://www.youtube.com  *.gstatic.com  *.ytimg.com; ">

Open in new window

With this meta tag I am still receiving the error, "127.0.0.1/:195 Refused to connect to 'ws://127.0.0.1:8080//ws' because it violates the following Content Security Policy directive:

I have no idea what ws is.  How do I change the localhost entry in the meta tag to make the error go away?  To state the incredibly obvious, I don't know what the port number will be until the application is loaded.  Most of the time it is 8080 but not always.

Thank you for your time,
0
Hello

We have different types of internal websites:

i. Access to everyone

ii. Requires AD authentication

iii. Requires SiteMinder authentication

We are looking into a custom mobile browser for our users and what the user experience is like with the three types of sites.

For (ii), on the desktop, we don't notice any prompt, since I assume Integrated Windows Authentication is used. However, on the mobile browser, would this be kerberos or NTLM? How would we notice the difference and in which format do we need to enter the credentials?

At the moment, the browser prompts in the format:

Username:
Password:
Realm or Domain:

Likewise, for (iii), SiteMinder doesn't have a realm or domain. What should we enter?
0
IIS/FTP InstallIIS Mgr.PNGAccessing Shared Folder  from Another PCAccessing FTP server via IEFTP LoginFTP ErrorHi,
  I have set up FTP server on a domain joined PC  (OS: Windows 7 Professional).
  I installed FTP Extensibility, FTP Service and IIS Management Console.
  I opened IIS manager and created a FTP site and new FTP site is up and running.
  I can access three test files by doing \\192.168.1.166 from the PC on the same network.
  I can also view three test files when I run ftp://192.168.1.166.

  However if I run FTP program to access the FTP server (NetBIOS name: DISK, IP address: 192.168.1.166), I get an error.
 
   What do I need to do to be able to connect to the FTP server running from "DISK" PC?

Thanks.
0
I have a webpage with a "slide show" of transitioning background images that sort of tell the story of the accompanying song: http://dijitalrealm.com/GrandDesign.html. I like the way it looks but when I'm in landscape view on my mobile phone and I have to scroll down the right hand div to see all the lyrics, the background image gradually gets covered with black from the bottom up as you scroll.

Is it possible to keep the background images showing full screen when I scroll? For comparison look at the same page with one stationary image: http://dijitalrealm.com/JCMusic/GrandDesignStill.html

I'm guessing that my code is pretty unprofessional but hopefully there's a solution that wouldn't require too much modification.

Thanks!
John
0
We started getting "Page not found" when trying to connect to BusinessObjects XI 3.1 SP6 via https, only for Internet Explorer. We could make the connection via Chrome (but Chrome doesn't fully work with BO for editing reports).

I've narrowed it down to Windows KB3172605 - when this installed, we started getting "Page Not Found". I removed it and we connected. The same scenario is reported in my third link below. This was part of this set of updates:
Windows updates
The page not found error occurred on our development box (with a DOD cert, Sha-1) and on Prod (self-signed cert). So since it fails on both, my conclusion is that it's not the cert.

Here are a couple of links on KB3172605
- Microsoft yanks buggy speed-up patch KB 3161608, replaces it with KB 3172605 and 3172614 (it doesn't say all that much about KB3172605)

- Microsoft rollup announcement, July 2016 (it says it works with Sha-1)

- German blog with discussion on KB3172605, which basically says "don't install it"
     - Also, the third comment is our exact issue

So my questions are
- These KB things, they (often) only affect IE, not Chrome, is that right ?

- BusinessObjects XI 3.1 SP7 officially works with IE-11, but SP6 (which we have) does not support IE-11, but it worked fine until KB3172605. So my gut reaction is that upgrading to SP7 wouldn't solve the issue, it seems to me that KB3172605 is the issue. What do you think ?
0
Hello all,
    I have an HP Layer 3 1920 switch as well as a Sonicwall NSA 2600 and am trying to figure out a way to restrict access on port 15 of the HP to only have internet, similar to a "guest mode" on a wireless router. I do not know what the IP will be nor do I know the MAC address of what will be on that port. What is the best way to go about this?

Thanks!
0
How to set it up ??
0
I have the below code i have been using for ages, that long that ive forgotten how to submit information via a URL to it rather than through an app.

Can anyone let me know what i have to type to get info out on the other end please.


<%
Dim TN,FN,SN,TL,EM,PC,NT,CT,ES,RV,LT,TT,AT,RF, stext

Dim fs, file

fs=Server.CreateObject("Scripting.FileSystemObject")
file=fs.CreateTextFile("C:\test\upload\" & request.form("Reference") & ".txt",true)

TN = request.form("TradingName")
FN = request.form("firstname")
SN = request.form("surname")
TL= request.form("Tel")
EM = request.form("Email")
PC = request.form("PostCode")
NT = request.form("Notes")
CT = request.form("CompanyType")
ES = request.form("Established")
RV = request.form("Revenue")
LT = request.form("LeadType")
TT = request.form("TTD")
AT = request.form("ATV")
RF = request.form("Reference")

AT = Replace(AT, "#"  , "")
AT = Replace(AT, """"  , "")
AT = Replace(AT, "£"  , "")
AT = Replace(AT, "&quot;", "")
AT = Replace(AT, "&lt;"  , Chr(60))
AT = Replace(AT, "&gt;"  , Chr(62))
AT = Replace(AT, "&amp;" , Chr(38))
AT = Replace(AT, "&nbsp;", Chr(32))

file.write("""")
file.write(TN)
file.write(""",""")
file.write(FN)
file.write(""",""")
file.write(SN)
file.write(""",""")
file.write(TL)
file.write(""",""")
file.write(EM)
file.write(""",""")
file.write(PC)
file.write(""",""")
file.write(NT)
file.write(""",""")
file.write(CT)
file.write(""",""")
file.write(ES)
file.write(""",""")
file.write(RV)
file.write(""",""")

Open in new window

0
Hi All,

We used Coova-Chilli for WiFi-Marketing and we got an issue with smartphone device, when the end-users accessed Access Point (AP), the system automatically popup iframe:

1. If using HTTP, it redirect to URL with HTTP
2. If using HTTPS, it couldn't popup URL using SSL

Please give us your advices how to resolve this issue.

Thanks in advance,

PS. it worked OK when using HTTP or HTTPS for PC/Laptop.
0
I have a nginx server sitting on dmz to poing traffic to a java application.  The reason why i call it java application is because it only has a xxx.jar file running. I could like to proxy the http traffic to the java application. The port is poart 80. I did the following nginx configuration as below, but it doesn't work. Is there any nginx experts here can help me with this issue?


[root@pmsdev jyu]# ps -ef | grep java
root      3108     1  0 13:29 ?        00:01:56 java -Dspring.profiles.active=dev -jar /data/AveryRollProduction.jar /tmp
root      3933  3918  0 17:24 pts/0    00:00:00 grep --color=auto java



    server {
        listen       80 default_server;
        listen       [::]:80 default_server;
        # server_name  localhost;
        # root         /usr/share/nginx/html;

        server_name  localhost;
        root         /usr/share/nginx/html;

        # Load configuration files for the default server block.
        include /etc/nginx/default.d/*.conf;

        location / {

        proxy_set_header X-Forwarded-Host $host;
        proxy_set_header X-Forwarded-Server $host;
        proxy_set_header X-Forwarded-For $proxy_add_x_forwarded_for;
        proxy_pass http://10.104.0.104:80;



        }

Open in new window

0

HTTP Protocol

The Hypertext Transfer Protocol (HTTP) is an application protocol for distributed, collaborative, hypermedia information systems. Hypertext is structured text that uses logical links (hyperlinks) between nodes containing text. HTTP is the protocol to exchange or transfer hypertext. HTTP functions as a request-response protocol in the client-server computing model. HTTP is designed to permit intermediate network elements to improve or enable communications between clients and servers. HTTP is an application layer protocol designed within the framework of the Internet Protocol Suite; it presumes an underlying and reliable transport layer protocol.

Top Experts In
HTTP Protocol
<
Monthly
>