HTTP Protocol

The Hypertext Transfer Protocol (HTTP) is an application protocol for distributed, collaborative, hypermedia information systems. Hypertext is structured text that uses logical links (hyperlinks) between nodes containing text. HTTP is the protocol to exchange or transfer hypertext. HTTP functions as a request-response protocol in the client-server computing model. HTTP is designed to permit intermediate network elements to improve or enable communications between clients and servers. HTTP is an application layer protocol designed within the framework of the Internet Protocol Suite; it presumes an underlying and reliable transport layer protocol.

Share tech news, updates, or what's on your mind.

Sign up to Post

Hello Experts,

I have a client that upgrade a machine that we installed that was running Windows 7 to Windows 10, well luck of the draw now the system shows connected to the network but have no web browsing capability. I am able to ping everything including anywhere on the internet. I have reset the winsock, I have uninstalled and reinstalled the network card with no changes. When trying to use the windows troubleshooting I get a response back of "One or more network protocols are missing on this computer" I have Deleted the winsock & winsock2 registry entries and tried to install the protocol back by going into the Network Card properties and install the tcp/ip protocols but get "Could not add the requested feature. The error is: This program is blocked by group policy. For more information, contact your system administrator." Well this machine is a stand alone machine and the user is an Admin on the machine and there is no other user.

Thank you in advance,
Bo Borchardt

I am trying to complete a HTTP post request via a stored proc.

The query returns the error: sp_OAMethod http status  407 which leads me to think proxy issues and that the request is never making it to the server.  The prints are in there for troubleshooting and it seems to break after step 5.

Any help would be greatly appreciated


USE [db]
/****** Object:  StoredProcedure [dbo].[HTTP_POST]   ******/
ALTER procedure [dbo].[HTTP_POST]( @sUrl varchar(8000)='https://api.apiurl/oauth/token?grant_type=refresh_token&client_id=
xxxxxxx&client_secret=XXXX-XXXX&refresh_token=XXXXXXX', @response varchar(8000)

@obj int
,@hr int
,@status int
,@msg varchar(255)
print @msg

exec @hr = sp_OACreate 'MSXML2.ServerXMLHttp', @obj OUT
if @hr <> 0 begin Raiserror('sp_OACreate MSXML2.ServerXMLHttp.3.0
failed', 16,1) return end

print '1'

exec @hr = sp_OAMethod @obj, 'open', NULL, 'POST', @sUrl, false
if @hr <>0 begin set @msg = 'sp_OAMethod Open failed' goto eh end

print '2'

exec @hr = sp_OAMethod @obj, 'setRequestHeader', NULL, 'Content-Type',
if @hr <>0 begin set @msg = 'sp_OAMethod setRequestHeader failed' goto
eh end

print '3'

exec @hr = sp_OAMethod @obj, send, NULL, ''
if @hr <>0 begin set @msg = 'sp_OAMethod Send failed' goto eh end

print '4'

exec @hr = sp_OAGetProperty …
We have a couple of XP's machines that we are not quite ready to upgrade to windows 7 or 10 but we need to to have Citrix Receiver to run on them for testing, we installed 4.1 version it runs but only in https, there is registry changes that make it work with http but been searching the webs but nothing on how to change them in Windows XP.
Anyone know how to do this?
I want to find a program that I can have external clients upload/download files via http URL web.

I want to make this as easy for them as possible without using any ftp clients such as WinSCP.

I would like them to type in a URL in their browser, and login and they would be able to upload files or download files.
Basically this would be web based front end.

Can any recommend any programs.
I have an HTML page, which includes an accordion with a list of slider questions in each panel. I hope the page could look like this:

Desired look for the panel
It’s content was build dynamically by AngularJS. I use $http.get() to an external API to get an array of data to build the accordion and sliders. (in the form of a JSON request).

I also have two JavaScript plugins in my file to make the accordion and slider look prettier.

After the data was loaded into my page (about 1 to 2 seconds), I got the basic structure of the page with the correct data in it.

However, the sliders and accordion looked the same as those without using the plugins. Those plugins are not working on my dynamically generated elements.

The page looks like this:

Current Panel
The code for the panel building looks like this:

                            <div class="col-md-9">
                                <div class="panel-group" id="accordion" role="tablist" aria-multiselectable="true">
                                    <div class="panel panel-default form-group" ng-repeat="group in accordion.groupQues">
                                        <div class="panel-heading" role="tab" id="heading{{group.gID}}">
                                            <h4 class="panel-title">
                                    <a class="collapsed" role="button" data-toggle="collapse" data-parent="#accordion" 

Open in new window

I would like to download a csv file from this website and save it to C:\temp.  I typed this.

H:\>wget64 --user="aaa" --password="aaa" "  --auth-no-challenge --content-dispostion -q$ -P C:\temp

I got the response below, but there was no file in C:\temp.

--2016-01-21 12:28:34--  https://website/files/download?type=144
Resolving ( IPAddress
Connecting to (|IPAddress|
:443... connected.
HTTP request sent, awaiting response... 200 OK
Length: 189 [text/html]
Saving to: 'download@type=144%20%20--auth-no-challenge%20--content-dispostion%20

download@type=144%2 100%[===================>]     189  --.-KB/s    in 0s

2016-01-21 12:28:35 (541 KB/s) - 'download@type=144%20%20--auth-no-challenge%20-
-content-dispostion%20-q$%20-P%20C%3A%5Ctemp' saved [189/189]
I am running a number of api scripts off of a single server. A number of outside sites access these scripts from different domains.

When I use this command, it works fine.

Header add Access-Control-Allow-Origin ""

My online research told me that this was the way to set up the .htaccess file for multiple domains, but it isn't working.

SetEnvIf Origin "^http(s)?://(.+\.)?(example1\.com|example2\.com | example3\.org)$" origin_is=$0
Header always set Access-Control-Allow-Origin %{origin_is}e env=origin_is

Can you provide assistance as to how this .htaccess file needs to be set up to provide cross browswer support?

I am using Entity Framework 5 and WCF data service.

I have the following method in the service1.cs

 public IList<Employee> GetEmployee()
            using (ChinookEntities DBEntities = new ChinookEntities()) { 

            IList<Employee> ListOfEmployees = (IList<Employee>)(DBEntities.Employees.ToList());
            return ListOfEmployees.ToList();

Open in new window

When I debug through WCF test client I am able to get the list of employees in the above IList<> ListOfEmployees, however after the method executes in the WCF Test client it gives the following error:

An error occurred while receiving the HTTP response to http://localhost:8733/Design_Time_Addresses/ChinookWCF/Service1/. This could be due to the service endpoint binding not using the HTTP protocol. This could also be due to an HTTP request context being aborted by the server (possibly due to the service shutting down).

Just for information I have another method GetData and that works fine from WCF test client and able to invoke the method.

public string GetData(int value)
            return string.Format("You entered: {0}", value);

Open in new window

Am I missing something.

Thanks in advance.
Assuming I have a userID and Password, how do I download files from this website to my hard disk?

I have a Powershell script like this.  It's called Test2.ps1

$client = New-Object System.Net.WebClient
$client.Credentials = New-Object System.Net.NetworkCredential("", "Reuters123")

which I call with a batch file like this.  The batch file is in the same directory as the Powershell script and is called Test.bat

PowerShell.exe -NoProfile -ExecutionPolicy Bypass -Command "& '%~dpn0.ps1'"

When I run this the files contain HTML and javascript rather than data.
Hello Experts,

I recently register a domain name lets say as example LINE.COM, please note I am using LINE.COM as an example.

I would like users to reach to it by typing www.LINE.COM. What do I need to do.

Right now I can browse to it by typing http://LINE.COM and not Http://www.LINE.COM
As I understand it .NET has some tools for enabling browser caching but what are our options with classic asp applications?  

I found a tool that works on older versions of windows similar to the way appache works with .htaccess files but it won't work on Windows 2012 which is what we have running at the moment.

Here is that tool:


I am trying to understand SSO concept.

Here in the link, at page 7, Figure 1a, I see a flow that the client starts the initiation via IDP and it is redirected to IDP and authentication is done.
1) At this point, has the authentication been done?
2) and, why is there another redirection to RP (4)?

My other questions are that in at section Web Browser SSO Profile,
3) I couldn't differentiate the order in sections between SP POST Request; IdP POST Response and SP Redirect Artifact; IdP Redirect Artifact. Can you explain?
4) And comparing to the above question 3, is RP representing SP?
5) And finally, is the SSO authentication ordered always as from Client->IDP->SP? Or can this order be changed?
I am using the url rewrite module 2.0 in IIS7 to redirect all http requests to https requests.

<rule name="http to https" enabled="false" stopProcessing="true">
<match url="(.*)" />
<conditions logicalGrouping="MatchAll" trackAllCaptures="false">
<add input="{HTTPS}" pattern="^OFF$" />
<action type="Redirect" url="https://{HTTP_HOST}:{R:1}" />

It works great but now it doesnt work for old static links.  For example, the url:  used to work but with the rule it doesnt redirect it to   What is the best way to fix this for static links?  Do i tweak my current redirect rule or should a create a new rule and give it higher priority. IF so what should the new rule look like. I have taken many guesses with no luck.
I am having issues with the config for a sip phone (Aastra 6737i) and would like to manually download the config and look at it.

The basic settings I have are - directly from the phone;
  Download Protocol - Http
  HTTP Server - FQDN
  HTTP Path - aastra6737i
  HTTP Port - 80

I also know the MAC address of the phone and the SIP Username and Password

After some reading, I tried to use the Powershell "invoke-webrequest" command to download the file.

I have tried two different ways to pass the Username & Password.
Please Note - I did not write this code, but copied it from examples I found substituting my SIP username and Password

Method One
        $username = "username"
        $password = "password" | ConvertTo-SecureString -asPlainText -Force
        $cred = New-Object System.Management.Automation.PSCredential($username,$password)
        invoke-webrequest -outfile mac.cfg http://fqdn/aastra6737i/mac.cfg -Credential $cred

Method Two
       $user = 'username'
       $pass = 'password'

       $pair = "$($user):$($pass)"

       $encodedCreds = [System.Convert]::ToBase64String([System.Text.Encoding]::ASCII.GetBytes($pair))

       $basicAuthValue = "Basic $encodedCreds"

       $Headers = @{
             Authorization = $basicAuthValue
        invoke-webrequest -outfile mac.cfg http://fqdn/aastra6737i/mac.cfg -Headers $Headers

 === Again I did not write these scripts, and I am NOT a programmer.

However regardless of the …
Hello Expert Exchangians.

I am trying to inquire how we can completely disable http communications and enforce https on all SharePoint services,
So far I am aware of
a. IIS where there is
--- Webserver
   ---Default-Website - running only on port 80
   ---servername-hostname - where it is a main /SitesPages/Home.aspx - running only on port 80
   --- SharePoint Central Administration v4 - running only on port 13723
   --- SharePoint Web Services - running on http(32843) and https(32844)
      +++ we have seven different subpages containing random generated 32 character name pages running on the same ports as webservices
      +++ SecurityTokenServiceApp - running on the same ports as Web Service
      +++ Topology - running on the same ports as Web Services.

b. is there anything else we need to be aware off?

c. we have AD intergration is there a way to change this to encrypted AD to SP2010 communiacation as well.

d. all databases are on separate SQL server, is there a way to entyrp traffic between SQL and SP2010 as well.

e. we have mail server setup thru central admin console and inside IIS global settings is there a way to set that up as well to be encrypted.

f. am I missing anything else.

Appreciate all the help I can get


Happy Holidays

I am trying to edit a feed that is created for my blog extension. I want to place a line break after each tag (there is another problem with the feed and bugs are hard to find when it is all on one line) but I cannot get it to work. I have tried /n but this just outputs /n.

It is not echo so I am not sure this is correct to use. Here is the code

            $output  = '<?xml version="1.0" encoding="UTF-8" ?>';
            $output .= '<rss version="2.0" xmlns:atom="">';

Open in new window

I have tried

            $output  = '<?xml version="1.0" encoding="UTF-8" ?> /n';
            $output .= '<rss version="2.0" xmlns:atom=""> /n';

Open in new window

this just outputs

<?xml version="1.0" encoding="UTF-8" ?>/n<rss version="2.0" xmlns:atom=""> /n

I have also tried

            $output  = '<?xml version="1.0" encoding="UTF-8" ?>';
			$output  = "\n";
            $output .= '<rss version="2.0" xmlns:atom="">';
			$output  = "\n";

Open in new window

This makes these lines disappear and replaced with a single line break.

Can someone please give me some advice?

Many Thanks
We are currently having difficulties access a site we have that is configured for secure (443) access. A short description of the topology. We have a server located in our DMZ lets call it it is acting as a web server for We are able to ping the address for both internally and externally however when we try and reach we only receive a "This webpage is unavailable" Please assist. Feel free to ask any questions.
i was playing around with my router configuration page and changed it to https. now I can't log on because it gives a certificate error. How do I log in? it is a linksys
I have a sub domain that I would like to forward to another domain. is this possible? I tried using a cname, but haven't had any luck. Example needs to forward to

I am trying to redirect a IIS 8.0 URL from HTTP to HTTPS. Have installed URL redirect and followed below articles.
But still getting error. Can you please help.
I'd like to deepen my understanding / knowledge of core web protocols and technologies.

The web is a great resource - but perhaps I've missed some of the sites that might serve me better I'd appreciate some recommendations.

I'd also appreciate any books you have read and can recommend that can make my understanding of HTTP, IIS, and perhaps even TCP/IP rock solid and practical.

I've been in IT for over 20 years, but I've struggled with web.  I can build and maintain a basic website, but I'd like to understand more about the journey of a web page, from the moment the page is requested up through when the page is done rendering after being sent to the browser from the server.  I don't think I truly deeply understand it.  Not really.  So I'd like to learn it.

for example:

click my test link

This is a link to an HTML page residing on a server I am hosting my website on.  I have no idea where the server is physically located.  This is an HTML page in as simple a format as I can conceive of one.  What journey does it take from clicking on the link to getting the message back in the browser moments later?  I want to know, under the hood, everything that happens as deeply as possible.
I have a web page the opens in a window via JavaScript.  I've spent a lot of time debugging without much success.  I do see the following error when I go into Developer Tools for that window (in Chrome):

GET https://localhost:44399/505266b2c97b422994d16354c880340c/browserLink net::ERR_INSECURE_RESPONSE

I am wondering what I might focus on in order to resolve this?
I'm trying to read data from external php file using ajax, then I want to assign this data to a javascript document variable. I want to check if my code is ok like that or should I define the variable inside the ajax brackets.

Here is my code:

      url: '',
      success: function(data) { alert(data); }  
     var foo = data;
Hello, I am trying to redirect domainA to domainB via the following entry in my .htaccess file:

RewriteEngine On
RewriteCond %{HTTP_HOST} ^
RewriteRule ^(.*) [P]

Open in new window

This works quite well as I thought it did but it does not when a person types into the url 
Then the customer is not redirected to

What am I missing here ?

I get an error on firefox that this site isn't secure. I have secured every item that I can find, when I do a view source / search I can't even find http://

HTTP Protocol

The Hypertext Transfer Protocol (HTTP) is an application protocol for distributed, collaborative, hypermedia information systems. Hypertext is structured text that uses logical links (hyperlinks) between nodes containing text. HTTP is the protocol to exchange or transfer hypertext. HTTP functions as a request-response protocol in the client-server computing model. HTTP is designed to permit intermediate network elements to improve or enable communications between clients and servers. HTTP is an application layer protocol designed within the framework of the Internet Protocol Suite; it presumes an underlying and reliable transport layer protocol.

Top Experts In
HTTP Protocol