Hyper-V is a native hypervisor; it can create virtual machines on x86-64 systems and supersedes Windows Virtual PC as the hardware virtualization component of the client editions of Windows NT. A server computer running Hyper-V can be configured to expose individual virtual machines to one or more networks. Hyper-V Server supports remote access via Remote Desktop Connection. Administration and configuration of the host OS and the guest virtual machines is generally done over the network.

Share tech news, updates, or what's on your mind.

Sign up to Post

Replication ErrorReplication ConfigurationFirewall Inbound RulesHi,
 I have two Hyper-V servers - W2012 (running Windows Server 2012, & W2016 (running Windows Server 2016, on the same network.  When I select the VM on W2012 and go thru replication, I get an error.
(1) I can ping W2016 from W2012 and ping W2012 from W2016.
(2) Both Hyper-V servers are "Enabled as a Replica server" using "Kerberos port 80" and chose "Allow replication from any authenticated server".
(3) I tried to replicate the VM in W2016 onto W2012, but it failed because I could not replicate 2016 VM to older version of HyperV.
(4) so I tried to replicate the VM in W2012 onto W2016, but I am getting this error. (please see the screenshot).
(5) On both Hyper-V servers, I enabled "Hyper-V Replicate HTTP and HTTPS Listeners" and rebooted the servers.
(6) Both Hyper-V servers have the same administrator password.

What can I do?
Hyper-V Machines in Stopping State?
It's not because of Hard drive space 472 GB Free of 1.09TB
30 VM's of which 14 are in stopping state..

Server 2016 Datacenter
HP DL380 G6
96 GB Ram
2x e5649  6 core CPU's2018-12-30_20-14-31.png
I just installed a new Office PC (Win 10 Enterprise). I have an old billing program on my prior Win7 Pro PC that I want to keep using. Created a VM of the Win7 PC using Macrium viBoot, installed the Hyper-V role in Win10 and am able to boot / use the VM without issue. Great!

But what about backup? I have Macrium setup to image my Win10 PC daily. Would restoring my Win7 VM (if needed) be a simple matter of restoring all the files in the Macrium viBoot folder (where all VM files are stored I believe).

I realize (and use) VM backup software (Altaro) at my Server clients. But Altaro, Veeam, etc. programs require the Host to be running Server software. Looked at BackupChain but that would need a Server license as well.

I'm hoping just a simple backup of the VM files will suffice in this scenario.

Anyone have experience with Hyper-V backup on a Win10 host?
MVMC Connection Option Screeb Warning on Summary ScreenConvertion Process Screen
 I am trying to convert Windows 2003 Server running virtual machine "FS1_W2003-recovered"  in VMWare ESXi server into Hyper-v virtual machine using Microsoft Virtual Machine Converter and have some questions:
 (1) In Connection option screen, I am not sure if the message means or applies to my situation?
 (2) In Connection option screen, why I can't select "On" for "Final state of source virtual machine"?
 (3) In Summary Screen, should I be concerned about the warnings (1. OS not supported  2. having one USB device) ?
(4) In Completion screen, I see "Uninstall tools" on the 3rd line. I assume it will uninstall VMWare tools? If so, why does it do that? Will it alter or harm existing VMWare VM in any shape or form?  This is where I CANCELLED the conversion because I was not sure what would happen to source VM.
Extra avhdx filesHi,
  I have a HyperV  virtual machine that has two disks (P...K1-0.vhdx & P...K1-1.vhdx) - C drive and E drive. Each drive carries three files (vhdx, vhdx.mrt vhdx.rct).
 But then there are extra files of avhdx (4AD ...avhdx & B59...avhdx) seen on the screenshot and I like to get rid of it.
 Here is how they are created.
 I created new virtual machine using first disk - P...K1-0.vhdx. But when I tried to add 2nd disk (P...K1-1.vhdx), I added it to the wrong existing virtual machine (called TS1).
 When I eventually added 2nd disk (P...K1-1.vhdx) to the right virtual machine and started the VM, it complained about "file being currently used ...".
 So I rebooted the hyper-V server and was able to start my virtual machine with P...K1-0.vhdx & P...K1-1.vhdx. But my TS1 VM would not start saying "file being currently used ..." and it was put in "saved state". I deleted "saved state" from TS1 and now TS1 is working now.
 However during this process, two sets of extra avhdx, MRT and RCT  files were created and I like to delete them because they are not used and not intended.
 But I just wanted to check to make sure that I can delete them without casuing problems. Fyi, I have not created any snapshot for any VMs in Hyper-V server.

 Can I just delete them?
I am running a Hyper V cluster with two hyper v hosts and one of the host says Host not responding. We cannot see the GUI when we connected to a monitor, nor we can do a remote desktop connect to the server it simply hangs at creating session while doing RDP. Issue is there are few critical vm's running under it which we cannot take them down or risk loosing them due to some issue in future. Is there a way to get the host GUI back without disturbing the VM's? so I can safely migrate the vm's to another host and perform maintenance once I get access to GUI. As of now I feel its too risky to attempt host migration without knowing the root cause.

I have powershell access to that host and I tried restarting terminal services to attempt successful RDP connection however with no luck too.

Looking forward for experts help to get this resolved

Hello everyone,

I have a scenario in which there are:
3 x Ex2010 Mailbox Server in DAG (on vSphere cluster)
2 x HT and CAS with NLB configured (on Hyper-V cluster)
2 x UM server
and also hybrid configuration.

I am not really an expert in O365 / hybrid configurations.

As per refresh cycle, I have to move VMs from existing Hyper-v and vmware (all above roles) to new vSphere cluster.

For Mailbox I have planned to create new MailboxServer VMs with new name,IP and add them in DAG, add a copy of each databases to new VMs, remove copy from old VMs and uninstall Exchange from old VMs.
Also will be updating the RPCClientaccessserver, move arbitration mailbox

For HT-CAS and UM, I am planning to use vmware converter to move VMs from hyper-V one at a time to vSphere cluster.
I believe I will have to retain the mac address of NICs from hyper-v vms

I am here for some advice, suggestions and caution I must take, specially with hybrid setup.
appreciate your comments.

Thank you.
I have a HyperV Cluster environment.
One of the servers is not listing the virtual machines.
But VMs are up and running.
I can view the VMs of host01, but not of host02.
Also by the Cluster Manager function I can not manage the VMs.

The error below occurs:
The cluster Resource Hosting Subsystem (RHS) process was terminated and will be restarted. This is typically associated with cluster health detection and recovery of a resource. Refer to the System event log to determine which resource and resource DLL is causing the issue.

A component on the server did not respond in a timely fashion. This caused the cluster resource 'Virtual Machine SRVCWBMON01 (2)' (resource type 'Virtual Machine', DLL 'vmclusres.dll') to exceed its time-out threshold. As part of cluster health detection, recovery actions will be taken. The cluster will try to automatically recover by terminating and restarting the Resource Hosting Subsystem (RHS) process that is running this resource. Verify that the underlying infrastructure (such as storage, networking, or services) that are associated with the resource are functioning correctly.
we have an ongoing issue with cloudcare where we cannot log on to our vm servers.
we have 2 vms, 1 our 2016 dc and the other our 2016 exchange server.

once we get into this “lock out” situation we try closing down the servers but they just hang, so the only way we have been able to resolve this is to hard reset the server.

we have just done this again and now both vms are stuck starting up, where the status shows "merge in progress", but the progress is just sat at 26% for our dc and 7% for our exchange server.

we really need these servers back online, so does anyone know how we can tidy this up and get them operational?

any help much appreciated - desperate!!

Hi All,

Hopefully a quick question...

I have a Hyper-V host which does not have a TPM or BitLocker enabled.

There is a Windows 10 Enterprise guest VM.... On this VM can I enable BitLocker on the guest OS boot drive or only secondary data drives?

Most of the information I can find seems out of date, except Microsoft Docs but i couldn't find this info there..

I am using Backup Exec 2016 and trying to back up a Hyper-V virtual Server 2016 with Exchange.  Backups were running fine until I installed Exchange 2016, I am now unable to backup that server.  I get the following error in Event Viewer on the host server and nothing in the virtual server:

A VSS writer has rejected an event with error 0x800423f4, The writer experienced a non-transient error.  If the backup process is retried,
the error is likely to reoccur.
. Changes that the writer made to the writer components while handling the event will not be available to the requester. Check the event log for related events from the application hosting the VSS writer.

   PrepareForSnapshot Event

   Execution Context: Writer
   Writer Class Id: {66841cd4-6ded-4f4b-8f17-fd23f8ddc3de}
   Writer Name: Microsoft Hyper-V VSS Writer
   Writer Instance ID: {86a4095e-f206-4b63-add4-59d60f5469a1}
   Command Line: C:\Windows\system32\vmms.exe
   Process ID: 2744
Win10 Physical PCVolume Configuration in MVMC
I am trying to convert a physical Windows 10 PC (1TB HD, <30GB used) to a virtual machine in Hyper-V server using Microsoft Virtual Machine Converter.
In Volume Configuration screen, I need to select either "Dynamic" or "Fixed" ,  By default "Dynamic" is selected.
Which option should I choose and what difference does it make?

 I have a HP Proliant ML110 G9 server with Intel(R) Xeon(R) CPU E5-2603 v3 @ 1.60GHz CPU and I am running Hyper-V with 4 VMs - SBS2011, W2012R2, WIn10 and  Win7.
Currently a single virtual CPU is assigned (by default) to each VM.  This CPU has have 6 cores.

 Should I assign more virtual CPUs to SBS2011 or/and W2012R2 TS and how would these VMs would benefit from having more than one core?

SB2011: Domain Controller, Exchange Server.
W2012R2: Terminal Server where users (up to maximum 8 users concurrently, typically 5 users)  log in and run applications programs like Quickbooks, Outlook Word, Excel, Internet Surfing, Printing.
 WIn10: Occasional login by single user
  Win7: Occasional login by single user
I have archiving system with 100tb that is work with mssql
I have hp g10 with 2x 500gb ssd harddisk  that is work with Hyper-V and sql server will install on  vm that it will be on storage
we plan to get a storage. the storage will have ssd hard disk for Hight performance or sas regarding the cost
the san with ssd from hp will be so much so we planed to work with qnap nas storage
do you agree with that ?
Hi everyone!

I'd like to know how to implement the following.

This is what I have:

I have a physical server with Windows 2012 R2 and inside it (HyperV) Windows 2016 Advanced Server. The server has 2 NICS. I have one static IP.

The goal: Configure the HyperV machine to be accessed from OUTSIDE/REMOTELY for 10 users. We have 10 User Remote Desktop Services licenses
So far nothing has been configured.

My questions are:
1.) Where should I install Remote Desktop Services, on the physical server or the HyperV, and how is this done? (if you have a link that will be helpful.

2.) How to make sure the 10 users will have access to the HyperV directly from outside?

3.) Anything else I should be aware of?
Dear Experts,

I have a Sophos vhdx installed into my hyper-V version SFOS 17.1.3 MR-3.

How do i login and configure the IP address and its interfaces?

I only managed to access the console via the Main Menu.
I have recently purchased the following
Synology DS1817 NAS (not the + version, this version has 2 x built in 10GB NIC's & 2 x 1GB NIC's)
2 x Intel X540-T2 NIC's
1 x DLink DXS-1210-10TS 10GB switch

I installed the 2 x  X540-T2 in our Windows 2012r2 Hyper-V host. Each card has two ports. I have configured
all 4 ports as a team and connected each to the DLink DXS switch. All 4 connections are 10GB as expected - perfect!

Connecting the Synology DS1817 NAS I only get a 1GB connection. Local 2m CAT6 cable.

I raised a support case with Synology. Synology support got me to connect the 2 x 10GB NIC's together with a CAT6 patch lead
and connect the NAS to the DLink switch via one of the 1GB ports. Synology confirmed that the were getting 10GB communications
between the 2 x 10GB and concluded that the issue lay "somewhere else" on the network!

I have used tested 2m CAT6 cables from both 10GB NIC's to the Dlink DXS switch - both connect at 1GB
If I set the switch ports to 10GB I loose communication with the NAS.
All ports on the DXS are 10GB.

Anyone have any idea why, if the Synology DS1817 NAS is working correctly, I am not getting a 10GB connection to the DXS10 switch?
Thanks in advance

On my Windows 10 Pro OS laptop I created a Server 2016 Hyper-V virtual machine.

I shut down this Server 2016 VM within the OS using the shutdown -s -f -t 0 command.

For the last hour, this VM has remained stuck and says "Stopping" within the Hyper-V Manager. This VM already had all of the Windows updates installed.

I don't have the option to stop or shut down this VM and when I open this VM I only get a blank screen.

I have already shut down the Windows 10 Pro host OS but when I have booted Windows 10 back up and opened the Hyper-V Manager the Server 2016 VMis still in its same state.

What command line or PowerShell commands can I use to force the shutdown of this Server 2016 VM?

Or what else can I do to completely shut down this Server 2016 VM?

S2016DC Hyper-V VM stuck
I have server hp ml10 g9 with windows 2016 with Hyper-V and I have a mikrotik 951
I set the server to shutdown everyday @6pm
 I set a mikrotik to wake on lan script on 8am

the problem that is the windows 2016 not support wol on s5 state
its only on s4 and s3
regarding hp:
Press Win + x, select Run and type regedit in the run line.
Select OK to launch the Registry Editor.
Navigate to KEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\NDIS\Parameters.
Right click on Parameters.
Select New DWORD (32-bit) Value.
Add the key AllowWakeFromS5.
Set the value to 1.
Close the Registry Editor.
Restart the computer.
but it's not work too I have last bios update and I enable wake on lan via bios.
any solution for that ?
Hyper-V 2012R2 VM acting as DC with PDC role always comes back to CMOS clock source after reboot.  Takes W32TM /RESYNC command to get clock source back to NTP and external where it will run fine again until the next reboot.

Hyper-V Host is Server 2016 with Time Integration service NOT checked.
Currently ,I have a following infrastructure

One physical server (2012 R2) which is  Configured as a Domain Controller.Also, It contain only a C drive and all file shares running on my  C drive DATA folder.
All files and folders in Shared drives  that are shared with groups and individuals where needed.
All the shared folders  has extensive share permissions definedI bought a new server(server 2016) and planning to creat a Hyper-V host.Then planning to create a DC and file server.
All shared folder mapped to users through GPO's

1)What's the easiest way migrate a physical DC to Hyper-v VM (same Domain Name)?

2)What's the easiest way to copy all the shared DATA folder to new file server ?
Planning implement new Hyper-V server with 4 vm's.
I bought a 4 bay Server which has 3.5" 600GB 15K SAS 12Gb Hot Swap 512n HDD with raid 5.
Also, this has M.2 CV3 128GB SATA 6Gbps Non-Hot Swap SSD.
Planning to install Host OS (server 2016) on M2 SATA SSD .
I am going to use the 3.5" 600GB 15K SAS 12Gb Hot Swap 512n HDD with raid 5 for VM's storage.
Host server only going to have the hyper-v role.
1) I just wanted to find out whether 128GB is sufficient for HOST OS ?(capacity)
2) 3.5" 600GB 15K SAS 12Gb Hot Swap 512n HDD with raid 5 is ok to store all my VM's ?(performance vise)
2) Performance vise RAM 16GB X4 TruDDR4 2666 MHz (1Rx4 1.2V) RDIMM sufficient to implement Hyper-V hypervisor
I have cisco slm224g switch
I have a windows server 2016 with Hyper-V rule
I have three vlans 2, 3
Hyper-V on port 1
adsl router on port 2
client work station on port 3
on Hyper-V I have a pfsense as vm with two network interface the first one with vlan id =2 and the second one vlan id=3 on the same interface.
I want to assign client ,Hyper-V to vlan 2 and should connect over port 1 to first interface on Hyper-V
I want to assign adsl router to vlan3 and should connect  over port 1 to second interface on Hyper-V
regarding above:
port 1 should be trunk  for vlan id 2,3
port 2 should be access to vlan 3
and port 3 should be access as vlan 2
I tried that but it's not working so what the basic configuration for that ?
HyperV ManagerSnapshotVMs paused-Critical stateHi,Virtual Hard Disk FolderVM stuck during shutdownOptions under Action menu
 I accidently created a snapshot on the VM "FT1" and there are two problems:
(1) Every so many seconds, when I open this VM in Hyper-V manager, it goes to "pause" state showing the screen in shaded color. When I start it, it goes back to shaded/pause  state.
(2) Now I am getting "Out of Disk" message on my Hyper-V server.

I did not intend to create a snapshot at all. I was expecting a snapshot manager screen as I chose "snapshot". But I think it is trying to create a snapshot and the server ran out of space. It seems that the logical thing to do is to cancel "snapshot creation process" because there is no hard drive space for the snapshot to be created in the first place, delete the temporary file "FT1_2481848F-1B1E-4667-A1A2-985A4E532138.avhdx"(18.9GB), and restart the "FT1" VM.

What should I do?

** I forgot to mention that I was trying to shut down the VM, but that is even stuck.
I'm running Hyper-v in a 2012 R2 cluster.  (Note: this is NOT SCVMM)
I'm trying to get a list of all the VMs currently running on the Host I'm logged into and their respective possible owners. i.e. which cluster nodes they could potentially migrate to.  The reason is that I THEN want to set those VMs to only run on that particular host for patching purposes.  Once done I'll want to reverse it so the VMs can once again migrate when needed.  Here is the code and attendant error message.  I'm hoping someone can assist me with achieving my goal or at least point me in the right direction.

$VMs = get-vm
foreach ($vm in $vms)
	get-clusterresource -vmid "$VM.vmid" | get-clusterownernode

Open in new window

The error I am getting is:

Get-ClusterResource : Cannot bind parameter 'VMId'. Cannot convert value "Microsoft.HyperV.PowerShell.VirtualMachine.vmid" to type "System.Guid". Error: "Guid should contain 32 digits with 4 dashes (xxxxxxxx-xxxx-xxxx-xxxx-xxxxxxxxxxxx)."
At line:1 char:50
+ foreach ($vm in $vms) {get-clusterresource -vmid "$vm.vmid" | get-clusterownerno ...
+                                                  ~~~~~~~~~~
    + CategoryInfo          : InvalidArgument: (:) [Get-ClusterResource], ParameterBindingException
    + FullyQualifiedErrorId : CannotConvertArgumentNoMessage,Microsoft.FailoverClusters.PowerShell.GetResourceCommand


Hyper-V is a native hypervisor; it can create virtual machines on x86-64 systems and supersedes Windows Virtual PC as the hardware virtualization component of the client editions of Windows NT. A server computer running Hyper-V can be configured to expose individual virtual machines to one or more networks. Hyper-V Server supports remote access via Remote Desktop Connection. Administration and configuration of the host OS and the guest virtual machines is generally done over the network.