IBM System i

IBM i, formerly known as AS/400, is a proprietary, midrange, object-based operating and application system. It includes a relational database, a menu-driven interface, support for multiple users, block-oriented terminal support and printers, and supports security, communications, and web-based application servers including Websphere, Apache and Tomcat.

Share tech news, updates, or what's on your mind.

Sign up to Post

How can i save restore  an  stored procedure  type external from system V6R1 to another with V7R1 .
this object is looked from iseries navigator >database>schema>procedure.
0
Have a pc attempting to log on to a AS400 but gets no response after entering userid & password.  Makes connection to AS400 and gets log on screen with no problem.  I even entered a wrong password to see if I received an error message but I did not.  Any suggestions?
0
Hi Team,

For one of our server the  tape drive has been broken , so please confirm if we need to IPL the system after the replacement

Regards
Avinash Chandra
0
Hi,

I have an application still running old 36 programs. (on the list to converted, but has not made it to the top of the list)
Can anyone tell me how to get the wait record no max to function in a 36 proc on the  '// file' statement? (like the *nomax on the ovrdbf)  
 
OVRDBF     FILE(CUSTDT) TOFILE(&FILE8) WAITRCD(*NOMAX)
// FILE NAME-CUSTDT,DISP-SHR,LABEL-?L'1,1'?CCUSTDT,*******?  - I want the program to wait forever for the record instead of timing out


Thank You,
Lynn
0
I am attempting to receive data from a data quue that is attached to an outq.

From there I take some of that information and use QUSLSPL API to get the List of Spool files that meet the criteria of what was found from the RCVDTAQ API.

I then create the pointer using QUSPTRUS API  to a user space that I created previous and attempt to run the spool list.  when I do this is not working as expected.  Basically the follow IF fails on NUMBER-LIST-ENTRIES being equal to 0.

           IF (INFORMATION-STATUS OF QUS-GENERIC-HEADER-0100 = "C"  (14)
              OR INFORMATION-STATUS OF QUS-GENERIC-HEADER-0100 = "P")
              AND NUMBER-LIST-ENTRIES OF QUS-GENERIC-HEADER-0100 > 0  (16)
      *
      * address current list entry
      *

              SET ADDRESS OF STRING-SPACE TO SPCPTR,

              SET ADDRESS OF QUS-SPLF0200 TO
                  ADDRESS OF STRING-SPACE((OFFSET-LIST-DATA
                  OF QUS-GENERIC-HEADER-0100 + 1):1),     (18)
      *
      * and process all of the entries
      *
              PERFORM PROCES
                 NUMBER-LIST-ENTRIES OF QUS-GENERIC-HEADER-0100 TIMES,  (20)

           ELSE
              DISPLAY "List data not valid.  **** THIS IS WHAT EXECUTES!!!!" 

Open in new window


I have referenced this link with a COBOL example.
https://www.ibm.com/support/knowledgecenter/en/ssw_ibm_i_73/apiref/cmnKeysCOBOL.htmhttps://www.ibm.com/support/knowledgecenter/en/ssw_ibm_i_73/apiref/cmnKeysCOBOL.htm

I can provide more code if necessary.
0
Workstation program version 6.0 for windows
Iseries access for windows

User profiles are getting disabled for no aparenr reason. for example, user is enterning correct password while logging on however the user gets i ' =@@@ and his user account got diabled on iseries app. I tried to replciate the issue, by hitting connect/disconnect button - my profile got disabled. any advise should be helpful for me.

day 5 at the job :)
0
I am looking for script help with copping cell data from excel and pasting to AS400.
Example: copy data from Excel cell D3 paste in AS400 09,040 enter, copy from Excel cell E3 paste in AS400 13,030 enter. I need  this to repeat or loop until all the data from Excel column D and E have been entered in AS400.
0
Can someone help with below requirement.....

I have a physical file with one of the field with variable length and it has contents as given below. My requirement is to substring the the IFS links just before the *OMIT for all occurrence .

For example, the i should get  /QSYS.LIB , /QDLS, /TMP/BRMS , /QIBM/ProdData ....from first record.

From second record, nothing, as the *OMIT is not present

From third record, i should get /QIBM/UserData/OS400/TCPIP/QTOCHOSTS

From fourth record, i should get /QSYS.LIB, /QDLS

Once i get these substrings, i will right it them to another file in one column field.

Sample records in the file are ....

OBJ(('/*' *INCLUDE) ('/QSYS.LIB' *OMIT) ('/QDLS' *OMIT) ('/TMP/BRMS' *OMIT) ('/QIBM/ProdData' *OMIT))
OBJ(('/home/cdimage'))
OBJ(('/QIBM/UserData/OS400/TCPIP/QTOCHOSTS' *OMIT))
OBJ(('/*' *INCLUDE) ('/QSYS.LIB' *OMIT) ('/QDLS' *OMIT))
OBJ(('/fixes'))

Thanks in advance !!
0
Is it possible to generate AS400 spool file with 2 different overlay objects. 2nd Overlay is applicable only to last page of the spool file?
0
Hello. I am trying to setup a 5250 Printer Session from a remotely located IBM ISeries (V7R1M0) to my local machine using an HP LaserJet M605 printer. I have setup many 5250 Printer Sessions before using other printers (HP LaserJets, Lexmark) but for some reason after I set this one up to print to the M605 printer, nothing prints. The ISeries seems to be sending the print file normally but the M605 does not print anything. I am assuming that there is some "trick" to getting this to work but I don't know what it is. I have tried the Manufacturer and Model Type paramter to other types of printers without success. Any help would be appreciated. Thank You!

Here is the DEVD for the printer:

Device description . . . . . . . . :   XXX    
Option . . . . . . . . . . . . . . :   *BASIC    
Category of device . . . . . . . . :   *PRT      
                                                 
Device class . . . . . . . . . . . :   *VRT      
Device type  . . . . . . . . . . . :   3812      
Device model . . . . . . . . . . . :   1        
Advanced function printing . . . . :   *NO      
Online at IPL  . . . . . . . . . . :   *NO      
Attached controller  . . . . . . . :   QVIRCD0001
Font:                                            
  Identifier . . . . . . . . . . . :   011      
  Point size . . . . . . . . . . . :   *NONE    
Separator drawer . . . . . . . . . :   *FILE    
Separator program  . . . . . . . . :   *NONE    
Printer error message  . . . . . . :…
0
I'm looking for zipping tools that could create zips with password
for OS/400 R7  platform so that sensitive data in files are encrypted
& when we sftp over to Windows/Unix, the encrypted zipfiles are
sent over : for PCI-DSS compliance, we want data at rest to be
encrypted both at AS400 & the Windows/Unix ends.

Ideally the zipping tool can be called by RPG & Cobol

In Unix, we can 'pipe' data stream directly into a zip; would be good
to have this feature for the AS400 tool.  

Also, we have tons of logs (eg: audit trails) taking up valuable space
in AS400 so this zipping can hopefully reduce the size of these
0
I'm totally confused, nowhere I'm getting proper information about how to start programming in AS/400.
What are the software & hardware requirements of AS/400? What should I know about AS/400 to become a programmer in that?
How can I do JAVA, C, C++, C#, .net programs using AS/400, or is there any other way?

I will be pleased, if anyone could provide a detailed information.
0
I have tried to stop it, recreate it, but it will not let me end journal or change journal.  I keep reading but cannot find anything.  Any idea's out there?
0
i wish to know how to check a list of programs linked to file.
if i use hawkeye then need to put library otherwise in (*all) it runs in batch ( dumps out )which is quite longer time .pls tell me.
0
Hi ,

I have some question regarding ICF file and its uses in AS400 RPGLE . It would be great help if someone explain me as I am beginner in this area.

1) How can I write source code of ICF File ( Please share file structure, if possible).

2) Is there any way to check , insert or delete data in ICF file as SQL and runqry does not work on ICF File.

3) How can I unit test my program or how to prepare dummy data in ICF file.

It would be great help.


Thanks
0
i'm trying to run net use from as400 through clp or command line to map drive on user pc but not working, anybody can advise.
here some example i tried not working but from command dos no problem

STRPCCMD PCCMD('start net use V:  //AS400system/sharename +
             /USER:xxxxxx xxxxxxxxxx /PERSISTENT:no')

STRPCCMD PCCMD('net use' V:  //AS400system/sharename +
             /USER:xxxxxx xxxxxxxxxx /PERSISTENT:no')

STRPCCMD PCCMD('net use' V:  //AS400system/sharename')
0
There's concerns that trojanized USB sticks are shipped with the following 2 servers below.
What are the best practices if the USB ports can't be disabled?    Physically block the ports,
use specific encrypted USB thumbdrives that doesn't require drivers (saw one such EE link)
or ??  Kindly provide risk assessments & any other mitigations.

Below is the response from the vendor:

For HMC Servers :
For HMC server (7042-CR6), it's likely that the HMC server's BIOS does not have the option to disable the USB ports.

For P750 Servers :
With reference to the P750 model server (8408-E8D), there are a total of 4 x USB ports, which are integrated with the different hardware components (cards & control panel) of the server.   Below are the details:


1. Control Panel                        
-- 1 x USB port integrated. No option to disable as it's build in together with the control panel.

2. Service Processor Card        
-- 1 x USB port integrated. This USB port is used for server firmware upgrade purpose for server that are not managed by any HMC. Thus it's build in together with service processor and no option to disable.

3. Integrated Multifunction Card (an integrated card that is install in the System CEC that provides two USB ports, one serial port, and four ethernet connectors)
-- 2 x USB ports integrated. This card is not assigned to any of the partition's profile, thus it's not recognized as part of the partition's hardware config. As such, it is not …
0
How do I change the default view from the WRKOUTQ command to get the view 2 details displayed straightaway, instead of having to press F11?

We just did an upgrade and for the life of me I can't remember where/how to change this. (release V7R3)

Thank you in advance!
Lynn
0
I'm used strpccmd to het the pcname and pcuser used for login to as/400
Everything is okay Except one thing
For each time I runs the cl login windows for as/400 requested to enter the username and password for as/400
The question
How i can avoid the login screen?
There is Any chance to use the user name with strpccmd
0
We have our server connected to our I-series (5.4) the other day it dropped our server information.  QNTC/AACFILE01/AS400  Where the AS400 is our folder/share.  The AS400 dropped and when we try and put it back we get an error stating the system failed due to an unknown error.  I cannot find why it dropped or why I cannot reconnect it.  PS. they dropped IBM support several years ago.  Yea....

CPE3474 "Unknown System State"

Also, when I place a 5 on AACFILE01(our server name) the next screen is blank.  Via WRKLNK /
0
We have a remote system running V5R4 and our current server is running v7r2.  

We have a remote location entry setup for the old machine it works with TELNET.  I can access using 'TELNET OLDSYS' but I'm not able to do as savrstlib to 'OLDSYS'  error:

Route to specified location not found.              
An error occurred during the SAVRSTLIB operation.  

spelling is correct.  If telnet works should savrstlib work?

Thank You!!!!
0
I have set up QNTC on my IBM i (AS400) and am able to see our network document server ("SERVER-A").  We have set up a second server ("SERVER-B").  

I can see SERVER-A and SERVER-B from QNTC (WRKLNK), but when i try to drill down, i can't see any folders on SERVER-B. I get a message "Error exchanging security information".  My userid and password are the same on both machines, all uppercase on both.  I can see everything on SERVER-A just fine, i can write to it, copy files, delete files, etc.

In Windows explorer i can create a mapped driver to SERVER-A and see everything below it, and I can create a mapped drive to SERVER-B and see everything, move, copy, delete, etc.
0
I have an iSeries PF file containing several records.  In order for the individual records to be imported into an imaging system, I need to be able to output each individual record to a file and then download the file either to a pdf or Excel format.  The file name for each record needs to contain it's key structure.  Is there a way to do this?
0
Hi,

Can we have CDC data mirroring between 2 different version servers.
Example a table is in V5R3 and we create the same table in V7R2 and we would like to have the data replicated from V5R3 to V7R2.

Is this possible. Do you see any issues.

Thanks
Chaitu
0
HI,

We run BRMS nightly. Last night the tape failed. The snapshot was created. Is there a way to push this snapshot to tape so we don’t lose a backup?

Thank You,
Lynn
0

IBM System i

IBM i, formerly known as AS/400, is a proprietary, midrange, object-based operating and application system. It includes a relational database, a menu-driven interface, support for multiple users, block-oriented terminal support and printers, and supports security, communications, and web-based application servers including Websphere, Apache and Tomcat.

Top Experts In
IBM System i
<
Monthly
>