Linux Distributions





A Linux distribution is an operating system made as a software collection based on the Linux kernel and, often, on a package management system and are available for a variety of systems. A typical Linux distribution comprises a Linux kernel, GNU tools and libraries, additional software, documentation, a window system (the most common being the X Window System), a window manager, and a desktop environment. Most Linux systems are open-source software made available both as compiled binaries and in source code form, allowing modifications to the original software. Over three hundred distributions are in active development, including commercially backed distributions (such as Fedora, openSUSE and Ubuntu) and community-driven distributions (such as Debian, Slackware, Gentoo and Arch Linux).

Share tech news, updates, or what's on your mind.

Sign up to Post

I am running wordpress 5.1.1 and WooCommerce 3.6.1 on a LInux 2 Amazon instance and I had a message that my db needed to be updated for WooCommerce. I opted to begin the process and this message popped up.

WooCommerce database update – WooCommerce is updating the database in the background. The database update process may take a little while, so please be patient. 

Open in new window

This message has been up for 24 hours now and I have a small store of 1400 sku's.

I have attempted the following:
1. restarted maria
2.  deactivated and activated woocommerce
3. checked the memory in wp-config which is set at 1024 MB
4. restarted Apache

How can I get rid of this message?  If the message isn't a problem how can I be assured the db integrity is intact?

CompTIA Security+
LVL 13
CompTIA Security+

Learn the essential functions of CompTIA Security+, which establishes the core knowledge required of any cybersecurity role and leads professionals into intermediate-level cybersecurity jobs.

i have a text  file. it looks like:
person's name. ......................text....................................
person's name. ......................text....................................
person's name. ......................text....................................
person's name. ......................text....................................
person's name. ......................text....................................
person's name. ......................text....................................
person's name. ......................text....................................


how do i open the file of names of people in a cemetery and return the text that goes with  ONLY that name in perl?
the file is a list of about 3000 people and the text is when they died and where they are buried.  any language will do
this but i'm trying to learn perl in ubuntu.
I'm running a Samba Active Directory domain with Ubuntu 18.04 clients.

I used the This Guide  to map local groups to domain users. It involved editing the following files...

    root@testpc:~# cat /etc/security/group.conf | sed '/^#/d'


Open in new window

    root@testpc:~# cat /usr/share/pam-configs/my_groups
    Name: activate /etc/security/group.conf
    Default: yes
    Priority: 900
    Auth-Type: Primary
            required               use_first_pass

Open in new window

    root@testpc:~# DEBIAN_FRONTEND=noninteractive pam-auth-update
    (I.e. no error...)

Open in new window

It seems to only work when I ssh as a domain user, but not when I  su - user  or do a local login (even though the local login is via the domain).
I.e. If I login via ssh as the user, the dialout group appears fine...

    rightmire@localPC:~$ ssh rightmire@remotePC
    Welcome to Ubuntu 18.04.2 LTS (GNU/Linux 4.15.0-46-generic x86_64)


    68 packages can be updated.
    43 updates are security updates.

    rightmire@remotePC:~$ groups
    domain users dialout master BUILTIN+users 

Open in new window

But if I su - rightmire, it does not appear...
    root@remotePC:~# su - rightmire
    rightmire@remotePC:~$ groups
    domain users master BUILTIN+users domain admins denied rodc password replication group staff konstrukteure vicongroup h2t rightmire

Open in new window

...AND users who login locally, but are still logging in as a domain user, and not being added to the group.

I have been running Ubuntu 14 with custom tcp tuning parameters for a couple years.  I applied, via puppet, all of the same tuning parameters, but on Ubuntu 18, my TCP Time Wait is very high.  What is the best method of finding the source of this high TCP Time Wait?  The process that is using the tcp connections is a java application.

Please let me know any other information I should provide.

Graph on the left is Ubuntu 18.04, right is Ubuntu 14.04

Thank you,


  compiling xerces on solaris box.
  /usr/lib/sparcv9/ and /usr/lib/64 have libicu*54.  
  In another location, /icu_needs_to_build_with/libicu*44.
  Whenver I compile, it's always picking libicu*54 version. I do want to build xerces with libicu*44 libraries.
  Do we have any flags like LDFLAGS or xyz to configure specific version shared libs?
coreos on xcp-ng failed:
i try to xscontainer-prepare-vm -v UUID -u core
Traceback (most recent call last):
  File "/usr/bin/xscontainer-prepare-vm", line 272, in <module>
  File "/usr/bin/xscontainer-prepare-vm", line 246, in main
    resultcode = _handle_ssh(session, options)
  File "/usr/bin/xscontainer-prepare-vm", line 139, in _handle_ssh
    resultcode = push_ssh_key(session, options.vmuuid, options.username)
  File "/usr/bin/xscontainer-prepare-vm", line 80, in push_ssh_key
AttributeError: 'module' object has no attribute 'ERROR_CAUSE_NETWORK'
I have just recently installed Ubuntu Desktop 18.10 on my old iMac, which I'm running at a remote location. All is working great, except I'm unable to get the VPN L2TP based client to connect successfully back to my Windows 2012 Server at home. This is a VPN server I know to be working fine, as am able to connect to no problem from both Windows 10 and MacOS integrated VPN clients.

In this configuration I'm using a pre-shared key, as well as the AD user credentials when logging-in to the L2TP VPN. On Ubuntu, I suspect the Phase1 and Phase2 algorithms need setting in the Advanced section of the IPSec options, but everything I've tried to enter here has bought no joy.

Does anyone have any thoughts on what I might need to enter here? I ran "sudo ike-scan" on the terminal command line, and in amongst various details it returned the following IKE details of my L2TP server:

"SA=(Enc=3DES Hash=SHA1 Group=2:modp1024 Auth=PSK"

As some have suggested, I've set variations of these details in the Phase1 and Phase2 algorithm boxes to no avail.

If anyone has any thoughts on how this might be resolved, I'd be grateful to hear them.

Many thanks :-)

Referring to above URL, I only see the harden_CentOS7  script but
not the two Debian & Alpine Linux: did I miss something or can
anyone point me to the right URLs to get the scripts?
I had boot menu options for Windows 7 and 10 on my windows laptop
However after installing Ubuntu and PrimeOS , I lost all the boot entries.

Even though Windows 7 and 10 are showing up, Windows 10 does not boot and comes with error message. Only Windows 7 boots up.  There are no entries for Ubuntu and PrimeOS.  When I installed Prime OS . It was multibooting fine., but after installing ubuntu I could get the boot menu to load to load win10, prime os and ubuntu.

How do I edit the bcd file to add Ubuntu and PrimeOS and restore win10 boot.

I need 4 entries in the boot menu now .  1) Windows 7  (2) Windows 10  (3) PrimeOS (android)   (4) Ubuntu
Audit has raised to harden middlewares & CIS doesn't have many (other than Tomcat)
while we have the following (refer to attached Excel for details) :
Jas service

Can point me to among the better sites for hardenings of above & ideally scripts that could be readily run.

Also, whereabout can we obtain patches for the above opensource middlewares?
OWASP: Avoiding Hacker Tricks
LVL 13
OWASP: Avoiding Hacker Tricks

Learn to build secure applications from the mindset of the hacker and avoid being exploited.


I am one of the network admins of a business complex, containing several different companies.
To handle internet for every company, we have an Ubuntu machine acting as a gateway.
There's several static. public ip-adresses, and several dhcp-networks, all being handled by this gateway(it acts as dhcp too)

What I need is something to monitor network traffic flowing through the gateway.   I've tried with NTOP, but I haven't been able to get the data I need, or, atleast, I don't understand how I'm supposed to. i've been looking in a graphical interface for it.

What i would like to be able to see, if possible, is what VLAN or what IP, be it static or set by the dhcp server on the gateway, is accessing what. If it's possible to get the type of traffic on that specific VLAN or IP, and even if there's possible to see what IP-address that specific host has.
It would be great if there's an interface for it accessible through http/s.

I've been looking some at munin, and nagios, but haven't really found out if this can do what I need.

Any tips?
So far the one most seem to suggest when I've googled is Ntop. but I can't seem to get the data broken down into VLAN level or something similar. I might have missed something in the configuration, but...

So if anyone have any tips or good sites with documentation to set up what i need to do, it would be very appreciated.

Thank you

We are trying to create two generic ID files in Domino admin for registering person docs (Registering New users) and re-certify user certificates which are expired. Current issue is we when we create a new person document with ID file and grant access to Admin server and try creating a new lotus domino account, we are unable to view list of certifiers to select.

When we try to modify recovery authorities but it fails and does not resolve the current issue, When we try to Modify certifiers and try to remove administrators its giving an error  “Cannot locate user certificate. Make sure server contains your certificate for encryption”. I also tried copying the person document of that administrator back into their directory and followed the same steps which did not help me.

Can any one help me at the earliest as its very important to us?2019-03-28-09_35_36-2019-02-10-10_46.png
I set up a Linux server (Ubuntu 18.10) for simple file sharing on our Windows network. The server is a Dell PowerEdge T30. It has an onboard NIC. I had given the server a static IP address and it was serving its purpose as desired for at least 2 weeks.

Last night I was testing a different (Windows) hard drive in the box, without the network cable plugged in. When I was done, I put the Ubuntu hard drive and network cable back in and rebooted the computer. When a message came up about software updates, I accepted the updates and rebooted again. When it came back up, it looked fine to me - though admittedly, I wasn't looking at it very closely.

This morning the server was not connected to the network. The network icon did not appear in the upper right corner of the screen and there was no option for the wired network in the Network control panel.  When I ran lshw -C network, it said *-network DISABLED. When I entered sudo ifconfig <adapter> up, I was able to get the network connected again and join the server to the Windows domain... until I rebooted the server again, and the connection was gone again.

I also set up a separate, old Dell Optiplex 760 with the same version of Ubuntu. I do not believe I set it up to automatically update, and hadn't touched it for about a week. It too had dropped its wired network connection. My boss and I were discussing whether we should just get another network card for the server until we noticed that the other computer's network …

I am running Debian 9 on Server 2012 R2 Hyper-V. The scnario is that I have 2 physical servers each with a Debian virtual machine.

A) Setup Hyper-v for mirroring

1) The goal is to capture packets so Hyper-v on both is set in monitoring mode.

2) Once the "Destination" settings under the virtual machine network adapter for mirroring is set in the Hyper-v configuration.
I immediately notice that the physical network interface on the server (for the Hyper-v virtual switch) starts increasing rapidly say 70 Mb/s ON BOTH Servers...
 this is good it means that the Hyper-v settings are sane (and of course the Network Configuration on the switch is perfect).

B) Setup Debian for promiscuous mode

1) Here I use:

allow-hotplug eth1
               iface eth1 inet manual
               up ifconfig eth1 promisc up
              down ifconfig eth1 promisc down

Open in new window

and verify with ifconfig as shown below

Debian VM1 on Server1
        ether 00:15:5d:15:16:17  txqueuelen 1000  (Ethernet)
        RX packets 5090918  bytes 3090553169 (2.8 GiB)
        RX errors 0  dropped 6  overruns 0  frame 0
        TX packets 89  bytes 7638 (7.4 KiB)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

Debian VM2 on Server2
        ether 00:15:5d:15:16:17  txqueuelen 1000  (Ethernet)
        RX packets 42094  

Open in new window

I am running nginx on Ubuntu server 16.04LTS

I am trying to configure

During the install, this error appears when  I use this config

server {
    # Listening port and host address
    listen 80;
    server_name inventory.techpress.internal;

    # Default index pages
    index app.php index.html

    # Default character set
    charset utf-8;

    # Turn off access.log writes
    access_log off;
    log_not_found off;

    # Send file is an optimization, but does not work
    # across unix sockets which I use for php fpm so is best
    # used for local static content onlya 
    sendfile off;

    # Root for / project
    root /var/www/html/inventory.techpress.internal/web/;

    # Setup rewrite helper
    rewrite ^/setup/webserver-test$ /setup/tests/webservercheck.json;

    # Handle main / location to symfony app.php controller
    location / {
        try_files $uri $uri/ /app.php?$query_string;

    # Handle /setup location to symfony setup.php controller
    location /setup {
        try_files $uri $uri/ /setup.php?$query_string;

    # Handle all locations *.php files via PHP-FPM unix socket
    location ~ \.php$ {
        fastcgi_split_path_info ^(.+\.php)(/.+)$;
        #fastcgi_pass unix:/var/run/php5-fpm.sock;
        fastcgi_pass unix://var/run/php/php7.0-fpm.sock;
        fastcgi_index index.php;
        include fastcgi_params;
        fastcgi_param SCRIPT_FILENAME 

Open in new window

  • IBM Power9/PowerVM LPARs
  • Intel x86_64/vSphere 6.7 VMs (using EFI)
  • SuSE Manager (SUMA) 3.2
  • SLES 15

I'm attempting to create a build infrastructure for both PPC LPARs and x86 VMs using a single SUMA.

By following the SuSE Documentation for Deploying SLES on Power, I am able to build SLES 15 on Power9/PowerVM LPARs.

My problem now is getting the same infrastructure to also build SLES 15 on x86_64/vSphere VMs.

I am able to build SLES 15 on the VMs using the ISOs - so there is nothing intrinsically wrong with the VMware environment. I also was able to produce an AutoYaST profile from an install.

The DHCP server on SUMA correctly identifies the VMs and assigns an IP address from the proper range, and also properly directs the VM to load the grub.efi file. Watching via WireShark, I see the VM successfully transfer the file using TFTP.

And then nothing happens.....

If I boot the VM into the boot selection screen and manually initiate the PXE boot via a network interface, it gets the file and cycles back to the boot selection screen. Lather, rinse, repeat. I never get a GRUB menu, the installer never starts, nothing.

Looking at the docs I linked above, there is some custom GRUB configuration and a special Cobbler …
I am trying to write a microservice that writes the SD card on dell edge box 3001 so the data can be saved directly to the SD card.
any ideas how can I achieve this.
Thanks in advance.
im using debian, ubuntu, linux, mint, ext4 if that specific info helps

when saving a file from within notepad ap or from within the libreoffice word processor ap the exact same message box appears when saving to a file name that already exists.....  it warns that the file already exists and asks if one wishes to cancel or overwrite.....   does this identical message box originate from the application or the OS?   and is the fact that the file already exists determined within the ap or is the message box generated by info passed between the ap and the OS

rename fails when renaming to a filename that already exists but mv and cp overwrite with no warnings.....
New ubuntu 18.04 server build. Running zfs for datastorage for backup. Receiving Errors about ata2.00 failed command: WRITE FPDMA QUEUED.

Please see attached screen shot.

What does this mean? Are my drives going bad? or is it a motherboard issue?

Any guidance would be appreciated.
Amazon Web Services
LVL 13
Amazon Web Services

Are you thinking about creating an Amazon Web Services account for your business? Not sure where to start? In this course you’ll get an overview of the history of AWS and take a tour of their user interface.

I have OpnSense (Another version of Pf Sense) Firewall installed. I can not get out to the Internet on my second, 3th, 4th LAN ports.
I have an OpnSense Firewall PC box I made which has the following inside…
OpnSense 18 (latest version) 
-G.SKILL Ripjaws V Series 16GB (2 x 8GB) 288-Pin DDR4 SDRAM DDR4 2400 (PC4 19200) Desktop Memory Model F4-2400C15D-16GVB
-King Spec SATA III 3.0 2.5" 60GB MLC Digital SSD Solid State Drive for PC B5Y1
-AMD Athlon 200GE 2-Core, 4-Thread, 3.2 GHz Base, Socket AM4 35W YD200GC6FBBOX Desktop Processor
-ASRock A320M-HDV AM4 AMD A320 SATA 6Gb/s USB 3.0 HDMI Micro ATX AMD Motherboard
-80 plus bronze certified power supply 380Watt
-Dell Intel PRO/1000 VT Quad-Port Gigabit Ethernet Card Standard Profile YT674
-IOCrest 4 Port Gigabit Ethernet PCI-e x1 Network Interface Card SI-PEX24042
This is inside a 4U server Case, inside an APC 48U Server Rack

My goals are the following...

-      I want to one 4 Port NIC using different IP Addresses such as --- Web server Network Entertainment Network Work Network --- Web server Network
I already setup these networks inside my box but I am willing to START from the beginning if you need me too.

-      I want the networks not to be able to talk to each other.
-      I have 5 block of Public static IPs which I want to use.
-      104.XX.xx.1--- This is assigned to the OpnSense itself
-      104.xx.xx.1 talks to …
I am trying to read a stored text file on SD card and this card is on  dell 3001 edge box with ubuntu core 16.04, I have tried to mount the SD card but I can not see the text file to edit or read the contents.
Thanks in advance
where is the logs files are stored in the snap that runs on edge boxes with ubuntu core 16.04
Thanks  in advance
Hello Experts,

I am a novice in Linux and having to try to enable the SSO ( Single Sign-on) for a website built on Ubuntu using apache2 web server. We basically wanted to have authentication in place for anybody connecting to that website and I enabled LDAP auth and it's working fine. But the client needs Sigle Sign on so that staff need not to manually authenticate using their AD credentials when accessing the website.  I have gone through online documentation, and its confusing what all i need to change in the existing config and install the new stuff. If any one can help/guide me in the right process. It would be of great help.

Thanks a lot in advance.
I am running Node.js app to check for connectivity and reboot if the timer reaches 0, and I am logging the status on a log file but when I run this code as a snap on ubuntu core, I can not find where the log files are in snap.
here is my code:
#!/usr/bin/env node
const moment = require('moment');
const shutdown = require('electron-shutdown-command');
const electron = require('electron');

const fs = require('fs');

let counter = 0;

function checkInternet(cb) {
    require('dns').lookup('',function(err) {
        if (err && err.code ===  "ENOTFOUND") {
        } else {
    }); }, 30000);

function rebootEdgeBox(){
    console.log('Shutting down now');

checkInternet(function (isConnected) {
        if (isConnected) {
             counter =0;
        } else {

            const timeStamp = moment().format('YYYY-MM-DD, HH:mm:ss');
            const status = 'Disconnected at ' + timeStamp;
            counter += 1;
            if (counter === 10){
                counter = 0;



function vortexLog(string) {
    fs.appendFile('./Logs/connectionLog', string + "\r\n", function (err) {
        if (err) throw …
I have a newly configured, headless, Ubuntu 18.04 dedicated server on a hosting company, so it's not a local server.

The problem is that while I am connected and doing something on the server using SSH, running top, transferring a file, etc, I get disconnected and cannot connect again. I have to reboot the server to do so.

The hosting company says the server is configured to have power saving mode turned on, and it goes into power saving mode.

I find it weird because:
1. I never had encountered a server OS with power saving mode turned on, because, well, it's a server
2. Even it it was turned on, it should not kick in while it's in use. At lease that's how I understand how it should work
3. The server is almost 2 months old, and we only encountered this issue twice. Had it been on all the time, it would have been a constant problem since day 1

So my question is, how do I check that power saving mode is on, and how do I turn it off? I've read some articles in other sites, but I'd rather have the answers here.

Thanks in advance!

Linux Distributions





A Linux distribution is an operating system made as a software collection based on the Linux kernel and, often, on a package management system and are available for a variety of systems. A typical Linux distribution comprises a Linux kernel, GNU tools and libraries, additional software, documentation, a window system (the most common being the X Window System), a window manager, and a desktop environment. Most Linux systems are open-source software made available both as compiled binaries and in source code form, allowing modifications to the original software. Over three hundred distributions are in active development, including commercially backed distributions (such as Fedora, openSUSE and Ubuntu) and community-driven distributions (such as Debian, Slackware, Gentoo and Arch Linux).