Linux Networking

18K

Solutions

15K

Contributors

The variety of Linux distributions creates myriad issues relating to configuration and operations when computers are networked, not the least of which is the use of various network management applications, some of which are included with specific distributions, while others are standalone applications.

Share tech news, updates, or what's on your mind.

Sign up to Post

what are the best ways to migrate or move Zimbra 8.6 on RedHat Linux 6.6 to Zimbra 8.8

current usage: authentication is LDAP, cbpolicyD,fail2ban, spamfiltering is in cloud level

it is possible to install a latest version of CentOS. but what is the best choice? CentOS or Ubuntu ?

thanks,
0
I have a NAS server that I recently have lost the ability to access using the IP address. When an attempt to access I receive an Access Denied error. Below is what I have checked and the results.

  • I have verified that account credentials are correct.
  • I have verified that the account permissions are correct to access the share.
  • I am able to ping the device from any other device in the network.
  • I am able to access the SMB share using the Hostname and the FQDN with the same account credentials mention above but not the IP address.
  • I have verified that the IP address is not assigned to any other device on the network.
  • I have verified that the ARP table correctly associates the IP address to the correct MAC address. (However after a packet capture when the device attempts to authenticate with the SMB share it gets a response from a different MAC address which I can not locate anywhere on the network.)
  • I have verified that NTLM is not disabled on the device or in GPO.

I have reached out to the manufacturer (Panzura) and they said after reviewing the packet capture and all the items above they believe that it is a network issue. At this point, I have run out of ideas of what to do next. The manufacturer suggested changing the IP address, however, I would like to reserve that as a last resort.
0
no one in ubuntu 16.04 can change password. permission deni...
and new user (sudo adduser (not permission to give a password).
0
how to import sessions from putty or mputty to securecrt.
https://www.vandyke.com/products/securecrt/

I recently installed securecrt not sure how to import all existing conections to different servers on different environments that are present in putty to winscp.

any tips on effective use of securecrt as i am new to it

Please advise
0
Hello Experts,

I have a DELL server that I am going to mirror a couple of hard drives. It needs to become a file server.

My question is, is there a NAS software I could install on it and make it NAS server?

Software like FreeNAS or OpenFile. I will like the software to be free or otherwise, I will use a Linux server like CentOS 7 or Ubuntu.

If that is the case configuring Samba will be enough? Recommendation needed, please.

Thank you!
0
Hello everyone!. Perhaps somebody could help me. I am trying to configure firewallD (Centos 7) so public network only has access to http and https services but my trusted networks to ssh, webmin, http, https, etc...
Btw I have only 1 interface.

I need to achieve something like this:

PUBLIC ZONE:
-source: 0.0.0.0
-interface: eth0
-allowed services: http, https

TRUSTED ZONE:
-source: 192.168.10.0/24
-interface: eth0
-allowed services: http, https, ssh
-allowed ports: 10000

Ho can I do it?
0
What is the process needed to get the AWS KVM and ZEN drivers loaded in a VMWare Ubuntu 18.04 LTS System before we use the AWS migration tool to put in on an AWS Instance ?  I’m specifically needing what and how to preload the drtivers etc.
0
dhcpconfiguration.txt
Dear Experts

We have a network of less than 15 systems with 2 broadband connections from 2 different ISP's.
1. ISP1 in their provided router configured the network of 192.168.1.0/24 and their provided router ip 192.168.1.17 and function's as DHCP server in the LAN
2.. similarly ISP 2 also configured in their provided router with network of 192.168.1.0/24 and their provided router ip 192.168.1.1 and this also funcationing as DHCP server in the LAN.2
Both the routers of both ISP's are connected to the same switch at the present I have turned off ISP 2 router to avoid 2 DHCP in the LAN.
3. have linux server working as internal private DNS
As per the experts exchange experts advice I am in process of procuring the router with 2WAN port so that each one of the ISP will be connected to one of the WAN port and will stop DHCP service on the router level and will configure DHCP server in linux server. I would like to divide the network of 192.168.1.0/24 to 4 subnets, as following
a)192.168.1.0  of ip range 1 to 62
b)192.168.1.64 of ip range 65 to 126
c)192.168.1.128 of ip range 128 to 190
d) 192.168.1.192 of ip range from 193 to 254

attached DHCP configuration, request to please review the defined 2 subnets statements in the config
Soution design and suggestion for the below please:
in this dhcp server the defined 2 subnets i,e access point-1 to one of the subnet of above a) i,e 192.168.1.0  of ip range 1 to 62 and access point-2 to another …
1
i try to mount synology nas drev on ubuntu but in different ip rang
nas has nfs support and permission
i say
sudo mont 12.11.1.5/volume1/backup /mnt/backup/

my ubuntu har 12.10.1.8
i get connection timeout
amd with smb connection
sudo mount -t  cifs //12.11.1.5/volume1/backup /mnt/backup user=Administrator
get mount error(115) Operation now in progress
0
Dear Experts

We are in process of setting up very small IT infra where local dns (private dns server) be done on ubuntu server16.4.4.  We will be hosting web based application server in on-premise and for the internet we have 2 service providers  both are of different,
1.  ISP 1 provided device enabled with the dhcp service for the network and it is ON with the subnet of 192.168.1.0/24  this is more stable connection
2. ISP2 also provided device and enabled with DHCP service for the network and they are asking to turn it ON -
purpose of 2 service provider is to have backup when one is down operation can happen with other service provider
As of now I have not yet turned ISP-2 modem/router ON as this will also function as DHCP server and in a network 2 DHCP server cannot be enabled.
Please suggest the best practice
1. Should I have to ask ISP-2 to configure for different subnet like 192.168.70.0/24 and configure one DHCP server in linux server define 2 subnets here and stop both service providers ISP-1 and ISP-2 modem/router DHCP service but when the clients systems boot which subnet to be released as ISP-1 may be down and but the DHCP server release the IP of subnet ISP-1 , how to switch here to another subnet - NOT sure if this is good way to go with please suggest
2. stop dhcp service of ISP-1 and ISP-2 devices and configure dhcp server in linux but with one subnet only but segment the ip range for ISP-1  router and gateway sections pointing to ISP-1 in dhcp …
0
Would anyone know if there is an open source firmware like WRT or Tomato that will work in a Netgear FVS318N? I have a number of these and would like to use OpenVPN but am limited by the Netgear firmware among other limitations. It would be great to have the robustness of WRT or Tomato on one of these.
Any thoughts?
0
Hi

I have run the command Get-SmbConnection in Powershell and I see that one of the Linux fileshares presented is showing dialect 1.5

My question is if I change the smb.conf for that server, adding protocol = SMB2 - will that 'break' the existing file share using SMB1?

Many thanks

Jason
0
on my windows 10 machine after installing oracle virtua box and centos on top of it while starting getting below error


Failed to open a session for the virtual machine centos.

The virtual machine 'centos' has terminated unexpectedly during startup with exit code 1 (0x1).  More details may be available in 'C:\Users\saiganesh\VirtualBox VMs\centos\Logs\VBoxHardening.log'.

Result Code: E_FAIL (0x80004005)
Component: MachineWrap
Interface: IMachine {b2547866-a0a1-4391-8b86-6952d82efaa0}

i tried on other laptop i do not see red hat 64 some reason but shows red hat 32 bit

Please advise
centos.png
centos.png
0
how to remember shell history and how to save unix queries for future use and share with the team

$HISTSIZE can be increased to unlimited size?

how to type attached l character

please advise
L_char.png
0
how below commands are different

su department (when i do pwd here says department)
vs
su - department(when i do pwd here says /home/department)

when i do below

su -c 'echo $echo  $DEPARTMENT_HOME' department
it does not work

when i do below

su -c 'echo $echo  $DEPARTMENT_HOME'  - department
it does work. Please advise the difference.

what is difference between
department and  /home/department

how su and sudo are different?

how can there is depearment inside home as well as outside at top level again?

what is visudo and sudoers file or folder?

Please advise
0
difference between below process killing signals

kill -15 123

vs

kill -TERM 123
vs

kill -9 123


how foreground and background processes are different and how to kill or suspend them?
is PID is always 4 digit or it can be 10 digit etc?

how job and process different?
how to distinguish between background and foreground jobs?

when i say
jobs

it simply shows 5 different jobs one with + other with -

but does not show whether background or foreground?

i have a job running in background i brought it to foreground and stopped it.
when i moved it again to background it automatically moved to RUNNING status? how this is possible?
how terminated suspended and killed etc are different?
Please advise
0
how to connect to samba ad via phpldap?
I have a samba 4 active directory in ubuntu and open ldap (slapd) is running. How to connect  open ldap to ad.
i connect to open ldap via phpldapadmin on port 1389.
0
i can't connect to openldap from webmin,
Failed to create new tree : The password in the LDAP server configuration is encrypted and cannot be used by Webmin
0
I have samba 4.x.x ad on ubuntu server 16.04.
I want to create 2 way identification.
then when user logon to domain get sms on mobil. is there any open software to this issue. (not google identificatio, this is only for ssh).
0
Hi,

I am seeing a lot of collisions and errors on a WAN port (Sophos SG210) which connects to fiber NTU ( Cisco ME 3400E)

This is 100Mb up/down fiber but I am getting around 60Mb download and 3Mb upload. I think the cause of the slow upload speed is because of the packet collisions and errors.

I get around 70Mb/70Mb when I connect my laptop directly to the NTP.

What would be the cause of the problem?

Here is ifconfig on the WAN link on SG210.

eth1   Link encap:Ethernet HWaddr xx:xx:xx:xx:xx:xx
          inet addr:110.xxx.xxx.xxx Bcast:110.xxx.xxx.xxx Mask:255.255.255.252
          UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
          RX packets:373271 errors:0 dropped:0 overruns:0 frame:0
          TX packets:220080 errors:2306 dropped:0 overruns:0 carrier:2306
          collisions:128842 txqueuelen:1000
          RX bytes:527821557 (503.3 Mb) TX bytes:48346583 (46.1 Mb)

 ethtool eth1
Settings for eth1:
        Supported ports: [ TP ]
        Supported link modes: 10baseT/Half 10baseT/Full
                                100baseT/Half 100baseT/Full
                                1000baseT/Full
        Supported pause frame use: Symmetric
        Supports auto-negotiation: Yes
        Advertised link modes: 10baseT/Half 10baseT/Full
                                100baseT/Half 100baseT/Full
                                1000baseT/Full
        Advertised pause frame use: Symmetric
        Advertised auto-negotiation: Yes
        …
0
If you have two accounts in AWS with one linux host in each - what options do you have to copy files (sftp) between the two hosts?
What would be the options? What would be the fastest? The least costly?
0
Individual log  files on my server getting zipped every 1 hour and individual log files getting deleted.

PRoblems i am facing with zipped log files are
1. not able to grep them as easily as individual files

2. not able to tail to see any recent issues



if i copy over to local windows laptop using winscp and unzil anf try to open individual file using notepadd++ says too huge file to open.


how to extract zip file in unix box itself and check log files by doing grep and tail etc

please advise
0
General concept of openVPN solution for private network. I'm thinking about layer2 bridging mode but... I have one VPS server with Ubuntu 16.04LTS, one local network and two mobile pcs. Starting from server - there is one Ethernet controller with public static IP address. I want to connect to them from 3 places. Should I create 3 TAP interfaces? What about the bridge - bridging eth with TAP(s) or only TAPs from network for example 192.168.2.0/24. Next computer is PC in local network also with one Ethernet controller with address from network 192.168.2.0/24 and Gateway 192.168.2.1. Additionaly two laptops with two network cards, one used for internet access with local address from network 192.168.2.0/24. Have I config TAP and bridge with network card unused or used to connect to internet (WLAN + home WiFi router). I would like to see every computer like in local network, use configured in local network DHCP, DNS (not obliogatory - can be static), used sharing folders, printers, active directory, connect to domain, use DFS. When I trying TUN IP packet routing i probably had wrong configuration but forcing DNS from VPN was disconnecting me from DFS service.
Any help please - routing or bridging and config of TUN/TAPs interfaces with ethernets and Bridges.

Thank You

Paweł
0
Hi Team,

I need an help , I have RHEL 6.5 installed on my machine . Its a dual boot. Iam unable to connect to the network.
When I type ifconfig I get two entries
lo Link encap:local loopback
inet addr:127.0.0.1 Mask:255.0.0.0
inet6 addr: ::1/128 Scope:Host

virbr0 Link encap:Ethernet Haddr 52:54:00:4C:9B:91
inet addr:192.168.122.1 Bcast:192.168.122.255 Mask:255.255.255.0
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1

How can I map the virbr0 to etho  and connect to the network
IMG_20180418_185501.jpg
0
anyone get vncviewer connecting to an ubuntu 16.04 instance?
i have remote connections enabled but vncviewer (6.17.1113) on windows 10 keeps saying it can't connect with the chosen security setting and to either upgrade vnc server or select weaker encryption.
I already did gsettings set org.gnome.Vino require-encryption false but made no difference
tried every encryption setting in the vnc connection
0

Linux Networking

18K

Solutions

15K

Contributors

The variety of Linux distributions creates myriad issues relating to configuration and operations when computers are networked, not the least of which is the use of various network management applications, some of which are included with specific distributions, while others are standalone applications.

Top Experts In
Linux Networking
<
Monthly
>