Linux Networking

18K

Solutions

15K

Contributors

The variety of Linux distributions creates myriad issues relating to configuration and operations when computers are networked, not the least of which is the use of various network management applications, some of which are included with specific distributions, while others are standalone applications.

Share tech news, updates, or what's on your mind.

Sign up to Post

I am trying to delete something from iptables in bash script.

Trying to delete port 5666 from iptable.

Below command will grep for the line number to delete.
iptables -L INPUT --line-numbers | grep -oP "([0-9]{1,3}).*tcp.*5666" | cut -d" " -f1
6
Here the command to delete it.
iptables -D INPUT 6

#!/bin/bash
iptables -L INPUT --line-numbers | grep -oP "([0-9]{1,3}).*tcp.*5666" | cut -d" " -f1
read a;
iptables -D INPUT $a
service iptables save
0
Hello,

I have a minimal install of CentO 6.4 x64 and it doesn't appear that the xfs font service is running by default. (unlike past releases of CentOS) If I run:

find /lib/modules -name xfs.ko -type f

I get;      /lib/modules/2.6.32-358.el6.x86_64/kernel/fs/xfs/xfs.ko

so I see the kernel object, I am just not sure how to launch it. If I try and run  "service xfs start", it returns "xfs: unrecognized service".

I have also run;   yum install xfsprogs xfsdump    which succeeds but doesn't help.
What font service is CentOS running if not for xfs?  Is there a way to run xfs service on CentOS 6.4?

really maddening.

Thanks,

Charlie
0
We have a ClearOS server, that is also a mail server. I have a smartphone android. In the phone i set up my e-mail account successfully. I am able to send and receive e-mails using my android phone. However when i am sending an e-mail, using my android smartphone, the e-mails are not shown in SENT items of MS Outlook or web mail. Can someone help me with this.
0
I have a Untangle 10 box set up behind a Fritz.Box modem/router. I have been able to set up the dynamic DNS on Fritz.box and is reachable externally. However, my ultimate goal is to allow me to access the Untangle box externally and to also have OpenVPN set up.

Unfortunately, I am have trouble getting to access the Untangle server.

I'l describe what I have set up on Fritz.Box and then Untangle.

Dynamic DNS:
account set up with: NOIP.COM
Host: mydynamicdns.no-ip.biz

Fritz.Box:

Internet > Permit Access > Dynamic DNS
Dynamic DNS provider: no-ip.com
Domain name: mydynamicdns.no-ip.biz
username: <my username>
password: <my password>
Internet > Permit Access > Remote Access
User name: <my username>
password: <my password>
Use HTTPS port other than the default HTTPS port 443: ticked
other HTTPS port: 450
IP Address for remote access

Access the Fritz.box outside of my network works with using "HTTPS://MYDYNAMICDNS.NO-IP.BIZ:450"

Moving forward with access to the Untangle box.

Fritz.box (further set ups):

Internet > Permit Access > Port Forwarding
Protocol: TCP
From Port: 443
to IP Address: 192.168.178.82 (fritz box IP to untangle box)
to Port: 443
Internet > Home Network > Network > Network Settings > IPv4 Routes
network: 192.168.2.1  (untangle internal network)
subnet mask: 255.255.255.0
gateway: 192.168.178.82 (fritz box IP for untangle box)

Untangle (set up):

Config > Network > Interfaces
0
I am unable to resolve windows NetBIOS names from inside CentOS.  I've tried the following:

Adding "wins" entry to "hosts:" in nsswitch.conf ("files wins dns")
Changing the order of "files", "wins", and "dns" in nsswitch.conf
Restarting networking "service network restart"
Adding "search WORKGROUP" to resolv.conf (replacing WORKGROUP with my particular workgroup)
Installing samba-common
Restarting the machine

I'm kinda out of options, and I'm not sure where to go from here.  From what I've read, adding wins to nsswitch.conf should solve it, but that doesn't work for me.

I'm able to ping the computers via IP address, and I can resolve the NetBIOS names on Windows machines.  I don't think it's a firewall issues, because when I stop iptables, the issue persists.  It could maybe be an SELinux issue, but I don't really know where to start troubleshooting that.

Help me, EE, you're my only hope!
0
Hello experts,

I have setup the vsftpd in my Ubuntu instalation.
I have the users set up, and everything works fine when i login from the local network.

But when i login from outside using our public ip, the login doesn't work, asks for password saying:
550 Permission denied
Requested action not taken (e.g., file or directory not found, no access).

What am i doing wrong? Or what should i be doing?

Thx in advanced,
Miguel
0
I want to send logging from vmware hosts to an rsyslog server that forwards the whole thing to Elasticsearch and Kibana on the same server. I used this guide:

http://www.rsyslog.com/tag/elasticsearch/

I can see log entries arriving at /var/log/messages on the rsyslog server from the vmware hosts, but when accessing http://servername:8000 Kibana shows no log entries in any of the predefined Dashboards.

How do I verify and/or troubleshoot if anything is ending up at the Elasticsearch and Kibana server? Is there any more configuration I need doing before I see anything in Kibana?

Adding the rsyslog.conf file here for information. There is nothing sensitive in it.
rsyslog
0
Hello folks,
    I have a eBGP linux box (using quagga) and I experience the following issue:
traffic to/from external network  x.y.z.0/24  is slow through one of the two BGP peers that I have (call it B1), and which seems to be the default in x.y.z's network route table.
    No problem I said, I will push a route rule "by hand", so that traffic with said class should be handled by my other bgp peer (B2). However, the problem persists, because even though I send packets to x.y.z.0/24 using B2 , the response comes through B1, thus laggy.
    Putting peer B1 in shutdown will force x.y.z. network to talk to me through B2 and all is fine, but this is obviously no solution.
    Any ideas?
0
Here is all I did:

I installed Ubuntu Server 12.04.4 in a VirtualBox.  Network is bridged.  Then I ran:
sudo apt-get update
sudo apt-get upgrade
sudo apt-get install vsftpd

Then I edited /etc/vsftpd.conf and uncommented local_enable=YES and write_enable=YES.  
Saved the config.
sudo service vsftpd restart
sudo ufw disable  (for good measure)

So then I go into Filezilla on the host machine and try to connect, but this is what I get:

Status:      Connecting to 192.168.1.91:21...
Status:      Connection established, waiting for welcome message...
Response:      220 (vsFTPd 2.3.5)
Command:      USER jsmith99
Response:      331 Please specify the password.
Command:      PASS *********
Response:      500 OOPS: priv_sock_get_result
Error:      Critical error
Error:      Could not connect to server


Any ideas on what the heck am I doing wrong?  I'm pretty sure this has worked for me very easily in the past, although it's been a while.  And I don't remember if I've done it in Virtualbox before.

Any help is appreciated!  Thanks.

[edited my username out]
0
Despite specifying no_root_squash, root most definitely is getting squashed. This makes it difficult when i need to access the share as root (e.g. with Clonezilla).

Access denied to tree /bk. /etc/exports is
# /etc/exports: the access control list for filesystems which may be exported
#		to NFS clients.  See exports(5).
#
# Example for NFSv2 and NFSv3:
# /srv/homes       hostname1(rw,sync) hostname2(ro,sync)
#
# Example for NFSv4:
# /srv/nfs4        gss/krb5i(rw,sync,fsid=0,crossmnt)
# /srv/nfs4/homes  gss/krb5i(rw,sync)
#
#/		192.168.1.0/24(rw,sync,crossmnt)
/		192.168.1.0/24(rw,sync,no_root_squash,crossmnt)
/bk		192.168.1.0/24(rw,sync,no_root_squash,crossmnt)
#/bk		192.168.1.0/24(rw,sync,crossmnt)
/mnt/mp3	192.168.1.0/24(rw,sync,crossmnt)

Open in new window

0
I have a shared folder in Samba. Everyone access the folder by mapping a drive in Windows and can put their files or folders there for sharing. However when one user create a folder or a file, it does not allow others to edit or can put other files into that folder. How can I set the permission to be autormatically granted for all others whenver one user create a file or a folder ???
0
Hi,

We have suffered a couple of serious Syn Flood attacks recently.  We thought we had put the right levels of protection on our server, but we are now seriously considering using a web based service (see list below).

What should we look out for with these services?

What should we expect to pay for the services?

Does anyone have any particular recommendations?

cloudflare.com
dosarrest.com
rivalhost.com
prolexic.com
incapsula.com

Many thanks
chris
0
i am in need of step by step guide for configuring SUSE linux enterprise high availability Extension cluster.for two node scenario in vmware v center.
0
we are trying to connect from external application to fuse. During telnet, we are getting below error.

Escape character is '^]'.
ðActiveMQ       Þ
                        MaxFrameSizeÿÿÿ CacheSize
                                                 CacheEnabledSizePrefixDisabled MaxInactivityDurationInitalDelay'TcpNoDelayEnabledMaxInactivityDurationu0TightEncodingEnabledStackTraceEnabledConnection closed.
0
Hi,

I can't access my domain via IP address or website:

http://emailmarketingservicesco.com
Also, the other domain http://myultratrust.com associated with this VPS on godaddy (service is pretty bad I think compared to other VPS providers I've had. Just my input and opinion).

I think it could be related to a WHM update but not sure.

I can access the cPanel via WHM (Home->Account information->List Accounts). Also, FTP works fine. Ping works fine too.

So I'm thinking related to the DNS records but not sure.

This is what I have in my logs:

Apr  4 09:55:49 ip-184-168-116-73 pure-ftpd: (?@127.0.0.1) [INFO] __cpanel__service__auth__ftpd__6r_VrEy0gEHWu9LjKzV27w_Xxg9d62wAzi3re9ayywHK3Lvfb3942fAmkKAENRNF is now logged in
Apr  4 09:55:50 ip-184-168-116-73 pure-ftpd: (__cpanel__service__auth__ftpd__6r_VrEy0gEHWu9LjKzV27w_Xxg9d62wAzi3re9ayywHK3Lvfb3942fAmkKAENRNF@127.0.0.1) [INFO] Logout.
Apr  4 10:00:49 ip-184-168-116-73 pure-ftpd: (?@127.0.0.1) [INFO] New connection from 127.0.0.1
Apr  4 10:00:50 ip-184-168-116-73 pure-ftpd: (?@127.0.0.1) [INFO] __cpanel__service__auth__ftpd__aRUhrLg6d3tUtpi4IDgOu4KqynW7Q_WEAjpHLXcVBfLP70X8Vnx3cugIbkP2l89Z is now logged in
Apr  4 10:00:50 ip-184-168-116-73 pure-ftpd: (__cpanel__service__auth__ftpd__aRUhrLg6d3tUtpi4IDgOu4KqynW7Q_WEAjpHLXcVBfLP70X8Vnx3cugIbkP2l89Z@127.0.0.1) [INFO] Logout.
Apr  4 10:03:02 ip-184-168-116-73 named[7207]: network unreachable resolving 'p3plsmtps2ded-v01.prod.phx3.secureserver.net/AAAA/IN': 

Open in new window

0
Hi,

I want to delete and remove a domain associated with my VPS via WHM cPanel.

There is an additional option in the Home->Account Functions->Terminate an Account checkbox stating:

Keep DNS Zone (necessary if removing an account because you have already moved it to a different server in the same DNS cluster)

What do they mean by "same DNS cluster"? I guess I don't have to have it checked since I haven't moved it to a different server, correct?

Thank you,
Victor
0
Dear all,

I run a cisco asa 5510 and I want to know how to configure the asa to let some of VPN client users navigate through the remote gateway (with remote public ip). We are using AnyConnect VPN client.

Do I have to configure some NAT ? Do I need to configure some rules to let the vpn ip pool go to the internet.

I just want my remote users to navigate on internet through the vpn tunnel and the remote gateway (the asa).

Any hints ? Do I have to setup some proxy ?

Thank you so much !
0
Hi experts,

I have a rather complicated problem which I am trying to debug.
We are using a proxy server (squid) for user authentication. We are trying to use Kerberos authentication and it works on our test systems without any problems.

On the production machine however, it fails and always falls back to NTLM authentication (on all browsers). We could find out that the system does not even try to use Kerberos.
The production machine is a windows server 2012 R2. If we look at the outpout of klist, we see no tickets for HTTP/Proxy.domain. However, we can succesfully obtain the tickets using klist get HTTP/Proxy.domain - but that ticket will not be used afterwards.

What we are looking for, is a way to debug this. Enabling LSA/Kerberos-Logging (setting SPMInfoLevel) did not reveal anything useful.

Systems:
squid/3.3.8 @openSuSe 13.1 (x64), using the built-in Kerberos authentication helper, the Proxy Server is domain-joined, SPN is set correctly.
0
I have perviously (october 2013 actually with this guide http://www.unixmen.com/install-and-configure-rsyslog-in-centos-6-4-rhel-6-4/) set up Loganalyser with mysql and rsyslog to receive log information from vmware vsphere hosts and store them. This has been running for some months. When I enter the webpage at http;//hostname/loganalyser I get the information below;


>>
No syslog records found - Error Details:
No syslog records found


Logstream Warning
While reading the logstream, the php script timeout forced me to abort at this point.

If you want to avoid this, please increase the LogAnalyzer script timeout in your config.php. If the user system is installed, you can do that in Admin center.
<<
I then start by checking the configuration and various outher troubleshooting steps shown below:


# more /var/www/html/loganalyser/config.php
(pasting relevvant information)
$CFG['UserDBEnabled'] = true;
$CFG['UserDBServer'] = 'localhost';
$CFG['UserDBPort'] = 3306;
$CFG['UserDBName'] = 'rsysdb';
$CFG['UserDBPref'] = 'logcon_';
$CFG['UserDBUser'] = 'rsyslog';
$CFG['UserDBPass'] = 'password!';
$CFG['UserDBLoginRequired'] = true;

$CFG['DefaultSourceID'] = 'Source1';

$CFG['Sources']['Source1']['ID'] = 'Source1';
$CFG['Sources']['Source1']['Name'] = 'My Syslog Source';
$CFG['Sources']['Source1']['ViewID'] = 'SYSLOG';
$CFG['Sources']['Source1']['SourceType'] = SOURCE_DB;
$CFG['Sources']['Source1']['DBTableType'] =
0
Hello
Solaris is installed on a VMware virtual machine.
After installation I installed VMtools to add VMXNET3 virtual NIC.
I also have second physical NIC E1000g that I cant plumb, it says that the interface is not found.
I used these manuals to setup the virtual NIC and to define network properties:

http://docs.oracle.com/cd/E19253-01/816-5166/6mbb1kq31/
http://kb.vmware.com/selfservice/microsites/search.do?language=en_US&cmd=displayKC&externalId=2009199

I can see the VMXNET3 NIC and my network configurations (IP, Default GW,Subnet) , I can send ping to my IP and default gateway but I can't ping to othe computers.

please help
0
The USB boots directly into linux with no menu.  No "Do you want to install Linux" nor "Do you want to try Linux" nor "Do you want to multiple install" nor "Do you want to checkdisk".  None of that.  You boot up from the and you end up at a desktop or a terminal window.  

B)  It has SSH server built into it so that when the system boots up it is ready to accept SSH connection.

C)  It is persistent in that if I add a user it will remember that I added that user and password the next time I reboot.

D)  Basic utilities like ping, traceroute, curl, ssh, telnet will be on there.  

That's it!  I have a Windows 7 system or an Ubuntu laptop from which I can create the USB.  What USB utility plus what distribution of Linux will get me to my needed bootable USB?
0
Hi,

I have the following problem:

I have a website that runs in a internal website on my company, but some pages inside my website requires internet, my problem is that i can't configure my server to have access to internet using the proxy settings. I need that the server have access to internet to process these pages inside the website. I review about 20 websites, but anyone provides me a solution that works, also try cntlm but anyone explains how to install properly so i do what can i do and don't work. What is the step by step process to do a proxy setting configuration in the server? Thank You!
0
I recently installed SmokePing on a server at work, so that I could monitor the state of our Internet connection to the cloud providers we use.  However, I'm having some trouble figuring out the meaning of the graphs that SmokePing generates.  For example:

http://chernavsky.dreamhosters.com/temp/smokeping.jpg

These five graphs cover the same 24-hour time period.  The bottom-right host (labeled "Frontier") is the next hop after our default gateway.  The other four hosts correspond to four cloud services we use.

What might cause the transient hump to appear for three hosts, but not the other two?  Also, what might cause the small, sudden step-wise increase in latency, followed by a decrease later?  Finally, is this type of behavior fairly normal, or is something amiss?
0
Hi all!

I have an old mac mini g4 (single ethernet) with debian on it.

I am very happy with it but, being also my download station, I want to be able to limit its bandwidth regarding internet.
Also updates and backups kill my network (main problem in upload).

I've read about wondershaper and similar tools but I don't want my server to be slow on LAN, just on the Internet.
Is there any way to achieve this?
0
Hello Experts,

This is been a long unsolved question in my mind, I want to replicate a installation like Ubuntu or Fedora with my Linux from scratch7.4

I have the tar which holds nesscary file to boot up a system.

But the real problem is i want to push the tar file into another system via CD or USB and make that new pc to boot it from LFS7.4.

How to accomplish this.

Thanks!
Puspharaj
0

Linux Networking

18K

Solutions

15K

Contributors

The variety of Linux distributions creates myriad issues relating to configuration and operations when computers are networked, not the least of which is the use of various network management applications, some of which are included with specific distributions, while others are standalone applications.

Top Experts In
Linux Networking
<
Monthly
>