Linux Security

The Linux operating system, in all its flavors, has its own share of security flaws that allow intrusions, but there are various mechanisms by which these flaws can be removed, generally divided into two parts: authentication and access control. Authentication is responsible for ensuring that a user requesting access to the system is really the user with the account, while access control is responsible for controlling which resources each account has access to and what kind of access is permitted.

Share tech news, updates, or what's on your mind.

Sign up to Post

I  have a few question for selection of drop policy applied place.

1. Which one first apply the drop rule ?
2. iptables and nftables are user space appliances but i do not know deeper , are they work in kernel space and pipe the requests from user space or are they work completely after kernel space ?
3. Is there any possibility to drop a packet before any kernel space module ,i tryed with netfilter and drop an ip xx.xx.xx.xx and i realize that tcpdump still reading the traffic but iptables not. So the traffic is passing to kernel space still on netfilter.
Ransomware Attacks Keeping You Up at Night?
Ransomware Attacks Keeping You Up at Night?

Will your organization be ransomware's next victim?  The good news is that these attacks are predicable and therefore preventable. Learn more about how you can  stop a ransomware attacks before encryption takes place with our Ransomware Prevention Kit!

i am in particular folder say abc.

I did ls -ltr where there are bunch of files.

i want to search all the files starting with file name xyz alone ignoring other starting with pqr etc(ignore pqr000.log.20170806.gz etc).
My search should result like

xyz789.log.20170806.gz etc

What is the command i have to use for that.

is it grep or find or something else.

when i gave grep xyz.* it did not gave any result.

how searching inside a file content is different from search outside on unix file names.

any good link on these commands? please advise
I haven't worked on SUSE long time. Can some one explain me the process of patching in SUSE and I want to update the bash package.

need some steps as well. I would appreciate.

I want to cover this
I am running  proFTPD server on  my system. When i use filezilla ftp client i get the folllowing error when i try to access the files on my server. What is causing this error? See attached file for exact screenshot of the issue.
The issue is as follows, I am running an centos 7 server with a  PHP Plesk Panel 12.5 running my subscribers and their sites. I just recently installed the Ipad site builder module and the site builder module to test each for a potential site building solution for my clients. Well after i installed both,  I was forwarded to a third party website where the actual website is created for each client. Well, after the site is created, on their site i have the option to publish it to a domain on my server.  At 50% install i get the following error  fsockopen failed No route to host (113). Now this same thing happens when i use the site builder module as well.  I am running  PROFTPD on the system, so i do have an ftp server running.  What i need to find out is how to resolve this issue. I am sending you a screenshot us running filezilla  as ftp on port 21, i get the following error. I know this is a minor issue , i just need help narrowing down the cause or misconfiguration.

My firewall and router are open for port 21.
I had installed Apache SVN over ubantu 16 . in which i am trying to put access base restriction for different path by AuthzSVNAccessFile /svn/net location.
 hear i am facing issue for [/]  groups are getting restricted but apart from this location any path is not getting restricted inspite of trying multiple combination in access file.

<Location /svn>
  DAV svn
  SVNParentPath /svn/repos/
  AuthzSVNAccessFile /etc/svn_serve.conf
  AuthType Basic
  AuthName "MITS"
  AuthUserFile /etc/svnpasswd
  Require valid-user

Access file

The error i get when i use port 21The error i get when i use port 21The error i get when i use port 21I have  this ftp dameon installed on my server for ftp access : psa-proftpd      1.3.5b-cos7.build1205160427.18. I am running centos 7 with a plesk 12.5 control panel. Each time i try to access port 21 with a valid user name and password i get an error. I have a screenshot of the area as an attachment to this question. I have never setup the ftpd dameon, it was installed when plesk was installed. I need help on understanding, do i need to do some manual changes to the config file of this dameon. I have firewalld and a router running, and both allow port 21 access to the real world. What can be the problem here, please help. I even check to see if the port is open from the web and it is. I am sure this issue is not hard, i just am a bit stuck at this point.
Error: Package: R-core-devel-3.4.0-2.el6.x86_64
           Requires: libicu-devel
yum can be configured to try to resolve such errors by temporarily enabling
disabled repos and searching for missing dependencies.
To enable this functionality please set 'notify_only=0' in /etc/yum/pluginconf.d/search-disabled-repos.conf

--> Running transaction check
---> Package R-core-devel.x86_64 0:3.4.0-2.el6 will be an update
--> Processing Dependency: libicu-devel for package: R-core-devel-3.4.0-2.el6.x86_64
---> Package kernel.x86_64 0:2.6.32-642.11.1.el6 will be erased
--> Finished Dependency Resolution
Error: Package: R-core-devel-3.4.0-2.el6.x86_64
           Requires: libicu-devel
 You could try using --skip-broken to work around the problem
** Found 2 pre-existing rpmdb problem(s), 'yum check' output follows:
tomcat6-admin-webapps-6.0.24-98.el6_8.noarch has missing requires of tomcat6 = ('0', '6.0.24', '98.el6_8')
tomcat6-webapps-6.0.24-98.el6_8.noarch has missing requires of tomcat6 = ('0', '6.0.24', '98.el6_8')
I have 300 Ubuntu 14 PC's that I block all internet except a whitelist - I do this by disabling dns, and have the central server do dns lookups for everything on whitelist and put it in a hosts file and have all the hosts use that. Obviously, this is a bit hacky but it worked.

The problem now - I have a need to whitelist * Slack says subdomains change too much, they cant provide a static list, or even a current list and then let me update it.

So I guess I need to enable DNS - what might be easy ways to still restrict to a whitelist of domains? I can easily run shell scripts on all 300 machines. (they check in with central server and grab a script and run it regularly). So anything I can install/configure via script is a viable option...

If it's not too hard I could set up an ubuntu machine to be a dns server.

Basically what I want is whatever is easiest so that I can just provide a whiltelist, that is allowed to have wild cards like * and block everything else. I suppose it doesn't actually have to be a DNS based block if there is some client app.

Whatever it is, I am OK to set up a server myself - but the clients, it needs to be scriptable install/config.

I want to be able to update the whitelist easily/quickly.

Any ideas/suggestions?
I have linux application account and  would like to restrict the user to login directly. I want this account to be under sudoers. users can login and sudo into this account. How do i do that in linux?
Need protection from advanced malware attacks?
Need protection from advanced malware attacks?

Look no further than WatchGuard's Total Security Suite, providing defense in depth against today's most headlining attacks like Petya 2.0 and WannaCry. Keep your organization out of the news with protection from known and unknown threats.

what are differences between
user defined, environmental. local, global variables

when to use which one. what are advanatages, disadvantages of using each with practical examples.
please advise

I like to write a unix shell script to check calendar year, date, current working directory.

how to write and shave .sh file(Say and how to execute to see the output.

Any detailed link explaining these steps with screenshots. please advise
What are differences between
touch cat vi differences

which one is better to use to create a file. When to use which one. please advise

I like to delete matched pattern in a file using vi editor and sed command

i tried as below not working

$ sed 'hello' aaaa.txt :%

please advise

I'm using Alienvault Ossim v. 5.3.79 together with ossec v. 2.8.

I'm trying to extend the following rules:
1002 - Unknown error somewhere in the system - bad words;
1003 - Non standard system message (size too large).

As these two rules give me a lot of false positive alerts, I've prepared custom rules in the local_rules.xml:
Original rules (syslog_rules.xml):

<rule id="1002" level="2">
    <description>Unknown problem somewhere in the system.</description>

  <rule id="1003" level="13" maxsize="1025">
    <description>Non standard syslog message (size too large).</description>

Open in new window

Custom rules (local_rules.xml):

<rule id="100002" level="0">
    <match>Sequence Errors: 0, Bad Packets: 0</match>
    <description>False positive</description>

  <rule id="100003" level="0">
    <description>Ignoring 1003 from specified host</description>

Open in new window

Unfortunately looks like above custom rules are ignored when I'm trying to use ossec-logtest:
For 1003:
echo "Apr 27 11:10:04 host1 user1[21565]: ./ - Lorem ipsum dolor sit amet libero et lacus vestibulum vel, nibh. Fusce nonummy risus sit amet quam tempus vehicula, dui tellus, at lorem odio adipiscing at, egestas non, nulla. Maecenas in nulla quis 

Open in new window

I am conducting a penetration test against a fake Apache Tomcat server.  I have exploited the vulnerability in Metasploit and was able to open a Meterpreter session.  Some of my commands work with Meterpreter; however, commands such as "run hashdump" and "getsystem" return an error of this version of Meterpreter is not supported with this script.  I am running a virtual environment of Metasploit v4.10.0.  Is there any other script that can be used to complete this hashdump? Below is the exploit and payload that I used to open meterpreter:
use exploit/multi/http/tomcat_mgr_upload
set payload java/meterpreter/reverse_http

I have tried all other payloads that are are shown from the "show payloads" command.
Dear Colleagues,

I have a problem with executing SU command in Ubuntu 16.04.02. LTS.
The output is « -bash: /bin/su: Permission denied » (see attached screenshot).

Plz suggest something to overcome this issue.
Hi All,

Getting the above following message in my auth.log on my server from the above ip and many others ... what does this mean?

It is some type of Linux honey pot program. I was given a fife,, that is supposed to set the program up to to end to a SIEM to gather information on my internal network. Supposed to be installed on Linux Mint Mate 18. Classified as a "Low-Interaction" HoneyPot.

I have not been able to locate the installer or information more that I have given. Any help would be appreciated.
U.S. Department of Agriculture and Acronis Access
U.S. Department of Agriculture and Acronis Access

With the new era of mobile computing, smartphones and tablets, wireless communications and cloud services, the USDA sought to take advantage of a mobilized workforce and the blurring lines between personal and corporate computing resources.

I want firefox to not erase cookies on browser close. I want to set this via a script. Below are gui based instructions for the goal settings.

Anyone know how to do this?



At the top of the Firefox window, click the Firefox button and then select Options
Select the Privacy panel
In the History section, set Firefox will: to Use custom settings for history
Select the check box for Clear history when Firefox closes
click the Settings… button. The Settings for Clearing History window will open
In the Settings for Clearing History window, click the check mark box next to Cache.
Click OK
What is 'sticky session' when considering web traffic load balancing and how session-stickiness is usually achieved ?

can you please explain me a real world scenario. Like how it is used.
I am trying to set up a linux box as router ( packet forwarder to external + NAT). All the references I have found show that can be achieved using  iptables.
The question I have , if for performance  reasons  I can’t use iptables, is there any other alternative to achieve the same result ?

i'm looking for the quickest way to query Windows Event ID's from a Linux CentOS device.
I managed to do it via WMI but the enumerations of security logs using WMI simply takes too long.
what other methods are there to query Windows Event ID's as well as information from Active Directory using Linux?
can i use powershell from linux to query? how do SIEM devices like mcafee\greylog do it? what are the methods that can be done to query this info from linux other then WMI?

any help will greatly be appreciated this is driving me nuts
hi all,

I am now learning basic operation of Lunix and unix:

1) how to list active process in linux and unix and kill it accordingly.
2) how to change application start mode so that we can choose to start in administator/root user mode instead of general user mode in lunix and Unix.
3) how to check disk space left in linux and Unix.
4) what is the commonly use Linux and Unix administrative tools so that I don't need to use command mode?
5) how to check existing CPU usage of all CPU core in Linux and Unix, and therefore which application use the most CPU resource can be found.
6) how to check existing RAM usage of all application in Linux and Unix and therefore know which application use the most RAM/

I want ot learn and practive Linux commands on my windows 10 laptop. how to instal and set up and practice in centos. please advise
I was checking below but not sure where and how to get software etc

please advise

Linux Security

The Linux operating system, in all its flavors, has its own share of security flaws that allow intrusions, but there are various mechanisms by which these flaws can be removed, generally divided into two parts: authentication and access control. Authentication is responsible for ensuring that a user requesting access to the system is really the user with the account, while access control is responsible for controlling which resources each account has access to and what kind of access is permitted.

Top Experts In
Linux Security