We help IT Professionals succeed at work.

Linux

66K

Solutions

33K

Contributors

Linux is a UNIX-like open source operating system with hundreds of distinct distributions, including: Fedora, openSUSE, Ubuntu, Debian, Slackware, Gentoo, CentOS, and Arch Linux. Linux is generally associated with web and database servers, but has become popular in many niche industries and applications.

boot ko after bios _osi linux query ignored.

Hello all

I have a system that will not boot and just hang after the above message ( see attached photograph ) from an old ubuntu 14

I am pretty sure the issue is hardware since the os has multiple bootable oses and all of them hang somewhere after an acpi message. Tested with multiple linux and freebsd kernels. Not tested windows yet.

... and the laptop fell yesterday. It did work for s few hours normally afterwards and was cleanly shutdown without issues

My questions are

Do you happen to know what is the next step in the boot sequence ? I suspect loading graphic drivers but i am unsure and a dmesg output would help.

Do you happen to know some options i can pass the kernel in order to circumvent and go on with my work till i fix this ? I tried various combinations of noapic noacpi vga... i would be more than happy with a working command line and a vesa screen

Thanks for your time
IMG_20200221_081832.jpg
0
The issue is strait forward.  On Ubuntu 18.04 I have deleted reolve.conf from the /ETC dir.  Resolv.conf appears to get recreated on reboot but it does not contain any DNS server entries save 127.0.0.53.  This will not work, you cannot edit the file as it is symbolically linked.  How do I correct, and provide it with the correct entries.  I was trying to install Dnsmasq.  The following commands were issue

john@VBserver1:~$ sudo systemctl stop systemd-resolved
john@VBserver1:~$ sudo ls -lh /etc/resolv.conf
lrwxrwxrwx 1 root root 37 Feb 17 21:35 /etc/resolv.conf -> /run/systemd/resolve/stub-resolv.conf
john@VBserver1:~$ sudo rm /etc/resolv.conf
john@VBserver1:~$ echo "nameserver 8.8.8.8" > /etc/resolv.conf
-bash: /etc/resolv.conf: Permission denied
john@VBserver1:~$ sudo echo "nameserver 8.8.8.8" > /etc/resolv.conf   This one is where the failure results.
-bash: /etc/resolv.conf: Permission denied
john@VBserver1:~$
0
error starting ubuntu vm
ubuntu
i did this before i restartvm
https://help.ubuntu.com/community/Oracle%20Instant%20Client
0
Run Android X86 in Graphical Mode,

I have installed Android x86 as a VM, but when I run it, it does not go to Graphical Mode. it stays on the window displayed below:
a
any help?
Thank you
0
How do I create a user in Linux and grant them remote access via ssh ?

I am using the Redhat version of the Linux distribution.

I am new to Linux and is learning this OS as I go.

Alos any recommendations on how to master this OS would be appreciated.
0
hi am not able to ping another vm but am able to ping the same vm from another vm
ping23vmping234.PNG
0
no internat no gui after installing oracle linux
lnxusr43unx
0
hi,

I am creating hyper V CentOS VM but it seems never can reboot to server UI screen,  I see this screen when I was configuration the disk but I gave it 500GB, can't see why it can't see it.

CentOS disk space

any reaosn why ?

disk space in total:

disk space in total
0
Dear Gurus
I have a old AIX machine which has MicroFocus Cobol 5.1 running on it.
Now I need to move it to RHEL Version 7.
Is there a way we can find if this will be compatible with Red Hat Linux 7 or not.
If not, which version of Linux it will be compatible with.

Best Regards,
Flex
0
We have a slow responding web application running on a local server, it is running on MariaDB 10.4.8, PHP7.2 FPM and nginx on Ubuntu 19.04.

It doesn't look to be due to a lack of resources as far as I can see using top and looking at free memory & CPU usage. I have used iotop to look at disk usage and I think this is probably OK as far as I can see.

Can anybody help me find a solution to our slow application performance or at least point me in the right direction to diagnosing the problem? I have attached a couple of screen grabs of TOP and IOTOP for reference.

This is driving me a bit nuts and would really appreciate any help!

IOTOP 1IOTOP 2TOP 1TOP 2
Many Thanks,
Alex
0
hi am not able to connect to my linux via vnc from window
vnc
1
I need to install a Let's Encrypt SAN Certificate, so that multiple domains can use Let's Encrypt. I am currently running AWS Linux (basically RedHat). Does anyone have a good "go to" set of directions on how to create a Let's Encrypt SAN Certificate on AWS Linux?

Thanks
0
Hi Experts



Scenario
 
In this server, we have a directory called /important  
 
We need to backup this directory every hour to a different path to /backup
 
Then check if the backup successful we need to remove the data from /important  
 
For this, we need you to write for us a shell script, which can do this task for us automatically every hour  
 
Note: we need to specify the time stamp for the backup files


i have this question and i need full answer i manged just to fix the first part which includes making the backup with time stamp

but i need the other part

1-  check if the backup successful remove the data from /important




Solution


#!/bin/bash
backup=/backup/important-`date +%Y-%m-%d-%H-%M`.tar
tar -cvf "$backup" /important




thnaks
0
hi error installing oracle linux i have attach the disk
linuxvdii2
0
Hi Experts

we have in our environment NAgios-XI  the commercial version of Nagios

and i am monitoring file systems under red-hat box  and everything was ok no issues

yesterday i extend the filesystem from 1.3 TB to 2.9 TB and after one day i start to get critical massage from Nagios-XI


[root@nagios ~]# /usr/local/nagios/libexec/check_nrpe -H 192.168.42.11 -t 30 -c check_disk -a '-w 50% -c 80% -p /oracle/RAN/oraarch'
DISK CRITICAL - free space: /oracle/RAN/oraarch 2291546 MB (77.93% inode=100%);| /oracle/RAN/oraarch=648895MB;1471509;588603;0;2943018


but this is not true the file system status like this


/dev/mapper/oraarch-oraarch                         2.9T  632G  2.2T  22% /oracle/RAN/oraarch



so only 22% used from this file system

i am monitoring another file systems on the same box and the everything ok just this file system so it cannot be agent issue on the red hat box


any idea here



thanks
Sword
0
How do I get ssh access back to my centos linux vm if I'm locked out due to selinux policies?

My coworker turned on some selinux policies and now we can't ssh back into the linux vm which is hosted on azure cloud.

This is a centos vm hosted on Azure cloud. I'm not able to ssh into the machine anymore. How do I get inside the machine to disable the policy?
0
A dual boot computer, Windows and Linux, ..
In Windows the LInux computer's partition was deleted.
Now when the computer tried to load it looks for the Linux Grub..
how can this be repaired?  So that it will boot into Windows?
0
I'm having issues with my haproxy servers (running Ubuntu 16.04) rejecting new connections (or timing them out) after a certain threshold. The proxy servers are AWS c5.large EC2's with 2 cpus and 4GB of ram. The same configuration is used for both connection types on our site, we have one for websocket connections which typically have between 2K-4K concurrent connections and a request rate of about 10/s. The other is for normal web traffic with nginx as the backend with about 400-500 concurrent connections and a request rate of about 100-150/s. Typical cpu usage for both is about 3-5% on the haproxy process, with 2-3% of the memory used for the websocket proxy (40-60MB) and 1-3% of the memory used for the web proxy (30-40MB).

Per the attached config, the cpus are mapped across both cpus, with one process and two threads running. Both types of traffic are typically 95% (or higher) SSL traffic. I've watched the proxy info using watch -n 1 'echo "show info" | socat unix:/run/haproxy/admin.sock -' to see if I'm hitting any of my limits, which does not seem to be the case.

During high traffic time, and when we start to see issues, is when our websocket concurrent connections gets up to about 5K and web requests rate gets up to 400 requests/s. I mention both servers here because I know the config can handle the high concurrent connections and request rate, but I'm missing some other resource limit being reached. Under …
0
A computer has a Linux Mint installation and a Windows 10 installation - in dual boot.
Currently there is not enough space with the current portioning size to install Office 365 on the Windows partition.
Therefore the Linux partition has to be made smaller.
How can this be done?
Thanks in advance.
0
We have an Ubuntu Server (Xenial) that will never touch the internet.  We can't query the Ubuntu Repo from another Ubuntu Server that has Internet access, how can we get the packages we need, with all dependencies?
0
Ive usually installed PHP via:-
sudo apt install php libapache2-mod-php php-mysql

Open in new window

Which works great and installs the latest version of PHP and configures everything fine :-)

Problem is I want some of my sites to run on PHP 5 (for historical purposes), some to run on the current version of PHP 7 and some to run on a future version of PHP 7 for testing.

On my hosting website, I can add a line into the vhost configuration to tell it what version of PHP to run, for example to run PHP7 I just add this into the htaccess file and it runs the site with PHP 7:-
AddType application/x-httpd-php70 .php
This is exactly what I want to do, however all the guides Ive found online talk about running everything under the same version, but not individual sites.

Anyone got any ideas on this?

Ideally I want to download different versions of PHP into a folder \PHP\PHP7.3\ and then inside htaccess point to use \PHP\PHP7.3\ or something different.

Im using Ubuntu server with Apache if that helps, and this is only for development purposes, not production.
0
Hi,
I get file "courier-imap-5.0.8.tar" (attached) but am not sure about its setup in Ubuntu. Please help.
courier-imap-5.0.8.tar.bz2
0
I'm working on a Laravel project and I'm attempting to "add" and "commit" a number of files simultaneously and I've run into something I've never seen before.

Rather than plow ahead with solutions that seem intuitive on the web, I wanted to run this by some folks who I'm sure have seen this.

When I go to do a

"git commit -m "my message"

I get this error:

[code]error: invalid object 100644 6a247fefd088bae6baae483aa27872517393f5fe for 'app/Http/Controllers/Auth/ForgotPasswordController.php'
error: invalid object 100644 6a247fefd088bae6baae483aa27872517393f5fe for 'app/Http/Controllers/Auth/ForgotPasswordController.php'
error: Error building trees[/code\

When I went out to Google in an attempt to remedy the situation, I saw this:

https://medium.com/@panjeh/git-error-invalid-object-error-building-trees-44b582769457 (see also https://git-scm.com/book/en/v2/Git-Internals-Git-Objects)

Sha-1 looks as though it's just a way of telling GIT to overlook what would otherwise be a snag. Is that right?

Then I found this: https://stackoverflow.com/questions/17628305/windows-git-warning-lf-will-be-replaced-by-crlf-is-that-warning-tail-backwar

From what I can gather, depending on your OS, Windows is going to interpret LF differently than a Linux system, hence GIT looks at LF and wants to replace it with CRLF.

Right?

I'm getting to share this with another developer and I want to make sure that I'm not just blowing through something I need to be …
0
Hi Experts

we have ERP system SAP running on red hat Linux 7  using oracle 12C

from time to time our file system which reserved for ora logs  get full so fast out of the sudden

we are not able to know the root cause which  

process or transaction or user  generate such amount of logs

do you know anyway or tool to know such info


thanks
0
Hi,
Jpg file does exist in "/var/www/pict" path, but html file below is not able to show Jpg file. Why?

<html>
    <body>
        <!--div align="center"-->
        <div class="container" style="background:url('../pict/ID-10028343.jpg') no-repeat center top; Height:780px; Width:1220px; background-size:100% 100%; margin:0 auto; ">
        ...

Open in new window

0

Linux

66K

Solutions

33K

Contributors

Linux is a UNIX-like open source operating system with hundreds of distinct distributions, including: Fedora, openSUSE, Ubuntu, Debian, Slackware, Gentoo, CentOS, and Arch Linux. Linux is generally associated with web and database servers, but has become popular in many niche industries and applications.