We help IT Professionals succeed at work.

Linux

66K

Solutions

33K

Contributors

Linux is a UNIX-like open source operating system with hundreds of distinct distributions, including: Fedora, openSUSE, Ubuntu, Debian, Slackware, Gentoo, CentOS, and Arch Linux. Linux is generally associated with web and database servers, but has become popular in many niche industries and applications.

Is it possible to do a social engine migration without cpanel or a myphpadmin?

This is the knowledge base article:

https://www.socialengine.com/support/article/5472314/se-php-moving-your-website-to-another-server

I'm moving from a windows 2008 machine to linux cento machine with no GUI installed (should I install this?) hosted on Azure

I migrated the database and set the configuration parameters in the database.php files but when I try to open the community site in the browser, I get the generic "something is wrong page" and in the error logs there is a bunch of .php errors

Not sure what to do, the KBA mentions to open up cpanel/phpadmin, I don't really have that on my centos environment, is there a way to work around this?
0
Hi Experts,

we have two old DCs in the network -> WIN2008R2.
Now we have 2 new DCs (2016) in the network.
We like to demote all old DCs (2008).
And we have many linux servers in the network.

First try, we demoted the old DCs from the network.
After that, the linux server and services had major problems to connect again.

Can you help me out to find out why this happens ?
0
Hi Linux experts,
could you help what is the best way to quickly or fastest way to find files with number range please. Basically need to copy files between 4000 and 5000 range.

Since this directory is huge, so my below command takes very long time to execute :)

for i in My_liferay_{4000..4005}*csv; do echo $i; done

Files
My_liferay_4000_1_51.csv
My_liferay_4001_1_52.csv
My_liferay_4002_1_53.csv
.
.
My_liferay_5000_1_60.csv

Open in new window

0
Failed to open a session for the virtual machine Ubuntu.

Call to VidMessageSlotMap failed: Last=0xc000000d/87 (VERR_NEM_VM_CREATE_FAILED).

Result Code: E_FAIL (0x80004005)
Component: ConsoleWrap
Interface: IConsole {872da645-4a9b-1727-bee2-5585105b9eed}
VBOX.LOG
0
I need assistance to write shell script to resolve guess number game, called “guess.sh" this shell script will use  guess2  program  which written by C Program to generate a secret number and shell script “guess.sh” will ask user to guess a secret number which generated by guess2 program .
0
I have specified underscore ( _ ) character to show for space.  :set listchars=eol:$,nbsp:_,tab:>-,trail:~,extends:>,precedes:<

In file opened in vim,
I see end of line character as $
I see tab character as >-
but I don't see underscore space character

 50 addtask listtasks$
 51 do_listtasks[nostamp] = "1"$
 52 python do_listtasks() {$
 53 >-import sys$
 54   print('Hello World')$
 55 >-for e in bb.data.keys(d):$
 56 >->-if d.getVarFlag(e, 'task', False):$
 57 >->->-bb.plain("%s" % e)$
 58 }$

Open in new window


I changed my background from Black to White but I still don't see space character?
0
When I reinstall Ubuntu I was going to move my SSH Keys to that machine.

They are GPG encrypted and stored on a USB Drive that is Luks encrypted.

When I reinstall Ubuntu can I just decrypt id_rsa and id_rsa.pub and move them into

~/.ssh/

Open in new window

?
0
Hello I've got an Ubuntu 16.04 server that I've installed AIDE on.  I've confirmed that it installed and is running with the following command

sudo apt list aide

Listing... Done
aide/now 0.16~a2.git20130520-3 amd64 [installed,local]

However there isn't an AIDE directory in /etc so there is no aide.conf file either.  Does something else need to be done?
0
Hi
I have a comma separated values in two variables, would like to compare both variables and get values which are available in both variables.

leftString="ami-06bc7b1fd6d88be49,ami-04db3b64b5f3990dd,ami-0063dd4d697377715,ami-01f8ea3141121cda4,ami-083a15980f7fcf2ad,ami-0b22b5f710211"
rightstring="ami-023d322923f1bb271,ami-0390dfc7d966ce65d,ami-04db3b64b5f3990dd,ami-05f492333c31e3971,ami-066e692403bb98cd3,ami-06bc7b1fd6d88be49,ami-07ebe2d3da06f1831,ami-0a621c6a67fc67a3f,ami-0afa5ade0d61726ef,ami-0b41712d2aef56be1,ami-0f0b1e112bdf5034f"

Open in new window


what we are expecting in the final variable as below..since they are in both.
compareString="ami-06bc7b1fd6d88be49,ami-04db3b64b5f3990dd"

Open in new window


thanks in advance
0
How can we configure pam.d in freebsd to let a user login using ssh private/public key pair with having the user exist in /etc/passwd ( like in local system ). I meant user is not created in system but authentication can be done via public/private key of sshd. Pleas let me know if there is a way.
0
Hi experts.

could you kindly help....how to get current date - 45 days in below format please

Basically would like to go back 45 days

YYYY-MM-DD
0
Hello,
I want to log all rysylog I configure and everything is fine.
I create a new template that is:
template(name="stdSQLformat" type="string" option.sql="on" string="insert into SystemEvents (Message, Message2, Facility, FromHost, Priority, DeviceReportedTime, ReceivedAt, InfoUnitID, SysLogTag) values ('%msg%','%msg:R,ERE,0,DFLT,1:([0-9]+\.){3}[0-9]+[:]?([0-9]+)?"--end%', %syslogfacility%, '%HOSTNAME%', %syslogpriority%, '%timereported:::date-mysql%', '%timegenerated:::date-mysql%', %iut%, '%syslogtag%')")
but when I run rsyslog I get:
error during parsing file /etc/rsyslog.d/mysql.conf, on or before line 8: invalid character '"' in object definit
I know that the problem is with
%msg:R,ERE,0,DFLT,1:([0-9]+\.){3}[0-9]+[:]?([0-9]+)?"--end%
but I don't understand what I have to do !
thanks.
0
We tried to move current mySql DB out of Linux system
partition by following the instructions in the links below
but mySql gave an error after migration:

https://www.digitalocean.com/community/tutorials/how-to-change-a-mysql-data-directory-to-a-new-location-on-centos-7

& how do I change the location of the data directory? (Doc ID 1023178.1)
https://www.digitalocean.com/community/tutorials/how-to-move-a-mysql-data-directory-to-a-new-location-on-ubuntu-16-04#step-3-%E2%80%94-configuring-apparmor-access-control-rules

# systemctl start mysqld
Job for mysqld.service failed because the control process exited with error code. See "systemctl status mysqld.service" and "journalctl -xe" for details.

DBA colleague told me there's not much of a clue from journalctl -xe
We're on RHEL 7.   Have also tried to create soft links to new partition
but it did not work.

What's missed?
Hopefull don't have to export all data out, recreate DB & re-import:
we don't want this option
0
Sometime's when logging into our Ubuntu server we get "Signature not found in user keyring" other times we don't.  Does this pose any kind of security issue, or any other issues?
0
Ive got a server running Nagios, and I want to post its logs onto another site. Ive been trying to figure out a way I can post the results by modifying the code, but it seems not to be a great idea with updates, then I thought I could monitor more log files, so it wouldnt be great to modify each program to do it.

So, my next idea was to monitor the log file, and post the results. I can use the command:-
sudo less +F  /var/log/nagios/nagios.log

Open in new window

But it echos out onto the main console. Is it possible to post the changes to the log file to a webpage using a curl script?

Thank you
0
In my apache 2.4 configuration httpd.conf file I have port forwarding and reverse proxy configurations. However it looks like I'm getting foreign spammers trying to forward use my apache to forward to their malicious sites.

I've already set override to this:
<Directory />
    AllowOverride All
    Require all denied
</Directory>

I also set the logs from %h to %{X-Forwarded-For}i (to see the ip addresses)

I see the ip addresses and I put the deny of the website in .htaccess file but I'm still getting a lot of logs from the spammer.

How do I prevent spammers and from spammers blowing up my log files in apache?

Here is an example from my access_log and error-logs

access log:

- - - [10/Jan/2020:00:10:23 +0000] "GET http://www.qyl788.com:777/js/main.min.js?e81cf HTTP/1.1" 302 - "http://www.qyl788.com/" "Mozilla/5.0 (X11; U; Linux x86_64; en-US) AppleWebKit/534.16 (KHTML, like Gecko) Ubuntu/10.10 Chromium/10.0.648.127 Chrome/10.0.648.127 Safari/534.16"
- - - [10/Jan/2020:00:10:36 +0000] "GET http://www.qyl788.com:777/js/main.min.js?1b3038fb98e71c3c8597d2f5ae580 HTTP/1.1" 302 - "http://www.qyl788.com/" "Mozilla/5.0 (X11; U; Linux i686; fi-FI; rv:1.9.0.9) Gecko/2009042113 Ubuntu/9.04 (jaunty) Firefox/3.0.9"

error log:

[Fri Jan 10 01:16:57.258926 2020] [access_compat:error] [pid 74944] [client 115.236.23.214:62608] AH01797: client denied by server configuration: /var/www/html/TP
[Fri Jan 10 01:16:57.596460 2020] [access_compat:error] [pid 74945] …
0
System used to work perfectly. GUI comes up type root, ENTER, password ENTER, done
Now I get Sorry that didn't work. Try again.
No amount of tried will get me logged in.

Followed the below instructions to a T. No joy. I really don't want to spin up a new VM and load my utilities again. Any way to fix this>

How to Reset your Forgotten Root Password in Kali Linux 2019.2?

Step 1: Restart your Kali Linux, and when your computer boots up to Grub menu, use your downward arrow key to highlight 'Advanced Options for Kali/GNU linux', and then hit Enter key on the keyboard. 

Step 2: Highlight 'Recovery Mode', and then Press 'e' key on the keyboard.

Step 3: Now, On the Next Screen, Go to line linux and replace 'ro' with 'rw'. Also, go to the end of the line linux and then hit space key, and then type init=/bin/bash. Press 'f10' key (if you are using laptop, press fn + f10 key) on the keyboard. 

Step 4: Type command below to change password

        passwd root

and then hit enter. Type your password, and then hit Enter. Again, Re-type the password, and hit Enter. you will see the message, password updated successfully.

Step 5: Now, use the command below to reboot kali linux.

        reboot -f 

and then, hit Enter. 

Step 6: Let kali linux restart normally, and when you see login screen, enter new password. You will be able to login with that.

It's done 

Open in new window

0
I have a client where we just upgraded from Server 2008 to server 2016. They use remote desktop on this server (and did on the 2008 box.) The screen on the remote clients (which are primarily Puppy linux 6.0.5) was fine on the 2008 box. On the 2016 box, the background is black with the mouse cursor also being black.  They are using rdesktop for the rdp client.

If the user who logs on has admin rights, everything is fine. If they are just a standard user then the screen is black on black.

On another linux box that's built on Linux mint and uses remmina for the desktop client, that's fine as well regardless of whether the user is admin or standard.

I've tried adjusting the group policies without any luck.

Anyone have any ideas on what the problem might be or how to adjust this?

Thanks in advance for the assistance.
0
Using Wordpress on a LAN (ip range 10.0.0.x/8) on Ubuntu 18.04. I'm trying to upload a plugin but keep getting a message that I can't because it exceeds the 2Mb file size limit as set in php.ini. What I've done up to now is to edit the htaccess file (it needed creating), the php.ini file (also needed creating) and the wp-config.php file. All the files are owned by the administrator user and have the appropriate rights - I think. chmod 777 applied across the lot. However phpinfo,php still reports the max file upload size as 2Mb, the file attached has the details outlined above. Is there anywhere else this value is being set? I've grep'ed the entire site and can't find a relevant response, it's mentioned but only as a reference.
file-upload-code.docx
0
i add windows pc and client in freeipa domain. all is ok except for windows is very slow. My windows is vmguest in xenserver.
when i ask for cmd or powershell or something like that it's take 2-5 min to open program after opening is everything ok.
what should i do?
my windows has 4 cpu and 16 gig mem.
what is wrong?
0
I remotely connect to Linux virtual box from secure shell (ssh).  I have smallest bitbake project.

I type bitbake from shell prompt.  
The output is as follows:
Nothing to do.  Use 'bitbake world' to build everything, or run 'bitbake --help' for usage information.

Bitbake document says default build task will be executed.
build default task is in Base.bbclass file.

How can I be sure this task actually executed?  How do I print something to the screen from this task?
base.bbclass
bblayers.conf
bitbake.conf
layer.conf
0
After installing the Centos 8 and ssh to the server, it tells me that the server is using v1. How to upgrade my Centos to use v2 ?

Thx
0
OS: Centos 7
Following tutorial @5:00: https://www.youtube.com/watch?v=KgfljMtrKkI
I get a linker error after compiling this code. What steps do I have to take to build this program?
The author indicated that this is for 32-bit code; and later he may do a series on 64-bit. I am guessing that I am having a 32-bit/64-bit issue here.
I saw a comment that may shed some light:
"I had to run apt-get install gcc-multilib to compile 32 bit on ubuntu."
global main
extern printf

section .data
  msg db "Testing %i...", 0x0a, 0x00

main:
;*** prologue - preserving stack, registers, and allocating space ***
  push ebp      ; preserve caller's ebp (base pointer) value
  mov ebp, esp  ; ebp holds the top of the stack
;*** END prologue - preserving stack and allocating space ***

  push 123
  push msg
  call printf
  mov eax, 0

;*** epilogue ***
  mov esp, ebp  ; restore the top of the stack (effectively deallocates the stack)
  pop ebp       ; restore the caller's ebp value
  ret
;*** END epilogue ***

Open in new window

Configuration:
$ uname -a
Linux localhost.localdomain 3.10.0-1062.9.1.el7.x86_64 #1 SMP Fri Dec 6 15:49:49 UTC 2019 x86_64 x86_64 x86_64 GNU/Linux

$ nasm -v
NASM version 2.10.07 compiled on Jun  9 2014

$ nasm -felf -y

valid debug formats for 'elf32' output format are ('*' denotes default):
    dwarf     ELF32 (i386) dwarf debug format for Linux/Unix
  * stabs     ELF32 (i386) stabs debug format for Linux/Unix

$ gcc --version
gcc (GCC) 4.8.5 20150623 (Red Hat 4.8.5-39)

$ whereis crt1.o
crt1: /usr/lib64/crt1.o
$ which crt1.o
/usr/bin/which: no crt1.o in (/usr/lib64:/usr/local/bin:/usr/local/sbin:/usr/bin:/usr/sbin:/bin:/sbin:/home/user/.local/bin:/home/user/bin)

Open in new window

The error:
$ nasm -f elf32 ex10.asm -o ex10.o
$ gcc -m32 ex10.o -o ex10
/usr/bin/ld: cannot find crt1.o: No such file or directory
/usr/bin/ld: cannot find crti.o: No such file or directory
/usr/bin/ld: skipping incompatible /usr/lib/gcc/x86_64-redhat-linux/4.8.5/libgcc_s.so when searching for -lgcc_s
/usr/bin/ld: cannot find -lgcc_s
/usr/bin/ld: cannot find -lc
/usr/bin/ld: skipping incompatible /usr/lib/gcc/x86_64-redhat-linux/4.8.5/libgcc_s.so when searching for -lgcc_s
/usr/bin/ld: cannot find -lgcc_s
/usr/bin/ld: cannot find crtn.o: No such file or directory
collect2: error: ld returned 1 exit status

Open in new window

0
Dear Gurus
We are planning to have a 10 TB capacity Oracle 12 C Database hosted on a Virtual BL660 servers.
Typically the number of users/apps who will connect is around 200 max at any given time.
Was looking to find out how much vCPU and vRAM should I request for the same.

IS there any simple thumb rule to follow for this.?

Thankyou.
Flex
0
I installed SUSE Enterprise 11 just so I can extract drivers from an ISO file using special commands from the ISO itself. The pre-requisites are openssl and squashfs-tools to be installed which I'm having issues with since I never installed anything on linux before. Both are copied to my desktop openssl 1.02 and squashfs-tools-4.3-x86_64.pkg.tar.xz and txz.

Here's an error I get without the pre-reqs:
~/Desktop/ucs-c220-huu-3.0.4l/GETFW> ./getfw -s /home/myname/Desktop/ucs-c220-huu-3.0.4l.iso -d /tmp/
Error: Extraction Failed

I also get an error installing openssl when at the "make" line
  tar -xvzf openssl-1.0.1g.tar.gz
  cd openssl-1.0.1g
  ./config --prefix=/usr/
  make
  sudo make install

Makefile:287: recipe for target 'build_crypto' failed
make: *** [build_crypto] Error 1
 
And not sure how to install squash either.

Thanks in advance
0

Linux

66K

Solutions

33K

Contributors

Linux is a UNIX-like open source operating system with hundreds of distinct distributions, including: Fedora, openSUSE, Ubuntu, Debian, Slackware, Gentoo, CentOS, and Arch Linux. Linux is generally associated with web and database servers, but has become popular in many niche industries and applications.