We help IT Professionals succeed at work.

Linux

66K

Solutions

33K

Contributors

Linux is a UNIX-like open source operating system with hundreds of distinct distributions, including: Fedora, openSUSE, Ubuntu, Debian, Slackware, Gentoo, CentOS, and Arch Linux. Linux is generally associated with web and database servers, but has become popular in many niche industries and applications.

I am having an issue with sudo on RHEL.

I have a domain account that has been given sudo rights. However I cannot sudo commands (e.g. sudo netstat -ltnup | grep -E ':80') unless its a sudo su - command.

The resulting error is as follows:

Sorry, user [abc] is not allowed to execute '/bin/netstat -ltnup as root on [hostname.domain] 

Open in new window


Can anyone offer a solution please?
0
I have a virtualized Ubuntu environment. One of my servers allows SSH from the LAN but not the WAN. When I SSH to this server it responds with access denied.  I have other ports open on this server that I can access with no problems. What logs should I look at to determine why I can not SSH from the WAN
0
I woke up this morning and my AWS Linux EC2 instance running Wordpress is showing just the Apache test page. I have Wordpress installed on this site and it's been up and running for about a week or so.

Here's a few things I've done to resolve this:

  • Restarted Apache
  • Confirmed MySQL is running
  • Restarted the EC2 Instance from the AWS Management Console

Anything I missed? I'd love to save my work and show it to the world.

The URL is http://coparent-coach.com

Thank you for your assistance.

....
0
HI Experts,

Have an AWS Instance and I would like to manage them using AWS CLI.

So I was able to install, configure, and setup aws cli on linux and able to stop/start a particular instance using CLI.

my request here is
Since I have this as part of a CDCI Jenkins Pipeline...When starting an instance, would like to
  1. Ensure instance is fully up and running.
  2. Required services are up and running as well (e.g. jenkins, docker, etc)
  3. Before I trigger downstream job.

Could you pls help what is the best way to achieve this. I'm not restricted to AWS CLI, we can also try boto3 as well if we have more control over there.

thanks in advance
0
I am unable to roll back my recent updates.

[root@ansible ~]# yum history
Loaded plugins: product-id, search-disabled-repos, subscription-manager
ID     | Login user               | Date and time    | Action(s)      | Altered
-------------------------------------------------------------------------------
     7 | root <root>              | 2018-02-28 13:11 | Erase          |    2
     6 | root <root>              | 2018-02-27 18:12 | I, O, U        |  309 EE
     5 | root <root>              | 2017-11-18 12:57 | I, U           |   32
     4 | root <root>              | 2017-11-16 01:13 | Install        |   33
     3 | root <root>              | 2017-11-16 01:10 | Install        |   23
     2 | root <root>              | 2017-11-05 10:37 | Install        |   13 E<
     1 | System <unset>           | 2017-11-05 10:01 | Install        |  385 >
history list


[root@ansible ~]# yum history undo 6
Loaded plugins: product-id, search-disabled-repos, subscription-manager

..........(output omitted)
---> Package zlib.i686 0:1.2.7-17.el7 will be erased
--> Processing Conflict: kernel-3.10.0-693.17.1.el7.x86_64 conflicts kexec-tools < 2.0.14-3
--> Finished Dependency Resolution
Error: kernel conflicts with kexec-tools-2.0.7-50.el7.x86_64
 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodigest
0
Have you tried Windows Susbsystem for Linux yet? I'm curious what your thoughts are. Do you have any tips and tricks before I start using it?
0
Hello,
i have a web application that is work on wamp on windows server and its work fine, i moved the application folder to linux ubuntu 16.4 with apache.
i see the permission and apahe config.
when i try to open the application is't give me 404 page not found
under ci log the error is page not found index
so where is the problem?
thanks.
0
I’m creating a clone of open.spotify.com.

The site will stream live concerts of bands that allow taping.

I have a Dell Poweredge T310 with 8TB of space and 32 GB of RAM,

I was going to put this in a data center as VPS don’t have as much space and are expensive.

Is this an acceptable solution?
0
I've been sending and getting files using Linux sftp to various providers for many years. The scripts to do this are batch/unattended and utilize a public key for authentication.

A few days ago, this mechanism stopped working with one of the information providers. They said I needed to install a certificate on my end. I've never installed a certificate for this process for either this provider or any other. I'm puzzled as to where I should install this certificate and how sftp is to reference it. I see not command line parameters for specifying a certificate. I'm thinking the provider is mistaken that I need such a thing, but I want to confirm one way or another before I say anything.
0
hi Experts,
Can someone help me to take mysql incremental backup using mysqldump? All my databases are on AWS RDS, so bin logging is not possible.
0
i have nagios core version 4.3  installeret på server ubuntu 16.04 . and nrpe version 3 og plugin 2.2.1 from client. on ununtu 16 and 14.
alle works . except for one ubuntu 16.04 i have error connection reset by peer )from nagios server)
from client when i say
./check_nrpe -H ipadress        then connection reset by peer
./check_nrpe -H 127.0.0.1       working  NRPE 3.2.1
./check_nrpe -H localhost    connect to address ::1 port 5666: Connection refused
NRPE v3.2.1

i have disabled = no on /etc/xie../nrpe
and  only_from       = 127.0.0.1 client-ip  server-ip

from /usr/local/.../nrpe.cfg
allowed_host = 127.0.0.1,::1,client-ip,server-ip

like all other 16.04 and 14.04.
what is wrong?
0
I am using an .htaccess file with Helicon Ape on a Windows server to do URL redirects. I have the following code in .htaccess which was on an older Linux server and was working:

RewriteEngine On

Redirect /berks-ham-steak-parmesan/ http://www.domain.com/recipe-ham/?id=38

Open in new window


However, on the Windows server with Helicon Ape, it does not work, and I see this message in the logs:

[2018-02-27 19:46:18.883] [ConfigLoader:85] (error) [/_ape_start_developer_session] d:\domain.com\wwwroot\.htaccess(28): Invalid command 'Redirect /berks-ham-steak-parmesan/ http://www.domain.com/recipe-ham/?id=38' on line 28, perhaps misspelled or defined by a module not included in the server configuration

Open in new window


Is there some other way I should be handling Redirect? Is that no longer a valid command, or is it an incompatibility with Helicon Ape?

Thank you.
0
HPE Smart Array controller P408i-a G10 ML350 Proliant Server, 12 core, 4x SAS 600GB 10K HDDs in a Raid5. Would using an SSD drive for SR Smartcache on a VMWare configuration with 3 VMs benefit performance? Does this SR Smartcache work in some configuration and not others? VMs include WS16 RDS, OES Linux Server, WS16 WebServer. VMWare will be loaded onto a HPE Micro Secure 32GB Digital Card.
0
Our company has been growing in the last few years and requires us to upgrade our systems a bit. We are on a local domain, we will call it mydomain.local, and use Windows Server 2012 R2 currently as our domain controller. One of the projects I was put onto was to remove all file shares from our domain controller and put them on a file server so our domain controller can do only that. So my solution was to use a Linux based system to store our files. one of our hired IT guns suggested I go with FreeNAS as an OS for this file server. So I took his advice and here we are.

Just Installed the latest version of FreeNAS on the new server build.  The DNS Hostname for the new server is "filesvr" Everything installed great,  and I can see it on the network. I can login to the web GUI fine. Seems to be a very robust operating system.  When I first logged into the web GUI it had me go through a wizard for setup. One of the wizard steps was to create a list of shares for SMB. Which I did, the three shares are "public", "engineering" & "accounting". We also run a mixture of Windows 7 Pro and Windows 10 Pro Work Stations. All of these workstations have been slowly updated to Windows 10 Pro which is the majority of machines now. When I goto a Windows file explorer session, and put this in the address path, "\\filesvr", I get the three shares that I created. This is where I'm having an issue when I click on the share, it comes up with a Windows Security Dialog which asks's me to enter …
0
I just stood up a new Apache server on a Ubuntu 14.04 VM.   My consultant requested this.   I am trying to get SSL to work and I'm stuck.   the site works if I access over http:// however   Every time I access the URL with https:// I'm getting

This site can’t provide a secure connection
authorize.mpbio.com sent an invalid response.
Try running Network Diagnostics.
ERR_SSL_PROTOCOL_ERROR

Here is the .conf file.   I'm lost on figuring out why it's not working.  

Any help is greatly appreciated.  I'm sure the solution is something simple.

Thanks in advance.  

<VirtualHost *:80>
        ServerName mysite.com
        ServerAlias server.mysite.com
        ServerAlias dev-app-2
        DocumentRoot /var/www/vhosts/xxxxx
        <Directory /var/www/vhosts/xxxxx>
                Options -Indexes +FollowSymLinks -MultiViews
                AllowOverride All
                #Order deny,allow
                #Allow from all
                Require all granted
        </Directory>
        CustomLog /var/log/apache2/xxxxx.log combined
        ErrorLog /var/log/apache2/xxxxx-error.log
        # Possible values include: debug, info, notice, warn, error, crit,
        # alert, emerg.
        LogLevel warn
</VirtualHost>
<VirtualHost *:443>
        ServerName mysite.com
        ServerAlias server.mysite.com
        ServerAlias dev-app-2
        DocumentRoot /var/www/vhosts/xxxxx
        SSLProtocol all -SSLv2 -SSLv3
        SSLEngine on
        …
0
I’m creating a online bill pay software.

I was wondering should I write a script and call it from a cron job to bill clients monthly and add a late fee?

Please let me know if this is an acceptable way to write the software.
0
Is it possible to build my new server and install the SSL while my existing server continues to use the SSL? Both are using Apache.

Example: I am running mystore.com and using GoDaddy economy Linux. I want to move the magento site to FastComet Virtual Private Server (VPS), but I need the SSL in place for things to work. Can I copy my site to FastComet, then have them issue a new SSL to myStore.com on the new Linux VPS without invalidating the SSL cert on my existing GoDaddy eco Linux?

Is it easier to just copy the SSL cert from GoDaddy eco Linux to the new Linux VPS in FastComet?

The goal is to have everything ready so on the evening of the cutover, we just change DNS, then everything magically works since the new Linux server is already built.
0
4 x Store Virtual  3200 SANs are being returned because they're terrible.  We need the ability to wipe 44 SAS 2.5" disks within a reasonable amount of time.  The platform for the storage controllers is a dual redundant/HA flash storage controller which uses two SD cards to write data on for the appliance OS.  I'd like to live boot some linux and just DD the drives, but I'm not even sure how to.  Anyone have any ideas?
0
I am getting no help from IBM.  I need iAccess for Linux and can't find it.  I need it for a Debian (Ubuntu) computer.
0
Erro with unix query

grep -C20 'contactNumber before is------>'  *

above grep command gives below error message
grep: diagnostic_images: Is a directory
grep: jmsservers: Is a directory

what it means?

please advise
0
how to use Haproxy to publish an internal SFTP server.
0
Hi Experts,

I'm trying to install a php application on Bluehost, which I belive is Linx, but I keep getting

Warning: Cannot modify header information - headers already sent by ...

I'm not getting this on IIS. I tried fixing this by adding the following line, but the error perssists.

ini_set('output_buffering', 4096);

Open in new window


Any help will be appreciated.
0
i have sftp install in ubuntu 16.04 hwo to disabled user to has a ssh login. user has only sftp login not ssh login.
0
Hi

Problem Mounting NFSV3 share from IBM Mainframe uss.
We are providing a NFSV3 share on a redhat linux. We want to mount the Share with nfs client on the IBM Mainframe USS and we are getting the following error
 Async mount proceeding for OURSHARE.MOUNT.POINT
 Asynchronous mount failed for OURSHARE.MOUNT.POINT
 mount error: 0000045E 6E030007
OURSHARE.MOUNT.POINT
ENETUNREACH: Network is unreachable

The root cause is NOT: http://www-01.ibm.com/support/docview.wss?uid=isg1OA05806

There is no FW between the two systems.

Any help would be very appreciated
0
grepping a xyz.tar.gz file?

how to grep a xyz.tar.gz file on unix box?

i moved it to loical using winscp.

how to extract it to see file contents

i used qizip and 7 zip they simply changing zip to tar and then tar to zip again and again

please advise
0

Linux

66K

Solutions

33K

Contributors

Linux is a UNIX-like open source operating system with hundreds of distinct distributions, including: Fedora, openSUSE, Ubuntu, Debian, Slackware, Gentoo, CentOS, and Arch Linux. Linux is generally associated with web and database servers, but has become popular in many niche industries and applications.