We help IT Professionals succeed at work.

Linux

66K

Solutions

33K

Contributors

Linux is a UNIX-like open source operating system with hundreds of distinct distributions, including: Fedora, openSUSE, Ubuntu, Debian, Slackware, Gentoo, CentOS, and Arch Linux. Linux is generally associated with web and database servers, but has become popular in many niche industries and applications.

I accident deleted one of the accounts on OpenLDAP and now the files/folder in my NFS and Isilon are all messed up. I need to search for folders/files with UID 3015 and change <user> account as owner. The problem is that there are too many files and folders that were changed because the account doesn't exist any more. Is there a script or command I can run to search for folder/files with <ID> then change <user> account as owner

For example:

drwxrwsrws.     3   3015   neuro     28 Dec 19      subject_5002

Need to change 3015 to <user> account
0
I'd have a *nix box sitting on the open internet with an L2TP tunnel to our LAN (PFSense router). Everything works fine as is but I'd like to be able to use the multiple public IPs I have available on the *nix machine to route / NAT traffic into our LAN (in effect having multiple public IPs to play with, both inbound (mainly)/outbound.
I feel relatively comfortable with our router but I am seeking advice about the "edge" machine, with the understanding that it has to be some Linux distro. What tools would you use to configure such a setup ?

Any suggestion / pointer welcome
0
What does it mean in Ubuntu after entering command in terminal, no output just blinking cursor?  I'm trying to find directories that don't have a valid group owner using the following command  sudo find / -nogroup
0
Hi,

I would like to know how to do a network setting on VMWare Workstation.

Conditions:
■Windows 10 Pro (64bit)
■VMWare Workstation 15 Pro (Ver 15.5.1)
■Added 2 NIC cards on the PC (ST1000SPEX2L)
■Installed "Realtek - Ethernet Diagnostic Utility"
■Two Linux Virtual machines are on VMWARE Workstation

Here are what I would like to do:
*Please refer to the attachment file.
1)  Each Linux machine needs to connect with "Specialized Monitor"s using PC NIC 2 or 3.
2) There two monitors need to connect to "Central Server" through internet access using PC NIC1 in order to download "program".l
3) There is a network setting of the Linux machine:  two Ethernet Network Card (for global and private address)

I am not sure how to do the setting:
1) "Network adapter" setting on Virtual machine.
     Should I config using Bridge with physical network connectivity. Is so, which of the "VMnet" number should I use?
      How about another virtual machine setting? what is the difference? what is  "VMnet" number?
 
2) "Virtual Network Editor" setting:
      How I should configure on here? VMWare-Workstation---2-VM-connecting.pdfLinux Network card setting       ex.  VMnet 0 and VMnet 1 are configured as Bridge and connecting to PC NIC 2 and 3...

3)  "Realtek - Ethernet Diagnostic Utility"
    I assigned VLAN ID 2 as PC NIC2 and VLAN ID as PC NIC3 for now.


I appreciate it if you can tell me the step by step instruction. If you have the VMWare Workstation screenshots, that will be helpful.
0
I am running Amazon Linux with Apache (for a Wordpress installation) and I'd like to redirect all traffic to the "WWW" instance of my site.

So, if someone types in "sitename.com" I'd like Apache to redirect them to "www.sitename.com".

Thanks for your help
0
Hi

Probably an obvious one but for the life of me I can't seem to find the right syntax for the lvextend command under ubuntu 16.04.6:
someadmin@tableau-sx-01:/dev$ sudo pvs
  PV         VG               Fmt  Attr PSize  PFree
  /dev/sda5  tableau-sx-01-vg lvm2 a--  59.28g 10.02g
someadmin@tableau-sx-01:/dev$ sudo lvextend –rl +100%FREE /dev/sda5
  Path required for Logical Volume "–rl".
  Please provide a volume group name
  Run `lvextend --help' for more information.
someadmin@tableau-sx-01:/dev$ sudo lvextend –rl +100%FREE /dev/sda5 tableau-sx-01-vg
  Path required for Logical Volume "–rl".
  Please provide a volume group name
  Run `lvextend --help' for more information.
someadmin@tableau-sx-01:/dev$ sudo lvextend –rl +100%FREE tableau-sx-01-vg /dev/sda5 
  Path required for Logical Volume "–rl".
  Please provide a volume group name
  Run `lvextend --help' for more information.

Open in new window


As you have guessed I am trying to resize /dev/sda5

What is the "correct" syntax ?
0
I have Ubuntu 18.04 LTS (64-bit) laptop.  Was it shipped with anti-virus software?  If not, what anti-virus do I need to install?

How to run full anti-virus scan?
0
Following are code snippets from python 3.6 standard library logging module, filename __init__.py

On line 1732, class RootLogger gets instantiated.  But on line 1733, what is Logger.root ?  dot notation is used with object name, not class name ?
On line 1734, what is Logger.manager ?  Again, why dot notation is used with class name ?

#--------------------------------------------------------------------------- 
1250 #   Logger classes and functions
1251 #---------------------------------------------------------------------------
1252 
1253 class Logger(Filterer):
1254     """
1255     Instances of the Logger class represent a single logging channel. A
1256     "logging channel" indicates an area of an application. Exactly how an
1257     "area" is defined is up to the application developer. Since an
1258     application can have any number of areas, logging channels are identified
1259     by a unique string. Application areas can be nested (e.g. an area
1260     of "input processing" might include sub-areas "read CSV files", "read
1261     XLS files" and "read Gnumeric files"). To cater for this natural nesting,
1262     channel names are organized into a namespace hierarchy where levels are
1263     separated by periods, much like the Java or Python package namespace. So
1264     in the instance given above, channel names might be "input" for the upper
1265     level, and "input.csv", "input.xls" and "input.gnu" for the sub-levels.
1266     There is no arbitrary

Open in new window

0
I have an Ubuntu server running 10.04.6 LTS.  It is providing web services.  I have setup sftp and given permission to an 'sftp' group to login but have set their root directory to be /var/www/html.  They are able to connect to the server but cannot write to the folder.  I use setfacl to give the group write permission.  If they are already logged in, they can now create folders and files.  However, once they logout, they can no longer login.   If I remove the acl, the condition reverses again.  It is not limited to acls though.  I even tried just giving 'other' write-access.  Same thing happened.

sshd_config snippet:
Match group sftp
ChrootDirectory /var/www/html
X11Forwarding no
ForceCOmmand internal-sftp

Error when trying to write:
Permission denied.
Error code: 3
Error message from server: Permission denied

Error when trying to login (from session log):
! 2019-12-11 08:23:42.538 Using username "ddinkin".
. 2019-12-11 08:23:42.569 Server offered these authentication methods: publickey,password
. 2019-12-11 08:23:42.569 Prompt (password, "SSH password", <no instructions>, "&Password: ")
. 2019-12-11 08:23:44.955 Sent password
. 2019-12-11 08:23:44.963 Access granted
. 2019-12-11 08:23:44.963 Opening session as main channel
. 2019-12-11 08:23:45.127 Network error: Software caused connection abort
* 2019-12-11 08:23:45.181 (EFatal) Network error: Software caused connection abort
* 2019-12-11 08:23:45.181 Authentication log (see session log for …
0
Hi All,

Iam running a progrm wrtten in c++ program executable  in linux operating system and getting Core Dump error while runnning it. Iam using Linux operating system. Can anyone help how to analze the core dump file to figure out the cause of the issue.
I was told to use the  valgringd and bt command  ,but need help how to use these commands and debug the issue in the core dump file. iam very new to this type of error. Any help is really appreciated.
Also can I run the process using valgrind command?
0
I have vim version 8.0 editor.  I want to copy code snippets from vim editor and paste them in windows applications.
I don't have clipboard and xterm_clipboard support in my vim.

How do I copy code (including line numbers) from vim editor to windows applications?
0
i upload a folder to nextcloud on ubuntu (lxd)(just drop folder in webpage) all file is uploaded except for .files (hiden file).
How to upload hiden file where is it to accept which file extension is ok to upload. (i want to accept all type files).
1
Hi all i am currently going made trying to move my python project to a linux server,
1. i have got the mysql  database one there
2. i am trying to install all on the modules but having some issues i am trying  to get pip3 install parse , it tells me it works but it still comes up with a error when i run the python
3. i tried sudo pip3 install urllib
Collecting urllib
Exception:
Traceback (most recent call last):
  File "/usr/lib/python3/dist-packages/pip/basecommand.py", line 215, in main
    status = self.run(options, args)
  File "/usr/lib/python3/dist-packages/pip/commands/install.py", line 353, in run
    wb.build(autobuilding=True)
  File "/usr/lib/python3/dist-packages/pip/wheel.py", line 749, in build
    self.requirement_set.prepare_files(self.finder)
  File "/usr/lib/python3/dist-packages/pip/req/req_set.py", line 380, in prepare_files
    ignore_dependencies=self.ignore_dependencies))
  File "/usr/lib/python3/dist-packages/pip/req/req_set.py", line 554, in _prepare_file
    require_hashes
  File "/usr/lib/python3/dist-packages/pip/req/req_install.py", line 278, in populate_link
    self.link = finder.find_requirement(self, upgrade)
  File "/usr/lib/python3/dist-packages/pip/index.py", line 465, in find_requirement
    all_candidates = self.find_all_candidates(req.name)
  File "/usr/lib/python3/dist-packages/pip/index.py", line 423, in find_all_candidates
    for page in self._get_pages(url_locations, project_name):
  File …
0
Hello Guys,
i need your advice in this scenario, i've my company fileshare on EMC vnx5500 and work on it using nas and using the cifs permissions for users and it works fine in the management for users, we made an upgrade to using vxrail and in my company thinks if we made an linux machine and use it as file share service and attach new lun for it for transfering the data from the vnx to the new fileshare server, does this scenario aplicable and i need to know about the steps to make linux machine (ubuntu,centos,..) to allow me to gie cifs permissions not using nfs, also need to know about i we implement it what about the support if i face any problem.
Thanks
0
Dear Experts,

I'm currently using ffmpeg on RaspberryPi 4 (4 CPU, 4GB RAM, 16GB SD Card) for encoding bitrate from Camera (experimental environment).

As my first though when running encode process, from 1024Kbps input (Camera) to 512Kbps output (RaspPi4), the CPU consumption/ usage is quite a lot: 220->260% in the total 400% CPU Power (4 CPU).

This is my encode command:
/usr/bin/ffmpeg -re -rtsp_transport tcp -i rtsp://testing:testing123@172.16.1.200:554/Streaming/Channels/101 -an -c:v libx264 -b:v 512k -strict experimental -flags +global_header -f flv rtmp://172.16.1.201:1935/RTMP/testing-storage

Open in new window


I just wondering if there is anything I could do to reduce this CPU consumption.
And if i keep using that RaspPi with that much CPU, how long till it go down? What I mean is, can we calculate the attenuation, and the time the device can be used with such a load?

Many thanks for reading this Experts.
0
nginx on ubuntu 16.04 not redirect permanently.
i running nginx version 1.12.2
my ssl  page not working and  curl -I  http://webserver.com says
HTTP/1.1 302 MOves Temporrarily

i have the same on other ubuntu exactly same nginx and no problem. what is wrong?
0
Hi all i have a question i am hoping you can help with, i have been working on a python project on a dev windows system and now i want to move it to a production linux system what will be the best way to do tis so i dont have to do allthe pip commands again
0
If we have a need to retain (can be in zipped/gz format) bsm
(Solaris Basic Security Module), what's the sizing of the partitions
recommended?

I know it depends on the amount of activity but suppose I
currently have 2GB left, how much more to extend?

BSM is merged with auditd logs
0
Bitbake is a python program. Following guide shows how to setup BitBake.
https://a4z.bitbucket.io/docs/BitBake/guide.html

Form Linux command prompt, I invoke bitbake by simply typing bitbake.  Since the location of this program is in PATH variable, bitbake runs. But how does python compiler know it's a python program.  Aren't python programs required to have .py extension?

filename:  bitbake
#!/usr/bin/env python3
# ex:ts=4:sw=4:sts=4:et
# -*- tab-width: 4; c-basic-offset: 4; indent-tabs-mode: nil -*-
#
# Copyright (C) 2003, 2004  Chris Larson
# Copyright (C) 2003, 2004  Phil Blundell
# Copyright (C) 2003 - 2005 Michael 'Mickey' Lauer
# Copyright (C) 2005        Holger Hans Peter Freyther
# Copyright (C) 2005        ROAD GmbH
# Copyright (C) 2006        Richard Purdie
#
# This program is free software; you can redistribute it and/or modify
# it under the terms of the GNU General Public License version 2 as
# published by the Free Software Foundation.
#
# This program is distributed in the hope that it will be useful,
# but WITHOUT ANY WARRANTY; without even the implied warranty of
# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
# GNU General Public License for more details.
#
# You should have received a copy of the GNU General Public License along
# with this program; if not, write to the Free Software Foundation, Inc.,
# 51 Franklin Street, Fifth Floor, Boston, MA 02110-1301 USA.

import os
import sys

sys.path.insert(0, 

Open in new window

0
How to create a PGP key in redhat linux? This key pair will use to encrypt and decrypt VCC Images.
0
Hi all i am trying to setup my ubuntu server so i can run my python scripts and when i try to install mysql-client or mysql for python i am getting a error
Command "/usr/bin/python3 -u -c "import setuptools, tokenize;__file__='/tmp/pip-build-nwk7rejx/mysqlclient/setup.py';f=getattr(tokenize, 'open', open)(__file__);code=f.read().replace('\r\n', '\n');f.close();exec(compile(code, __file__, 'exec'))" install --record /tmp/pip-10shw23u-record/install-record.txt --single-version-externally-managed --compile" failed with error code 1 in /tmp/pip-build-nwk7rejx/mysqlclient/

i have  tried good old google and all the ones i have found on there to try didnt work any help would be great
0
I have the following in a php file:

<?php
$output = shell_exec(dirname(__FILE__) . '/add_sku_to_get_flat_rate_quotes.sh');
?>

When I call that file from a browser, it is supposed to run this .sh command in another file in same dir:

me@myserver:~/public_html/mywebsite.com/symfony$ app/console myaccount:get_flat_rate_quotes sku 7017

Which is supposed to add that sku to a table. When I run that sh command from an SSH terminal, it works. What am I missing?

My web host confirmed shell_exec will work on my server.
0
On a linux server when I source ping out the interface (using 1.1.1.1 as source port of linux box)
ping -c3 -N 1.1.1.1 2.2.2.2
PING 2.2.2.2 (2.2.2.2): 56 bytes of data
sendto: 5033
sendto: 5033
snedto: 5033

I can ping 1.1.1.1 from 2.2.2.2
I can ping 1.1.1.1 from other interfaces
Question is what the 'sendto: 5033' response indicate?
0
We have 6 Linux servers with support activated on all servers. Out of the 6 servers 2 are test servers.
I bought 4 new servers and installed new version of Linux and I want to deactivate  support license from the 2 test servers and activate in 2 new servers.
How to use the same license and activate support in the new servers? We no longer need the old test servers.
0
I've installed several Linux distributions in virtual machines running under VMWare Workstation v15.5  [Elementary v5.0,  Linux Mint v19.2,  Ubuntu LTS v18.04.4,  and Ubuntu v19.10

NONE of them have sound when they boot up -- they all display the following message during the boot process:

Linux Sound Issue in VMWare
The "FIX" is very simple:   After the OS is running, just go to VM - Settings - Sound Card and click on the "Connected" box and all will be well.

But it'd be nice if this wasn't necessary.   Anyone know how to resolve it?
0

Linux

66K

Solutions

33K

Contributors

Linux is a UNIX-like open source operating system with hundreds of distinct distributions, including: Fedora, openSUSE, Ubuntu, Debian, Slackware, Gentoo, CentOS, and Arch Linux. Linux is generally associated with web and database servers, but has become popular in many niche industries and applications.