Mac OS X





Mac OS X is the desktop operating system from Apple Inc., found on Macintosh computers. OS X consists of a Mach/BSD-based kernel, operating system interfaces primarily based on FreeBSD and additional frameworks (written in C, C++ and Objective-C providing user interface and application-level services.

Share tech news, updates, or what's on your mind.

Sign up to Post

I want to see a list of files that are currently backed up by time machine while the backup is running.

Is there no backup log file (plain text) that is written to? Only database structure or special application internal information?

I would like to see what is going on...

Thanks a lot for your help

(running actual MacOs, Time Capsule).

I'm using iMac its new recently brought, installed office 2016.
Each program of Microsoft Office 2016are very slow (around 1mins) to start up.I tried to uninstall Microsoft Office and reinstall it.
no previous version office has been installed on the computer before.

Do you know what to do to fix it?

Thank you
On random Mac OS devices running Mojave (any version):

SOCKS proxy is automatically re-enabled after every reboot/power cycle.

By default, no proxy settings should be configured.

The proxy is configured with: localhost port 8080

This causes all email apps to go offline intermittently. Also it causes all web browsers to become "unable to load" any web page.

Once the proxy is manually disabled in Network Preferences; everything works fine.

How do I disable permanently?
Why does the SOCKS proxy auto enable after the device is power cycled?
Dear expert,

We are using o365  ProPlus on Mac and Win platform.
One of our user is using MacBook pro and suddenly his inbox became transparent like the attachment below. Only inbox folder is like this.
I have reinstalled the latest version then remove the cache of the outlook after that restart the laptop but nothing is changed.

Please help me
Hey all,

I have a wierd one here.. I have a client running 2012 R2 - this runs their file & print sharing, Active Directory and backup software. The IT officer that I deal with has been asking me to help him with an issue, which is the server goes offline and has no connectivity. The server remains on and the OS is in tact but the network card says "no internet" unidentified network.

DHCP is running through the firewall which is (Default Gateway / DHCP). Long story but we will leave that.. This firewall is around 8 years old btw so it could be the culprit and will be providing them with a test unit to see if we can narrow down but I haven't given you the curve ball yet.. wait for it.

Things we have tried;
  • Checked error logs at the time it drops and nothing pops up at the time of the drop out.
  • Testing all cables running from server, Tested OK.
  • Tested connecting to the Firewall LAN port, tested OK.
  • Swapped NICS from NIC4, to NIC3, NIC2 on the server and still no go.
  • Checked all the IP config is ok. (server) / / (gateway) / (DNS)
  • From a client's computer, provided a static IP address. Cannot connect to server or gateway so it does not see the network at all which is odd
  • We have swapped out to a new switch as a test which we will leave there for the time being
  • Checked DNS services, forwarders & entries are correct on the server
In Mac OS Mojave, I'm contending with lengthy delays in applying changes to network interfaces. Sometimes 60 seconds to apply a change to Service Order (i.e. move Ethernet ahead of wifi) or to configure a Static IP address.

The Network Pref window also appears blank when first loaded and takes a full minute to populate. (I have many network configs in my list)

When preparing, testing, and troubleshooting networks (a big part of my job) this is really bogging me down. Never saw this before with any previous release. Always in the past changes are instant with no "apply" delays.

This symptom continues after installing 10.14.2. I've also tried:

- Resetting PRAM
- Resetting SMC
- Reinstalling MacOS using Recovery Mode
- Removing all 3rd party apps that could interfere
- Booting with Shift key down - no performance improvement

My last move is to wipe the machine and recover from backup, discarding the network config option. However since I have so many VPN configurations this is a really big deal.

I'm hoping someone has some other suggestion.
A MAC user reported"The mailbox database is temporarily unavailable. underlying MAPI stream threw an exception. Mail could not be sent. The message has been moved to your Drafts folder."
Need some help in tracking down an IP conflict that I have.  DHCP servers are Windows 2016 servers (setup in a failover scenario) but I have a MacBook that has had this happen twice in the last month.  He will get a popup saying:

Another device on the network is using your computer's IP address (  

I'm not sure if this IP was for his wired connection or his wireless but only seems to affect his MacBook.  With DHCP servers there shouldn't really ever be IP conflicts (unless someone adds a static IP which I don't think this is the case here - it could be but I doubt it).  In DHCP servers, logs don't show anything...

Anyway at this point to track down what grabbed the .204 IP?
I’ve got a MacBook Pro, running High Sierra 10.13.4 & an HP OfficeJet 4650 All-in-One printer & can’t get them to work together. Using the HP software, I get no devices detected.
If I connect Mac to the printers built in WiFi network, it detects & sets up ok, but of course there goes my internet connection!
I have a Mac connected to a network but can't get the "other user" account to pop up when u reboot or logout... I see it appear when I turn on the guest account and logout but it disappears after  few seconds ....I also tried manually setting the DNS and that was a no go ... I am able to ping the domain from Terminal. I have all the log in options set correctly but I just can't get that option does not populate to the screen.

We have a MAC Book Pro (2017) running High Sierra, we push most settings via Profile Manager - however when we try to deploy Proxies under MAC OS in Profile Manager payloads, it doesn't apply to the MAC book in question, especially the exceptions.

When you look on the MAC book at settings, the wi fi proxy settings are fine, but the proxies exceptions are not applied (does this apply to only Ethernet connections and not wi fi)

I have a Mac with Parallels for a boot camp
Partition. I want to create a user account who’s sole purpose after login is to start Parallels with the boot camp partition as full screen and should it crash or the user shut down will close the app and log out without being able to make any changes to this account. The user should not be able to reduce the screen to get to any of the other Mac software on the device If I need to maintain, I will do it from an admin account.

Any suggested startup script for this and the appropriate user settings would be appreciated.
Buying a new Mac Mini to replace an old Pro tower. Would like to keep the os (Mac and boot camp) on the internal SSD and have the user directories on a Thunderbolt drive. I know the importance of keeping a admin account on the SSD to troubleshoot, but would like to preconfigure the user accounts to exist this way before reestoring files from the Pro. When I have tried this in the past, drive numbers seem to change causing all sorts of hell.

If this is not doable, would prefer to put some of the users bigger subdirectories (photos and videos) on the thunderbolt or a NAS device.

Any how to or best practices would be greatly appreciated.
i can only login to my macbook on safe mode only not when how i does log in normally. i removed the mac from the domain and re-add and its still not working.

please help
Just wondering we use High Sierra and the Server app - however if you upgrade to MAC OS Mojave then the websites feature of server app has bee removed/ depreciated. We use this for pushing out a proxy pac file to our clients. Just wondering how people are getting around this? Also has anyone had any experience of upgrading clients to Mojave but retaining the MAC server on High Sierra?

Link as to whats changing in MAC OS
Have been battling this issue for over a year now, here is my setup

i have mac AD users, their macbooks are joined to AD with a software called Centrify, every 90 Days our AD users need to reset their passwords. the Centrify app prompts them to reset their AD password however when they enter their old and new password the Centrify app prompts them that they have not reach their complexity requirements require for their password. Now AD actually takes the password but the user thinks it does not and now the user cannot login to their macbook

the workaround for me is to remove the user from the domain then re-add the macbook

any ideas what this could be.
We have a group of Mac's (High Sierra) connecting via SMB to our Windows Server 2016 share.

When they browse folders on the share without opening files, the files within that folder show up in "Open Files" within "Computer Management" on the server; if they leave that folder, they remain in "Open Files".

When they try to rename a browsed folder, they get a permissions error (because the file is open)

Is there a way to stop the Mac marking these files as open?
I am trying to copy over a photo library approx 14GB from a mac hard drive connected via external usb connection to my desktop on my macbook.
The hard drive keeps freezing up whenever I try to copy it via finder. I also tried to do first aid on the drive via Disk Utility. My guess is that the hard drive is very close to failure but I can browse the files and folders. How can I get these photos recovered?
I'm looking for an automatic location switcher based on my Mac's location. For instance, when I go to the office I need wifi to automatically turn off when I plug in my USB-C hub and/or network cable (the network cable is plugged into the hub).  In the past I would have used Marco Polo, SideKick, or ControlPlane, but those no longer work on the Mac. I'm using Mac OS Mojave.
I have developed a website ( that my credit union will be using to upload a picture from a members phone to our Azure storage blob that will be printed onto their custom debit card. The main issue is right after the upload page (and before the thank you page just fine while exiting that action fine) Safari will display one of two error messages.
The first and most common one is "This web page has been reloaded because a problem has occurred." Sometimes this is accompanied by a dialog box asking to resubmit the form.
However, everything on the back end worked fine. No server side errors were thrown and the image is successfully uploaded to our azure storage. I step through the controller and everything works fine and exits the action with no issue. This problem does not occur on desktop or Android devices.

Now I know that I can reproduce the bug so I look into how to diagnose iOS safari pages and tried to use their Web Inspector tool. I get it loaded up on my Mac just fine and tethered my iPhone to the Safari session. I go to the page and not only does it error on my iOS device it crashes my Mac's Safari window of debugging. So next I try to use Xcode's Simulator and system logging to capture the issue, and nearly the same thing happens only I get an on screen(simulator) error of "This page can not be loaded because the web page stopped responding." This doesn't crash the Simulator, but the logger window did not record …

I need to lock down the USB ports of all devices to only allow specific device ID's.  I have a solution for the windows PC's but I am looking for the best way to do it on the Mac devices.
This is a domain environment so I need to be able to push it out to multiple machines.

When Installing .app, we use Apple Remote Desktop to deploy .app and .pkg to our Macs. However I can install .pkg files fine, but .app (apps that are not available through the app store (e.g. vlc/java/air)) don't like to install, has anyone come across this and if so what fix can I apply.
Cannot mount .dmg file when filevault is turned on the macbook. Found this out when went to install Mojave to see what it features were before looking at updating the rest of our macs. But after downloading from the app store and trying to install  - it does get someway though and fails to install due to the filevault being on. I know it says here it needs to be turned off but i was wondering is there a setting that allows installation of .dmg files when filevault is turned on? (e.g. when you want to install a program that is not in .pkg or .app format.
Profile Manager with Mac Book Pro (2017). We use Apple Server running on Mac High Sierra (latest version before Mojave) to manage our iPads and Macs, however we are setting up a profile for the MacBook Pro and have come across a couple of problems....

Cannot browse the internet when at home. The Mac can connect to the work wi fi network and can browse the internet all fine - however when the user takes the laptop off site and connects to their home wi fi, they can connect fine but not browse the internet (nothing comes up). Has anyone else come across this? If so what was the fix - before any one says anything yes I have tried re-installing the OS and have tried with no profile applied (and that works). So it has to be something in the profile manager settings - but for the life of me cannot see anything obvious. Have opened up terminal and can ping bbc and google when the user is at home. I know it can't be the ISP provider as I have tried this at my friends house who is on a different provider and its the same there. All other devices connect fine to the home network and work network (e.g. my mobile) that are not managed. Even windows laptops work fine when taken home.

I've got a user on a MacBook Pro, who's connecting to a 2016 server via rdp 8.0, but cannot use his local printer.
Of course this all worked fine under the old 2008 terminal server, but hasn't worked with the new & improved stuff.
When trying to add the printer, I can see other macs showing up, like TS009 (Joes-MacBook-: PRN2:# 9), but am not seeeing this guy's mac listed there.
Went back to try installing printer on the server & while I see full function software & driver for all desktop OSs, the servers listed stop at 2008.
Is printer just incompatible with that server, killing the whole idea right there?
Looks like that printer is about 8 years old, is it time for a new one?
Any other work arounds?

Mac OS X





Mac OS X is the desktop operating system from Apple Inc., found on Macintosh computers. OS X consists of a Mach/BSD-based kernel, operating system interfaces primarily based on FreeBSD and additional frameworks (written in C, C++ and Objective-C providing user interface and application-level services.