Mac OS X





Mac OS X is the desktop operating system from Apple Inc., found on Macintosh computers. OS X consists of a Mach/BSD-based kernel, operating system interfaces primarily based on FreeBSD and additional frameworks (written in C, C++ and Objective-C providing user interface and application-level services.

Share tech news, updates, or what's on your mind.

Sign up to Post

I have a Sarbent Hard Drive Docking Station (DS-UBLK) and it was working perfectly fine. A few days after I updated OSX (10.13.3), I no longer see the icon. I can't find it anywhere.

I talked to the support at Sarbent and they just sent me another docking station which doesn't work either.
They have a driver for windows, nothing for mac.

I borrowed another docking station (Thermaltake BlacX): nothing.

Could there be a problem with the new OSX update? Or maybe that's not the problem at all. Could my harddrive just be dead?

I found a similar question here:'t-my-laptop-recognize-the-Thermaltake-Blacx-hard-drive-docking-station.html

But I'm not computer literate enough to know if I have the same problem.

Also, I tried to downgrade the OS to before the update. And you need Time Machine for that.
The problem is that the hard drive I use for my docking station IS the Time Machine.

Thank you.
I need an OS agnostic script or HTML page created that will spawn VLC player and open a static UDP stream.  I already have an HTML (actually a .hta) file that will work on Windows machines using IE.  However, Chrome and Safari won't allow me to open VLC links on OSX, which is my next OS to deploy this to.

We have school buildings with internal live stream "channels" provided by a Marshal VS-11 appliance.

I'm attaching a slightly redacted version of my current hta file, I might have had some editing mistakes as I tried to remove school names.  I'm also attaching screenshots of the UI.  Also is a basic diagram showing my hardware setup, for reference.
I got a computer and need to know how to reset it. I got it at an estate sell, the administrator is locked in and i dont know password. Cant use internet
Hi All,

I have a question regarding MAC. We have about 75 MACs in our environment. We would like for users to have an shortcut on their desktop that will lead them to our Intranet or set the default webpage to in safari to our Intranet.
We are using Casper server (Jamf pro) V. 9.10
Is it possible to push it out using configuration profiles or managed preferences.

Thanks in advance
I am using Parallels Desktop 13 for Mac Pro Edition(Version 13.3.0(43321)), and  I am trying to upgrade Windows 8.1 VM to Windows 10.   I keep getting the following error: 0xC1900101-0x40017 The installation failed in the SECOND_BOOT phase with an error during BOOT operation.  Note that before trying to upgrade, I ran Windows Update and installed all important updates and my Windows Firewall is turned off.  

Any suggestions?
I would like for my mac users to be able to change the passwords for their Active Directory Accounts from their Macs.  These users do not have domain joined macs and connect to my network to get web access and email access via Office 365.   Their password policy recently changed from "Never Expire" to require a password change.  These users need to be able to change their domain passwords either by a command or by some type of software.   Macs are running OS 10.12.6 Sierra.   I don't want to to join Macs to domain, I just want them to be able to change their domain passwords from their Macs.  Also, they will not be able to change thier passwords using any web portals.
Just recently replaced a failing Server 2003 server with a Buffalo NAS unit running Server 2012 Storage Server R2 - this is a small shop so this unit is working nicely so far with the following exception.

Transferred files off the Server 2003 box onto a NAS share and all operations are functioning properly for all users.....EXCEPT 2 MAC users who access files off a share setup for these MAC users to work with. When these users browse the Window share using "Finder" - they do the initial connect fine. The drive is mounted and an alias is setup on their desktop. All the files will display in the share for a few seconds..and then the file share window will do a refresh...and all the files disappear. The files are still on the share..they just disappear from the MAC view. It's the oddest issue. No problem for any of the Window users...just happening to these 2 MAC users.

My last effort today was to add the username/password these MAC users use when they log onto their MAC systems (they don't have to put in the password..the MAC's boot straight to a desktop after a restart/power-up) - I added these same username/password to the "Local Users and Groups" on the Server 2012 - re-propagated permissions on the share...still no go.

Looking for a life-line as I'm out of
MAC OS - Terminal command to clear RecentDocuments?

defaults delete RecentDocuments
Domain ( not found.
Defaults have not been changed.

defaults delete RecentDocuments
Domain ( not found.
Defaults have not been changed.

I need to be able to clear the Recent Documents on my Macbook which currently shows the last 1500+ items I've opened.
The APPLE Logo, Recent Items, Clear Menu doesn't clear the items in Recents when I open Finder.

Anyone got a quick and easy way to do it via Terminal?

By the way, to clear all the up arrow / down arrow history in terminal type history -c and press ENTER.
Hi, I have an internal Adobe Acrobat from that I have made to be filled out, and also use it for calculations.  All my PC user can use it fine, my Mac users can not.  The field that is supposed to calculate miles and also calculate dollar amounts, does not work.  The fields stay blank where the calculations are.  I have text fields that populate on another page, and that works.  I have downloaded Acrobat Reader for Mac, downloaded the form to their desktop, and then opened from Acrobat Reader.  Are they any solutions to this?  Do I have to create the form on a pro version of Acrobat for Mac? I'm getting ready to redo the whole form on a Mac, but the form is complicated, so checking here first before starting it.  Thanks for any help!  
I have an original video that is 1092x820. I'd like to make this radio 16:9, so something like 1280x720.

Could I create this as a "letterbox" video in Final Cut Pro, meaning can I create the 1280x720 project, import the 1092x820 video and get it to fit inside of those constraints?

Any suggestions on how to do this? (I'm a newbie at FCP X).

Parental control logs on Mac show only numbers possibly the websites IP Address not names of websites visited.
IBM Notes 9.0.1 (64-bit) on MAC OSX is Not Responsive After Installing Java 8 Update 152 or Later Versions
I have problem which is "solved" here:
but is any other option without instaling old Java (that solution is crazy)
hi Mac folks

as you might have known that, for some reasons, macOS HS has removed Translation Widget from its Dashboard, and one of the workaround methods is to copy the widget from previous OSX or macOS to the HS installation's /Library/Widgets folder.

I did that, copied the Translation.wdgt from my Mac Pro running El Capitan to MacBook Air running High Sierra.

But, it doesn't work as expected: as shown in the screenshot below, the copied widget can be added into the Dashboard, but it doesn't work at all because the language fields can't be switched or selected.  the fields just show <b>nothing</b>.

do you have any idea what to do now? thanks.

kind regards.
TP-Link Router - what does "auto" mean in relation to wireless security settings?

TP-Link AC1200 VR400 Wireless Dual Band Gigabit VDSL/ADSL Modem Router under wireless security settings i.e. encryption used to secure wireless

Choices given are:

Version: Auto OR WPA2

Encryption: Auto or TKIP or AES

What is "auto" mean in both cases?

(underlying problem: Mac OS Sierra connects great for 45 minutes then connection cuts out. I am suspecting this is due to the encryption level)

(all other devices have a stable connection)
Extract messages from iPhone iTunes backup?

Is there a manual way to do this OR am I better off using a utility?
Currently experiencing an issue with access to mapped drives using SMB protocol with a MacBook Pro running High Sierra, we only see this issue with that machine. The problem effects the user when attempting to move or rename a file in on the share, the MacBook becomes hung up, showing only the spinning pin wheel and needs to be completely restarted in order to allow the user to use the computer. I found the article below attempted recommended changes (no resolution) also opened a ticket with apple support and was directed to open a pay per incident ticket because the technician had no insight other then what I performed on the issue other thanking for directing him to apples article and saying that what he recommends I should attempt.

Macbook Air won't turn on at all. I will power on when plugged in, I hear a startup chime, Pressing the Caps Lock key on the keyboard causes it to light...
I tried the followings:

- ommand+R
- reset the SMC

Still nothing
I've got a friend with a desktop Mac. She tells me that when she tries to save a document in Word, she sees a wait cursor for quite a long time. One of my hypotheses is that this could be a failing hard drive. Before looking into diagnostics i was wondering if any of you could think of any other apps (likely to be present) that would employ such a wait cursor, so i could eliminate a problem solely with Word. Or maybe you can think of something else?
Looking for Deep Freeze for Mac OS alternative due to problem with it not working once I upgraded to High Sierra and SSD drive switched to APHS.

I've used Deep Freeze for many, many years and love it.

I feel very vulnerable not being able to lock my computer and revert to previous state with reboot.

It's been a few months since High Sierra came out and so far Faronics Labs has not come up with a fix for Deep Freeze.
I have a MAC user on our internal windows domain. She often saves work to a network share which runs on a Windows 2012 R2 file server.
The SMB: connection randomly loses connection to the shared drive. I know this has long since been an issue with Apple but it seems there would be a solid fix
for this by now?
I have a mid-2010 iMac running Sierra that has served me well. I’ve been using it as an external monitor for my new MBP the last few months. Last week the SuperDrive failed... then a few days later it wouldn’t restart.

I booted in Recovery mode and ran disk first aid - errors (The First Aid error message says: {checking several files & volumes...} The volume Mac HD could not be verified completely. File system check exit code is 8. File system verify or repair failed. Operation failed.) I’ve tried to reinstall the OS - it appears to Download fine, but cannot install.

I've zapped the PRAM.

I've also started in Internet Recovery mode. Disk first aid returned the same errors as above, with the addition of "Problem -69842 occurred while restoring the original mount state"

Is there anything else I can try before trying to wipe the drive clean? (Hoping this is a last resort; I believe all my info is backed up... but it’s still a scary thing to do!) Of course if my HD is simply dead, maybe even that won't  help.... However, when in Recover Mode, it gives me the basic info of the HD, so I'm thinking it can at minimum be seen - and perhaps IS operational?
I have a document based app but I have secondary windows with grids for entering data that are modal.
User clicks button to open secondary window... lets say they add some data there... then they click
the red ball to close the window (instead of clicking the save button).

Should we revert back to the data before they opened the window?
In which case their edits are lost.
Should we save the changes but just close the window?
Hi I have a certificate which I need to distribute to all my MACs.
All of them are on a domain.
An office of 9 Macs. All up to date OS wise. All are joined to the domain xxxxxx.local and can log on and authenticate as domain users.

Connecting to the server to access a share  brings this message: There was a problem connecting to the server. URLs with the type "smb:" are not supported.

Only happening on one Mac. Any ideas? I've removed it and re-added it to the domain fine!!! It picks up and IP address just fine but SMB seems problematic. I had been fine for the past 10 days since I bought and installed it...

Does anyone know of a one click solution to open up .MSG folders in Mac Mail?

I have tried MSG Viewer but the user has to jump through hoops just to open one attachment.

There must be a better way?

Mac OS X





Mac OS X is the desktop operating system from Apple Inc., found on Macintosh computers. OS X consists of a Mach/BSD-based kernel, operating system interfaces primarily based on FreeBSD and additional frameworks (written in C, C++ and Objective-C providing user interface and application-level services.