Microsoft Server Apps

12K

Solutions

14K

Contributors

Microsoft server applications are those applications developed specifically, but not necessarily exclusively, on the Windows Server platform. In addition to well-known products like SQL Server, Exchange, Internet Information Services (IIS), Microsoft Dynamics, Forefront, Lync and Sharepoint, they include applications like Skype, BizTalk, Hyper-V, Groove and Commerce Server. Server applications are managed with the Microsoft System Center.

Share tech news, updates, or what's on your mind.

Sign up to Post

I am looking to buy a server that can run multiple applications. At the moment that would be Active Directory, File and Print Services, and maybe SQL for about 3000 employees. I am interested in HP. I was looking at the DL380 as a candidate. Any thoughts or recommendations would be greatly appreciated.
0
Hello Everyone:

I have a .MSI Application that I trying deploy, but I first need to have a VBS script run before it.  I would like to avoid using a Task Sequence to perform this.  Below is what I currently have defined for the Application, but it is only executing the VBS, and unfortantely not installing the .MSI after.  Did I miss something or did I configure something incorrectly?

Application Name = SEP 10 Agent

Deployment Types =2

1. Name = SEP 10 Agent - Windows Installer
Technology Title = Windows Installer (*.msi file)
Installation Program = msiexec /i SEP.MSI /q /norestart
Detection Method = MSI Product Code: {etc}
Dependencies = Name - SEP 9 Unininstall, Application - SEP 10 Agent,  Deployment Type = SEP 9 Unininstall, Automatically Install = Yes

2. Name = SEP 9 Uninstall
Technology Title = Script Installer
Programs = SEP 9Uninstall.vbs
Detection Method = Setting Type = File System, Type = Folder, Path = %WINDIR%, Folder = System32b, Checked - This file or folder is associated with a 32-bit application on 64-bit systems.  (I set the detection to C:\Windows\System32b as the folder doesn't exist and it will then enforce the VBS to get executed.)

Result:  When I deploy this, it will successfully downloads the VBS and .MSI into Cache on the client PC.  It will successfully run the VBS script before running the .MSI.  Unfortunately, after it runs the VBS script it is not running the .MSI and it is showing that it failed the deployment.

Any …
0
After installing updates on Windows Server 2008 I cant start MS Exchange Replication. The Error log says:

Log Name:      Application
Source:        MSExchangeRepl
Date:          28. 7. 2016 6:39:20
Event ID:      4004
Task Category: Service
Level:         Error
Keywords:      Classic
User:          N/A
Computer:      
Description:
Couldn't start the Microsoft Exchange Replication service. Error: System.TypeInitializationException: The type initializer for 'Microsoft.Exchange.Cluster.ReplayService.ReplayComponentManager' threw an exception. ---> System.InvalidCastException: Specified cast is not valid.
   at Microsoft.Exchange.Cluster.Replay.RegistryParameters.<LoadRegistryValues>b__2(RegistryKey key)
   at Microsoft.Exchange.Cluster.Replay.RegistryParameters.TryGetRegistryParameters(Action`1 operation)
   at Microsoft.Exchange.Cluster.Replay.RegistryParameters.get_ConfigUpdaterTimerIntervalSlow()
   at Microsoft.Exchange.Cluster.ReplayService.ReplayComponentManager..ctor()
   at Microsoft.Exchange.Cluster.ReplayService.ReplayComponentManager..cctor()
   --- End of inner exception stack trace ---
   at Microsoft.Exchange.Cluster.ReplayService.ReplayService.OnStartInternal(String[] args)
   at Microsoft.Exchange.Cluster.Replay.Watson.<>c__DisplayClass1.<SendReportOnUnhandledException>b__0()
   at Microsoft.Exchange.Common.IL.ILUtil.DoTryFilterCatch(TryDelegate tryDelegate, FilterDelegate filterDelegate, CatchDelegate catchDelegate)
   at …
0
As part of an IT audit, what would/should you focus on in terms of group policies applied to computers and servers. I'm just not sure what you could really focus on, or what common issues there would be - and what tools you could look to to assist in identifying any problems/risks in the group policies being deployed?
0
Hello IT Pros.

I just installed System Center Configuration Manager to deploy Windows updates. I'm having trouble with 2 things, but what's on the screenshot I haven't been able to figure out and decided to ask here, before "giving up".
Error
Any lead you can give me to fix this issue I will really appreciate that. Thanks so much.
Untitled.png
0
Skype for Business on-premises - on-prem or O365 accounts?

I am looking to roll out the Skype for business in a small organization. Not looking for PSTN or PBX at this time, just the chatting and conferencing.    
     
We have volume licensing, which I think includes Skype for Business Server. We also have O365 accounts (free licenses) that inludes the basic Skype for Business.    
   
What I'm unsure of is if I should deploy the Skype for Business client on-premises and instruct people to login with their O365 accounts, or deploy a S4B on-premises server and setup pass-through authentication.    
While I use AD Sync for on-prem AD and O365, I don't think the fact that their AD UPN logins match their O365 logins will mean automatic/pass-through authentication for the Skype client, so I'm worried about the end-user inconvenience factor on that approach.    
We do have Microsoft Exchange server on-prem where their mailboxes would be, so I'm wondering if on-prem Skype server makes more sense in that regard.    
Just not sure what is better to use. At this time I only recommend they install the O365 Office 2016 Suite, which include Skype, onto their personal computers only.
There's an article here "Deploy the Skype for Business client in Office 365" but I'm not sure if that's recommended for on-prem, and if it uses up a licenses for the users, taking away from their personal license count.
0
IN SCCM 2012 R2 1602, if I push a Windows Update Package to the DP's then create an advertisement for a server collection.  On the server endpoint, which log will it tell me which DP it was using to download/install the package?
0
Hi,
I am trying to find a way to upgrade SCCM 2012 SP1 to SCCM SP2, had anyone done the upgrade? whats the correct procedure and link for upgrade?

Thanks.
0
Hi,

We found out that our gpo's are not applied anymore. We've already checked that the security filtering is set the right way. We keep seeing that they're inaccessible when running the group policy results. The group policy also appears in numbers when reviewing in group policy results. Not with its name.

User can also browse to \\domain\sysvol\domain\policies

Any help is appreciated

Regards,
0
Hi, I have imported drivers for HP 840 G3, under drivers in SCCM console, now i am trying to add them to drivers package, but i am getting the following error attached, even if i try to add one driver, it gives the same error.
thanks.
drivers.jpg
0
Could someone tell me if II 7 is no longer supported?

To make a long story short, we have been flagged that this was Vulnerable because of the version.  My guess is that Microsoft has patched it.

Any thoughts would be appreciated.
0
Hi All,
Using SCCM 2012, trying to add driver package for HP EliteBook 840 G3, whenever i tried to add the driver package, it shows the error attached, "The specified file is not valid" no matter where i put the zip files for the drivers, it doesn't want to proceed.
Permissions are right, so not sure what i am missing?
thanks.
sccm.jpg
0
I turned on forms based authentication for OWA and everything seams to be working great.  The only issue when I log in for example and attempt to pen a mailbox in another AD site where OWA has to proxy to a different address for OWA to access the mailbox in the remote site.  I'l get another FBA logon page and then it just sits at a blank page.  I confirmed that OWA and ECP for all CAS servers have the same authentication methods and restarted IIS on all CAS servers after making the FBA change.  Any idea what could be causing this issue?  Enabling FBA should be a pretty straightforward process.
0
Hi recently something went wrong with two secondary site , distribution points. It seems as though they kicked off a complete re-distribution of all packages. These consist of windows and endpoint protection updates. I've been struggling for a month without the in progress bar moving. Things I've noticed is that the despool.inbox is filling up like crazy. one secondary site has a database replication link as failed, think its un-related though as the other site replication is active and I have the same content update issue with it. looking at the logs I see the distmgr.log keeps saying using 0 of 3 processing threads. the smsdpmon.log has errors 0x80070003 failed to evaluate package. Since this isn't 2012 r2 I cant use the tools to monitor the distribution points progress, so I'm not sure if anything is actually working.
Below are some extracts from the secondary site server
Waiting for ready instruction file....      SMS_DESPOOLER      2016/06/21 10:09:19 PM      3832 (0x0EF8)
Waiting for ready instruction file....      SMS_DESPOOLER      2016/06/21 10:14:19 PM      3832 (0x0EF8)
Waiting for ready instruction file....      SMS_DESPOOLER      2016/06/21 10:19:19 PM      3832 (0x0EF8)
Waiting for ready instruction file....      SMS_DESPOOLER      2016/06/21 10:24:19 PM      3832 (0x0EF8)
Waiting for ready instruction file....      SMS_DESPOOLER      2016/06/21 10:29:19 PM      3832 (0x0EF8)
Waiting for ready instruction file....      SMS_DESPOOLER      2016/06/21 10:34:19 PM      3832 (0x0EF8)
Waiting for ready instruction file....      SMS_DESPOOLER      2016/06/21 …
0
I wish to install just my companies custom applications on Microsoft Surface devices not the OS. I have created a task containing just the "Install Applications" task sequence. I am testing this process using a VMware virtual machine by opening a command prompt and entering "cscript \\server\deploymentshare$\scripts\litetouch.wsf" The Deployment wizard launches but hangs at "processing bootstrap settings" i found hitting the enter key progressing things along but the process again hangs on "processing custom settings". Once again hitting enter resumes the process, i then receive the task sequence screen where i select the task for installing just applications. I am installing 9 applications so i select those and hit begin however the process fails.

Z:\>cscript scripts\LiteTouch.wsf
Microsoft (R) Windows Script Host Version 5.812
Copyright (C) Microsoft Corporation. All rights reserved.

Microsoft Deployment Toolkit version: 6.3.8330.1000
CleanStartItems Complete
Removing C:\MININT folder (final log entry)
ZTIUtility!GetAllFixedDrives (False)
New ZTIDisk : \\MININT-8QMLDJU\root\cimv2:Win32_DiskDrive.DeviceID="\\\\.\\PHYSICALDRIVE0"
New ZTIDiskPartition : \\MININT-8QMLDJU\root\cimv2:Win32_DiskPartition.DeviceID="Disk #0, Partition #1"    \\MININT-8QMLDJU\root\cimv2:Win32_LogicalDisk.DeviceID="C:"
New ZTIDisk : \\MININT-8QMLDJU\root\cimv2:Win32_DiskDrive.DeviceID="\\\\.\\PHYSICALDRIVE0"
New ZTIDisk : …
0
Hello. I am using Maik Koster's MDT/SCCM/AD web services from Codeplex to set various items. One of them is Active Directory attributes. I can successfully set the Computer description. However, when I try to set the department for the computer object I get access denied. I can manually update it but cannot do update it via PowerShell or the Web Services. Is there some special permission that I need to perform this action? Thank you for any information.
0
Error: "We can’t connect to the server for presenting right now."

Background and Setup Info:
1X Skype for Business Server 2015 FE
1X Skype for Business Server 2015 Edge
1X Web Application Proxy Server (Combined with ADFS) Used for Publishing Skype for Business Server URLs
1X Office Web Apps Server

Internal users can open  whiteboard, Q&A, Polls, and PP presentation just fine. The problem exists only with external users. Also pinging webconf.domain.com times out, not sure if that is related to the issue.

I ran out of options and pretty much went 10 pages deep into Google search trying to find a solution for this. Thanks in advance for any help and sorry if I posted this in the wrong place.
0
I have setup a Windows deployment system (please see Spec below).  In my deployment I add the feature .net 3.5.  The whole network points to my WSUS server for updates.  Most of the time the .net 3.5 feature fails to install and when I also try to add the feature to non Windows MDT deployed computers it also fails.  I have found a work around by adding a registry key that will bypass my wsus server and get the files from windows update. but is there a way to add the files needed to my WSUS server so I don't have to do the registry key patch.



Deployment Servers Spec

Windows Server 2012R2 with WDS /MDT (2013 Update 2)
Windows Server 2012R2 with WSUS
Windows Server 2012R2 with KMS
0
hello, upgraded my admin pc to win 10, however seems my sccm client and essentials av not installing. is there somthing I need to update on sccm 2012 r2? thnx
0
Currently running 2012 RDS Services.  I published an application and in the User Assignment section for the published app, I selected "Only specified users and groups".  I selected the Active Directory security group I set up.

My AD account is NOT a part of the AD security group I selected in User Assignment but I am still able to see the application icon when I log in to RDWeb.

Looked all over the internet and have not found a good fix so far.
0
Hi,
we have a WSUS version 3.2.7600.226 built on windows server 2003 SP2
It works fine for existing client machines.

there is a issue with new built machine. the log as below

#############
2016-06-07      21:57:37:483      1076      1398      AU      ## START ##  AU: Search for updates
2016-06-07      21:57:37:483      1076      1398      AU      #########
2016-06-07      21:57:37:484      1076      1398      AU      <<## SUBMITTED ## AU: Search for updates [CallId = {433C774D-C1DD-4A05-A223-ADD1F24255FF}]
2016-06-07      21:57:37:484      1076      1038      Agent      *************
2016-06-07      21:57:37:484      1076      1038      Agent      ** START **  Agent: Finding updates [CallerId = AutomaticUpdates]
2016-06-07      21:57:37:484      1076      1038      Agent      *********
2016-06-07      21:57:37:484      1076      1038      Agent        * Online = Yes; Ignore download priority = No
2016-06-07      21:57:37:484      1076      1038      Agent        * Criteria = "IsInstalled=0 and DeploymentAction='Installation' or IsPresent=1 and DeploymentAction='Uninstallation' or IsInstalled=1 and DeploymentAction='Installation' and RebootRequired=1 or IsInstalled=0 and DeploymentAction='Uninstallation' and RebootRequired=1"
2016-06-07      21:57:37:484      1076      1038      Agent        * ServiceID = {3DA21691-E39D-4DA6-8A4B-B43877BCB1B7} Managed
2016-06-07      21:57:37:484      1076      1038      Agent        * Search Scope = {Machine}
2016-06-07      21:57:37:485      1076      1038      Setup      Checking for agent SelfUpdate
2016-06-07      21:57:37:485      1076      1038      Setup      Client version: Core: 7.6.7601.18979  Aux: 7.6.7601.18979
2016-06-07      21:57:39:758      1076      1038      Misc      Validating signature for
0
Hello, can anyone provide me with some step by step details how I can configure/achieve this,
Project Manager wants up to update the Hardware Calles that are gathered by SCCM so that the TPM details are collected. This policy will need to be published which will mean this information is gathered on an ongoing basis, which will improve our ability to report on the model of TPM chips being used in the future.

We have an SCCM 2012 infrastructure, no CU's applied,
I'm not really well versed when it come to SQL, and came across this thread, referencing some SQL query that needs to be run

https://eliasleal.com/2014/09/19/show-tpm-values/

Any assistance will be greatly appreciated.
0
Team, got this question put to me by one a staff who manages the assets and configuration information for my clients workstation fleet, I understand they have a few 3rd party and customs tools that leverages information from our SCCM 2012 instance,
Her question as follows:
"
Last month we had SCCM registering the following Manufacturers;
• HP
• LENOVO
• Microsoft
• TOSHEBA
This month we have SCCM registering these Manufacturers?
• Hewlett Packard
• Hewlett-Packard
• LENOVO
• Microsoft Corporation
• Toshiba
Whats the reason for why we are seeing SCCM collecting different Manufacturer formats etc?"
I can't see any reason why Configuration Manager will change this, but please correct me if I'm wrong, your thoughts?
0
Is it possible to support Extended desktop in server 2012 R2 Remote Desktop Session Host. The user wants to be able to open two applications in RDS and display them on two monitors.
0
Hi, We are running SCCM 2012, I am trying to deploy image for HP EliteBook G1, G2, G3.
When the task sequence starts, it goes through partitioning  the drives and then it tries to install OS where it fails, I have attached logs and screenshots....kindly assist.
SCCM1.jpg
SCCM2.jpg
smsts.log
0

Microsoft Server Apps

12K

Solutions

14K

Contributors

Microsoft server applications are those applications developed specifically, but not necessarily exclusively, on the Windows Server platform. In addition to well-known products like SQL Server, Exchange, Internet Information Services (IIS), Microsoft Dynamics, Forefront, Lync and Sharepoint, they include applications like Skype, BizTalk, Hyper-V, Groove and Commerce Server. Server applications are managed with the Microsoft System Center.