Want to protect your cyber security and still get fast solutions? Ask a secure question today.Go Premium


Microsoft Server Apps





Microsoft server applications are those applications developed specifically, but not necessarily exclusively, on the Windows Server platform. In addition to well-known products like SQL Server, Exchange, Internet Information Services (IIS), Microsoft Dynamics, Forefront, Lync and Sharepoint, they include applications like Skype, BizTalk, Hyper-V, Groove and Commerce Server. Server applications are managed with the Microsoft System Center.

Share tech news, updates, or what's on your mind.

Sign up to Post

I want to update ownerid in one of the lead in dynamics crm 2011
all google tells me about the codes below. but i do not know how to declare "SystemUser.EntityLogicalName".
I already ahve SDK reference in the website. please help if you know what to do.

// Create the Request Object and Set the Request Object's Properties  
AssignRequest assignowner = new AssignRequest {  
    Assignee = new EntityReference(SystemUser.EntityLogicalName, _otherUserId),  
        Target = new EntityReference(Account.EntityLogicalName, _accountId)  
// Execute the Request  

Open in new window

Veeam Disaster Recovery in Microsoft Azure
Veeam Disaster Recovery in Microsoft Azure

Veeam PN for Microsoft Azure is a FREE solution designed to simplify and automate the setup of a DR site in Microsoft Azure using lightweight software-defined networking. It reduces the complexity of VPN deployments and is designed for businesses of ALL sizes.

I'm on on premises SP 2013 but limited to SP 2010 workflows.
I have a long complicated workflow that I'm working on.  I need to backup it periodiocally so that I can restore it to its previous configuration if the workflow becomes corrupted (which it can during designer editing on rare occasion).
I can see the workflow detailed files under all files in the workflow library but can't download these directly from Designer.
You can't view this library as a normal library with views and it has special behind the scenes handling evidently even if you make that library visible to the browser.  
Since it's not a 2013 workflow, you can't save as a template.
Does anyone have the DETAILED steps for backing up the workflow files and then restoring them over top of a more recent change if needed.  I've attempted to download the contents of the workflow files themselves and then restore them but this doesn't work as SP keeps track of the the saved copy and the published copy separately.
I' ve read the blogs - please only answer if you have actually successfully and have restored a 2010 workflow back to a previous configuration.  
I've searched on the Internet blogs and here but can't quite get it to backup and restore properly on the same list.

If it matters - I don't care about preserving the state of previously running copies of the workflow.  It runs within a few minutes and finishes so there's no active workflows running under normal conditions.
In SCCM , my Inventoried Software doesn't show IE (except for v.7 and 8) so I when I run query on IE versions, I get no results.
If I do a software report, again, no IE (iexplore.exe)

Is it because the new versions of IE come in as KBs and aren't in add/remove programs?
How can I query for IE 9,10,11?

I tried this:

select SMS_R_System.Name, SMS_R_System.LastLogonUserName, SMS_R_System.LastLogonTimestamp from SMS_R_System inner join SMS_G_System_SoftwareFile on SMS_G_System_SoftwareFile.ResourceID = SMS_R_System.ResourceId where SMS_G_System_SoftwareFile.FilePath like "%\\Program Files\\Internet Explorer\\" and SMS_G_System_SoftwareFile.FileName like "iexplore.exe" and SMS_G_System_SoftwareFile.FileVersion like "10.%"
Hi all,

I've hit a problem capturing a windows 10 image using MDT in a virtual environment (hyper-v). When I test the process by creating a reference image (using all the default settings) the .iso builds fine, syspreps and save the new capture no problems at all.  As soon as I attempt to and any applications (tested using Office 2016 or Chrome) the process runs fine and creates a .wim file only doesn't pass it back to the deployment share.

I've tried several different approaches (silent installs, suspended task sequence, custom capture sequence) to no avail and i'm starting to pull my hair out over this.

From the newly created window 10 instance I have discovered that I can't browse (or cmd net use) the deployment server share (either by unc or ip) but I am able to access other shares on my network. I am able to access the deployment shares from other machines on my network.

Both Windows 10 and MDT are the latest available versions.

Hope someone can help,
Hello SCCM Guru's!

We have 10,500 clients

We are trying to deploy a task sequence that has a startmod.vbs (vb script) file in it. The TS works perfectly every time, until we add the VB file at the end.

I've tried 10 different ways according to the internet findings, but so far, nothing is working. The script never even runs. All the other items run before it, but once it gets to the .vb script, it errors out.

Any clue as to how to deploy a .vb script in a task sequence?

Thank you so much for your kind assistance.

I heard NTP server sync using a protocol to its NTP clients / endpoints so
no credentials (or authenticators) is involved.

What about MS SCCM & MS Dsktop Central?  Do they contain authenticators
of the endpoints they manage?  Can point me to some authoritative/MS
links that state this?  

If they contain them, when the authenticators are being sent to the endpoints,
are they encrypted?

It's a query raised by our Audit.  By authenticators, I assume it refers to
login id & password?
How to get all documents from SharePoint services document library at once?
Hi All,

When I create my first DAG through the ECP, I cannot see the C:\FSW like what I have typed in the Database Availability Group window?

Should I manually create the folder in the File Server (that I have chosen as the Witness), or do I have to wait until I add all 5x Mailbox database Nodes ?

Note: The File Share Witness is my PRODFS01-VM (my Production file server).
I have a lync  2013 setup and I have multiple pools. For some reason when I go to the Admin console, I get prompted for either of the two pools we have deployed and I cannot open the lync control panel. I continually get prompted for credentials, then get the error message below.

401 - Unauthorized: Access is denied due to invalid credentials.
You do not have permission to view this directory or page using the credentials that you supplied.

When I use the browser and go to https://poolname.domain.com/cscp I get the same as above.

when I go to each server directly like this url https://lyncserver1.domain.com/cscp I can get in without a problem.

I thought maybe it's a problem with the certificate but I have the pool name in the certificate and I assume I'd be running into much more problems if that was the case.

If I try to host file my machine to point the pool name as the ip of one of my servers, I also continuously get prompted for credentials and then get the above error.

We have our pools behind a radware load balancer but I don't think it's an issue as going directly to the server as the pool name seems to not fix the problem.

recent changes include the latest CU and probably all recent windows updates. I took over the environment fairly recently so I do not know if anything else was done or how long this was occurring. I do know it was working recently. Thank you.
Hi Team, Could you let me know how can I export all 'Active Alerts' to excel/csv from the scom console.

version - OM 2012 R2

Thanks in advance.
NFR key for Veeam Agent for Linux
NFR key for Veeam Agent for Linux

Veeam is happy to provide a free NFR license for one year.  It allows for the non‑production use and valid for five workstations and two servers. Veeam Agent for Linux is a simple backup tool for your Linux installations, both on‑premises and in the public cloud.

I added a site to the Search Result Removal under the SharePoint 2013 Search Administration page that I did not mean to remove is there a way to undo this change?

Does anyone know why there is multiple mailboxes migration that is stuck at 95% on the AutoSuspended process ?

Because when I do my migration from between the two Exchange Server 2013 VM within the same AD site, it is completed successfully most of the time or can be retried manually for completion.

So how to clean up the AutoSuspended mailbox migration safely without deleting the actual mailboxes itself ?

I'm running Exchange Server 2013 standard Version 15.0 (Build 1130.7)
We have a on prem 2013 SharePoint farm 2 WFE and an application server. Our Search is throwing the following errors:

The mount operation for the gatherer application 37804509-7ebe-4dd0-80f6-846e90d288e9-crawl-0 has failed because the schema version of the search gatherer database is less than the minimum backwards compatibility schema version supported for this gatherer application. The database might not have been upgraded.

As this is a production environment, we are reluctant to rebuild for fear of taking SharePoint offline.

I have looked and there is a lot of information for 2010 and not so much for 2013.

Looking for help
Afternoon all, im looking for a little advice on the Microsoft ATA solution. I have a client that has asked me to review the tool and implement it the network if appropriate. At present we have this in a Proof of Concept environment but i am having trouble getting anything to report back that is of any use (it notes new machines and users etc..)

Microsoft seem to have very little information on the tool and have not managed to come back with much useful information (they just keep providing web links to articles) we have the following setup in place at present:

Center Server: Virtual Server 2012 R2
Light Gateway: Virtual Server 2012 R2
Light Gateway: Azure Server 2012 R2
Light Gateway: Virtual Server 2008 R2

We have had limited feedback from the console on things that are happening within the network (but we did receive today on exposed credentials in clear text) so we know it is reporting things back. I wondered if anyone had used this before and could expand on the following:

  • How long is the learning period for the system
  • Will i be able to track access events (user/engineers accessing servers/shares they shouldnt
  • User account privileges (can i see if someone is given additional rights)
  • New administrator level account tracking

I would like to know how useful the system is in auditing the local network to offer feedback on potential security issues or will i need to review somthing like ManageEngine AdAudit?
Hi All,

I've got the task to install / deploy a custom application like Adobe Acrobat specific version to a specific group of computers (based on certain OU).

So I wonder how can I do it with no DOS batch scripting using the built-in Windows  Group Policy feature or GP preferences ?

Most of the clients are using Windows 10 (from 10240 up to TH2 and latest anniversary edition). I do not have access to SCCM.

Hi All,

Can anyone here please share some steps and procedures in how to deploy Windows 10 (Win10_1607_EnglishInternational_x64.iso) to my new bunch of HP laptops ?

ISO file name: en-gb_windows_10_multiple_editions_version_1607_updated_jul_2016_x64_dvd_9058848.iso

From what I know is that WDS+MDT is free can be deployed on any Windows Server 2012 R2. But I do not know how and where to start ?

Thanks in advance.
Microservices is a lot I hear, particularly in the cloud computing world, is there any relevance to Windows server apps?
Does anyone know if SCOM 2012 R2 extends the SCHEMA of AD when installed?  If so can someone point me to the documentation on removal?

We deploy image of Win7 x64 HP 840 Elitebooke G3 through SCCM 2012, the image deployment goes fine, but when it starts up, Network and USB drivers are not there, rest of them are fine (Image Attached) just want to know how can import drivers for Network and USB under HP G3?

[Webinar On Demand] Database Backup and Recovery
LVL 11
[Webinar On Demand] Database Backup and Recovery

Does your company store data on premises, off site, in the cloud, or a combination of these? If you answered “yes”, you need a data backup recovery plan that fits each and every platform. Watch now as as Percona teaches us how to build agile data backup recovery plan.


I have found various posts here and online but cant find one that can do everything I need in one report. I would like to create a SQL Reports for SCCM 2012 to show the following information in one report

PC Name
MS Office Version installed
MS Project version installed(if installed)
MS Visio Version installed (if installed)
MS Visual Studio Version installed (if installed)

I have had a look at the post below but when I select Office version 2010 it brings back 5-6 entries per PC

Hello all SCCM Guru's!

We have SCCM 2012 R2 and have been having issues updating Endpoint clients with definitions. Originally, the definitions were updated successfully for months, but suddenly now nearly 1/3 of the endpoint clients definitions will not update.

How do I begin to troubleshoot this issue on the clients? Can I uninstall and re-insttall the endpoint client easy enough?

Thanks for all your great assistance.


I have an issue on SharePoint 2010 Foundation and the Quick Launch. We have a list of several sites on the Quick Launch that not every user has access to. For example, we have 2 sites called '2.0 Pondfield' and '5.0 Rheola'. User A has no access to either site, however, '2.0 Pondfield' shows on the Quick Launch but '5.0 Rheola' doesn't for User A. When I check the permissions for User A on each site, they have no permissions on either site. So why does one site show on the Quick Launch and the other doesn't? I've recorded a quick video to show this issue and you can download it on the link below.

SharePoint Video

Hi Guys could you help me with my server storage.

I have one server which is ruuning out of space.

This server runs mainly sharepoint 2013

Question is could I delete these files which are on the image below ?

Thank you
Trying to create a hyper-v template for server 2012. I did run sysprep /OOBE and checked "generalize" but how come when I started this template it was asking to
1. accept license term
2. select region and language and click <Next>
and then comes the <Alt-Ctrl-Del> screen for you to log in the Administrator. Oops, if I didn't type the password I set prior to creating the template, I wouldn't be able to log in. A template should NOT be this way. Instead, it should allow you to set up a brand new password for the local Administrator. But in my case, it didn't happen that way.  
I must have done something wrong while creating the template. Can you help?
I have Lync Server 2013 running on Server 2012 R2. All of a sudden the Lync Server Control Panel isn't loading anymore. Attached is an image of the errorLync-Error.PNGI am getting HTTP Error 404.4-Not Found page.
Detailed Error Information
Handler: not yet determined
Error Code: 0x8007007b.

I have been able to log in just fine in the past but when I tried the other day I am getting the error. I have verified that Lync is 100% up to date as of now. I looked through the event log and haven't found anything that would point to an error. I'm sure it is a setting somewhere in IIS but I cannot find where. Someone please help

Microsoft Server Apps





Microsoft server applications are those applications developed specifically, but not necessarily exclusively, on the Windows Server platform. In addition to well-known products like SQL Server, Exchange, Internet Information Services (IIS), Microsoft Dynamics, Forefront, Lync and Sharepoint, they include applications like Skype, BizTalk, Hyper-V, Groove and Commerce Server. Server applications are managed with the Microsoft System Center.

Top Experts In
Microsoft Server Apps