Microsoft Server OS

56K

Solutions

41K

Contributors

The Microsoft Server topic includes all of the legacy versions of the operating system, including the Windows NT 3.1, NT 3.5, NT 4.0 and Windows 2000 and Windows Home Server versions.

Share tech news, updates, or what's on your mind.

Sign up to Post

I want to deploy my SSRS reports on my local laptop. How do i determine what my TargetServerUrl should be?>
0
JavaScript Best Practices
LVL 13
JavaScript Best Practices

Save hours in development time and avoid common mistakes by learning the best practices to use for JavaScript.

We've created a share for LAPS on our file server, the share Permissions had to be set as follows:
Everyone - Read & Execute, List Folder Contents, Read, Write
System - Full Control
Administrators - Full Control

The issue is this share is visible to Everyone & Everyone can write to it.  What we're looking for is a way to hide this share from Everyone in a way they can keep the same permissions.  We don't want it in a drop when browsing the shares on our server.  We need to keep the permissions for Everyone intact in order for LAPS to function correctly.
0
I am sure this question will have been asked and answered several times in different ways. I have researched but I would like a bit more specific answers to feel comfortable

I would like to add a new member Server 2019 to an existing replication group and ensure it will not delete or mess with the live data on another server, approx 500,000 files and 242 GB.

I have added the DFS namespace and replication roles
I've added the new server as a namespace server, this will replace a Server 2008 R2 DFS file server which is also a namespace server.

When I go to add a folder target the New Folder Target dialog box has defaulted to "Add this folder target to the replication group by using the following topology:"

"Single bi-directional connection to:" with a greyed out drop-down list

I would have thought "Full mesh to all members" would be more appropriate?

Questions:

1) What would happen if it's left on the default option
2) If Full mesh to all members is selected will that start the first replication to the new server from the nearest other DFS server?
3) Is it better just to untick the add to the replication group option and add it manually to the group after adding the folder target?

I have read the primary DFS member is only relevant during the first replication of the group. This would have been years ago when the 2008 server was configured to sync with the DFS server on another site. How does DFS know not to remove live files when there is now a blank…
0
Hi:

I really hate that someone has made it very difficult to create or edit a SQL Reporting Services (SSRS) Report.  In the old days, when I worked with SSRS everyday, I simply used the Business Intelligence Development Studio (BIDS).

Now, you cannot find anything like BIDS in the newer versions of SSRS.  I hate Report Builder and refuse to use it.

Last week, I followed instructions found online and installed Visual Studio Tools.  And, I asked the IT department to reboot the SQL box late at night.  This was all in an effort to find the latest equivalent of BIDS.

But, I cannot find this.

What in the world do I use and how do I find it?

Please help!  I can't believe that this tool has been buried, in the newer version of SSRS.  

Thank you!  Much appreciated!

John
0
Hi,

We have a corrupt exchange .edb file that we need to recover email from.

I have tried the exeutil soft recovery option, this did not work. I havent tried the hard recovry yet because the file is 600GB and reading up say its takes 3-4 hours per 3GB ish, this would take an ice age so im exploring other options first

The edb was part of a Raid 10 array that 2 of the drives for some reason marked themselves as foreign. We have to clear the virtual drive and reassign the disks to the new VD. All the data is still there. I dont think this is a factor but worth mentioning just in case.

The idea I had was to use some third party software that claims it can mount a corrupt edb and get what I can, but I cant even copy the edb file to another drive as it keeps failing saying the file is corrupt.

Any help or advice I could get at this point would be very appreciated.

The database is currently marked as dirty shutdown. I tried reading how to make it a clean shutdown but couldnt seem to get anyhting to work.

Thank you
0
process id for lsass.exe keeps locking out account
0
On a  Windows 2016, VM I need to do an offline repair of the OS using DISM. Now matter what syntax I use, I cannot get it to work. My CDRom is on E:\ and my OS is on C:\. What is the correct syntax. I have been at this for hours without luck.
0
Good morning,

We have just migrated our KMS server from an old 2008R2 server to a new 2016 server. The old server only really activated Office 2016 Pro Plus and a couple of old 2008R2 machines. We removed the keys and put them into the new 2016 KMS server and all was well except for the Office key. Also there are new Server 2016 keys on the new server that have taken and are activating the new VMs without issue.

The Office 2016 key will not load into the new KMS server, it returns "error 0xC004F050 The software service reported that the product key is invalid". So we contacted the supplier and they verified with Microsoft that the key is genuine and valid (we have been using it for over a year already).

Some online searches later we found many other users with this same issue when moving to Server 2016 KMS activation for Office, however no solutions that were presented have been effective.

The 'technical guy' from the licence supplier was able to replicate the error using his test environment, however they have no solutions for the issue.
All our Windows Server keys are working from the new KMS and activating as expected, which suggests it's some kind of compatibility issue with 2016 office and 2016 KMS.

So, have any of you ever managed to resolve this issue? We are running out of grace period for the Office 2016 (about 12 days left) and seem to have run out of ideas.

Can you help?


info:
Office 2016 Pro Plus is on a perpetual licence, we don't …
0
I have a client that wants us to migrate their existing Server 2008 R2 Enterprise to Server 2019 Standard. We will be provisioning the new server from scratch so I want to make sure that we have the new server properly configured before we start the process. Can anyone direct me to a resource where I can find the exact steps required to move the AD and all of the data on the old server to the new server. I am hoping that when everything is finished all the users have to do is to log off and then log back in and all of their settings, desktops and files etc. are available to them. I am contemplating getting our NOC help desk involved to do this or if the instructions are starightforward then we will do it on our own. We are efficient at provisioning servers but we have never attempted a migration.
1
how do I upgrade adfs 3.0 to adfs 4.0? from windows server 2012 to 2016 proxy or do I need desperate se

Does ADFS 2016 comes with Web application proxy or do I need separate server?
0
C++ 11 Fundamentals
LVL 13
C++ 11 Fundamentals

This course will introduce you to C++ 11 and teach you about syntax fundamentals.

I cannot access a shared drive from Win 10 Pro PC on a Win 2012 server.
Troubleshooting done:
- Pinged server successfully by IP address
- Pinged server unsuccessfully by NetBIOS name
- Did an ipconfig /flushdns still not able
- From the server can ping the workstation by both IP address and NetBIOS name.
- It is a workgroup environment
Please help!
0
Hi, we have DellEMC VXRAIL VMware vSAN Cluster consist of 4 ESXi hosts. We are using vSAN iSCSI targets hooked up to Virtual Machines for Windows Server 2012 R2, Failover clustering. The cluster works fine after configuring.

However, when I run the cluster validation test, it fails with below error:

Two disks have been found on node SRVVDB01.domain.local that cannot be distinguished from one another. The disks involved have disk signature c10b5a63, SCSI page 83h VPD descriptor iqn.1998-01.com.vmware.52e5e355fe26a1cb-a80ef9982d7fc722,L,0x0000000000000000, SCSI page 80h VPD Serial Number VITSERIALbaebec5cee2b845f0bcde4434b5acd30. Please verify the storage configuration. You must either mask (unpresent, detach) one of these LUNs at this node, or, run validation and specify a disk list that includes only one of these disks, for example by using the Test-Cluster cmdlet in Windows PowerShell.

Please help !!
0
We want to deploy a simple VDI infrastructure based on Windows Server 2019 RDS.

We have a two node S2D cluster and we would like to know if we can use this cluster as the RDS virtualization host.
0
Hi Experts,

how to activate PXE-Boot on a SCCM-Distribution Point Server ?
The server already exists but PXE Boot is not enabled.
0
1.  I need to change the destination of an SSRS report in Visual Studio 2010 so that when I deploy it, it goes to the correct folder.  There appear to be about 6 or 10 places where I can change options, I just cannot seem to find the right place to change these deployment options.

2.  On this particular report, there are two subreports.  I would like to deploy these two reports to a separate (subfolder) under the folder which contains the main report.  I assume that the changes I make in #1 are for SSRS, not for a particular report (is that correct).  If so, I will need to change the path for those subreports as well.  How do I change the path to these subreports in the Visual Studio report designer?
0
What would be the disadvantages of installing a server on a workstation machine?

For instance, on a DIY machine with i9-9980XE and SSD 905P, a motherboard I've not decided on yet (any suggestion?), I'd install Win Server 2019.

But still, that's workstation hardware, not server hardware.  It is not cheap, but fast, and it seems it is even more reliable, especially due to the  905P.

A server as fast as this from Dell would be double the price probably.
And now I wonder what I loose buy installing a server on a workstation...
0
HI, i am building a new server with vmware, with 2 physical cpu's and i want to run 4 vm's running server 2016.

What would be the appropriate licensing i would need for this ?
0
SSRS subreport does not display properly after deployment.

I've developed (modified actually) a report in SSRS (via Visual Studio).  The report and subreports display properly in the VS report designer, but after I deploy the reports, the main report deploys properly but the two subreports fail to render.

Any ideas?
0
Hi

I have a Hyper-V VM (Host an VM are Windows 2012 R2) that work fine this morning and after 1 hour after employed begin to work, it began to have many problem, most are network specific. It is a DC. This week-end we had a power outage, so I think first that it come from there. I tried to find the problem but it that something is stuck somewhere. many service seem to initialising but stay there or many doesnt seem to start. But there nothing in event log. I have a remote access program on the vm and it is not start, Sql server don't respond, RDP don't respond and many other service don't respond but all share work fine. Internet access is working.

When I check windows activation it said product id unavailable. I tried to reinsert the key but it seem to work without stopping. The key come from an open licence account and it is use on the host and it work fine on it. When I check the maintenance manager it said maintenance running. I tried DISM.exe /Online /Cleanup-image /Scanhealth but it did nothing after 2 hours.

I have in server manager I have problem with managability, it said, online - data retrieval failures occured. I have an other problem reported by server manager for the automatic refresh: Configuration refresh failed with the following error: Call was cancelled by the message filter.

When I shut down the server it stuck on Stopping service  :

I tried restore a 1 month old vm backup and start from there but it does the same thing. That's very weird. …
0
Become a CompTIA Certified Healthcare IT Tech
LVL 13
Become a CompTIA Certified Healthcare IT Tech

This course will help prep you to earn the CompTIA Healthcare IT Technician certification showing that you have the knowledge and skills needed to succeed in installing, managing, and troubleshooting IT systems in medical and clinical settings.

Hi EE,

I have a rather unusual problem I can only get either  Web Portal URL working or  Web service URL working but not both.

What is currently happening is if the web service URL and web portal URL match (virtual directory name is the name) the web service works but the web portal doesn't.

And if the web service URL and web portal URL have different (virtual directories) the web address for the web portal works.

Attached are pictures of my current settings.



Right now I can only see the web service working.

From the reportserver config file.

<URLReservations>
            <Application>
                  <Name>ReportServerWebService</Name>
                  <VirtualDirectory>Autumncareuatreport</VirtualDirectory>
                  <URLs>
                        <URL>
                              <UrlString>http://+:81</UrlString>
                              <AccountSid>S-1-5-80-4000206335-4242116595-3118339656-1734867201-556326921</AccountSid>
                              <AccountName>NT SERVICE\ReportServer$AUTUMNCARETESTRS</AccountName>
                        </URL>
                  </URLs>
            </Application>
            <Application>
                  <Name>ReportServerWebApp</Name>
                  <VirtualDirectory>Autumncareuatreport</VirtualDirectory>
                  <URLs>
                        <URL>
                              <UrlString>http://admin:81</UrlString>
                              <AccountSid>S-1-5-80-4000206335-4242116595-3118339656-1734867201-556326921</AccountSid>
                              <AccountName>NT SERVICE\ReportServer$AUTUMNCARETESTRS</AccountName>
                        </URL>
                  </URLs>
            </Application>
      </URLReservations>

Thank you
Web-Portal.PNG
Web-Services.PNG
0
I've remoted into test servers directly by installing Unattended GoToAssist - which is my preferred remote access platform.

But often servers are set up to not have web access on purpose.

I can imagine using RDP from a work station into the Server on the same LAN and use Unattended GoToAssist to reach that workstation first.

Any suggestions?  What do *you* do?
0
we have a windows 2016 vm which is our exchange 2016 server.

we are trying to install the cumulative update for 2019-06, which installs in the first instance, but when we restart the server, as required, we are told that it could not be installed and is removed. the server is then restarted, and we see that the update did fail.

i notice that this has being happening for the past 4 cumulative updates, although several smaller updates like stack updates etc install ok.

i have tried downloading the kb manually and installing, but again thus too fails.

can anyone advise how we can resolve this issue, so that we can get the cumulative updates installing again?

any advice much appreciated.

many thanks
0
Do you have to take intermediate steps in upgrading to Windows server 2016, or can you upgrade directly?
0
What's the process for replacing a Domain Computer for a Domain User?

DC Server is 2019 Essentials and New Computer is Windows 10 Pro. Old Computer is Windows 7 Pro

1. The only GPO running at login  does Folder Redirection for Desktop, Documents, Pictures and Contacts. So, the user already has all of that data on the server in her folder created by the GPO

2. We don't use roaming profiles...so I know I cant just simply log her in with the users credentials and everything is there.

3. Do I need to remove the old computer from AD Users & Computers before joining the new one to the domain?

We only have one DC and 12 computers on it. I have already installed Office 2016 and her other applications onto the new computer but afraid to join the domain. I have had SIDs issues before monkeying with Computers/User Profiles etc.

 Just trying to do this right.
0
I create a new file server to move users home folders.
The share folder name is Users$, I add with following permissions:
Domain Users - Traverse folder, List Folder, Create Folders in 'This Folder Only'.
Creator Owner - Full Control in Subfolders and file only.
System - Full Control in This folder, subfolders, and files.
Domain Admins - Full Control in This folder, subfolders, and files.
But I got this error when AD try to create the user home folder: The shared folder already exists. Because the folder is at the root of the file share, you must verify that the user has the appropriate permissions to manage the contents of the folder.
I tested also given to the Domain Users full access of the folder and I got the same error.
Any suggestion on how to troubleshoot this issue.
Capture.PNG
0