Microsoft Server OS

57K

Solutions

41K

Contributors

The Microsoft Server topic includes all of the legacy versions of the operating system, including the Windows NT 3.1, NT 3.5, NT 4.0 and Windows 2000 and Windows Home Server versions.

Share tech news, updates, or what's on your mind.

Sign up to Post

Hi Experts,

how to activate PXE-Boot on a SCCM-Distribution Point Server ?
The server already exists but PXE Boot is not enabled.
0
1.  I need to change the destination of an SSRS report in Visual Studio 2010 so that when I deploy it, it goes to the correct folder.  There appear to be about 6 or 10 places where I can change options, I just cannot seem to find the right place to change these deployment options.

2.  On this particular report, there are two subreports.  I would like to deploy these two reports to a separate (subfolder) under the folder which contains the main report.  I assume that the changes I make in #1 are for SSRS, not for a particular report (is that correct).  If so, I will need to change the path for those subreports as well.  How do I change the path to these subreports in the Visual Studio report designer?
0
What would be the disadvantages of installing a server on a workstation machine?

For instance, on a DIY machine with i9-9980XE and SSD 905P, a motherboard I've not decided on yet (any suggestion?), I'd install Win Server 2019.

But still, that's workstation hardware, not server hardware.  It is not cheap, but fast, and it seems it is even more reliable, especially due to the  905P.

A server as fast as this from Dell would be double the price probably.
And now I wonder what I loose buy installing a server on a workstation...
0
we have migrated our SSRS 2014 Reports to SSRS 2016 . we have successfully deployed all the reports and data sources. However, the Report Subscriptions are not migrated .

can anyone help me how to migrate SSRS email subscriptions to 2016 ? I don't want to create them manually as there are loads of them.

Many Thanks
0
HI, i am building a new server with vmware, with 2 physical cpu's and i want to run 4 vm's running server 2016.

What would be the appropriate licensing i would need for this ?
0
SSRS subreport does not display properly after deployment.

I've developed (modified actually) a report in SSRS (via Visual Studio).  The report and subreports display properly in the VS report designer, but after I deploy the reports, the main report deploys properly but the two subreports fail to render.

Any ideas?
0
Hi

I have a Hyper-V VM (Host an VM are Windows 2012 R2) that work fine this morning and after 1 hour after employed begin to work, it began to have many problem, most are network specific. It is a DC. This week-end we had a power outage, so I think first that it come from there. I tried to find the problem but it that something is stuck somewhere. many service seem to initialising but stay there or many doesnt seem to start. But there nothing in event log. I have a remote access program on the vm and it is not start, Sql server don't respond, RDP don't respond and many other service don't respond but all share work fine. Internet access is working.

When I check windows activation it said product id unavailable. I tried to reinsert the key but it seem to work without stopping. The key come from an open licence account and it is use on the host and it work fine on it. When I check the maintenance manager it said maintenance running. I tried DISM.exe /Online /Cleanup-image /Scanhealth but it did nothing after 2 hours.

I have in server manager I have problem with managability, it said, online - data retrieval failures occured. I have an other problem reported by server manager for the automatic refresh: Configuration refresh failed with the following error: Call was cancelled by the message filter.

When I shut down the server it stuck on Stopping service  :

I tried restore a 1 month old vm backup and start from there but it does the same thing. That's very weird. …
0
Hi EE,

I have a rather unusual problem I can only get either  Web Portal URL working or  Web service URL working but not both.

What is currently happening is if the web service URL and web portal URL match (virtual directory name is the name) the web service works but the web portal doesn't.

And if the web service URL and web portal URL have different (virtual directories) the web address for the web portal works.

Attached are pictures of my current settings.



Right now I can only see the web service working.

From the reportserver config file.

<URLReservations>
            <Application>
                  <Name>ReportServerWebService</Name>
                  <VirtualDirectory>Autumncareuatreport</VirtualDirectory>
                  <URLs>
                        <URL>
                              <UrlString>http://+:81</UrlString>
                              <AccountSid>S-1-5-80-4000206335-4242116595-3118339656-1734867201-556326921</AccountSid>
                              <AccountName>NT SERVICE\ReportServer$AUTUMNCARETESTRS</AccountName>
                        </URL>
                  </URLs>
            </Application>
            <Application>
                  <Name>ReportServerWebApp</Name>
                  <VirtualDirectory>Autumncareuatreport</VirtualDirectory>
                  <URLs>
                        <URL>
                              <UrlString>http://admin:81</UrlString>
                              <AccountSid>S-1-5-80-4000206335-4242116595-3118339656-1734867201-556326921</AccountSid>
                              <AccountName>NT SERVICE\ReportServer$AUTUMNCARETESTRS</AccountName>
                        </URL>
                  </URLs>
            </Application>
      </URLReservations>

Thank you
Web-Portal.PNG
Web-Services.PNG
0
I've remoted into test servers directly by installing Unattended GoToAssist - which is my preferred remote access platform.

But often servers are set up to not have web access on purpose.

I can imagine using RDP from a work station into the Server on the same LAN and use Unattended GoToAssist to reach that workstation first.

Any suggestions?  What do *you* do?
0
we have a windows 2016 vm which is our exchange 2016 server.

we are trying to install the cumulative update for 2019-06, which installs in the first instance, but when we restart the server, as required, we are told that it could not be installed and is removed. the server is then restarted, and we see that the update did fail.

i notice that this has being happening for the past 4 cumulative updates, although several smaller updates like stack updates etc install ok.

i have tried downloading the kb manually and installing, but again thus too fails.

can anyone advise how we can resolve this issue, so that we can get the cumulative updates installing again?

any advice much appreciated.

many thanks
0
Do you have to take intermediate steps in upgrading to Windows server 2016, or can you upgrade directly?
0
What's the process for replacing a Domain Computer for a Domain User?

DC Server is 2019 Essentials and New Computer is Windows 10 Pro. Old Computer is Windows 7 Pro

1. The only GPO running at login  does Folder Redirection for Desktop, Documents, Pictures and Contacts. So, the user already has all of that data on the server in her folder created by the GPO

2. We don't use roaming profiles...so I know I cant just simply log her in with the users credentials and everything is there.

3. Do I need to remove the old computer from AD Users & Computers before joining the new one to the domain?

We only have one DC and 12 computers on it. I have already installed Office 2016 and her other applications onto the new computer but afraid to join the domain. I have had SIDs issues before monkeying with Computers/User Profiles etc.

 Just trying to do this right.
0
I create a new file server to move users home folders.
The share folder name is Users$, I add with following permissions:
Domain Users - Traverse folder, List Folder, Create Folders in 'This Folder Only'.
Creator Owner - Full Control in Subfolders and file only.
System - Full Control in This folder, subfolders, and files.
Domain Admins - Full Control in This folder, subfolders, and files.
But I got this error when AD try to create the user home folder: The shared folder already exists. Because the folder is at the root of the file share, you must verify that the user has the appropriate permissions to manage the contents of the folder.
I tested also given to the Domain Users full access of the folder and I got the same error.
Any suggestion on how to troubleshoot this issue.
Capture.PNG
0
I need to extend the C drive on windows 2003 server.
Dispart cannot expand it as it is a system partition.
Which tool can I use to expand the C drive.
This server is a virtual machine.
1
Hi Experts,
I have an ssrs 2008r2 report linked to images.  The report renders the image in Visual Studio but does not find the image in runtime
scr= ""  when looking at the browsers response i.e there is no path included to render the image.
When you type out the full web address of the photo in a browser it can be seen in the browser
The photo is stored locally on the PHP website.  Both the reporting services and database server are on the same domain.
The folder has anonymous access for testing, so not sure what else I can trouble shoot.
Any help would be appreciated.
Regards
Chris
0
What is Microsoft’s recommendation for AD design?
0
In active directory, is it best to configure all DC’s as GC’s?
0
I work in VS 2015 VB.Net
I creatd SSRS report with subrepot.
I read that to do that you have to populate both your main report and subreport in code, and for the subreport you create an event handler to populate.
In my case the subroutine that handles the event handler never gets invoked, and the subreport is not getting populated. Report displays only the main report, the subreport returns a message: Error: Subreport could not be shown.
Here are the references I have on the page:
Imports System.Data.SqlClient
Imports Microsoft.Reporting.WebForms
Here is my page load event:
Private Sub Page_Load(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles MyBase.Load
        If Not IsPostBack Then
            ReportViewer1.ProcessingMode = ProcessingMode.Local
            ReportViewer1.LocalReport.DataSources.Clear()
            ReportViewer1.LocalReport.ReportPath = Server.MapPath(".") + "/SSRSReports/" + "PvPDOrder.rdlc"
            ReportViewer1.LocalReport.DataSources.Add(GetReportDataSource)
            AddHandler Me.ReportViewer1.LocalReport.SubreportProcessing, AddressOf SubreportProcessingEventHandler
            Me.ReportViewer1.LocalReport.Refresh()
        End If
    End Sub

   Public Sub SubreportProcessingEventHandler(ByVal sender As Object, ByVal e As SubreportProcessingEventArgs)
        Try
            e.e.DataSources.Add(GetSubreportDataSource)
        Catch ex As Exception
            ' MessageBox.Show(ex.Message, …
0
I have been trying to have this GPO work to update Chrome on my client computers but not successful.  

I follow this link https://support.google.com/chrome/a/answer/6350036?hl=en, and copy the google, chrome, and googleupdate admx, adml files into the Policyupdate folder in SYSVOL of my domain controller.  

I go to the administrative templates>google>google update>applications, and enable the update policy override default policy, and choose the "always allow updates" under options.  

Under administrative templates>google>google update>applications>google chrome, I have enabled "Allow installation", and "update policy override".  

I run RSOP on my client, and see the policy has been received, and all updates show.  However, when I check the hkey_current_user\software\google\chrome\blbeacon, the version still show 74.0.3729.169 instead of the new version.  

I posted this question previously, and someone said google chrome updates itself.  I do not see update happens on my clients until I click HELP>ABOUT GOOGLE CHROME from the browser.  If I do not see the latest version in the registry, I am assuming the update is not happening.  


Please advise if someone has an idea.
0
Trying to install SERVER 2012 R@ or Server 2016 on Dell T110.  Cannot get past the initial setup screen as it says there are no storage devices.  
I have 3 Drives in RAID 5 (newly created volume) - When I try to install 2012 or 2016 it tells me there are no storage devices - it doesn't see the integrated Perc S100 controller.  I have downloaded and expanded the Dell Pre-OS Deployment kit and I have to remove the "hide non compatible devices" to see any type of controller, but it does not load it or recognize the Volumes.
0
i would like to seek expert advice for the licensing window 2016 standard.Recently we just purchase one OLP license to upgrade 3 server from 2008 to 2016.

 We purchased (qty=32) Windows Server 2016 Std ,i would like to provision another VM using window Server 2016.Do i need purchade additional license?How many VM i can provision based from 32 .

Let said the license above insufficient ,how many license need to purchase ?

we have running hyper-v cluster in our enviroment.

1.HV-Nodes 1
processor: 2 x processor with 6 cores each

2.HV-Nodes 2
processor: 2 x processor with 6 cores each
1
Hello. We have an Exchange 2010 server with a wildcard SSL certificate covering a particular domain, let's call it main.exa.

The server is multi-tenant, so it covers more than one e-mail domain. Let's call the other domains test1.exa and test2.exa.

These other domains are not certified, but we are redirecting autodiscover.test1.exa and autodiscover.test2.exa to autodiscover.main.exa. There are guides online to do this, but this doesn't seem to work.

What happens is, if I connect Outlook from an external PC to an address from test1 or test2, I'll always get a certificate warning saying for instance test1.exa doesn't have a certificate.

I was wondering if someone can shed any light on this conundrum. Thanks.
0
I had used below command to perform windows activation:
cscript slmgr.vbs /skms "IP"
cscript slmgr.vbs /ato

And i got an prompt Windows activated

i still having prompt saying "you windows license is valid for 180 days"
But down there, it showed "Windows Activated"
wa1.PNG
wa2.PNG
0
Hello,

I have a message in my windows 10 check update of SQL 2019 service pack which i posted it's image below.

sql 2016 windows update
I have sql 2017, do I need this service pack?
If I do, how can successfully install this update?
If I do not need this update, how can delete this continuous windows update check?

Thank you very much.
0
Hi Experts,

can you help me with ADFS trouble shooting ?

When my client connects to ADFS, he has to choose between several certificates.
Is it possible to switch it off ?

Do you have any guidelines how to troubleshoot ?
Maybe some sites to test ?
Test authentication and so on ?
0