Microsoft Server OS

56K

Solutions

41K

Contributors

The Microsoft Server topic includes all of the legacy versions of the operating system, including the Windows NT 3.1, NT 3.5, NT 4.0 and Windows 2000 and Windows Home Server versions.

Share tech news, updates, or what's on your mind.

Sign up to Post

I hope this makes sense, this is about as plain as I can describe.  I searched everywhere for an answer.
Current setup-
Individual Servers
 -   Windows Server 2012 Dc's, Functional Levels -  Windows Server 2012
Exchange 2010 SP3

A requirement is to install Windows Server 2019 schema (ver 88) without raising forest/domain levels
My question is, will this break exchange 2010 sp3 ?
0
I have been given a report that is currently group by these fields:
EmployeeID
Project
CostCategory

They now what me to add not only the location and department but to have the ability at runtime to be able to select whether to print in location/department/employee/project/cost category order or department/location//employee/project/cost order.  The SQL query has been modified to handle this, however the report was originally written using groups for the
EmployeeID,Project,CostCategory values. Should I scrap those groups and start over? How do I insert the location/department groups at the beginning? Do I create a parent group? How do I get the report to sort in two different orders?
0
I am attempting to run an SSRS report on a brand new SSRS installation. I am getting this message:

"The current action cannot be completed. The user data source credentials do not meet the requirements to run this report or shared dataset. Either the user data source credentials are not stored in the report server database, or the user data source is configured not to require credentials but the unattended execution account is not specified. (rsInvalidDataSourceCredentialSetting)
 "

When I try to look at the data sources in SSRS it is not there. I even tried servername/reports/browse/data sources and it tells me it is not there. I tried running repair on this instance of SQL and that did not help. What can I try to get the data sources folder back so I can check on the data sources under this instance of SSRS? There also is no Home icon and when I click Show Hidden Items nothing appears.
0
Dear all,

I'm going to use Storage Migration Service under Windows Admin Center, when I click "Storage Migration Service", it returns
"Try reloading this page—something didn't work quite right."

Is there anyway to resolve it?  I'm using Windows Server 2019 (1809, 17763.379).  Windows Admin Center I use is Version 1904 (1.2.1904.11004)

I'm using Chrome to access this Windows Admin Center

Please refer to below screen shot for details:

Error Message
Storage Migration Version
0
I have an SSRS report and want to Schedule it to run on the last day of the month. You can't easily do this in subscriptions so I changed the schedule in the job to this:
ScheduleWill this work?
0
We use MS Reporting Services to send out daily reports to some of our customers. Reporting services is configured with email@domain1.com. Before we switched to Office 365 from Gmail we were able to send some of our reports out through email@domain2.com. These would come across as "reporting services via Company 2 Support" with email@domain2.com showing as the from and reply-to address. I was not employed with this company at the time of setup and cannot figure out how this was done.

Basically, if reports are being sent to customers of company 1, show email@domain1.com.
If reports are being sent to customers of company 2, allow sending on behalf of email@domain2.com.

I know that reporting services will only allow one "from" email address. Is this possible to achieve through some other means? Through some sort of relay perhaps? Thanks in advance.
0
I am trying to install the MS Volume Activation Management Tool using the feature with Server 2016.  It appears when I install that feature, it only allows for KMS licenses and I need to be able to manage MAK licenses.  Is there a way to use MAK licenses with this feature.  Should I just download VAMT 3.1 and install that on the 2016 server.  We currently use the VAMT 3.1 on 2008 R2 and 2012 R2.
Thank for your help

Art W.
0
I have a server running Windows Server 2012 R2 Essentials and Access Anywhere VPN is setup and WAS working. Now everyone who attempts to access this server remotely using the VPN gets the following symptoms. The VPN connects (apparently) but all access to the Internet goes down at the same time. Disconnecting the VPN restores Internet access. I have tried unchecking the tick box to 'use remote network default gateway'. This restores connectivity locally but I cannot access anything on the remote end of the VPN - the whole point of the VPN! I have other servers setup similarly and they are working fine, but I cannot determine what is causing this VPN connection to fail. I have also tried adding a route to the remote server in my routing table but that also doesn't work. How should I troubleshoot this. I have been looking for differences in RRAS / VPN setup between a server that works and the one that fails but cannot determine anything different. I can access the server via RDC and I can get the Remote web access website up using the external address (same as VPN uses. Ports are forwarded same as working system. VPN using same SSL certificate as default website in IIS. VPN is SSTP.  Some users report it stopping nearly 3 weeks ago (maybe?) . Can anyone help?
0
I can connect to a laptop via the SCCM console, but it automatically disconnect me, why?
0
GUys,
I have sql 2014 ent edition that installed with SSRS, this version of sql servers was actually an upgrade version from sql 2008 R2. Today I have a report that having a row size more than 65536 and somewhat report subscriptions failed to sending this report with following errors.  from what I understood this sql 2014 ssrs should have bigger row limit size.


 
 An updated rendering extension for Microsoft Excel 2007–2010, supported both by Report Builder and the SSRS web rendering controls (both covered in this chapter). The maximum number of rows you can export from an SSRS report to an Excel worksheet is now 1,048,576, the maximum number of columns you can export is now 16,384, and the maximum number of colors supported for generated content is 16 million. The export format is Open Office XML (OOXML), and files are generated as zip-compressed *.xlsx archives.
 
 
 
 
 ▶
 
 An updated rendering extension for Microsoft Word 2007–2010 (and 2003). It also supports the OOXML standard, generating zip-compressed *.docx files. Note that in order to open *.docx and *.xlsx files, Microsoft Office clients must be at version 2007 or later, or you must install the Office Compatibility Pack (available free from Microsoft’s download site)


Failure sending mail: Excel Rendering Extension: Number of rows exceeds the maximum possible in a worksheet of this version. Rows requested: 105676. Maximum rows: 65536.Mail will not be resent.
0
Hello,

I am preparing exam results reports in SSRS using Visual Studio 2008, and the actual report is visually very simple.

I have attached a simplified version here, and it simply lists subjects, grades, and the total of each grade.

I am trying to add a column at the end, to show the percentage of both A and B grades together, within all grades (A,B,C,D).

So, for example, in English, out of a total of 25 candidates, 14 had A or B, so the percentage of A,B is 56%

I'm struggling to write an expression to do this. I would normally do a expression, consisting of a calculation, and reference textboxes in the report grid
to get the values, but in this case the data is grouped, so I'm not sure what to do.

I can't find any similar example on the web.

I have attached sample of the report preview, rendered report, and the SQL output grid showing all the field names.

Can anyone help, please?

Many thanks,

Jim Dorans

the report in design modethe rendered reportthe SQL output showing file names
0
Hey gents we have been experiencing several shutdown errors with our ESXI Host.   We have the companies FS/ DC running off this host I believe its 6.0.   Last night around 4 or 5PM EST The servers shut down again.   I have attached some event viewer logs.   Server OS is 2012 R2.   Now after the server went down it did not automatically reboot.   I checked for memory.dmp files and could not find any under the %systemroot% (I don't think they are hidden).   So I am wondering if its related to power.  Also looking at our Datto backup in place which stopped working 3 hours prior, looking at the meta data it showed a communication loss to one of the shared partitions on the server which was their E:\ volume where all their shares sit.     Here is the Meta Data Log.

Tue 23/04/19 1:01:02 pm - metrics {"name""HighlyRandomUnidentifiableMimetype","description""Detects file entries that contain a known extension, unidentifiable mimetype, and are highly random","result"false,"occurrences"0,"total"0,"percent"0,"threshold"0.05,"minimum_samples"20,"maximum_occurrences"9223372036854775807,"files"[]} 
Tue 23/04/19 1:01:02 pm - Rule "HighlyRandomUnidentifiableMimetype" did not detect ransomware. 0 out of 0 files checked showed signs of ransomware (0%%). 
Tue 23/04/19 1:01:02 pm - metrics {"name""KnownRansomwareExtensions","description""Detects file entries that contain a known ransomware 

Open in new window

0
Hello.

I have this SBS 2011 server which is retaining a whole lot of previous versions of files, more than a month's worth.

So System Volume Information takes up about 120GB of space. I was wondering, which way would be the best to reduce this space, say by about 20%?

Thanks, y'all.
0
We are going to start migrating sbs2011 to server 2016 STD.
We are trying to backup the system state using Windows server backup utility.
we have tried running CMD Wbadmin start backupsystemstate -backuptarget:L:    we are using a external usb Drive
it will always fail with The filename, directory name, or volume label syntax is incorrect.

I also tried backing up to a network share and to a different partition on the server.

I also setup the Server Backup utility to manually backup the system state also. Still fails with same error
Does anyone have any ideas as to why this is happening or a workaround?

We also have Datto backup which uses storagecraft shadowcopy which is a service that datto uses to backup the server.

Not sure if that will stop the server backup to run. I also checked the VSS writers and they are all stable.
0
Need some advice on how to do a license calculations for Hyper V Cluster environments? Thanks.
0
Hello Experts,

We are migrating a lot of windows 2008 R2 stand alone servers, some with hyper-v.  The VM's are running the same OS.  Is there any third party software that can move all of the roles, features and any software currently installed to a newer server such as Windows Server 2016 or 2019?  I haven't really heard of something like this but figured this would be the best place to ask first.

thank you,

-GTS
0
I'm planning on replacing my "Domain Controller Authentication" template with "Kerberos Authentication" for domain controllers.  The ADCs are currently configured for auto-enrollment.  I've put "Domain Controller Authentication" template in the Supersedence tab on the "Kerberos Authentication" certificate template, configured that domain controllers will auto-enroll and published the new template.

My question is do I leave the old "Domain Controller Authentication" template published or should I remove it from Certificate Templates?
0
Does anybody have any projects or insight on upgrading the SQL Server source databases to 2017 and still use existing SSRS 2012 .rdl files? We need to upgrade our OLTP environment and do not currently have enough SSRS report developers to get the SSRS part done by the due date. Our thought was to leave the current .rdl files at 2012 revision level and just upgrade the OLTP source database to 2017. We will not be upgrading the SSRS databases or the SSRS engine.

Thanks experts!
0
Server 2008 Standard -- SQL 2014 -- Need to recover two folders from RAID 5 (4 disks).    System failed to boot and rather than spend incredible amounts of time (beyond attempting to boot to 'last known' or attempt 'safe mode'), just popped in four new drives and reinstalled operating system and SQL2014.

However, I need a couple of folders off the broken array.   Any suggestions on how to get these rather than send the drives out?   It sure would be nice to get the server back online so staff can come back to work.  (sigh).
0
Hi all,
I'm trying to build a graphs in ssrs report , when I test to receives this report I'm curious why  I can view all  namesgraphs_ssrs_email.PNG which only ssrs present me 3 names  ( managersemail ( those marked as dark ) where the actual  values I should be able to have 100 of them here.

This is how the report looks like in ssrs report builder graphs_ssrs.PNG
0
Hi Experts,

  I'm receiving the error below after changing a single-value parameter to allow multiple values and I have not been able to get past it for weeks. Oddly enough, I have another parameter (@state) that I've set to allow multiple values, and it works perfectly fine.

Under the error is the primary data set code, as well as the ones used for suppliers (@Manufacturer) and states (@state). I have also included a number of screenshots that show the column visibility expressions, the single tablix filter for the ship2_state column and screenshots with the errors, column filters and parameter details.

I have attempted to use joins - e.g. =IIF(Join(Parameters!QueryParameterType.Value,",").Contains("1"), False,True) or =Switch(

Parameters!QueryParameterType.Value(0) = "2", False,

Array.IndexOf(Parameters!QueryParameterType.Value,"1") > -1, False,

True, True

)

and nothing is working. I really need someone to help take a look and show me what I'm missing. I've outlined everything in the SSRS report.

ERROR:

The Hidden expression for the tablix ‘table1’ contains an error: Overload resolution failed because no Public '<>' can be called with these arguments:
    'Public Shared Operator <>(a As String, b As String) As Boolean':
        Argument matching parameter 'a' cannot convert from 'Object()' to 'String'. (rsRuntimeErrorInExpression)


DataInfo dataset source (main body of report):


IF @QueryParameterType=1
(
SELECT …
0
This is something that I've had trouble with over the years.   In the script below I need to move the date script in the where statement into the select.  so I want to the the last 365 days for po_count and line_count.  This way I see all suppliers even if they have a 0. The issue is the group by as I don't want to add date_created into the group by or it make a different line for each date and I want the sum so one line per supplier.

This is my case statment but requires me to put po_hdr.date_created into the group by which is not what I want.  

case when ( po_hdr.date_created >= Getdate() - 365 ) then  Count(DISTINCT po_hdr.po_no) else 0 end AS po_count

Open in new window

case when ( po_hdr.date_created >= Getdate() - 365 ) then  Count(DISTINCT po_line.po_line_uid) else 0 end AS po_count

Open in new window



SELECT DISTINCT p21_view_contacts.first_name + ' '
                + p21_view_contacts.last_name       AS buyer,
                p21_view_supplier.supplier_id,
                p21_view_supplier.supplier_name,
                Count(DISTINCT po_hdr.po_no)        AS po_count,
                Count(DISTINCT po_line.po_line_uid) AS line_count
FROM   p21_view_supplier
       INNER JOIN p21_view_contacts
               ON p21_view_supplier.buyer_id = p21_view_contacts.id
       INNER JOIN po_hdr
               ON p21_view_supplier.supplier_id = po_hdr.supplier_id
       INNER JOIN po_line
               ON po_hdr.po_no = po_line.po_no
WHERE  ( p21_view_supplier.delete_flag

Open in new window

0
We are about to setup a new server. the Server has 24 cores. we purchased 1 16 core license and 4-2 core licenses.

we only have the 16 core license right now and the other 8 are on back-order.  

Can we still setup the server with the 16 cores license for now. or do we have to wait for the other 8 before we start the install.
1
We have a 2012 R2 RDS farm created by someone that left the company and wrote nothing down. i have created a new RDS farm similar to our existing one, with published apps and everything. However, our current farm he created has a published app that is actually the link to our rds host servers - select that "published app" and it takes you to a desktop selected from our load-balanced RDS servers. <pic of link is attached>

This is NOT in the published apps portion of that collection on the broker. This is being configured somewhere else. I assume in a config file on the web server? How can i recreate that for the new Farm?  I cannot use a regular published app mstsc because it needs to be load balanced between multiple servers, you don't get that option in a regular published app and that's NOT how it's configured currently in our production farm. There is no entry in a GPO to do this other than to say "load balance the servers". How can i create that so users can select it and be placed into a rdp load balanced desktop between host servers?  I can't find a walkthrough on line to do this. Please help.
FarmPic.png
0
Hi All,
In Report Manager I have assigned a user to the browser role at the report level  of a single report (and also to the browser role of a folder) but she cannot see the folder or  report in her browser.
Here is what she can see
rs The Folder and Report are both set to  not inherit Parent Security.
The user is assigned to the Browser role in the Home Folder.
If you require any further information please do not hesitate to ask.
Any Guidance appreciated.
0

Microsoft Server OS

56K

Solutions

41K

Contributors

The Microsoft Server topic includes all of the legacy versions of the operating system, including the Windows NT 3.1, NT 3.5, NT 4.0 and Windows 2000 and Windows Home Server versions.