Microsoft Server OS

57K

Solutions

41K

Contributors

The Microsoft Server topic includes all of the legacy versions of the operating system, including the Windows NT 3.1, NT 3.5, NT 4.0 and Windows 2000 and Windows Home Server versions.

Share tech news, updates, or what's on your mind.

Sign up to Post

Hi Experts,

  I'm receiving the error below after changing a single-value parameter to allow multiple values and I have not been able to get past it for weeks. Oddly enough, I have another parameter (@state) that I've set to allow multiple values, and it works perfectly fine.

Under the error is the primary data set code, as well as the ones used for suppliers (@Manufacturer) and states (@state). I have also included a number of screenshots that show the column visibility expressions, the single tablix filter for the ship2_state column and screenshots with the errors, column filters and parameter details.

I have attempted to use joins - e.g. =IIF(Join(Parameters!QueryParameterType.Value,",").Contains("1"), False,True) or =Switch(

Parameters!QueryParameterType.Value(0) = "2", False,

Array.IndexOf(Parameters!QueryParameterType.Value,"1") > -1, False,

True, True

)

and nothing is working. I really need someone to help take a look and show me what I'm missing. I've outlined everything in the SSRS report.

ERROR:

The Hidden expression for the tablix ‘table1’ contains an error: Overload resolution failed because no Public '<>' can be called with these arguments:
    'Public Shared Operator <>(a As String, b As String) As Boolean':
        Argument matching parameter 'a' cannot convert from 'Object()' to 'String'. (rsRuntimeErrorInExpression)


DataInfo dataset source (main body of report):


IF @QueryParameterType=1
(
SELECT …
0
This is something that I've had trouble with over the years.   In the script below I need to move the date script in the where statement into the select.  so I want to the the last 365 days for po_count and line_count.  This way I see all suppliers even if they have a 0. The issue is the group by as I don't want to add date_created into the group by or it make a different line for each date and I want the sum so one line per supplier.

This is my case statment but requires me to put po_hdr.date_created into the group by which is not what I want.  

case when ( po_hdr.date_created >= Getdate() - 365 ) then  Count(DISTINCT po_hdr.po_no) else 0 end AS po_count

Open in new window

case when ( po_hdr.date_created >= Getdate() - 365 ) then  Count(DISTINCT po_line.po_line_uid) else 0 end AS po_count

Open in new window



SELECT DISTINCT p21_view_contacts.first_name + ' '
                + p21_view_contacts.last_name       AS buyer,
                p21_view_supplier.supplier_id,
                p21_view_supplier.supplier_name,
                Count(DISTINCT po_hdr.po_no)        AS po_count,
                Count(DISTINCT po_line.po_line_uid) AS line_count
FROM   p21_view_supplier
       INNER JOIN p21_view_contacts
               ON p21_view_supplier.buyer_id = p21_view_contacts.id
       INNER JOIN po_hdr
               ON p21_view_supplier.supplier_id = po_hdr.supplier_id
       INNER JOIN po_line
               ON po_hdr.po_no = po_line.po_no
WHERE  ( p21_view_supplier.delete_flag

Open in new window

0
We are about to setup a new server. the Server has 24 cores. we purchased 1 16 core license and 4-2 core licenses.

we only have the 16 core license right now and the other 8 are on back-order.  

Can we still setup the server with the 16 cores license for now. or do we have to wait for the other 8 before we start the install.
1
We have a 2012 R2 RDS farm created by someone that left the company and wrote nothing down. i have created a new RDS farm similar to our existing one, with published apps and everything. However, our current farm he created has a published app that is actually the link to our rds host servers - select that "published app" and it takes you to a desktop selected from our load-balanced RDS servers. <pic of link is attached>

This is NOT in the published apps portion of that collection on the broker. This is being configured somewhere else. I assume in a config file on the web server? How can i recreate that for the new Farm?  I cannot use a regular published app mstsc because it needs to be load balanced between multiple servers, you don't get that option in a regular published app and that's NOT how it's configured currently in our production farm. There is no entry in a GPO to do this other than to say "load balance the servers". How can i create that so users can select it and be placed into a rdp load balanced desktop between host servers?  I can't find a walkthrough on line to do this. Please help.
FarmPic.png
0
Hi All,
In Report Manager I have assigned a user to the browser role at the report level  of a single report (and also to the browser role of a folder) but she cannot see the folder or  report in her browser.
Here is what she can see
rs The Folder and Report are both set to  not inherit Parent Security.
The user is assigned to the Browser role in the Home Folder.
If you require any further information please do not hesitate to ask.
Any Guidance appreciated.
0
Hi I have a column named TEST in our database s varchar(20). Now in SSRS report i have added this
column as NUMBER and when i try to export the report to excel , i can see an error in excel called
like "the number in this cell is formatted as text"

i then used the expression =CDbl(Fields!Test.Value) in SSRS for that column and the excel issue
is now resoloved but the numbers starting with 0 , 0 is removed..

for example if a value is like 012435, then in the preview tab i am getting 12435

can any one suggest a solution for this ?

Many Thanks
0
Honored Experts - I have an annoying problem RIGHT now with a disappearing print job from a Server 2012 RDS server.

I have multiple users connected from the wan side through port 3389 (no VPN) and needs to use the printer redirect to be able to print on the users locally connected printers.
When I log in to the RDP sessions on the server the local printer redirect just fine.
HOWEVER when I try to do a print, I can confirm that the job goes to the queue and the status is PRINTING, but after 10 seconds, it changes status to DELETING and disappears???

Any suggestions?
0
Good morning,
I receive this error when i try to remote into my office computer from home. " Can't connect securely to this page" This might be because the site uses outdated or unsafe TLS security settings.

My server is SBS 2003 R2. Remote access worked great until today.

Please help, very urgent.
0
Just trying to get some advise

We are looking into options to have some sort of virtual mirror of our current server setup so that if one of the servers goes down the other one takes over and no loss of service.

What would you think would be the best option for this as I know there are online services that do this sort of replication?

We have the following servers
DC SERVER
EXCHANGE SERVER
SQL SERVER
VPN SERVER
FILE SERVER

Thanks
0
Hi

I have a seperate DC and APP server. I need to install ADFS. Which server should I install the role on. What's best practise.

Thanks
1

Dynamics 365 9.1,  

We are working on converting SQL SSRS reports to FetchXML for the Dynamics 365 Online environment.  We have completed most of a report but still have the following to convert:


SQL
select Value
from FilteredStringMap
where FilteredViewName ='FilteredFEI_nanoportdemo'
and attributename = 'fei_nano_nnplocation'

Open in new window


FETCH
<fetch mapping="logical" version="1.0">
  <entity name="StringMap">
    <attribute name="Value" />
    <filter>
      <condition attribute="ViewName" operator="eq" value="FEI_nanoportdemo" />
      <condition attribute="attributename" operator="eq" value="fei_nano_nnplocation" />
    </filter>
  </entity>
</fetch>

Open in new window


We can query the Stringmap in SQL and can see it Fetchxml Builder but cant link the stringmap/option set to the report

0
Good Morning,
I am attempting a GRT Backup using the following:
Backup Server:
Windows Server 2008 R2 Standard SP1 64-Bit
Backup Exec 2010 R3 Version 13.0 Rev.5204 64-Bit

Exchange Server:
Windows Server 2003 R2 SP2 64-Bit
Exchange 2007 Enterprise Version 8.2

Attempting a full backup returns the following error:
Backup- \\Server.local\Microsoft Information Store\First Storage GroupV-79-57344-918 - Unable to complete the operation for the selected resource using the specified options.  The following error was returned when opening the Exchange Database file:  '-546 The log file sector size does not match the sector size of the current volumn. '

Backup- \\Server.local\Microsoft Information Store\Second Storage GroupV-79-57344-918 - Unable to complete the operation for the selected resource using the specified options.  The following error was returned when opening the Exchange Database file:  '-546 The log file sector size does not match the sector size of the current volumn. '  Love how they misspell error

Backup Server:
C:\Windows\system32>fsutil fsinfo ntfsinfo C:
NTFS Volume Serial Number :       0xc61879e71879d6c1
Version :                         3.1
Number Sectors :                  0x00000000707cc7ff
Total Clusters :                  0x000000000e0f98ff
Free Clusters  :                  0x000000000a4a02fc
Total Reserved :                  0x0000000000000040
Bytes Per Sector  :               512
Bytes Per Physical Sector :       4096
Bytes Per 

Open in new window

0
Hi, I am running an SSRS report using SSIS  and i have a parameter in SSRS with 4 values.

UK
germany
france
ALL

Now in the ssis script task, i am succesfully able to generate a report for UK, france and germany
seperately but when i try to use ALL , its failing.

below url works fine for UK --

http://ReportServer?%/&rs:Command=Render&rs:Format=CSV&Portfolio=UK

below is what i am using for ALL in my url which is failing

http://ReportServer?%/&rs:Command=Render&rs:Format=CSV&Portfolio=UK&Portfolio=germany
&Portfolio=france

can someone please give let me know the write expression for ALL so that i can get a report for all
3 countries in one report ?

Thanks
0
Windows Server 2012, unable to create new users, or better yet, to give new users remote or direct login access to server.  Users that have never logged on to the server before will get error message about profile service unable to log in.  
     I discovered this recently when trying to RDP into the server with my domain admin user account.   Thinking I had some profile corruption going on I deleted my user and tried creating a new one.... same result.  
   During t/shooting of this I discovered that there is no default user profile and all of the solutions that I could find regarding this particular scenario suggested copying the default user profile from another server running same version of Windows, which I do not have.  
   I will gladly answer any and all questions regarding this and would appreciate any help you can give.
0
Hello Experts
I was recently appointed as IT Manager at one of the companies.
This company is using microsoft CRM.
The former Director of Information Technology used traditional VPN technology from Internet service providers to connect all the company's branches around the country. Which cost the company a lot of money per month.
While this VPN is only used to run that program in these branches.
What I think if I can develop or modify this system to use cloud technology or any thing else To reduce costs and also to develop the company
0
I am working on an asp.net c# web application that creates a report and saves the report as a pdf. The report could reach up to 140 pages and is already over 22 MB at page 35. Is there any way to reduce the size of these files as they will then be retrieved and emailed. The application is asp.net webforms using ms reportviewer.

this is the code I used to save the report. I created a LocalReport in the code behind instead of using the reportviewer control beause we don't need to display the report.

            private void SavePdf()
            {
                  var path = GetReportPath();

                  var bytes = _localReport.Render(
                        "PDF", null, out string mimeType, out var encoding, out var filenameExtension,
                        out var streamIds, out var warnings);

                  using (var fs = new FileStream(path, FileMode.Create))
                  {
                        fs.Write(bytes, 0, bytes.Length);
                  }
            }

this is the code to create the report before saving it as a pdf.

            private void RenderReportForSaving()
            {
                  var reportDataSource = new ReportDataSource("DataSet1", base.GetDiscipleshipReportView());

                  try
                  {
                        var path = Server.MapPath($"~/Administration/Reporting/Reports/{_reportType}.rdlc");
                        var report = new LocalReport();

                        _localReport.EnableExternalImages = true;
                        _localReport.ReportPath = path;
                        _localReport.DataSources.Clear();
                        _localReport.DataSources.Add(reportDataSource);

                        AddSubQueriesToLocalReport();

                        _localReport.Refresh();
                  }
                  catch (Exception ex)
                  {
                        …
0
IN SSRS, we have a AD new security group that has users with browser permissions. However when members in this group try to run reports we get this error..

The permissions granted to user 'DOMAIN\testit' are insufficient for performing this operation. (rsAccessDenied)

If we add these same members of the AD group individually with browser permissions, it works fine.  What are we missing on this AD security group?

SSRS is running on SQL2008
0
D365 Online 9.1, SSRS FetchXML

We are working on converting a report to FetchXML.  We started with a new report and added a MSFetch datasource.  However, when attempted to create a dataset from the datasource, we get the error:

Invalid URI: The Authority/Host could not be parsed.
----------------------------
The URL "https:\msddev1.crm.dynamics.com" that you specified is invalid. Specify a valid URL, and try again.

We added the organization unique name from Customizations :: Developer Resources but still get the error (i.e. https:\msddev1.crm.dynamics.com;msddev1)

Your help is appreciated.
0
Using SqlServer Db 2012 and ReportBuilder 3.0:
Using an embedded dataset calling a sproc with 7 parameters
Stanard Tablix Report with headings and Columns generated from the fields in the Sproc

Running this produces  3 data row and the heading however the data is blank but running same sproc in SqlServer Management Studio produces the correct 3 rows of data with content.

I know it must be something to do with my definition in the Tablix but I have:
1.  deleted and re-created to no effect.
2. Verified the parameters are passing data - and they must be as it is clearly returning the data but for some reason can't display it
3. Tried running in the report on the Query Designer providing those same parameters and DO get data back there!

obviously I know the problem is in the Tablix but I am at a loss to know what else to do!
Why can I not get data in the Report??

Any Ideas?
Screen-Shot-2019-03-28-at-11.59.46.png
0
We've got an Upstream WSUS & a down stream WSUS.  I've create a new group on the Upstream WSUS in an attempt to move a few machines into for testing purposes.  On the upstream (where i created the new group) all machines are currently in the 'Unassigned Group' from within the Unassigned Computer group i have no option to change membership.  On the downstream in the Unassigned group i can right click & Change Membership is there, I can select the new group I created on the upstream to move the machines into.  The new group is not visible on downstream, when i moved the machines into the new group they disappeared from the Unassigned Group, but with that new group not being present on downstream where'd it move them too?  I've synced the two, the new group on the upstream remains empty.  I've also selected the Computer from the options menu & selected 'Use GP or reg settings on computers'
0
Im setting up Veeam backup and replication to backup my vm. the host is a server 2012, the vm is a linux [with the windows vm I have no issue] In the Guest Processing tab at the  Guest OS credentials, when I run a task it fails. Itreid with my user and pass and with the root none work.
 Veeam1.JPGVeeam2.JPG
0
Hi Experts

I am using SQL Report Builder to create this report.

It is grouped by the first 3 characters of the Account ID i.e. =Left(Fields!AccountID.Value,3)

I have just been asked to move accounts 102-010-07 and 102-010-13 from the 102 Account Group and have it moved to the 101 Account Group under the "Subtotal - Tickets" where it will have its own subtotal and be part of the 101 total.

How would I accomplish this?

Screenshot_2.png
0
Setup, Citrix XenApp 6.5.  Running on Windows 2008 R2.  Farm consists of 4 nodes (XenApp servers).  

Due to issues, we have been asked to create a new Farm for our Test Environment.  

Had the DBA's create a new database without any data.

So the process, have removed one of the existing FARM servers from the TST farm using the XenApp installer.  Success
So, have run the installer and selected to create a new farm, however; it keeps erroring on the Initializing the Citrix Data Store.  "Initializing the Citrix data store failed.

Check the Windows Event Log for warning or error messages that may provide details on this error and how this issue may be resolved."

I look in the Event log and I see, "Citrix XenApp failed to connect to the Data Store. ODBC error while connecting to the database: S1000 -> General error: Invalid file dsn ''

This is where I'm not sure what to do.

So, at the command line, I have Recreated the Cache (dsmaint recreatelhc) and rade cache (dsmaint recreaterade).  I have verified through ODBC that I can indeed connect to the SQL Server (which I was able to do before this upgrade as this was an active member of the existing farm).  

What appears to be happening is that though I updated the SQL Server driver and tested this to be compatible with SQL as we had to update a few months back for TLS, that something in here is not working as expected when running the installer.

I also tried from the command line running, "dsmaint config …
0
Visual Studio 2012, Report Authoring Extensions


We have VS2012 and VS2015 installed locally with SSDT installed.  We are trying to install the Microsoft Dynamics Report Authoring Extensions to enable Fetchxml as an option in the datasource type.  Regardless of the version of the Report Authoring Extension download, we get an error when trying to add the Report Authoring extensions.

Need advice on which version of the report authoring extensions to install.  We have reviewed the internet extensively for an answer to this problem.

Thanks
0
I am working with an existing .RDL. An additional requirement was introduced. Based on a report parameter a section of the report is not visible. This is leaving a blank spot in the report that want to collapse as it throws off the rest of the report formatting.

Is there a way to completely collapse rows that are not visible?

Example:

This is set at Tablix Row Level:

=IIF(Parameters!RunInLocalCurrency.Value = "0" And Parameters!ConsolidateBroker.Value = "1" And Parameters!UnconsolidateBroker.Value = "0", False, True)

When ConsolidateBroker.Value = "1"  I want to compress those rows.

Thanks,

Robert
0