Microsoft Server OS

56K

Solutions

41K

Contributors

The Microsoft Server topic includes all of the legacy versions of the operating system, including the Windows NT 3.1, NT 3.5, NT 4.0 and Windows 2000 and Windows Home Server versions.

Share tech news, updates, or what's on your mind.

Sign up to Post

One of our clients is experiencing issues with their Windows server.  Their previous IT installed the Server Essentials Role, along with almost every role available (Hyper-V, RDS, Fax server, etc.).  I have removed the Server Essentials Role successfully, (They have a 2012 R2 Standard license).  I need to remove the excess roles and get the machine down to only being a domain controller, DNS server, and DHCP server.  When I try to remove any of the other installed roles it fails completing the operation after the reboot and undoes the changes.  I have run the DISM utility multiple times and it keeps indicating it fixed corruption in the component store, but after a reboot and running the /scanhealth parameter, it still discovers more corruption (have tried this cycle 4 times).

Advice on where to go, or how to troubleshoot is greatly appreciated
0
This is a Windows DNS Server question.

On the windows server that has the DNS role, this server connects to a SAN as well. So basically the server has 8 nic ports. 4 are teamed for the windows environment, and the other 4 ports are used for multipath to the SAN.

So in the dns config section i go to the properties tab of the dns server. On the interface tab it shows 5 ips. The 1 that entails my windows team, and then the 4 that go to the san. I unchecked all of the SAN ips since my clients were associating this san ip to the server when looking for a logon server etc.. However when i uncheck all my san ips that goofy self test it does on the monitoring tab always says it fails.

However when i put in this server to my laptops static dns list it seems to work fine for web, browsing pc names on the network. I even flushed all the caches locally and on the server to make sure.

Does it matter if the monitor tab fails? If i put all my san ips back in under interfaces it passes, but then the server advertises these address on my network as a way to get to it which is wrong obviously. I am content with not worrying about the monitoring tab if this is normal for people who have had a server running dns server which also connected to a san.

Any comments or suggestions welcome. Thanks!
0
How do I install TLS version 1.3 on server 2012 R2?
What steps do I need to follow
0
Environment:  Windows 2012R2, and W2016; auto updates.  Business Application hasn't been updated in 4months. - happening on more than one site.
Tsplus is the RDP server application.

Problem:  Time of problem varies from site to site 3wks to 1 yr,  Application generates .pdf documents; e.g. invoices, quotes, statements either singularly or in a batch process, current fault happens in all pdf generated process'.
A Process, e.g. Invoices runs; create a 0kb .pdf, no errors displayed, then emails the .pdf to the customer; usually only found when the email receipient of the .pdf says can't open it.
Tried removing all .tmp files,    appdata\local\temp & appdata\roaming\"any rdp session files not deleted".
Stop Print Spooler / Remove any files in windows\system32\spool\printer\*.* / Start print spooler.
Sometimes allows the correct generation pf the .pdf file; occassionally works - mostly not.
If user logs out of the Application and RDP Session, (back to the PC desktop) login to Server via RDP then application and perform the print - works everytime.


My summation but can't grasp the answer, is: Logging out of the Session obviously terminates a process that is affecting the "Printing"

Does anyone have any suggestions as to how to identify the process &  recitification.

Thank you for reading this.
0
We built a new remote desktop services server just recently. We are very happy with it except for one strange issue. When one of our domain joined laptops launches the login page from either IE or Chrome, a certificate windows pops up asking to use one of our sub-ca certs to login. If I say yes, it gives me a login failure and an IIS screen pops up. If I say no, the cert screen goes away and continues to the correct login page. Its almost as if the site initially once to use the cert for authentication when it should not. Any ideas?

Built on Server 2016
0
Hello everyone, I am hoping someone might be able to help with an odd NLB issue we seem to be experiencing on our ADFS farm setup. This environment has been setup for at least a year and this issue could have been going on for a while without being noticed. Both servers are Hyper-V guests with two network cards attached and MAC Spoofing enabled on the second NIC (Cluster Operation Mode Unicast). The issue that we are having is that we are able to add ADFS-1 to the cluster with no issues, however when we add AFDS-2 into the cluster the Network Location Awareness (NLA) changes from Domain Network to Public Network (Images below). No errors are displayed as it joins the cluster, but the NLB NIC is no longer reachable on the network.

ADFS-1
Host NIC: x.x.x.33
NLB NIC: x.x.x.151
NLB VIP: x.x.x.150

ADFS-2
Host NIC: x.x.x.10
NLB NIC: x.x.x.152 (Unreachable after Joining to cluster)
NLB VIP: x.x.x.150

Before NLB Join
After NLB Join
I have already verified the IP configurations before and after the addition to the cluster and restarted NLA, and nothing has changed. When you drop the NIC from the cluster it returns to its normal state of Domain Network. I have also deleted the cluster completely and rejoin the servers in a different order but the same server/same NIC does the exact same thing. Anybody Expert ideas on where to go next?
0
We have ran a scan on our environment and we have servers OS's like 2008 R2, 2012 R2, 2016.
The scan came back complaining about the following:
Birthday attacks against TLS ciphers with 64bit block size vulnerability (Sweet32)

How do we resolve this on these server so that this is not an issue any longer with them?
0
Hi,

I have a question regarding redirected printers on a terminal server.

How do I set different print settings than on the client?

Thank you in advance!
0
I have a Windows Server 2012 R2 server that crashed hard after a power failure.

Upon reboot, the system gets stuck at the “Please Wait” screen.

I use Remote Desktop to log in and do a taskkill on TrustedInstaller and the server finishes booting to the desktop and the server runs normally.

It's asking for Windows Activation, but I don't think that can be done without demoting the server from its Domain Controller role.

Running repair utilities doesn’t work.

C:\Windows\System32>sfc /scannow
Windows Resource Protection could not start the repair service.


C:\Windows\System32>DISM /Online /Cleanup-Image /CheckHealth
Deployment Image Servicing and Management tool
Version: 6.3.9600.17031
Image Version: 6.3.9600.17031
Error: 87
The cleanup-image option is unknown.

I tried again with a source.

C:\Windows\System32>DISM /Online /Cleanup-Image /RestoreHealth /Source:C:\W32\in
stall.wim

Deployment Image Servicing and Management tool
Version: 6.3.9600.17031
Image Version: 6.3.9600.17031
Error: 87
The cleanup-image option is unknown.

Any suggestions on what to try next?

Thanks.

Tom

2019-02-18 15:07:12, Info                  DISM   PID=9616 TID=8496 Scratch directory set to 'C:\Users\ADMINI~1.HM\AppData\Local\Temp\2\'. - CDISMManager::put_ScratchDir
2019-02-18 15:07:12, Info                  DISM   PID=9616 TID=8496 DismCore.dll version: 6.3.9600.17031 - CDISMManager::FinalConstruct
2019-02-18 15:07:12, Info                  DISM   PID=9616 TID=8496 

Open in new window

0
We have the standard set up of an internet facing wsus server.  Which we export. And then import to the internal wsus server.   Running fine. For years.  

I ran a script which declines all the supersede and no longer required patches.   Dropped from 250gn to 40gb

Next export worked fine

But I had to rebuild the internal one recently.  And it stalled on downloading. As files were missing.

I re approved all the declines on the external one.  And copied those files back in and it started working.

Why ?    I mean. They were deleted by wsus own server clean up.  Why would the meta data still be there ?
0
What are the steps to enable Phased Deployments within SCCM 1810?
0
When I ran repadmin /showism
I got this result;

C:\Windows\system32>repadmin /showism
==== TRANSPORT CN=IP,CN=Inter-Site Transports,CN=Sites,CN=Configuration,DC=contoso,DC=com CONNECTIVITY INFORMATION FOR 1 SITES: ====
        0
Site(0) CN=Default-First-Site-Name,CN=Sites,CN=Configuration,DC=contoso,DC=com
    0:0:0
    All DSAs in site CN=Default-First-Site-Name,CN=Sites,CN=Configuration,DC=contoso,DC=com (with trans & hosting NC) are bridgehead candidates.

I_ISMGetConnectivity( CN=SMTP,CN=Inter-Site Transports,CN=Sites,CN=Configuration,DC=contoso,DC=com ) failed with status 1168 (0x490):
    Element not found.


So when I look in AD Sites and Services I see no entries under SMTP.
I don't ever recall setting up an SMTP site link. How can I go about safely repairing this?
0
We operate a remote installation on a satellite link. Our WSUS downloads can take from 4 days  to up to 30 days! While the download is in progress, this information is displayed on the WSUS snap-in summary screen, but disappears when the download completes.

I'm trying to get specific information out of the Windows Update log (C:\Windows\Windows Update.log) running on my WS2012 R2 VM.
Specifically, I need to know:
  • When download from Microsoft started
  • When it completed
  • The size of the download

Attached is the log from our "Update Tuesday through the date that the WSUS server began pushing out updates to workstations. I'm sure what I'm looking for is in there, I'm just not recognizing it due to the density of information.

Also attached are images of the WSUS summary screen, befoer and after completion. During downloads, the circled area contains start date, size of download, and amount currently downloaded. After completion, all that info is gone.

Thank you.
WindowsUpdate.log
WSUS-in-progress.jpg
WSUS-done.jpg
0
On a MAC if you have an alias on the desktop which points to a local server,
when you double click on that alias you need to keep entering the credentials based on DOMAIN\user and password.
And even if you check the box to remember the password in the keychain, it keeps popping every time you reboot and try to access the folder on the local server.
How can I resolve this?
Thank you.
0
I am having a problem with an Oracle Server running Windows Sever 2012 R2. I have a scheduled job running from a Business intelligence server to this Oracle Server in another country, this job runs at 2am daily but takes like 2 hours to complete. How can I check the server performance during this period?

Thanks for your time!
0
I received a USB drive and wanted to know how I can verify if this is a keylogger or anything malicious?  How can I verify?
0
My SQL Server 2014  "SQL Server Windows NT 64 bit" suddenly jump to use 90% of the CPU and then it goes down after 5 sec, then the spike comes again after 3 to 5 mins (normal usage is just around 10% to 50% of cpu). Sometime I have to restart the server  to get it to comedown but some time it goes backup.

What should be the normal range of CPU usage before you will need to take action? What should those actions be?  Also, I would like to understand how CPU usage work, when SQL Server Windows NT 64 bit uses 70% does that mean all other processes have to share 30%( ...and does the same applies for memory?)


Windows Server 2012 R2      
4 CPU (8 virtual)  @ 2.50GHz      
64GB memory      
500GB      
SQL 2014
0
Hello,

We created an AD account which is in the domain admin group and use it in some Windows Services.  

If I want to disable  interactive logon for this service account, what is the best way to do it?

Please advise.

Thanks.
0
WE allowed our RDP  license to expire and now cannot get in , it there a way to get in to the server to allow us to apply a license ?
RDPPPPPPCapture.PNG
0
Have a report in SSRS that I've added a link to another report within a textbox using "Go to URL" because wanted to open in new tab. The below code will open the report but doesn't pass the parameters:

="javascript:void(window.open('https://servername/RsMgt/Pages/Report.aspx?ItemPath=%2fInventory+Data%2fActivity+Lifespan&rs:Command=Render & Fields!Location.Value & Fields!SN.Value'))"

Any ideas what I'm doing wrong?
on SQL Server 2008 R2.
0
What is the command line command for listing which servers run the different Active Directory FSMO roles:

•      PDC Emulator (One per domain)
•      RID Master (One per domain)
•      Schema Master (One per forest)
•      Domain Naming Master (One per forest)
•      Infrastructure Master (One per domain)
•      Domain DNS Zone Master role (one per domain)
•      Forest DNS Zone Master role (one per forest)

I have been told that there is a single command line command that will list which servers are assigned these roles and I would like to know what this command line command is.
0
I'm looking for the steps for using SCCM 2016 to deploy the Server 2019 and 2016 operating systems to VMware and Hyper-V virtual machines.
0
What are the best books for learning Microsoft System Center Configuration Manager (SCCM) 2016?

I need to learn how to use SCCM 2016 to:

- Approve and install Windows updates on Windows Servers and Windows 10 computers

- Install applications such as Microsoft Office, WinZip, Acrobat, Adobe Flash, Google Chrome, etc. on remote computers

- Deploy Server 2016 and Server 2019 within VMware and Hyper-V virtual machines

- Deploy Windows 10 on computers using PXIE boot

- Perform upgrades from Windows 7, Windows 8, and Windows 8.1 to Windows 10 on existing computers leaving all of the existing applications and settings intact

I am only interested in books that describe and have step-by-step exercises on how to do this for SCCM 2016.

I am hoping to find a book that describes these things exactly as they need to be done so that while I am on the job I will be able to refer to this book for the steps on how to do these things.
2
I have the following two queries below. What I am attempting to do is compare my results from current production to archived data from the week prior. My goal is to compare sales by season OTSWIP and SUM of the std_cost. However when I attempt to join the two queries together my results get exaggerated. I'm not certain what I am doing wrong?

Production Query is as follows. I Receive 23 rows. Results are attached.

SELECT  cs.season ,
        cs.season_name ,
	    SUM(CONVERT(INT, cs.OTSWIP)) AS OTSWIP ,
	    SUM(cs.Ext_std_cost) AS Ext_std_cost
FROM    ( SELECT    c.DIVISION ,
                    c.STYLE ,
                    c.COLOR_CODE ,
                    c.LBL_CODE ,
                    c.std_cost ,
                    c.season ,
                    CASE WHEN c.season IN ( '20121', '20122', '20123', '20124',
                                            '20125', '20131', '20132', '20133',
                                            '20134', '20135', '20141', '20142',
                                            '20143', '20144', '20145', '20151',
                                            '20152', '20153', '20154', '20155',
                                            '20161', '20162', '20163', '20164',
                                            '20165', '20171', '20172', '20173',
                                            '20174', '20175', '20181', '20182',
                                            '20183', '20184', '20185', '20191',
                       

Open in new window

0
I have 4 windows server 2012 R2 servers in my domain which are not getting updated gp policy.  when running gpresults on them they are all showing AD / Sysvol mismatch errors.  They are not DCs.  All DCs do not have this error, and are replicating properly. All other computers in this domain are pulling correct and updated GP.  

I have tried removing them from the domain and readding.  I have installed KB KB2919394.  with no luck.  thanks.
0