We help IT Professionals succeed at work.

Microsoft Server OS





The Microsoft Server topic includes all of the legacy versions of the operating system, including the Windows NT 3.1, NT 3.5, NT 4.0 and Windows 2000 and Windows Home Server versions.

I am unable to RDP to a laptop connected to AD. It was working fine for one day. This morning I attempt to connect and It hangs at security authentication. No error messages.
So unfortunately because of the situation at hand I have been furloughed and already going stir crazy.   I've decided to try to switch my focus from Microsoft to Cisco.   I was wondering since I am at home right now if anyone could recommend some good online courses I can start off with to look at a CCNA.   I need to keep myself going and would like to cert track as much as possible to spend some time.   I don'`````````````````t know if this can be done sitting at home and learning without a firewall or router but I figured I would ask if anyone has tried this and had success.   ```````````````````````````````````````````If its too much trouble thats fine I am just looking to expand my learning.

The other possibility would be to try and look at Microsoft server 2019 or 2016 MCSE.   I am thinking it may be easier doing that.   Again this would have to be done from home so I would need some good tools.   Not sure if reading a book will work I will probably need access to virtual environments.    As always the assistance is appreciated.   I am hoping this furlough only lasts a month or so.  

THanks in advance.
I have a client that runs a number of reports on SSRS.  These reports have been created and tested over the past two years, and have been running great for the last 6 months without problem.

Enter Covid19 and everyone working from home.  Users are now logging into the network via RDS and running the same reports, but many of them are now returning this error message after entering parameters SSRS Error message
The IT guys tell me that they have not done anything to the server, and when I log into the server I am able to run all of the Visual Studio reports without error.
Strangely, when I log into RDS and open the SSRS reports menu, the same way that the other users are doing, I don't get this error.

I do not know how to enable remote errors to get more info about the error.

Would appreciate any recommendations anyone might have.
I have a SSRS report and the cells in one column (MarketPrice) can be a number or text "NA". Is there a way in SSRS to have numbers in raw excel show as numbers even though another cell value in that column is text (NA)? Right now the raw excel dump shows the "Number Stored as Text" green triangle for numbers.Column with Number and Text values.
Thanks in advance.

Rob M.
Hi, i have a server 2012 r2 that fell off the domain, i tried to rejoin it now, and i get the specificed network name is no longer available right after it asks me for creds.

What could be the cause?
is there any simple script i can run to remove IIS log files older than 30 days on all exchange servers (2016) in DAG environment.

is there any recommended approach.

also are there any defined steps if i want to do OS patching on DAG exchange members which are windows server 2016.

we are deploying vulnerability patch through SCCM

do we need to put mailbox servers on maintenance mode as well?, will failover occur as well.
I have an ssrs report (sql server 2014) that takes county in as a parameter (10 possible counties)

I have a file share set up for each of the counties

Would like to write a single data driven subscription that will write the output for each county to the file share dedicated to the county

is this possible?

All the searching Ive done seem to be for emails
Windows Search not working properly with Data Deduplication on Windows 2016.

Many files are not included in the search.
I have reinstalled the search role, recreated the search index. reincluded the folders.
Nothing worked.

Please let me know how to fix this in the best way that I can.

I have found this article dated March 27, 2013:


We reported the indexing / deduplication problem to Microsoft at the end of February.
They got back to us confirming that it is a known problem related to design.
The windows search service is not able to index deduplicated data. The following steps can be used as a workaround to get all data indexed:
1. Deactivate deduplication (Server Manager)
2. PS:> Start-DedupJob -Volume X: -Type unoptimization
3. Rebuild Index
4. Activate deduplication (Server Manager)
5. PS:> Start-DedupJob -Volume X: -Type optimization
Pay attention: The above mentioned steps decrease the server performance. Unoptimization additionally requires more space on the volume. Check with the PowerShell command "Get-DedupStatus" if you dispose over enough available space on the volume.
PS: Microsoft told us that if a lot of customers report this issue, they will fix it. So feel free to report to Microsoft accordingly.

I have to defer Windows updates 14 days for all unmanaged clients. How can I do this with a PowerShell script?
All clients are Windows 10 1909 Pro.

I currently have a Citrix NetScaler VPX 200 and I would like to enable 2 factor authentication. I'm new to setting up 2FA and any advice would greatly be appreciated.

The goal is to have the user sign into the Netscaler web portal and authenticate with their domain (LDAP) credentials. Upon successful login, the user is required to enter a passcode/one time password that they would receive from an SMS message or ideally a code using an authenticator app (Microsoft or Google authentication app for example.) Once the user enters the one time password, the user can access the VPN or ICA portal.

When researching what is evolved to enable this, it looks like a RADIUS server is required. I do have a Windows Server 2016 RADIUS server, but it doesn't seem to support what I'm looking for, unless Microsoft's terminology is different. I've opened a case with Citrix, but the only thing provide is links to setup RADIUS on the gateway, which I already found before opening the case.

Has anyone been able to accomplish this? Thank you for your time.
Software Update Unknown

In SCCM software Update Console, I see some updates showing as "Unknown".
I would like to know what would be the reason causing the Unknown status.
it seems all 3 of the computers that have Client installed  and powered on are the ones which are unknown

Thank you .

I checked wuahandler.log,  and found the Scan Error: 0x80244019

in software update point role properties in SCCM console, I found 80 and 443 port were configured by default,so I changed to 8530 and 8531 . I am running summarization now and see if this will fix the issue.

I am looking for some help with planning the replacement of SBS 2011.  I see a few threads on the topic already, but they seem to cover a transition to Essentials.

I'm already looking at 30 users with potential to grow, so I think we have already outgrown the 'small business' part of SBS.  

I won't pretend to know much of anything about licensing/server features/etc., and don't stay current with M$ release 'news', so starting from scratch would be an accurate statement.

That said, I need to make sure I can replace/replicate the current functions of 2011.  

No doubt this list is far from complete, but these are the things I know it does that I'm worried about replacing (assuming DC/AD roles are covered no matter what route I go)...

  • On-site Exchange server
  • OWA features for rdp
  • Backups
  • File storage
  • Everything else I don't have the foresight to realize I'm losing

We don't use SP and don't have an intranet...so two things off the list of worries.

I know O365 is an option to replace the on-site exchange server, but I have my concerns about going cloud...namely cost effectiveness, security, and data retention.  I also don't know if it's a seamless transition in terms of features available to Outlook users.

As for the OWA side, we have a few users that remote in frequently from home.  I'm not really sure what …

I'd like to filter my existing SSRS report on creation date. Found the article below, but I am a bit lost on howto implement.
An example of my datetime format is 03/06/2020 10:17:46

Tried to change the query with this
select  Cast('9/10/2013  8:19:29' as datetime)  DateCreated
select  Cast('10/10/2014  8:19:29' as datetime)  DateCreated
select  Cast('11/10/2015  8:19:29' as datetime)  DateCreated
where Year(DateCreated)=@Year and Month(DateCreated)=@Month

Then I got the error:
Must declare the scalar variable "@Year".
Query execution failed for dataset 'MyDataSet'. (rsErrorExecutingCommand)
An error has occurred during report processing. (rsProcessingAborted)

---source which I used

select  Cast('9/10/2013  8:19:29 AM' as datetime)  LogTime
select  Cast('10/10/2014  8:19:29 AM' as datetime)  LogTime
select  Cast('11/10/2015  8:19:29 AM' as datetime)  LogTime
where Year(LogTime)=@Year and Month(LogTime)=@Month

I have this query

select  Name,Entitlements, LastWriteTime
from table1
join table1 ON table2.Name = table1.Name

This gives values with multiple timestamps

Name Entitelments,LastWriteTime
Item1 xyz            02/02/2019
Item1 xyz            03/02/2019

How do I get the LAST write time only, so that would be Item1 03/02/2019
Hello to everyone

I need to restore from backup our domain controllers in sandbox mode to test Shema change and update for 2FHA. And we want to be sure work before implemented on our production environment. When i recover our 3 domain controllers in the isolated network i get a lot of errors. We don't have this problem on a production site. A really be appreciated help.


Directory Server Diagnosis

Performing initial setup:
   Trying to find home server...
   Home Server = Sheriff-DC2
   * Identified AD Forest.
   Done gathering initial info.

Doing initial required tests

   Testing server: SJ\SHERIFF-DC2
      Starting test: Connectivity
         ......................... SHERIFF-DC2 passed test Connectivity

Doing primary tests

   Testing server: SJ\SHERIFF-DC2
      Starting test: Advertising
         Fatal Error:DsGetDcName (SHERIFF-DC2) call failed, error 1355
         The Locator could not find the server.
         ......................... SHERIFF-DC2 failed test Advertising
      Starting test: FrsEvent
         There are warning or error events within the last 24 hours after the SYSVOL has been shared.  Failing SYSVOL replication
         problems may cause Group Policy problems.
         ......................... SHERIFF-DC2 passed test FrsEvent
      Starting test: DFSREvent
         ......................... SHERIFF-DC2 passed test DFSREvent
      Starting test: SysVolCheck
Hi Expert,
I am getting stuck after restore the SSRS Database from 2008 to 2016. When i attempt to get into SSRS on the new Server it mentions the database is at lower version.


I have a Visual FoxPro application installed on windows server 2016. The ComboBoxes are not respecting the mouse position, or mouse clicks. So normally you would be able to move your cursor through the options and whichever option you are on would highlight blue as you move across them. Then you would be able to click on one of the choices and that option would be selected. Now; the application keeps the first option highlighted, and clicking on an option does not choose your selection but instead the highlighted one at the top.ComboBox in the application
How to determine PAE already configured in windows 2003 Enterprise

When i checked Windows system properties, i able to see that the General tab of the System Properties lists Physical Address Extension at the end of the Computer section.

But when i check the actual Boot.ini in notepad, i dont see any extension has been added " /PAE"
I have a sql server 2014 a separate ssrs report that returns the following sales info with region (hard coded) as a parameter with a standard subscription that writes the file to a file share

Region, salesperson_firstname, Salesperson_Lastname, Sales_total

Currently have 5 regions but being told new region numbers could be added

was thinking of creating a new ssrs report that did not take in region as a parameter (just create single report for all regions)

then Try to write a data driven  subscription that will write the information for each region in an excel file to a file share with a file name that indicates the region

for example, region 1 records would be in a file named region_1_sales_info.xlsx,

Region 2 records would be in a file named  region_2_sales_info.xlsx and so on.

Just wondering if this is doable?

Hopefully I have described the situation clearly

Lost our DBA so now during transition, trying to fumble through some things.  One being modifying existing SSRS reports.  I have a report that I simply need to add a new column for postal code next to service address.. I think i found the right table in the DB.  Trying to use report builder.  see attached
How do i run remotely commands on a machine .to let suppose find a file in D Drive if it exists or not from my local machine .

Here are the details
My local machine is in A domain and i connect to jump server through B Domain credentials .from there i connect to Windows Server 2003  through service account credentials.

I need to run a command find /N /I  "String" D;/Man/SC.txt (for example) from my local machine on that remote windows server .How do i achieve that .Everytime I need to RDP to jump server an then onto windows server .How can i acheive this using psexec or some tool .
What are the proper database roles to be granted to users to access reports being delivered via SSRS? I have an application that deploys a series of SSRS reports. The client wants security setup using their domain credentials.
Please advice how to cleanup or archive winsxs folder in the windows 2008 OS.
I had performed cleanmgr.exe and found there is no available file / folder / logs for the cleanup. All showed 0
Performed DISM command and found dism /online /cleanup-image /startcomponentcleanup /ResetBase this not available at the windows 2008 server.
Dear Experts,

I would like to find out what would be the best suited network certification to obtain for myself.
I have a mish-mash background, after getting M.S. in computer science with software engineering emphasis, I was working as a software/field engineer, then software project manager.
After taking time off to raise children, I started my own business as an IT consultant, where I did everything from hardware/software installation, infrastructure management, training, and troubleshooting for small businesses.  All of my knowledge came from basically learning as I needed from vendors and other sources.
A few more jobs later, I am now bouncing back and forth between Sr. System/Network Admin roles at my current employer.
My problem is, besides my degree, I do not have any certification, but I can administer Cisco/Fortinet Firewalls, switches, Windows servers, Exchange servers, and am versed in PowerShell scripts as well as Java, VBA.  I feel very non-standardized, and would like to have some type of certification.  Since I really don't need to learn more about Windows servers or Azure AD, I was leaning towards some type of network certification.  Cisco, CompTIA Network+, etc.  I do have basic theoretic knowledge on networking from my graduate courses, however I have a feeling some of those are outdated at this point.
Please advise.
I have a SSRS report where in one text box I want to only display part of the FIELD that populates the textbox.
For example, if the text in the field is "LASTNAME, FI - ID", I want to display only "LASTNAME, FI". So in the query I have Select LASTNAME + ', ' + LEFT(FIRSTNAME,1) + ' - ' + ID.
I can't just change the SELECT statement to leave off ID because I need that for grouping and sorting.
I changed the placeholder properties to recognize HTML tags
Something like:
Select LASTNAME + ', ' + LEFT(FIRSTNAME,1) +<font size= "3">' + ' - ' + ID + '</font>'
works, but I can't find a way to hide the ID
I tried:
Select LASTNAME + ', ' + LEFT(FIRSTNAME,1) +<div style="visibility:hidden">' + ' - ' + ID + '</div>'
References say that only certain inline CSS attributes are supported, so visibility must be one that isn't.
Any ideas, other than using one field for sorting and another for display.