Network Architecture

12K

Solutions

11K

Contributors

Network design and methodology, also known as network architecture, is the design of a communication network. It is a framework for the specification of a network's physical components and their functional organization and configuration, its operational principles and procedures, as well as data formats used in its operation. In telecommunication, the specification of a network architecture may also include a detailed description of products and services delivered via a communications network, as well as detailed rate and billing structures under which services are compensated.

Share tech news, updates, or what's on your mind.

Sign up to Post

I have 1 aruba 2930F 48G 4SFP+, 2 24G POE+ 4SFP+ switches. How should I stack them?
0
Microsoft Azure 2017
LVL 12
Microsoft Azure 2017

Azure has a changed a lot since it was originally introduce by adding new services and features. Do you know everything you need to about Azure? This course will teach you about the Azure App Service, monitoring and application insights, DevOps, and Team Services.

I'm attempting to connect some switches in my IDF locations to my MDF switch via SFP.

The fiber connecting each IDF to the MDF is multimode, OM3. It connects to a LANscape housing in each location. From the housing, I'm trying to connect a fiber patch cable to the SPF module on the switch.

I managed to get ONE switch working in ONE IDF by using an aqua OM3 patch cable connected to a Ubiquiti module. The only way I could get that connection to work was with a multimode fiber converter in the MDF connected to a port on the switch. SPF would not work. I've tried various SFP modules, including an SPF+ 10G multimode, a Trendnet 1.25G multimode, a generic 1.25G multimode module, and even a couple single mode SFPs, just in case. I've tried aqua OM3 patch cables, orange OM1 patch cables, various LC to SC adapters, and some yellow single mode patch cables, again, just in case. I've tried just about every single combination of the above in some fashion.

On a second switch in a second IDF, even with a fiber converter in the MDF, I can't get a link. If I remove the converter from the first connection in the first IDF, I can't get a link with any combination of the above.

I am about to go insane with this problem. This should be straightforward and easy, but it's driving me nuts.

The contractor installing the actual fiber backbone has told me it's multimode fiber, OM3, 50 microns. I suppose that might be incorrect information, but I have had no issues or inconsistencies …
0
Dear Experts

We are solution implementer like crm application and even server hosting for those companies who require us to host and maintain servers. Recently few of clients are mentioning about soc2 compliance. Can you please help me understand with respect to solution implementation point of view what does soc2 compliance means and how does it help our business, thanks in advance.
0
Hi
We are expanding our office so will need to install an additional switch in another room c20 feet away from the comms.  At the same time we are looking at replacing our existing switches.  

Currently have a hp 2910al poe+ 48 port serving as GW for hosts.  It routes to the local firewall and thereafter out tot he web via router.  We run two vlans for data and voice.  
We also have two other switches connected via ports on the 2910al.  These are HPv170 and 3com 2952, these run only data, no voice.

Looking for recommendations for specs and types of switches.  We like HP but would use any other.  Ideally have some form of resiliency and HA in the comms room and the same with the other switch in the other room.

Would modules be any good?

We also have STP disabled for our voice to work.

Thanks
0
Configuring NAT

in the LAB configuration below:
I have R1 and R2 in subnet 192.168.12.0/24 ----R3 in subnet 10.10.13.0/16  and R4 in subnet 10.10.24.0/16

I would like to have R3 be able to ping R4

The NAT configuration does not seem to work as it is supposed to.
Any Help ?

Thank you

n




R1#sh run 
Building configuration...

Current configuration : 2199 bytes
!
! Last configuration change at 02:39:42 CET Sun Sep 2 2018
!
version 15.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R1
!
boot-start-marker
boot-end-marker
!
aqm-register-fnf
!
!
no aaa new-model
clock timezone CET 1 0
mmi polling-interval 60
no mmi auto-configure
no mmi pvc
mmi snmp-timeout 180
!
!
!
!
!
!


!
!
!
!
ip cef
no ipv6 cef
!
multilink bundle-name authenticated
!
!
!
!
!
!
!         
!
!
redundancy
!
!
! 
!
!
!
!
crypto isakmp policy 5
 encr 3des
 authentication pre-share
 group 2
crypto isakmp key cisco@123 address 192.168.12.2   
!
!
crypto ipsec transform-set MY-SET esp-aes esp-md5-hmac 
 mode tunnel
!
!
!
crypto map IPSEC-SITE-TO-SITE-VPN 10 ipsec-isakmp 
 ! Incomplete
 set transform-set MY-SET 
 match address VPN-TRAFFIC
!
!
!
!
!
interface Ethernet0/0
 ip address 192.168.12.1 255.255.255.0
 crypto map IPSEC-SITE-TO-SITE-VPN
!
interface Ethernet0/1
 ip address 10.10.13.1 255.255.0.0
!
interface Ethernet0/2
 no ip address
 shutdown
!
interface Ethernet0/3
 no ip address
 shutdown

Open in new window

0
Understanding uRPF Loose Mode /Strict Mode,

Let's say we have R1 connected on both of its 2 interfaces to R2 and R3
R1 interface IP address(192.168.12.1/24) connecting to R2
R1 interface IP address(192.168.13.1/24) connecting to R3

R2 interface IP address(192.168.12.2/24) connecting to R1
R3 interface IP address(192.168.13.3/24) connecting to R1

R2 has a loopback 0 with ip address 2.2.2.2/32

R1 has static route : Ip route 2.2.2.2 255.255.255.255 192.168.12.2

For test purpose I have created lopback 0 on R3 with the same IP address 2.2.2.2/32 as the loopback 0 on R2

With Strict Mode or Loose Mode configured, I can ping from R2 (source Loopback 0:2.2.2.2) to R1 (192.168.12.1)
I can see the ping replies. but I cannot ping from R3 (Source Loopback 0: 2.2.2.2) to R1 (192.16.13.1).
However when reading online, it states that with Loose Mode, R1 will accept packets from R3 and with Strict Mode it does not.
from my side, I still cannot see the difference between Strict/Loose Mode as both will cause Ping fails from R3 source loopback 0 to R1

Any clarification on this ?

Thank you
0
Hi guys

Do you have a checklist that you go through for your network infrastructure on a daily basis that you are able to upload at all? We have one, but I was just keen to see what others are using and perhaps add the things (if relevant) to or list?

We do checks for fileserver space, VPN tunnels, backups, alerts for Vmware and Firewalls.

Thanks for helping
Yashy
0
Hello,

I have a flat network with some unmanage switches and  1 firewall.

I would like to separate at least Workstations and Servers in different VLANS

Do i need Switches Layer 3 or i can use Layer 2 Switches?
0
We have purchase the new Aruba 2530F and our HQ instruct us to create the SVI’s in the switch and perform the intervlan on this switch. I have some doubt regrading this configuration and hope that expert can advise me.
1.      For all the printer we should use which vlans
2.      From the switch I can see that have option for us to check primary and management in vlan interface, let said in this information provide by HQ should I enable “management” in  VLANS 4
3.      What is native VLANS
4.      We try to enable the management in VLANS 4 ,we lost access or web console but we still have connectivity ?
5.     we should connect all the configure all the management port in VLANS 4 ?


MGMT_VLANS: 4        10.10.4.1
OFFICE_VLANS: 5(Native) 10.10.5.1
STAFFWiFi_VLANS: 6         10.10.6.1
GUESTWIFI_VLANS :7        10.10.7.1
0
What are the best fiber cable manufacturers?  There're so many online and price varies and lot.
Looking for LC/LC SM and MPO MM cables.  
Please advice.  I normally buy on Amazon.
0
Exploring ASP.NET Core: Fundamentals
LVL 12
Exploring ASP.NET Core: Fundamentals

Learn to build web apps and services, IoT apps, and mobile backends by covering the fundamentals of ASP.NET Core and  exploring the core foundations for app libraries.

Experts, I am looking for a paid CA Devtest Service Virtualization tutorial online. The tutorial offered by CA requires me to provide a company email address which I can't at the moment. Does anyone have information about any websites that offer the training? Any inputs appreciated.
0
Never done that and need advice how its being done normally.

I need to relocate uplink one floor up in the building.  Larger server room, better AC, power, etc.
Moving all the switches up there.  How do I move the ISP handoff?  Fiber single-mode.
Do I just put a patch panel and route up there, or move the handoff?  Is it something ISP responsible per request or cabling contractors?
What's the best option?  Please advice.
0
Hi,

as attach file show, I have two firewalls, one is too old and could not support VRRP, but I want to make a backup route.

so I write two default route on Core switch:
ip route 0.0.0.0 0.0.0.0 192.168.1.1
ip route 0.0.0.0 0.0.0.0 192.168.2.1

I don't know if there will be problems.

if 192.168.1.1 is broken, the traffic will through 192.168.2.1?

Regards,
Kai
0
Have anyone used multi-mode to single mode fiber converters?  Are they reliable?  
I need to run 40G optics between the floors in the three building floors (floors 1,2,and3).  MM fiber is already in place.  To support 40G between these three floors we need single mode duplex LC fiber.  
Instead of doing new SM runs, can we install converters to achieve that?  Would that work reliably?
0
hi guys

I was hoping that you guys could help me with something. We have many stores across the UK. I am trying to do a revision of our network architecture. I have uploaded a very basic Visio diagram of what it looks like. Stores are connected via the MPLS to a datacentre which has our firewall and from which the internet breaks out. I have created Store A and this configuration is almost identical for all other stores. All stores have IP PDQ machines. The store network traffic goes from the PC's, Tills//PDQ's via the MPLS network to our datacentre and from there, it breaks out to the internet. PDQ's also failover to an analogue telephone line if there is an issue with the MPLS network.

We have additional internet lines at each store for other things such as footfall camera's and mobile devices which I have included on the right hand side. This is so that credit card information is going out of an entirely separate line in case of a breach. So of course, one issue we have is that if (this has not happened yet in the 4yrs I have been there) the internet side at the end of where the MPLS breaks out into the firewall and to the internet went down, then none of the 40 stores can transact properly. Well they can, but via the analogue phone lines which I think is just 20th century rather than 21st.

However, I am reviewing all of this and hoping that we can just reduce 2 to 3 internet lines into just one and introduce VLAN's and consolidate everything.

My questions …
0
help with setting up VLAN on a few switches for phone and data equipment.

i have a series of managed switches that are uplinked together.  I would like to set up a VLAN 100 for a dedicated router that is on port 48 of one switch. This router will listen to requests from phones that are plugged into any other random ports on the switch.  This switch is a ubiquiti unit that allows me to set port 48 to listen to vlan 100 traffic only.

The phones are set to 802.1Q with a vlan of 100.  there are other computers and servers on the switch that are on a 192.168.0.x subnet.  The server is handing out DHCP as well as the router on port 48.  The idea is to isolate the traffic for the phones to ONLY communicate with the DHCP server on port 48.  

Right now, this setting is working. However my question to you, is since the phones are all plugged into random ports 1-47 and set to vlan100  and these ports are set to listen to both default lan traffic as well as vlan100...am i simply congesting the switch with added default and vlan traffic vs setting the actual ports that the phones are plugged into to ONLY vlan 100?

Also, if i plug in another switch,, do i need to set the uplink from one switch to another switch with a vlan100 for them to comminicate or will they pass the phones traffic that is tagged 802.1Q VLAN 100 traffic to the other where the port 48 will ultimately listen and grab it? Thank you!
0
Hello,

I have a Cisco network running 10/100/1000Mbps. Should I planning on upgrading it to 10Gbps, 40 Gbps, or 100Gbps? What would be involved? New switches, cabling? I would appreciate input from anyone who's also doing the same or planning on doing the same. I would like to know what devices, cables etc you are thinking of, your plan of attack and approximate costs.

Thank you so much in advance.
0
I would like to know if I am on the right track.

I have a webserver directly connected to a DMZ interface on the active ASA5525X of the active standby failover pair. The failover is configured via another interface.

Right now, if the active ASA fails, the secondary will kick in but this webserver will not be accessible from the outside. What I plan to do is create a VLAN on a switch and plug in the webserver and the DMZ interfaces from both the active and standby ASAs into ports configured for that VLAN.

What am I missing? I do not plan on configuring an IP address for that VLAN or setup any sort of special routing. The only route on that switch is the ip route 0 0 gateway. The ASA DMZ interfaces are configured as ip address 172.16.1.1 255.255.255.248 standby 172.16.1.2. The webserver is 172.16.1.3. The webserver uses the 172.16.1.1 as the gateway.

When the active ASA is active, the webserver sees it as 172.16.1.1. What happens when the ASA fails over to the secondary? Will the webserver still see the ASA as 172.16.1.1? Or is there routing to be configured on the switch?

Thank you.
0
Dear Experts

We have been asked to deploy on premise mail server for which we are planning to go for zimbra network but before to that we have to design the network,  though this email server will be working for internal within main office and branch office as it is connected in mpls network but we also would like to send and receive mails to external domains following measures to be taken
1. if our server or internet goes down the sender mail should not get lost for us once the server or internet gets restored the mails should be delivered to our emails accounts.
2. our domain and ip reputation should be always good so that our messages gets delivered to the inbox on the recipient email
please suggest on how our email server to be configured have internal dns server and make it work as normal email server and for external we have to avail SMTP RELAY service with some service provider please suggest is this correct if not please suggest what service we have to avail for external email delivery with email security will be taken care.
0
Become a CompTIA Certified Healthcare IT Tech
LVL 12
Become a CompTIA Certified Healthcare IT Tech

This course will help prep you to earn the CompTIA Healthcare IT Technician certification showing that you have the knowledge and skills needed to succeed in installing, managing, and troubleshooting IT systems in medical and clinical settings.

Dear Experts

to setup new office what IP addressing is recommended as it is common to use 192.168.1.0/24 but I would like to go for something different and this network will have to be get connected over the VPN from other location and they may be using 19.168.1.0/24,  this new network yet to be setup will have internal dns and dhcp and leased line and mpls connectivity. the total users or end devices within this network will not be more than 75, I prefer other than 192.168.1.0/24 is there a recommend/best  practice in selecting a particular ip addressing for private lan network please suggest,  is it good to go with 192.168.0.1/24 or something like 192.168.100.0/24 or any other ip addressing recommended please suggest.
0
I have noticed on some Aruba wireless controllers the spanning tree is disabled.  Is there a reason to disable a spanning tree on aruba wifi controllers or on any wireless controllers?
0
How to combine two subnets?
AM  Volunteer IT for church.  Have one wired network, one server (W12 running DHCP) on 192.168.0 subnet mask 255.255.255.0 with printer/copiers wired workstations connected thru POE switches to Zxyel Firewall/switch to Comcast.  File sharing and SQL databases on server.  Zyxel also splits off to VIOP phone system. Originally had some Dlink routers acting as Access points for wireless (worked, but campus not fully covered).

Independently, another volunteer got approval to purchase campus wide wireless.  Third party installed Ruckus wireless POE units (10, one a controller) on subnet 10.59.0 subnet mask 255.255.255.0 running separate DHCP for wireless side (one workstation is also connected to this subnet).  All Dlink routers were removed. Supposedly inherent to the Ruckus system is health checking and repair/restoration of the Ruckus access points without human intervention.  I have no manuals or training on the Ruckus wireless system.

Needless to say, workstations (wired or wireless) on one subnet cannot see across the subnets. i.e. file explorer does not show machines on other subnet and visa versa.  Found that if I enabled WINS on the 10.59.0 systems, I could then address the server by manually entering servername i.e. \\servername\sharename.  Believe there are issues of getting to SQL databased from a wireless workstation as this week had to connect a wireless laptop via ethernet to setup an application using a SQL database.  There was a…
0
I'm looking for reference information regarding network connectivity into Microsoft Azure cloud environments for organizations starting to consider cloud/IaaS migrations. I'm familiar with the high-level concepts (Azure vNets, ExpressRoute, etc.), but am specifically looking for guidelines, and maybe conversation points for customers asking about network requirements for initial and possibly longer-term cloud investment.

Let's assume the customer already has redundant, high-speed Internet connectivity, and is (again) looking for input regarding how a migration plan to Azure would look like from a network perspective.

Thank you
0
If you have two Internet feeds with BGP attracting traffic to your site and one goes out - should that interfere with ongoing uploads?
Say I had 200 uploads via sftp to my site. Provider A does some maintenance but Provider B stays up. Traffic load drops to 50
uploads. Since the connections are TCP/SFTP I would think they would just pause and then continue once the available path became
available. Or is it the case that the reconvergence/hold down timers are likely just too long to keep most of those conversations
alive?
0
I have a (hopefully very simple question) regarding routing in a hyper-converged environment. In the simplest form, let's say we have a single HC node (HyperFlex, SimpliVity, etc.), and the VMs being hosted on this node are within a typical Web/App/DB hierarchy - so, all in different VLANs/subnets, virtual firewalls in-between, etc.

Given the above, would communication between the different tiers (W/A/DB) require exiting the HC node to an external routing device, or would the virtualization hypervisor somehow be able to handle this? (Let's assume NSX is off the table.)  This would seem to be a "normal" deployment for any HC environment, in that the more condensed the environment, the higher demand for internetwork connectivity.

I'm trying to get to whether a Layer 3 physical switch is "normal" for these environments to handle this inter-tier traffic, or if there are more efficient options.

Thank you
0

Network Architecture

12K

Solutions

11K

Contributors

Network design and methodology, also known as network architecture, is the design of a communication network. It is a framework for the specification of a network's physical components and their functional organization and configuration, its operational principles and procedures, as well as data formats used in its operation. In telecommunication, the specification of a network architecture may also include a detailed description of products and services delivered via a communications network, as well as detailed rate and billing structures under which services are compensated.