We help IT Professionals succeed at work.

Network Architecture

12K

Solutions

11K

Contributors

Network design and methodology, also known as network architecture, is the design of a communication network. It is a framework for the specification of a network's physical components and their functional organization and configuration, its operational principles and procedures, as well as data formats used in its operation. In telecommunication, the specification of a network architecture may also include a detailed description of products and services delivered via a communications network, as well as detailed rate and billing structures under which services are compensated.

Hello - what (if any) are the options for shaping traffic on an X-series firewall?  I have a customer with a Gig handoff Internet circuit, currently provisioning 150-Mbps. This is terminated on an old ISR, which is shaping the traffic via "bandwidth 150000" command to prevent carrier policing. We need to move this connection off of the ISR onto a ASA 5525-X.

From what I've found so, it appears there's no way to handle traffic shaping on the X-series firewalls. (I haven't looked into the new FTD appliances yet, so would be interested in feedback on those as well.) The 5525 is currently running 9.2 code, and the 9.2 configuration guide (https://www.cisco.com/c/en/us/td/docs/security/asa/asa92/configuration/firewall/asa-firewall-cli/conns-qos.html) indicates that traffic shaping is only supported on the 5505 (not the "multi-core models such as 5500-X"). I haven't checked newer release notes.

Is there a way to perform the same shaping function on an ASA 5525, with either the existing or newer code? If not, how are other customers handling sub-rated circuits to prevent policing and the potential resulting connection drops? Again, if the newer FTD appliances (2100's) can provide for this, that'd be helpful to know.

Thank you
0
Please see the attached diagram.

I have configured 10.0.3.61 and 10.0.3.62 as VPC peers with a port-channel comprised of links A and B as their peer-link.

I want to configure a third switch, 10.0.0.3.63 to be dual homed (using links C and D) and connect upstream to this VPC pair.

On the 10.0.3.63, I would configure the port channel with commands like:

switch63# int e1/31-32
switch63# switchport mode trunk
switch63# channel-group 1 mode active

What I would like to know is what command(s) do I run on either 10.0.3.61 and/or 10.0.3.62 to create a port-channel that spans both switches (so that the uplink from 63 is dual homed?)

I thought this was the most natural application of VPC but I cannot find any documentation for this scenario.

Thanks in advance for your help!
VPC-scenario.jpg
0
I have a wireless guest network and I'd like to test to make sure that it cannot get into my 10.10.0.0/16 internal network. Excluding ping sweep utility, what other tools can I use to do some sort of penetration testing? Thanks
0
I am at a new site and there are SVI interfaces in the core switch, which is fine but one thing I see is that the customer have the line

ip router ospf 21 area 0.0.0.21


Can I please have someone experience tell me if this is correct?
what does it mean, I looked at the ospf configuration and I have never seen any command in this syntax.

Thank you
0
Meaning of Port number in Show spanning Tree

in the output of the command below  I see:

 Port        1 (Ethernet0/0)

I wonder what Port 1 means?  I thought the port is the same as interface.

Thank you


SW1#sh spanning-tree  vlan 20

VLAN0020
  Spanning tree enabled protocol ieee
  Root ID    Priority    24596
             Address     aabb.cc00.0400
             Cost        200
             Port        1 (Ethernet0/0)
             Hello Time   2 sec  Max Age 20 sec  Forward Delay 15 sec

  Bridge ID  Priority    32788  (priority 32768 sys-id-ext 20)
             Address     aabb.cc00.0100
             Hello Time   2 sec  Max Age 20 sec  Forward Delay 15 sec
             Aging Time 300

Interface           Role Sts Cost      Prio.Nbr Type
------------------- ---- --- --------- -------- --------------------------------
Et0/0               Root FWD 100       128.1    Shr 
Et0/1               Altn BLK 100       128.2    Shr 

SW1#

Open in new window

0
DR(designated router) is for sending source message to receiver. I am not sure DR is located between source and RP, or between RP to receiver? Anyone can give some idea? Thank you
0
MPLS Layer 2 and NAT

If I understand with MPLS Layer 2 , you can connect 2 sites of your networks and will seem just like you are on the same LAN network, except for speed.

Well, let say ISP gave us MPLS L2, and we connect one of our routers of our Site1 to one end of MPLS and another router of our Site2 to the other end of MPLS.
in this case, should the interface of a router connected to Site1 have to have IP address on the same subnet as the interface of the other router connected MPLS on Site2 ?

I mean : (Site1)R1---Interface1------>MPLS-<------Interface2--R2(SIte2)
Interface1 will be on the same subnet as Interface2 ?


Assuming it should.

Now to get all networks of Site1 and Site2 to communicate, do we need NAT translation configured on Router connected to MPLS on Site1 and Router connected to MPLS on Site2 ?


Thank you
0
Is Root Bridge relevant when connecting to L3 Switches.

I would like to know when I have all my L2 switches connected to L3 (Distribution or Core) switches, if there is any concern about Root bridge election or even STP loop.
To my understanding as long as L2 switches are not connected directly between themselves there will be no Root Bridge election and there will be no STP loop to happen.
for instance in the Diagram below, all L2 switches are not connected directly between themselves, but connect to L3 switches.

Thank you

sp
0
I have a data jack that is terminated; but, not properly labelled.  I am trying to use a tone generator to find the correct patch panel connection that I need to use and cross connect the ethernet correctly to the end point.

https://www.youtube.com/watch?v=JHRIiw3OR6Y

The problem is that this specific data jack is in a machine shop floor and when I activate the toner every patch panel connection is triggered in the room.  If I turn off the toner generator every patch panel is still sounding off in that room.

If I try the toner generator in different locations(other rooms) there is no problem.  The toner generator works as I expect it to.

What could be causing the toner tester to sound off in that 1 specific patch panel?  Could it be that the ethernet cables were not grounded correctly?
0
in practice, where in the network (for shaping WAN/Internet traffic)  is best to connect packetshaper  in terms of security  and in terms of best network design?

Betw WAN router n external firewall, at DMZ external facing firewall or ?
0
Hi Experts,

we have to plan a big move to another building.
I have some questions about it.
Our datacenter is using RJ45 patch panels and cabling is done with CAT7

The new building has older technology installed and another patch system , called SYSTIMAX.
This SYSTIMAX patch system is new for all of us and the installed cables are all CAT6.

What kind of patch systems do you use in your datacenter ?
Do I have so many benefits with SYSTIMAX ?
1
Dear Experts

We are solution implementer like crm application and even server hosting for those companies who require us to host and maintain servers. Recently few of clients are mentioning about soc2 compliance. Can you please help me understand with respect to solution implementation point of view what does soc2 compliance means and how does it help our business, thanks in advance.
0
Hi
We are expanding our office so will need to install an additional switch in another room c20 feet away from the comms.  At the same time we are looking at replacing our existing switches.  

Currently have a hp 2910al poe+ 48 port serving as GW for hosts.  It routes to the local firewall and thereafter out tot he web via router.  We run two vlans for data and voice.  
We also have two other switches connected via ports on the 2910al.  These are HPv170 and 3com 2952, these run only data, no voice.

Looking for recommendations for specs and types of switches.  We like HP but would use any other.  Ideally have some form of resiliency and HA in the comms room and the same with the other switch in the other room.

Would modules be any good?

We also have STP disabled for our voice to work.

Thanks
0
Configuring NAT

in the LAB configuration below:
I have R1 and R2 in subnet 192.168.12.0/24 ----R3 in subnet 10.10.13.0/16  and R4 in subnet 10.10.24.0/16

I would like to have R3 be able to ping R4

The NAT configuration does not seem to work as it is supposed to.
Any Help ?

Thank you

n




R1#sh run 
Building configuration...

Current configuration : 2199 bytes
!
! Last configuration change at 02:39:42 CET Sun Sep 2 2018
!
version 15.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R1
!
boot-start-marker
boot-end-marker
!
aqm-register-fnf
!
!
no aaa new-model
clock timezone CET 1 0
mmi polling-interval 60
no mmi auto-configure
no mmi pvc
mmi snmp-timeout 180
!
!
!
!
!
!


!
!
!
!
ip cef
no ipv6 cef
!
multilink bundle-name authenticated
!
!
!
!
!
!
!         
!
!
redundancy
!
!
! 
!
!
!
!
crypto isakmp policy 5
 encr 3des
 authentication pre-share
 group 2
crypto isakmp key cisco@123 address 192.168.12.2   
!
!
crypto ipsec transform-set MY-SET esp-aes esp-md5-hmac 
 mode tunnel
!
!
!
crypto map IPSEC-SITE-TO-SITE-VPN 10 ipsec-isakmp 
 ! Incomplete
 set transform-set MY-SET 
 match address VPN-TRAFFIC
!
!
!
!
!
interface Ethernet0/0
 ip address 192.168.12.1 255.255.255.0
 crypto map IPSEC-SITE-TO-SITE-VPN
!
interface Ethernet0/1
 ip address 10.10.13.1 255.255.0.0
!
interface Ethernet0/2
 no ip address
 shutdown
!
interface Ethernet0/3
 no ip address
 shutdown

Open in new window

0
Understanding uRPF Loose Mode /Strict Mode,

Let's say we have R1 connected on both of its 2 interfaces to R2 and R3
R1 interface IP address(192.168.12.1/24) connecting to R2
R1 interface IP address(192.168.13.1/24) connecting to R3

R2 interface IP address(192.168.12.2/24) connecting to R1
R3 interface IP address(192.168.13.3/24) connecting to R1

R2 has a loopback 0 with ip address 2.2.2.2/32

R1 has static route : Ip route 2.2.2.2 255.255.255.255 192.168.12.2

For test purpose I have created lopback 0 on R3 with the same IP address 2.2.2.2/32 as the loopback 0 on R2

With Strict Mode or Loose Mode configured, I can ping from R2 (source Loopback 0:2.2.2.2) to R1 (192.168.12.1)
I can see the ping replies. but I cannot ping from R3 (Source Loopback 0: 2.2.2.2) to R1 (192.16.13.1).
However when reading online, it states that with Loose Mode, R1 will accept packets from R3 and with Strict Mode it does not.
from my side, I still cannot see the difference between Strict/Loose Mode as both will cause Ping fails from R3 source loopback 0 to R1

Any clarification on this ?

Thank you
0
Hi guys

Do you have a checklist that you go through for your network infrastructure on a daily basis that you are able to upload at all? We have one, but I was just keen to see what others are using and perhaps add the things (if relevant) to or list?

We do checks for fileserver space, VPN tunnels, backups, alerts for Vmware and Firewalls.

Thanks for helping
Yashy
0
Hello,

I have a flat network with some unmanage switches and  1 firewall.

I would like to separate at least Workstations and Servers in different VLANS

Do i need Switches Layer 3 or i can use Layer 2 Switches?
0
We have purchase the new Aruba 2530F and our HQ instruct us to create the SVI’s in the switch and perform the intervlan on this switch. I have some doubt regrading this configuration and hope that expert can advise me.
1.      For all the printer we should use which vlans
2.      From the switch I can see that have option for us to check primary and management in vlan interface, let said in this information provide by HQ should I enable “management” in  VLANS 4
3.      What is native VLANS
4.      We try to enable the management in VLANS 4 ,we lost access or web console but we still have connectivity ?
5.     we should connect all the configure all the management port in VLANS 4 ?


MGMT_VLANS: 4        10.10.4.1
OFFICE_VLANS: 5(Native) 10.10.5.1
STAFFWiFi_VLANS: 6         10.10.6.1
GUESTWIFI_VLANS :7        10.10.7.1
0
What are the best fiber cable manufacturers?  There're so many online and price varies and lot.
Looking for LC/LC SM and MPO MM cables.  
Please advice.  I normally buy on Amazon.
0
Experts, I am looking for a paid CA Devtest Service Virtualization tutorial online. The tutorial offered by CA requires me to provide a company email address which I can't at the moment. Does anyone have information about any websites that offer the training? Any inputs appreciated.
0
Never done that and need advice how its being done normally.

I need to relocate uplink one floor up in the building.  Larger server room, better AC, power, etc.
Moving all the switches up there.  How do I move the ISP handoff?  Fiber single-mode.
Do I just put a patch panel and route up there, or move the handoff?  Is it something ISP responsible per request or cabling contractors?
What's the best option?  Please advice.
0
Hi,

as attach file show, I have two firewalls, one is too old and could not support VRRP, but I want to make a backup route.

so I write two default route on Core switch:
ip route 0.0.0.0 0.0.0.0 192.168.1.1
ip route 0.0.0.0 0.0.0.0 192.168.2.1

I don't know if there will be problems.

if 192.168.1.1 is broken, the traffic will through 192.168.2.1?

Regards,
Kai
0
Have anyone used multi-mode to single mode fiber converters?  Are they reliable?  
I need to run 40G optics between the floors in the three building floors (floors 1,2,and3).  MM fiber is already in place.  To support 40G between these three floors we need single mode duplex LC fiber.  
Instead of doing new SM runs, can we install converters to achieve that?  Would that work reliably?
0
hi guys

I was hoping that you guys could help me with something. We have many stores across the UK. I am trying to do a revision of our network architecture. I have uploaded a very basic Visio diagram of what it looks like. Stores are connected via the MPLS to a datacentre which has our firewall and from which the internet breaks out. I have created Store A and this configuration is almost identical for all other stores. All stores have IP PDQ machines. The store network traffic goes from the PC's, Tills//PDQ's via the MPLS network to our datacentre and from there, it breaks out to the internet. PDQ's also failover to an analogue telephone line if there is an issue with the MPLS network.

We have additional internet lines at each store for other things such as footfall camera's and mobile devices which I have included on the right hand side. This is so that credit card information is going out of an entirely separate line in case of a breach. So of course, one issue we have is that if (this has not happened yet in the 4yrs I have been there) the internet side at the end of where the MPLS breaks out into the firewall and to the internet went down, then none of the 40 stores can transact properly. Well they can, but via the analogue phone lines which I think is just 20th century rather than 21st.

However, I am reviewing all of this and hoping that we can just reduce 2 to 3 internet lines into just one and introduce VLAN's and consolidate everything.

My questions …
0
I would like to know if I am on the right track.

I have a webserver directly connected to a DMZ interface on the active ASA5525X of the active standby failover pair. The failover is configured via another interface.

Right now, if the active ASA fails, the secondary will kick in but this webserver will not be accessible from the outside. What I plan to do is create a VLAN on a switch and plug in the webserver and the DMZ interfaces from both the active and standby ASAs into ports configured for that VLAN.

What am I missing? I do not plan on configuring an IP address for that VLAN or setup any sort of special routing. The only route on that switch is the ip route 0 0 gateway. The ASA DMZ interfaces are configured as ip address 172.16.1.1 255.255.255.248 standby 172.16.1.2. The webserver is 172.16.1.3. The webserver uses the 172.16.1.1 as the gateway.

When the active ASA is active, the webserver sees it as 172.16.1.1. What happens when the ASA fails over to the secondary? Will the webserver still see the ASA as 172.16.1.1? Or is there routing to be configured on the switch?

Thank you.
0

Network Architecture

12K

Solutions

11K

Contributors

Network design and methodology, also known as network architecture, is the design of a communication network. It is a framework for the specification of a network's physical components and their functional organization and configuration, its operational principles and procedures, as well as data formats used in its operation. In telecommunication, the specification of a network architecture may also include a detailed description of products and services delivered via a communications network, as well as detailed rate and billing structures under which services are compensated.