Network Architecture

12K

Solutions

11K

Contributors

Network design and methodology, also known as network architecture, is the design of a communication network. It is a framework for the specification of a network's physical components and their functional organization and configuration, its operational principles and procedures, as well as data formats used in its operation. In telecommunication, the specification of a network architecture may also include a detailed description of products and services delivered via a communications network, as well as detailed rate and billing structures under which services are compensated.

Share tech news, updates, or what's on your mind.

Sign up to Post

We are adding optus phones network at our office, I need to open up two ports on firewall. i.e.

FTP(XMPP) Port (1081) is Closed

How can I add this rule under Meraki MX?

Thanks.
0
Introduction to Web Design
LVL 13
Introduction to Web Design

Develop a strong foundation and understanding of web design by learning HTML, CSS, and additional tools to help you develop your own website.

Hello guys,

what's the best course to learn about design and build infrastructure?
I am looking for high-availability compute platforms and understand how to build scalable infrastructure.... cloud design principles ... these things as well

Regards
RM
0
Hello Experts,

We are planning for a network infrastructure upgrade. It includes structured cabling and active systems.
The network is currently running Cat5e cables, patch panels and faceplate modules.
Cisco Catalyst 3560 is deployed at edge and 6506 at Core.
We want to upgrade the infrastructure to Cat6a structured cabling, Fiber cabling supporting 10g and Cisco Switches with  SD-Access.
Therefore, we are looking for tips and suggestions to start preparing the plan.
0
Hi,

I have three Cisco firepower. Two of them are FPR2120-NGFW-K9 and the third one is FPR4110-NGFW-K9. I want to buy Cisco firepower management center. What type of License do I need? And what is the estimate price for it?

Thanks
0
We are planning to upgrade old fashioned Network infrastructure and this primarily includes deploying new evolving Cisco SDA
The existing infrastructure is having Cisco switches.
The current is design is very simple. It consists of two 6509 Cisco switches as Collapsed core and Edge Switches consists of mixed 2960s and 3560s
Core switches are configured as HSRP Active/Standby and Active Core switch is root bridge for all vlans.

VLANs are segmented  as per department wise and all vlans are configured and spanned through out all switches.

The plan is to:
- Upgrade all switches
- Migrate from traditional network to SDA.
- Prepare

Hence, we need experts here to guide us on above points.
What strategies need to be considered?
How to perform the migration?

Appreciating any help and suggestions
0
Dear Experts

We are planning to implement surveillance system in our factory for 24/7 recording footage and approximately 25 to 30 cameras  with feature of Night Motion Detection,  we prefer to have backups scheduled and replicated to head office our  factory and head office are connected with MPLS network. Synology has Surveillance solution would like understand does this serve the above requirement, it is also very much important for us to have every 4 hours backup and the same is secured and copy to the head office hence NAS box replication is required, please suggest.
0
Given Below:
VLAN8   Server
VLAN16  Users
VLAN32  VOIP
VLAN64  Staff-Wifi
VLAN128 Guest-WiFi


We are facing issue for the DHCP distribution,Currently SW port 25,26 and connected Hyper-V host1 and SW port 27,28(Cluster1) connected to Hyper-V host2(Cluster1),
Please help to see anythong was wrong in the configuration .I try in Cisco Switch i just configure sw port to access mode VLAN 8 .But i not too sure why they configure like below:

member 1 8    ! N2048
exit
ip route 0.0.0.0 0.0.0.0 10.65.8.254
interface vlan 1
ip address dhcp
exit
interface vlan 8
ip address 10.65.8.201 255.255.255.0
exit
interface vlan 16
ip helper-address 10.65.8.61
exit



interface Gi1/0/25
channel-group 5 mode active
switchport voice detect auto
switchport mode general
switchport general pvid 8
switchport general allowed vlan add 8
switchport trunk native vlan 8
exit
!
interface Gi1/0/26
channel-group 5 mode active
switchport voice detect auto
switchport mode general
switchport general pvid 8
switchport general allowed vlan add 8
switchport trunk native vlan 8
exit
!
interface Gi1/0/27
channel-group 6 mode active
switchport voice detect auto
switchport mode general
switchport general pvid 8
switchport general allowed vlan add 8
switchport trunk native vlan 8
exit
!

interface port-channel 5
switchport voice detect auto
switchport mode trunk
switchport general pvid 8
switchport trunk native vlan 8
exit
!
interface port-channel 6
0
7
Have site where there are two buildings connected by fiber with a WAN connection at both sides. Before I was involved, it seems there was never much thought about where different facilities are located - Phone System, Server Room, etc.

AT&T Symmetrical 1G fiber was run into one of the buildings (Spectrum cable on the other), but server room is across the parking lot. This has not been an issue for the LAN or any internal resources, as they primarily communicate amongst each other and can be configured to use any of the WAN connections as the default gateway.

The problem we are facing now is that I need to make a VM server in the building with Spectrum into a public-facing web application server on AT&T fiber WAN. I know this could be accomplished with port-forwarding to LAN IPs or within a DMZ, but I was thinking it would be easier to just create a VLAN on the two Cisco switches that simply carried over the Public subnet across the parking lot to a specific physical port. I would then hook the VM to a selected hardware NIC on the VMWare host with PCI Device Passthrough. Once I connect this Cat6 cable to the specific designated host port on the Cisco switch, it should just work... right?

Well, I least though so, but my simple tests are not showing connectivity to the public IPs. I think there must be something basic that is being overlooked.

I am not very experienced with Cisco routing, so this is very likely probability.

Here is a basic diag:

Diag
1
We are looking to replace our BCM450 which is operating off of a PRI. Our intentions are to replace this with a Shortel (Mitel) system, and maybe keep the PRI circuits.

Looking for opinions on what people have rolled out for their office phone system and how they like it.

Here are the requirements for our office:
- Office of about 100+ users (each use DIDs)
- Looking to keep the PRI, with option of moving to SIP/VoiP (Hybrid option)
- Have HUNT group features, with multilevel nested call options
- Soft phone feature to use on computers and/or mobile phones
- Voicemail to email functionality (you get an email with .wav file of your voicemail), in-case you are away from the office
- handle analog lines for fax machines
- Vendor that provides good support

Any feedback on what you use today and your opinion on Mitel as a solution would be appreciated.
0
Hi

We had two Windows 2008 physical domain controllers in our network 5 years ago.
One of the IT companies virtualized the network and they built Windows 2012 server and migrated the Windows 2008 domain controller roles to Windows 2012 server (not sure how they did this)

They also replaced our core switches and created different VLANS called, Server VLAN, Wireless VLAN and Legacy VLAN.
Server VLAN Subnet :10.14.112.0/22  
Legacy VLAN Subnet: 10.14.108.0/22

They put the Windows 2012 Domain controllers DC 1 and DC2 on the server VLANs. They also  created another Domain controller called as DC3 and put on this server on the on the Legacy VLAN and not sure why they did this.

Although the DC3 is located on the legacy VLAN, I am able to ping DC1 and DC2 from DC3 and vice versa.

Now I would like to assign an IP from this subnet 10.14.112.0/22 to DC3 and move this DC3 from Legacy VLAN to Server VLAN.

Please let me know if this will cause any problems and is there anything that I need to check before moving this.
Any help and suggestions much appreciated.
Many Thanks in advance !
0
Exploring SharePoint 2016
LVL 13
Exploring SharePoint 2016

Explore SharePoint 2016, the web-based, collaborative platform that integrates with Microsoft Office to provide intranets, secure document management, and collaboration so you can develop your online and offline capabilities.

I have the following network and wanted to get your opinion, from a security/network point of view as to what is wrong and what to do about it.security issue
1
I'm looking for recommendations for NTP appliances. We're re-designing their NTP deployment and had initially recommended a hierarchy leading up to pool.ntp.org, but they're insisting on appliances for local sourcing in case of an Internet outage.

They don't need anything fancy (such as GPS), so I'm looking for low-cost recommendations - physical or virtual appliances, very low capacity (probably fewer than 100 devices referencing them). Encryption for local device support might be nice (if relevant). If physical, redundant power supplies would be nice as well.

Thank you
0
Hi,
I want to have one shared place to path of CentOs 7 machine, like the below. How?
\\113.255.213.124\tmp
0
Migrate 3-tier app architecture test and production to azure cloud being able to deploy changes to production multiple times per day during peak hours

Anyone can help with high level Azure Cloud diagram with above?
Thanks
0
Hi,
Regarding some other way (like the below), to share file between Linux and Windows
https://www.techotopia.com/index.php/Sharing_Files_between_CentOS_6_and_Windows_Systems_with_Samba

is it possible to access shared path (of Linux) like

\\113.255.213.124\Shared_path

For instance, to back up files into such path, when doing Windows system Backup.
0
HI, we have a customer that uses unmanaged switches and has used all of thir 254 IP address on the local network.
What is the best way to achieve more local IP addresses on the LAN
Thanks
0
What would you say are some of the best practices when it comes to securing your system(s) against dependencies (any you can think of) to enable continuous access and delivery to/of data.

Do we need to replicate things that much between servers/countries, what would be alternative approaches?

I am thinking in concepts of things like: security, cloud, blockchains, messaging and whatever you have in mind.
0
In a business that is spread over three buildings, I am trying to connect Unify NanoStations to extend wireless access from the first building in which the ISP comes into.  From the ISP's router, I have an unmanaged switch connecting to a Nano mounted on the outside of the building where the ISP comes into.  From there I have it pointed to a second Nano mounted on the second building through another unmanaged switch and a Unify AP is also connected to that same switch within the second building.  Internet is working fine in the second building.  A third Nano is mounted on the second building with another unamanged switch connected to it.  The fourth Nano is mounted on building 3 with a fourth unmanaged switch and a Unify AP connected to it.  Initially, building 3 connected fine and also connected without the third Nano's help for a short period of time.  Recently and presently, I get a blinking light on the AP and no Internet connectivity.  All devices are setup to talk on a 192.168.2.x network.
0
We have a new site setup for MPLS and the provider is selecting a POP that is almost across country.  Is there any recommendations on the placement of the POP as I always thought it should be close to the site?
0
Angular Fundamentals
LVL 13
Angular Fundamentals

Learn the fundamentals of Angular 2, a JavaScript framework for developing dynamic single page applications.

I'd like to understand how to configure the FW to connect to a virtual DMZ.
I have a Palo Alto FW and I understand how to connect it to a physical device (like the F5) in the DMZ. I just assign an IP address to my FW interface and have a static route and allow policy pointing to the F5. But now if I have a virtual DMZ, meaning it will be stored in the VMWare environment in the datacenter (internal of my network), how will I logically configure my FW interface?
If we are talking about creating VLAN for the virtual DMZ, then  does it defeat the purpose of the separation of the DMZ and the internal network as the DMZ traffic  will traverse my internal network. Any thoughts?

I looked around and I could not find any sample of scenario with a virtual DMZ.
0
hello , need  a second pair of eyes on a site to site vpn from onsite to the cloud
more specificall as my CIDR in cloud is 10.0.0.0/16
and in-house is 10.10.150.0/24

i would imagine this will not work as they overlap

here is my setup:
VPN Gateway name:      
!   > Public IP addresses:  
!     + Public IP 1:         X.X.X.X
!   > Virtual network address space:
!     + CIDR: 10.0.0.0/16
!       - Prefix:   10.0.0.0
!       - Netmask:  255.255.0.0
!       - Wildcard: 0.0.255.255
!   > Local network gateway:
!   > On-premises VPN IP:    X.X.X.X
!   > On-premises address prefixes:
!     + CIDR: 10.10.20.0/24
!       - Prefix:   10.10.20.0
!       - Netmask:  255.255.255.0
!       - Wildcard: 0.0.0.255
0
How to decide to set dmarc to quarantine or reject? I am reviewing the dmarc reports but don't know what to set. Right now is set to none for collecting dmarc reports. What to do?
0
We have 2 offices that are about 250meters apart. We are yet to install the camera feed in one, but have done for the other years ago. We bought this, https://www.amazon.com/dp/B01N0B6KSA/ref=cm_sw_r_wa_api_ysh-BbDAEKWAS

But now have an issue. We want the security post to be in simply one location.

Q: How to transmit live video from camera  to another location 250m away, and where is the best place to put the 16 Channel NVR for each, so we can have a security personnel stationed to review
0
Hi,
I'm about to start a project for a serviced office with 10 offices looking to offer broadband and voip solution to these tenants and maybe a WiFi solution too.

1. What is the best way to do this?
2. What firewall do you recommend?
3. What type of cabling do you recommend for future proof.
4. Is it possible to offer public ip address to each tenant?

Thanks.
0
I have OpnSense (Another version of Pf Sense) Firewall installed. I can not get out to the Internet on my second, 3th, 4th LAN ports.
I have an OpnSense Firewall PC box I made which has the following inside…
OpnSense 18 (latest version) https://opnsense.org/about/about-opnsense/ 
-G.SKILL Ripjaws V Series 16GB (2 x 8GB) 288-Pin DDR4 SDRAM DDR4 2400 (PC4 19200) Desktop Memory Model F4-2400C15D-16GVB
-King Spec SATA III 3.0 2.5" 60GB MLC Digital SSD Solid State Drive for PC B5Y1
-AMD Athlon 200GE 2-Core, 4-Thread, 3.2 GHz Base, Socket AM4 35W YD200GC6FBBOX Desktop Processor
-ASRock A320M-HDV AM4 AMD A320 SATA 6Gb/s USB 3.0 HDMI Micro ATX AMD Motherboard
-80 plus bronze certified power supply 380Watt
-Dell Intel PRO/1000 VT Quad-Port Gigabit Ethernet Card Standard Profile YT674
-IOCrest 4 Port Gigabit Ethernet PCI-e x1 Network Interface Card SI-PEX24042
This is inside a 4U server Case, inside an APC 48U Server Rack


 
My goals are the following...

-      I want to one 4 Port NIC using different IP Addresses such as
10.10.10.1 --- Web server Network
2.2.2.1---- Entertainment Network
90.90.90.1---- Work Network
30.30.30.1 --- Web server Network
I already setup these networks inside my box but I am willing to START from the beginning if you need me too.

-      I want the networks not to be able to talk to each other.
-      I have 5 block of Public static IPs which I want to use.
-      104.XX.xx.1--- This is assigned to the OpnSense itself
-      
-      104.xx.xx.1 talks to …
0

Network Architecture

12K

Solutions

11K

Contributors

Network design and methodology, also known as network architecture, is the design of a communication network. It is a framework for the specification of a network's physical components and their functional organization and configuration, its operational principles and procedures, as well as data formats used in its operation. In telecommunication, the specification of a network architecture may also include a detailed description of products and services delivered via a communications network, as well as detailed rate and billing structures under which services are compensated.