Still celebrating National IT Professionals Day with 3 months of free Premium Membership. Use Code ITDAY17

x

Networking Protocols

11K

Solutions

16K

Contributors

Networking software modules are interfaced with a framework implemented on the machine's operating system that implements the networking functionality of the operating system. The best known frameworks are the TCP/IP model and the OSI model. Systems typically do not use a single protocol to handle a transmission. Instead they use a set of cooperating protocols, sometimes called a protocol family or protocol suite.[9] Some of the best known protocol suites include: IPX/SPX, X.25, AX.25, AppleTalk and TCP/IP. Other protocols indirectly related to networking include the hypertext transfer protocol (HTTP) and its related technologies, Dynamic Host Configuration Protocol (DHCP), Domain Name Server (DNS) and other Internet protocols.

Share tech news, updates, or what's on your mind.

Sign up to Post

Hello,

Two days ago I tried to print a PDF file to a networked printer and nothing happened.  It is like the printer disappeared.  I did some digging and found a new error in Device Manager - my Microsoft Teredo Tunneling Adapter had a yellow exclamation that said the device cannot start (Code 10).  

I tried disabling and re-enabling the adapter, no luck.  I did the same for my physical NICs on my PC and no luck.  I was able to get my printer to work, but now a screen capture utility called SnagIt 9 no longer displays the library of my screen captures (many thousands).

Here is info on my system:

Windows 7 Pro 64-bit
Up to date with Microsoft updates
Have three physical network interface cards in the PC, two are disabled - only one used
For all three cards, IP4 and IP6 are checked

I tried having Device Manager check for driver updates, and was told I have the latest version.  I also uninstalled the adapter and re-installed it, but I still have this error message.  Any suggestions?
0
How to Use the Help Bell
LVL 10
How to Use the Help Bell

Need to boost the visibility of your question for solutions? Use the Experts Exchange Help Bell to confirm priority levels and contact subject-matter experts for question attention.  Check out this how-to article for more information.

I am using file Zilla to connect an ftp server but unfortunately unable to do so below is the error

Status:      Resolving address of ftp2.churchs.com
06:38:14      Status:      Connecting to 209.208.247.23:21...
06:38:14      Status:      Connection established, waiting for welcome message...
06:38:15      Status:      Insecure server, it does not support FTP over TLS.
06:38:15      Status:      Logged in
06:38:15      Status:      Retrieving directory listing...
06:38:34      Command:      PWD
06:38:34      Response:      257 "/CFC-Analytics" is current directory.
06:38:34      Command:      TYPE I
06:38:34      Response:      200 Type set to I.
06:38:34      Command:      PORT 10,139,105,11,209,15
06:38:34      Error:      Disconnected from server: ECONNABORTED - Connection aborted
06:38:34      Error:      Failed to retrieve directory listing
0
Hello, so this firm has a Windows Server SBS 2011 which is mainly used for Exchange and for sharing purposes.

Lately one strange problem has emerged: you open a file from a client (the file is on the server and shared) and you get the usual warning about someone else using the file right now, the file is read-only and so on.

Mind you, I'm not talking about a particular file, this can happen with any file actually.

Problem is, the file is not being used by anyone else, we have verified this many times.
After a while, it will just "unlock" and became fully available.

So, does anyone know how to address this problem or try to diagnose it? It never happened to me in many a year. Thanks.
0
I am trying to see what the best way to assign vlans to my subnets. The below is what I was planning for with the 3rd octet as the vlan#:
- vlan 8 - 10.10.8.0/22 (10.10.8.1 - 10.10.11.254)
- vlan 18 - 10.10.12.0/22 (10.10.12.1 - 10.10.15.254)

But now we are breaking 10.10.8.0/22 to the below. Any tips on assigning the vlan #?
vlan8 - 10.10.8.0/28
vlan? - 10.10.8.16/28
vlan? - 10.10.8.32/27
vlan? - 10.10.8.64/26
0
Please help me understand about ARP.
I know the local ARP table is cached and records also can be manually added. But how come when I ping a remote IP it doesn't automatically create a corresponding ARP table record?
0
Hello ,

I have 2 questions about timestamp ;

1. I have try to convert time stamp value to normal time but it was returned anormal dates :) what is the format of this TS val ?
2. As far as i read on the http://www.networksorcery.com/enp/protocol/tcp/option008.htm 


This field is only valid if the ACK bit is set in the TCP header.


but nearly all SYN packets in normal traffic not a DDOS has TSval  while ack was not sScreen-Shot-2017-08-27-at-18.05.41.pnget
0
show ip pim nei
PIM Neighbor Table
Mode: B - Bidir Capable, DR - Designated Router, N - Default DR Priority,
      P - Proxy Capable, S - State Refresh Capable, G - GenID Capable


Neighbor          Interface                Uptime/Expires    Ver   DR
Address                                                                                                 Prio/Mode
10.0.0.193        TenGigabitEthernet1/2    11w1d/00:01:29    v2    1 / S P G
10.0.0.209        TenGigabitEthernet3/1    11w0d/00:01:41    v2    1 / S P G
10.0.16.13        TenGigabitEthernet4/7    11w2d/00:01:25    v2    1 / G
10.0.16.9         TenGigabitEthernet4/8    11w2d/00:01:27    v2    1 / G


What does it mean when I only have the G in the mode column?

The link at 4/7 and 4/8 is eBGP peer.
0
Hi All,

I am having problems loading OS image onto a new Nexus 9504 with 2 sup below are the steps i have tried, any advise would be much appreciated. image i am using is nxos.7.0.3.I5.2.bin

1. Reload switch and
2. Ctrl + C
3. cmdline recoverymode=1 and cmdline init_system
4. boot nxos.7.0.3.I5.2.bin (which is copied on bootflash/)
5. After this it starts configs and took some time but displayed other messages: System is coming up ... Please wait ...
6.After this, it returns to bash shell: bash-4.2# and nothing happens
7. Both switches, I have reloaded twice and retied again; but still same.

when i exit it takes me into (standby) login: but requires username and password which i have tried all the defaults and will not let me in.

Thanks
0
Hi Sir,

Would like to ask for your help about the problem listed below,

[Tunnel Authorize Fail] ignoring Delete SA payload: PROTO_IPSEC_ESP SA(0xccb797a8) not found (maybe expired)

Hoping that you can help me resolve this matter.


Thank you in advance.
0
Is this a mistake or  am i  checking sth wrong , how should be a packet with missing checksum ?

0000   a0 36 9f 55 7c aa dc 38 e1 ac 9b 89 08 00 45 00  .6.U|..8......E.
0010   00 25 8b cb 00 00 fd 11 d7 aa 89 3c 5a 64 b9 b6  .%.........<Zd..
0020   bc fa fc 5d 69 87 00 11 00 00 ff ff ff ff 55 38  ...]i.........U8
0030   55 76 03 00 00 00 00 00 00 00 00 00              Uv..........

Open in new window


Screen-Shot-2017-08-13-at-17.28.06.png
0
Learn how to optimize MySQL for your business need
LVL 3
Learn how to optimize MySQL for your business need

With the increasing importance of apps & networks in both business & personal interconnections, perfor. has become one of the key metrics of successful communication. This ebook is a hands-on business-case-driven guide to understanding MySQL query parameter tuning & database perf

I am using this Arris NVG443 router in conjunction with an Obitalk 200 to use internet (DSL)  VOIP to make and receive phone calls. The problem is no matter what service I use ie. Google voice (free), Onesuite (subscription),  ALL calls made and received drop within minutes. Using Onesuite provider  all calls drop at exactly 9 minutes every time. Obitalk support says to configure my router to this:
In order for your OBi to be able to send packets w/o interruption, please configure your router as follows:

Allow Outgoing:
TCP Ports: 6800, 5222, 5223
UDP Ports: 5060, 5061, 10000 to 11000, 16600 to 16998, 19305
Allow Incoming on UDP Port: 10000

Problem is: There is nowhere to enter all these ports? Just one range.
 Router has port forwarding and port triggering . In port forwarding there is only a global port range  one port # to another port #, and one base port.
In port triggering there is just a trigger range same as above, one port to one port, and one open port range same as above.

Not sure what to enter into router and can't seem to find any answers ?
0
Dear Team,

There is port already open between  Source -target servers.
i have tested the same using telnet command.

However while I am creating some Datasource in Application server, i am getting  the above error message.

Kindly let me know if there anything required  at OS/App servet/network side .

Kindly advice
=== ERR MESSAGE IS =========
>
<Aug 7, 2017 4:52:24 PM AST> <Warning> <Deployer> <BEA-149004> <Failures were detected while initiating activate task for application 'test'.>
<Aug 7, 2017 4:52:24 PM AST> <Warning> <Deployer> <BEA-149078> <Stack trace for message 149004
java.rmi.RemoteException: [Deployer:149150]An IOException occurred while reading input.; nested exception is:
        java.net.NoRouteToHostException: No route to host
        at weblogic.deploy.service.internal.transport.http.HTTPMessageSender.sendMessageToServerURL(HTTPMessageSender.java:343)
0
Screen-Shot-2017-08-06-at-11.30.59-A.png
on the topology above , I have R1 and R6 on AS 1, R5 on AS3 , R2,R3,R4 on AS2

I would like to have Routers on AS1 (R1 and R6) Not take route through AS3 to reach routers inside AS2, instead I want AS1 routers to go straight to AS2 through R1 using BGP Default Local Preference command on R1

you can see in the config below on R1 :
bgp default local-preference 600


Below is the BGP route configuration on R1, R6, R3. As you can see R6 is going through AS3 to reach routers in AS2 instead of going straight to AS2 through R1

If you need more info , please feel free to ask.


Thank you

R1#sh run | beg router bgp
 bgp default local-preference 600
 network 1.1.1.0 mask 255.255.255.0
 neighbor 192.168.12.2 remote-as 2
 neighbor 192.168.16.6 remote-as 1

Open in new window


R6#sh run | beg router bgp
router bgp 1
 no synchronization
 bgp log-neighbor-changes
 neighbor 192.168.16.1 remote-as 1
 neighbor 192.168.56.5 remote-as 3

Open in new window


R5#sh run | beg router bgp
router bgp 3
 network 5.5.5.0 mask 255.255.255.0
 neighbor 192.168.35.3 remote-as 2
 neighbor 192.168.56.6 remote-as 1

Open in new window


R1# sh ip bgp
BGP table version is 13, local router ID is 1.1.1.1
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
              r RIB-failure, S Stale
Origin codes: i - IGP, e - EGP, ? - incomplete

   Network          Next Hop            Metric LocPrf Weight Path
*> 1.1.1.0/24       0.0.0.0                  0         32768 i
* i2.2.2.0/24       192.168.56.5             0    100      0 3 2 i
*>                  192.168.12.2             0             0 2 i
* i3.3.3.0/24       192.168.56.5             0    100      0 3 2 i
*>                  192.168.12.2                           0 2 i
* i4.4.4.0/24       192.168.56.5             0    100      0 3 2 i
*>                  192.168.12.2                           0 2 i
* i5.5.5.0/24       192.168.56.5             0    100      0 3 i
R1#

Open in new window


R6#sh ip bgp              
BGP table version is 6, local router ID is 192.168.56.6
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
              r RIB-failure, S Stale
Origin codes: i - IGP, e - EGP, ? - incomplete

   Network          Next Hop            Metric LocPrf Weight Path
*>i1.1.1.0/24       192.168.16.1             0    600      0 i
* i2.2.2.0/24       192.168.12.2             0    600      0 2 i
*>                  192.168.56.5                           0 3 2 i
* i3.3.3.0/24       192.168.12.2             0    600      0 2 i
*>                  192.168.56.5                           0 3 2 i
* i4.4.4.0/24       192.168.12.2             0    600      0 2 i
*>                  192.168.56.5                           0 3 2 i
*> 5.5.5.0/24       192.168.56.5             0             0 3 i

Open in new window



R5# sh ip bgp             
BGP table version is 10, local router ID is 5.5.5.5
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
              r RIB-failure, S Stale
Origin codes: i - IGP, e - EGP, ? - incomplete

   Network          Next Hop            Metric LocPrf Weight Path
*> 1.1.1.0/24       192.168.56.6                           0 1 i
*> 2.2.2.0/24       192.168.35.3                           0 2 i
*> 3.3.3.0/24       192.168.35.3             0             0 2 i
*> 4.4.4.0/24       192.168.35.3                           0 2 i
*> 5.5.5.0/24       0.0.0.0                  0         32768 i
R5#

Open in new window

0
Need list of unencrypted protocols.

I know only port 80(HTTP) and 21(FTP)
0
Hi, I want to open connection from RHEL to FTPS server, receive "Fatal error: gnutls_handshake: A TLS packet with unexpected length was received" error when start to transfer file to the FTPS server.

Any idea?

 lftp -v
LFTP | Version 4.0.9 | Copyright (c) 1996-2010 Alexander V. Lukyanov

LFTP is free software: you can redistribute it and/or modify
it under the terms of the GNU General Public License as published by
the Free Software Foundation, either version 3 of the License, or
(at your option) any later version.

This program is distributed in the hope that it will be useful,
but WITHOUT ANY WARRANTY; without even the implied warranty of
MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
GNU General Public License for more details.

You should have received a copy of the GNU General Public License
along with LFTP.  If not, see <http://www.gnu.org/licenses/>.

Send bug reports and questions to the mailing list <lftp@uniyar.ac.ru>.

Libraries used: Readline 6.0


FileCopy(0xbcd2c0) enters state INITIAL
FileCopy(0xbcd2c0) enters state DO_COPY
---- dns cache hit
---- Connecting to x.com (10.0.0.1) port 21
copy: get hit eof
copy: waiting for put confirmation
FileCopy(0xbcd2c0) enters state CONFIRM_WAIT
GNUTLS: HSK[0xbfc2c0]: Keeping ciphersuite: DHE_RSA_AES_128_CBC_SHA1
GNUTLS: HSK[0xbfc2c0]: Keeping ciphersuite: DHE_RSA_CAMELLIA_128_CBC_SHA1
GNUTLS: HSK[0xbfc2c0]: Keeping ciphersuite: DHE_RSA_AES_256_CBC_SHA1
GNUTLS: HSK[0xbfc2c0]: 

Open in new window

0
bgp
on the topology above  I have R1 and R2 on AS12 and R3 on AS3

I am using Next-Hop-Self on R2 to tell R1 "in order to reach R3 come to me", but does not seem to work.

Here is the configuration  of BGP on each router.
R1#sh run | beg router bgp
router bgp 12
 no synchronization
 bgp log-neighbor-changes
 network 1.1.1.0 mask 255.255.255.0
 neighbor 192.168.12.2 remote-as 12

Open in new window


R2#sh run | beg router bgp
router bgp 12
 no synchronization
 bgp log-neighbor-changes
 neighbor 192.168.12.1 remote-as 12
 neighbor 192.168.12.1 next-hop-self
 neighbor 192.168.23.3 remote-as 3
 neighbor 192.168.23.3 next-hop-self

Open in new window


R3#sh run | beg router bgp
router bgp 3
 no synchronization
 bgp log-neighbor-changes
 network 3.3.3.0 mask 255.255.255.0
 neighbor 192.168.23.2 remote-as 12

Open in new window


I cannot ping from R1 to R3 and vice-versa

If I advertize networks 192.168.12.0 and 192.168.23.0 From R2 then I will be able to ping from R1 to R3 and back

Any idea ?

Thanks
0
bgpon the topology above I configured Route-Reflector on R5 to get full reachability.
My Confusion is I have seen some examples where they configure Next-hop-self.
for instance this :https://www.youtube.com/watch?v=QMkJfnMNZm8

Any BGP expert out there to clarify when Route-Reflector should be used and when Next-hop-self should be used ? If I had used Next-hop-self in my scenario, will that work fine just as Route-reflector did ?

Thank you

======


R2,R5,R3 are on the same AS  (AS2), they are IBGP Routers
 R1 is in AS1 and R4 in AS3



R1#sh run | beg router bgp
router bgp 1
 network 1.1.1.0 mask 255.255.255.0
 network 192.168.12.0
 neighbor 192.168.12.2 remote-as 2

R2#sh run | beg router bgp
router bgp 2
 network 2.2.2.0 mask 255.255.255.0
 network 192.168.12.0
 network 192.168.25.0
 neighbor 192.168.12.1 remote-as 1
 neighbor 192.168.25.5 remote-as 2

R3#sh run | beg router bgp
router bgp 2
 network 3.3.3.0 mask 255.255.255.0
 network 192.168.34.0
 network 192.168.35.0
 neighbor 192.168.34.4 remote-as 3
 neighbor 192.168.35.5 remote-as 2

R4#sh run | beg router bgp
router bgp 3
 network 4.4.4.0 mask 255.255.255.0
 network 192.168.34.0
 neighbor 192.168.34.3 remote-as 2

R5#sh run | beg router bgp
router bgp 2
 no synchronization
 bgp log-neighbor-changes
 network 5.5.5.0 mask 255.255.255.0
 network 192.168.25.0
 network 192.168.35.0
 neighbor 192.168.25.2 remote-as 2
 neighbor 192.168.25.2 …
0
bgp

I have the topology above.
I configured BGP on R1:AS1  ,R2: AS2  and R4:AS2 ,R5:AS3 , I have also configured OSPF on R2,R4,R3
BGP is not configured on R3, just OSPF

Now when I  try to ping R5 from R2 or the R1 from R4 I get the UUUUU

Below is the configuration of all 5 Routers

R1#sh run
Building configuration...

Current configuration : 1385 bytes
!
upgrade fpd auto
version 15.0
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R1
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
!
!
!
ip source-route
no ip icmp rate-limit unreachable
ip cef
!
!         
!
!
no ip domain lookup
no ipv6 cef
!
multilink bundle-name authenticated
!
!
!
!
!
!
!
!
!
redundancy
!
!
ip tcp synwait-time 5
! 
!
!
!         
!
!
!
!
interface Loopback0
 ip address 1.1.1.1 255.255.255.0
 !
!
interface FastEthernet0/0
 ip address 192.168.12.1 255.255.255.0
 duplex half
 !
!
interface Ethernet1/0
 no ip address
 shutdown
 duplex half
 !
!
interface Ethernet1/1
 no ip address
 shutdown
 duplex half
 !
!
interface Ethernet1/2
 no ip address
 shutdown
 duplex half
 !
!
interface Ethernet1/3
 no ip address
 shutdown
 duplex half
 !
!
!
router bgp 1
 no synchronization
 bgp log-neighbor-changes
 network 1.1.1.0 mask 255.255.255.0
 neighbor 192.168.12.2 remote-as 2
 no auto-summary
!
ip forward-protocol nd
no ip http server
no ip http secure-server
!
!
!
no cdp log mismatch duplex
!
!
!
!
!
!

Open in new window

0
bgpI have the topology shown  above.  R1 and R5 are running BGP, R2  and R4 are  running BGP and OSPF , R3 is running just OSPF

I would like to know if I need to run BGP on R3 in addition to OSPF, or just redistribute BGP into OSPF and OSPF into BGP on R2 and R4


Thank you
Screen-Shot-2017-07-27-at-2.33.23-PM.png
1
Moving data to the cloud? Find out if you’re ready
LVL 3
Moving data to the cloud? Find out if you’re ready

Before moving to the cloud, it is important to carefully define your db needs, plan for the migration & understand prod. environment. This wp explains how to define what you need from a cloud provider, plan for the migration & what putting a cloud solution into practice entails.

I have a verizon wireless net extender for signal increase. The extander needs port tcp 53 allowed for this to work. I have included the below packettrace and it looks like it's passing through just fine but... the extender does not work. If I bypass the ASA, it works even though I did not configure any NAT or permit ACL's. I was assuming that since the device start the communication, that I dont need it. I also included a link to verizon about what config I need on ASA. How can I make this work>?

https://www.verizonwireless.com/support/knowledge-base-25525/

FW/pri/act# packet-tracer input inside tcp 10.255.8.20 1234 69.78.34.151 53 detailed
Phase: 1
Type: ACCESS-LIST
Subtype:
Result: ALLOW
Config:
Implicit Rule
Additional Information:
 Forward Flow based lookup yields rule:
 in  id=0x2aaadaf78770, priority=1, domain=permit, deny=false
        hits=2410723433, user_data=0x0, cs_id=0x0, l3_type=0x8
        src mac=0000.0000.0000, mask=0000.0000.0000
        dst mac=0000.0000.0000, mask=0100.0000.0000
        input_ifc=inside, output_ifc=any

Phase: 2
Type: ROUTE-LOOKUP
Subtype: Resolve Egress Interface
Result: ALLOW
Config:
Additional Information:
found next-hop ******* using egress ifc  outside

Phase: 3
Type: ACCESS-LIST
Subtype: log
Result: ALLOW
Config:
access-group inside_in in interface inside
access-list inside_in extended permit ip any4 any4 log disable
Additional Information:
 Forward Flow based lookup yields rule:
 in  id=0x2aaad7b2c010, priority=13, 

Open in new window

0
I need to redistribute two (of about 10) static routes into BGP.  My memory  of route-map configurations are a little fuzzy.... does this look right?

ip route 1.1.1.1 255.255.255.255 2.2.2.2 tag 100
ip route 1.1.1.2 255.255.255.255. 2.2.2.2 tag 101

Route-map Static_Routes permit 10
 match tag 100 101

router bgp 00000
 redistribute static route-map Static_Routes
0
bgp
On the  screenshot above R1 is in AS1 and R2 in AS 2
I advertised Loopback networks from both Routers, but cannot see it in each other router BGP table

R1#sh run
Building configuration...

Current configuration : 1519 bytes
!
! Last configuration change at 19:08:12 UTC Tue Jul 25 2017
!
upgrade fpd auto
version 15.0
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R1
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
!
!
!
ip source-route
no ip icmp rate-limit unreachable
ip cef    
!
!
!
!
no ip domain lookup
no ipv6 cef
!
multilink bundle-name authenticated
!
!
!
!
!
!
!
!
!
redundancy
!
!
ip tcp synwait-time 5
! 
!         
!
!
!
!
!
!
interface Loopback0
 ip address 1.1.1.1 255.255.255.255
 !
!
interface FastEthernet0/0
 ip address 192.168.12.1 255.255.255.0
 duplex half
 !
!
interface Ethernet1/0
 no ip address
 shutdown
 duplex half
 !
!
interface Ethernet1/1
 no ip address
 shutdown
 duplex half
 !
!
interface Ethernet1/2
 no ip address
 shutdown
 duplex half
 !
!
interface Ethernet1/3
 no ip address
 shutdown
 duplex half
 !
!
!
router bgp 1
 no synchronization
 bgp log-neighbor-changes
 network 1.1.1.1 mask 255.255.255.255
 network 192.168.12.0
 neighbor 192.168.12.2 remote-as 2
 no auto-summary
!
ip forward-protocol nd
no ip http server
no ip http secure-server
!
!
ip route 2.2.2.2 255.255.255.255 192.168.12.2
!
no cdp log mismatch duplex
!
!
!
!
!
!

Open in new window

0
Hello

I dont understand why I would have this in my eigrp config. What is this filtering at this point? To me, this looks as not having any distribution list at all.

Router#
Router#sh run | sec eigr
router eigrp 2
 distribute-list prefix BLOCK-EIGRP-DEFAULT in
 network 10.0.0.0
 passive-interface default
 no passive-interface Tunnel0
 eigrp stub connected
Router#
Router#
Router#
Router#
Router#
Router#
Router#sh ip prefix-list BLOCK-EIGRP-DEFAULT
ip prefix-list BLOCK-EIGRP-DEFAULT: 2 entries
   seq 5 deny 0.0.0.0/0
   seq 10 permit 0.0.0.0/0 le 32
Router#

Open in new window

0
Hello Experts,
Please suggest how to configure Precision Time Protocol (PTP) client with Mellanox (driver: mlx4_en, version: 4.1-1.0.2 (27 Jun 2017), firmware-version: 2.40.7000) on Centos 6.8 64bit system.
0
Is there any cisco switch which can take the full internet BGP table?
0

Networking Protocols

11K

Solutions

16K

Contributors

Networking software modules are interfaced with a framework implemented on the machine's operating system that implements the networking functionality of the operating system. The best known frameworks are the TCP/IP model and the OSI model. Systems typically do not use a single protocol to handle a transmission. Instead they use a set of cooperating protocols, sometimes called a protocol family or protocol suite.[9] Some of the best known protocol suites include: IPX/SPX, X.25, AX.25, AppleTalk and TCP/IP. Other protocols indirectly related to networking include the hypertext transfer protocol (HTTP) and its related technologies, Dynamic Host Configuration Protocol (DHCP), Domain Name Server (DNS) and other Internet protocols.