Networking Protocols

12K

Solutions

16K

Contributors

Networking software modules are interfaced with a framework implemented on the machine's operating system that implements the networking functionality of the operating system. The best known frameworks are the TCP/IP model and the OSI model. Systems typically do not use a single protocol to handle a transmission. Instead they use a set of cooperating protocols, sometimes called a protocol family or protocol suite.[9] Some of the best known protocol suites include: IPX/SPX, X.25, AX.25, AppleTalk and TCP/IP. Other protocols indirectly related to networking include the hypertext transfer protocol (HTTP) and its related technologies, Dynamic Host Configuration Protocol (DHCP), Domain Name Server (DNS) and other Internet protocols.

Share tech news, updates, or what's on your mind.

Sign up to Post

I haven't dealt much with SBS Exchange / certificates.  

This network is getting this popup recently. Clicking on details, I see the certificate expired a couple weeks ago - I think that's when the users started getting the error message.

Realistically, what is the argument for paying the money to get a new certificate vs. removing the old one ( any tips on how to do that)?

This is a location that is not concerned about security - everyone in the office knows everyone else's passwords / they don't change their passwords, they are really frugal.  

How do I explain why they need / should spend the money for a new certificate (and who do you like getting them from?) or what's the downside of just removing the expired cert?
0
How can I find my ending IP address using my starting ip address? With a subnet mask of 255.255.255.0
0
VRRP to HSRP!?
We are moving from incumbent ISP who manage our WAN and firewalls.  The current config is the following:

HP L3 switch
vlan1 192.168.3.0/24
vlan20 192.168.100.0/24
vlan50 (no IP)

Firewall connected to vlan1 and vlan20
Router(s) running VRRP and connected to vlan50..

We now are changing the setup slightly for the new config.
Same principle but the firewall is in the cloud as an MPLS.

What/how best to deploy the routers in HSRP?

Thanks
0
Understanding Topology Change Notification on Switches

Reading this article:https://www.cisco.com/c/en/us/support/docs/lan-switching/spanning-tree-protocol/12013-17.html#anc12
If I am getting it right TCN can also be caused by the Hosts that are connected to Access Switches, the article states that this can be avoided by configuring Portfast on interfaces to which the Hosts are connected to .

As far as I know, not all environments configure Portfast on the Interfaces where Hosts connect to, at least the environment where I work. However there is no issue reported even if there was TCN .

Any Switch Expert to shade some lights on this topic.


Thank you
0
How does DHCP work with VoIP phones?  Do they phones need to get restarted every time the DHCP lease expires?  Or it works no different than a regular computer client?
For the first time phones need to be booted to obtain IP addresses.  Also when DHCP or DNS server changes.  What about a regular DHCP refresh at the end of the lease duration?
We use Polycom ip phones over poe.
Please advice.
0
trying to find out what is the best single authentication method is.

example:  having external users accessing Software As A Service (saas)
0
Are there any things to consider when adding another subnet to eBGP router?

Existing:
router bgp 43447
 bgp router-id 192.168.0.111
 address-family ipv4 unicast
  bgp attribute-download
network 16.17.236.0/22

Proposed:
config t
router bgp 43447
network 17.18.236.0/22
exit
wri mem

Do I need to notify the ISP? Any other gotchas? This site has had the one /22 for ages and
want to add this new network as unobtrusively as possible. Any tips appreciated!
0
I've changed the configuration of FTP on my Synology NAS from unencrypted to encrypted.
When I now attempt to connect using Filezilla the directory listing never appears:
Status:	Connecting to XXX.XXX.XXX.XXX:21...
Status:	Connection established, waiting for welcome message...
Status:	Initializing TLS...
Status:	Verifying certificate...
Status:	TLS connection established.
Status:	Logged in
Status:	Retrieving directory listing of "/My_Remote_Directory"...
Command:	CWD /My_Remote_Directory
Response:	250 CWD command successful.
Command:	TYPE I
Response:	200 Type set to I.
Command:	PASV
Response:	227 Entering Passive Mode (XXX,XXX,XXX,XXX,XXX,242)
Command:	MLSD
Error:	Connection timed out after 20 seconds of inactivity
Error:	Failed to retrieve directory listing

Open in new window

I've set Filezilla to use Passive transfer mode

My NAS settings are NAS Settings
0
I am trying to determine if a policy based routing rule is being hit.

ip access-list send-to-pbr
  10 remark Send traffic for PBR logic
  20 permit ip address group voodoo1 any
  30 permit ip address group voodoo2 any

route-map internet-pbr deny 10
  match ip address bypass-pbr
route-map internet-pbr permit 20
  match ip address send-to-pbr
set ip next-hop 172.16.1.1

Should show access-list send-to-pbr display hits occasioned by the pbr?
Should I be able to see this with show route-map internet-pbr?

I tried the latter and get an error message about stats not being enabled.
sho route-map internet-pbr pbr-statistics
% PBR statistics is not enabled for given route-map
0
I am trying to understand what the best practice is to set the metric when redistributed BGP to EIGRP. In my case, at my main location, I have it set as the code below. I know that EIGRP only uses k1 and k2 in its calculation. I did not configure this so I am not sure what k1 is 44.2 Mbps when my MPLS circuit is 300Mbps. It looks like my delay is not the default as well.

...
router eigrp 10
 network 10.0.0.0
 redistribute bgp 65001 metric 44200 2000 255 1 1500
...

Open in new window

0
How can I change the next hop in a RIP update.
0
I am familiar with making DHCP reservations in Windows Server But am now doing in SonicWALL TZ 215 I can see how this is done, But have some questions when doing this in the ARP section:

What does it mean to Publish Entry?

I assume that I want to bind the MAC address or why would I be setting this up in  the first place?

What is meant by Update IP address dynamically?

In the big picture the user will use PPTP from the Windows server to VPN in.  They have a business app that is Unix based and requires the client system to maintain the same IP address (reservation or static).  So, I need the client to obtain that same IP whether they are in the office or out on the road.

Thank you.
0
We currently have a Sonicwall NSA 2600.  We also have a Small Business Server 2011 running Exchange 2010.  The Sonicwall has NAT and firewall configured to pass the mail to the server.  That is working fine.

I have activated a 30 day trial of Sonicwall's Anti-Spam Service.  During the initial configuration I received the following pop up error: "Mail Server Auto-Detect Failed.  The system detects there are one or more NAT and/or Rule policies that use a service group of a service port range that includes SMTP and non-SMTPservice ports.  The system could not enable the Anti-Spam service using the current configuration.

The user guide for enabling Anti-Spam lists a step where you identify the mail server.  I am assuming I need to delete the current NAT and Firewall rules forwarding mail to the server and let the Anti-Spam setup configure them again.  Am I correct?

Any help is appreciated.
0
Router A and B are eBGP peers. Router A and C are OSPF neighbors and A learns its default route 0.0.0.0
from router C via OSPF. I want to advertise 0.0.0.0 from router A to router B via eBGP. What needs to be
added to allow that to happen?

Router A
  router bgp 7777
     network 10.0.0.0/8
     network 192.168.0.0/16

  router ospf 1

Router B
  router bgp 1088
    network 10.127.0.0/16

Router C
   router ospf 1
   
    ip route 0.0.0.0/0 10.7.7.1
0
Does Cisco CUBE pair need to have IP Addresses in 2 different subnets from MPLS CE Routers? We have a pair of CEs connecting to the Cisco CUBE for the voice. Please clarify.

Thanks;
0
Hi Experts,
Our office moved to a new location and suddenly one of my pc's does not want to connect to SQL.
When I try to reconfigure the same DSN, I get the attached error.
Mysteriously, this is only happening to one pc.
Also I'm able to browse the server from that pc thru win explorer.
Any Idea?
FYI- I'm using SQL server login to connect.
Untitled.png
0
qConfiguring 802.1 Tunneling Q-in-Q

I have the topology above. I  configured  Q-in-Q, however I cannot ping from R1 to R2 as it is supposed to.

R1#sh run  
Building configuration...

Current configuration : 1756 bytes
!
! Last configuration change at 15:08:00 CET Mon Mar 12 2018
!
version 15.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R1
!
boot-start-marker
boot-end-marker
!
aqm-register-fnf
!
!
no aaa new-model
clock timezone CET 1 0
mmi polling-interval 60
no mmi auto-configure
no mmi pvc
mmi snmp-timeout 180
!         
!
!
!
!
!


!
!
!
!
ip cef
no ipv6 cef
!
multilink bundle-name authenticated
!
!
!
!
!
!
!
!         
!
redundancy
!
!
! 
!
!
!
!
!
!
!
!
!
!
!
!
interface Ethernet0/0
 no ip address
!
interface Ethernet0/0.12
 encapsulation dot1Q 12
 ip address 192.168.12.1 255.255.255.0
!
interface Ethernet0/1
 no ip address
 shutdown
!
interface Ethernet0/2
 no ip address
 shutdown
!
interface Ethernet0/3
 no ip address
 shutdown
!
interface Ethernet1/0
 no ip address
 shutdown
!
interface Ethernet1/1
 no ip address
 shutdown
!
interface Ethernet1/2
 no ip address
 shutdown
!
interface Ethernet1/3
 no ip address
 shutdown
!
interface Serial2/0
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial2/1
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial2/2
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial2/3
 no ip 

Open in new window

0
I am not an expert in Cisco. I am just configuring VLAN in my network.
I have create 2 more VLANs other than native VLAN. VLAN 9 with IP 192.168.9.1, VLAN 10 with IP 192.168.10.1 and VLAN1(default) with 192.168.0.254.
Now VLAN9 can reach  VLAN10 and  VLAN10 can reach VLAN9. But VLAN9 and 10 cannot reach VLAN1 IPS. Now I would like to have communication between all these VLANs.
I would like to route all traffics to Fortinet firewall except internal IP traffic. Attached configuration.
Is there anyone who can guide me how to have inter VLAN communication as per best practice?
GTSwitch.txt
0
I am not an expert in Cisco. I am just configuring VLAN in my network.
I have create 2 more VLANs other than native VLAN. VLAN 9 with IP 192.168.9.1 and VLAN 10 with IP 192.168.10.1
now VLAN9 can reach  VLAN10 but VLAN10 cannot reach VLAN9. Is there anyone who can guide me how to have inter VLAN communication as per best practice? Attached configuration. Once I am done I need to configure traffic to firewall for internet access.
GTSwitch.txt
0
SNMP writable communities  shows up on my vulnerability scan.

I  am being told to disable it

How will disabling it affect printing
When is it needed?
Does it matter if the printer has a hard drive?
0
Hi,

I'm trying to add an Aruba POE Switch to a network which includes an Extreme 8810 Black Diamond switch chassis.

Can anyone assist please
0
I'm setting up an LACP trunk between 2 Procurve switches

How many links shall I provide? Is 4 better than two? Do I need 2 trunks on can all 4 links go into 1 LACP trunk?
0
Looking for a cost effective appliance based VPN solutions (Preferably clientless), for small business.
Thoughts/ideas/recommendations?

We have a number of small clients that we have been using the Netgear fVS-336s with a lot of success but they are no longer supporting it.
Some users remain on as much as 8-10 hours per day.

Thanks!
0
We’re using a SonicWall TZ-215 firewall.  Our LAN X0 port is setup as 192.168.0.1—254, with 192.168.0.2 setup as the gateway, 255.255.255.0 as the subnet.  

We’re getting VoIP phones, and the vendor is setting them up with static addresses between 192.168.1.100—200, subnet 255.255.255.0.  How do I configure the SonicWall to get the phones to access the 192.168.0.2 gateway?  (X3—X6 interfaces are unused on the SonicWall, if needed for the solution)
0
d
Failover to a different path


in the topology above, I would like R1 to always use the Path to R2. The only time it should use the path to R3 is when the link between R1 and R2 is down.
I am configuring OSP between all Routers, I also want to use BFD (Bidirectional Forwarding Detection), so that the link failure will be detected faster than OSPF , and once detected the path will switch automatically to R3.

I believe that there is HSRP ,VRRP,GLBP and other protocols that can do that. I just wonder if it can be done without those protocols. Unless if I am confused, probably BFD is used by the protocols I have previously indicated  (HSRP ,VRRP,GLBP )


Thank you
0

Networking Protocols

12K

Solutions

16K

Contributors

Networking software modules are interfaced with a framework implemented on the machine's operating system that implements the networking functionality of the operating system. The best known frameworks are the TCP/IP model and the OSI model. Systems typically do not use a single protocol to handle a transmission. Instead they use a set of cooperating protocols, sometimes called a protocol family or protocol suite.[9] Some of the best known protocol suites include: IPX/SPX, X.25, AX.25, AppleTalk and TCP/IP. Other protocols indirectly related to networking include the hypertext transfer protocol (HTTP) and its related technologies, Dynamic Host Configuration Protocol (DHCP), Domain Name Server (DNS) and other Internet protocols.