Networking Protocols

12K

Solutions

16K

Contributors

Networking software modules are interfaced with a framework implemented on the machine's operating system that implements the networking functionality of the operating system. The best known frameworks are the TCP/IP model and the OSI model. Systems typically do not use a single protocol to handle a transmission. Instead they use a set of cooperating protocols, sometimes called a protocol family or protocol suite.[9] Some of the best known protocol suites include: IPX/SPX, X.25, AX.25, AppleTalk and TCP/IP. Other protocols indirectly related to networking include the hypertext transfer protocol (HTTP) and its related technologies, Dynamic Host Configuration Protocol (DHCP), Domain Name Server (DNS) and other Internet protocols.

Share tech news, updates, or what's on your mind.

Sign up to Post

ARP vs Proxy ARP

Is ARP used when Host1  is trying to reach Host2 in the same subnet  and Proxy ARP used when Host1 and Host2 are separated by a router (Default Gateway) ? in other words, the Default gateway sends ARP request to Host2 and fetch that Host IP address to Host1 but with the MAC address of the Default Gateway.

Thank you
0
Increase/Decrease MTU

I would like to know when should we  manually increase or decrease MTU.
I  have seen some examples when there is an extra header for instance when using PPoE , they decrease the MTU.

Any clarification will be very much appreciated

Thank you
0
OSPF Path selection:  We all know the basic principles of OSPF path selection. It chooses an Intra area over an inter area and so forth. Ive been asked this question by a colleague, when will OSPF ignore this rule and choose an Interarea over an Intra area.

kind regards
0
GRE Tunnel Recursive Routing error

GRE

in the topology above I have created GRE Tunnel between HQ and Branch.
 For now it works fine, because the tunnel destination is not the IP address of the tunnel interface on the other end (the tunnel destination is the physical interface on the other end) .However if I  Traceroute from HQ to Branch or the other way around, then the traffic will go through ISP.


If ,for instance, on HQ I use Tunnel destination 192.168.13.3 (which is the  Branch Tunnel interface IP address), then the tunnel will collapse.

So, I do not know what would be the purpose of the GRE tunnel if traffic does not go through the Tunnel
 



ISP#sh run 
Building configuration...

Current configuration : 1790 bytes
!
! Last configuration change at 22:26:13 CET Sun Feb 25 2018
!
version 15.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname ISP
!
boot-start-marker
boot-end-marker
!
aqm-register-fnf
!
!
no aaa new-model
clock timezone CET 1 0
mmi polling-interval 60
no mmi auto-configure
no mmi pvc
mmi snmp-timeout 180
!
!
!
!
!
!


!
!
!
!
ip cef
no ipv6 cef
!
multilink bundle-name authenticated
!
!
!
!
!
!
!         
!
!
redundancy
!
!
! 
!
!
!
!
!
!
!
!
!
!
!
!
interface Ethernet0/0
 ip address 192.168.12.1 255.255.255.0
!
interface Ethernet0/1
 ip address 192.168.23.1 255.255.255.0
!
interface Ethernet0/2
 no ip address
 shutdown
!
interface Ethernet0/3
 

Open in new window

0
Redistributing RIP /OSPF / EIGRP

red
in the displayed topolgy

R1 has loopback 0 with ip 1.1.1.1/24

RIP is configured on R1 and R2
OSPF is configured on R2 and R3
EIGRP is configured between R2 and R4 and between R4 and R3


in the configuration below the redistribution is just on R2, however I can reach end to end in optimal way.  Probably it could have been a problem if OSPF or EIGRP is only between R3 and R4 . I mean if I had between R2 and R3 and between R2 and R4 the same IP routing protocol and between R3 and R4 a different IP routing protocol, I might run into Sub-optimal routing issue.




R1#sh run 
!
hostname R1

interface Loopback0
 ip address 1.1.1.1 255.255.255.0
interface Ethernet0/0
 ip address 192.168.12.1 255.255.255.0
router rip
 version 2
 network 1.0.0.0
 network 192.168.12.0
 no auto-summary
R1#

Open in new window


R2#sh run 
hostname R2
interface Ethernet0/0
 ip address 192.168.12.2 255.255.255.0
!
interface Ethernet0/1
 ip address 192.168.23.2 255.255.255.0
!
interface Ethernet0/2
 ip address 192.168.24.2 255.255.255.0
router eigrp 1
 network 192.168.24.0
 redistribute rip metric 5 1000 255 255 1500
!         
router ospf 1
 redistribute rip subnets
 network 192.168.23.0 0.0.0.255 area 0
!
router rip
 version 2
 redistribute eigrp 1 metric 5
 redistribute ospf 1 metric 5
 network 192.168.12.0
 no auto-summary

R2#

Open in new window



R3#sh run 
hostname R3
interface Ethernet0/0
 ip address 192.168.23.3 255.255.255.0
!
interface Ethernet0/1
 ip address 192.168.34.3 255.255.255.0
router eigrp 1
 network 192.168.34.0
!         
router ospf 1
 network 192.168.23.0 0.0.0.255 area 0

R3#

Open in new window



R4#sh run 
hostname R4
interface Ethernet0/0
 ip address 192.168.24.4 255.255.255.0
!
interface Ethernet0/1
 ip address 192.168.34.4 255.255.255.0

router eigrp 1
 network 192.168.24.0
 network 192.168.34.0
R4#

Open in new window


The redistribution is configured just on R2


R4#sh ip route | exclude L|C
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area 
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       a - application route
       + - replicated route, % - next hop override

Gateway of last resort is not set

      1.0.0.0/24 is subnetted, 1 subnets
D EX     1.1.1.0 [170/512281600] via 192.168.24.2, 02:13:30, Ethernet0/0
D EX  192.168.12.0/24 [170/512281600] via 192.168.24.2, 02:13:30, Ethernet0/0
      192.168.24.0/24 is variably subnetted, 2 subnets, 2 masks
      192.168.34.0/24 is variably subnetted, 2 subnets, 2 masks

R4#

Open in new window



Open in new window

0
R1#sh run     
Building configuration...

Current configuration : 1847 bytes
!
! Last configuration change at 03:00:50 CET Thu Feb 22 2018
!
version 15.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R1
!
boot-start-marker
boot-end-marker
!
aqm-register-fnf
!
!
no aaa new-model
clock timezone CET 1 0
mmi polling-interval 60
no mmi auto-configure
no mmi pvc
mmi snmp-timeout 180
!
!
!
!
!
!


!
!
!
!
ip cef
no ipv6 cef
!
multilink bundle-name authenticated
!
!
!
!
!
!
!         
!
!
redundancy
!
!
! 
!
!
!
!
!
!
!
!
!
!
!
!
interface Loopback0
 ip address 1.1.1.1 255.255.255.0
!
interface Ethernet0/0
 ip address 192.168.12.1 255.255.255.0
!
interface Ethernet0/1
 no ip address
 shutdown
!
interface Ethernet0/2
 no ip address
 shutdown
!
interface Ethernet0/3
 no ip address
 shutdown
!
interface Ethernet1/0
 no ip address
 shutdown
!
interface Ethernet1/1
 no ip address
 shutdown
!
interface Ethernet1/2
 no ip address
 shutdown
!
interface Ethernet1/3
 no ip address
 shutdown
!
interface Serial2/0
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial2/1
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial2/2
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial2/3
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial3/0
 no ip address
 shutdown
 serial restart-delay 0
!
interface Serial3/1
 no ip address
 shutdown
 serial restart-delay 0
!

Open in new window

0
Hello Everyone,

I have a SoniWALL NSA 3500 that I am trying to configure to open port 8000 for a Network Video Recorder (Hikvision). I want to port forward.  I created an object for port 8000 and then for the internal IP address that the recorder is going to use. I then went through the Public Server Wizard and and entered the internal IP and then the wizard went ahead and added our WAN address and then created the inside, outside and loopback parameters.  For all intents and purposes this should have opened port 8000 once I went through the wizard.  

Issue is when I try accessing from outside (or even inside my LAN network) using our WAN IP and then adding the 8000 suffix (x.x.x.x:8000) it's not reachable.  I believe I should receive at least a SonicWALL test page, correct?  Even if the device is not plugged into the switch yet I should still get something from the SonicWALL I believe.

Can anyone tell me if there is anything else I can do to make sure that port is open?  Web tests still say the port is closed.

Any help would be most appreciated!

Thanks!
0
OSPF/RIP Redistribution

I have this topology :
I have advertised networks 1.1.1.1/24 and 192.168.12.0/24 into OSPF
 then Redistributed   OSPF to RIP with metric 10. Now : 1.1.1.1/24  shows with metric of 10 in R3 RIP Routing table, but 192.168.12.0/24  still shows with metric of 1.





ospf
R1(config-router)#do sh run 
Building configuration...

Current configuration : 1412 bytes
!
upgrade fpd auto
version 15.0
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R1
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
!
!
!
ip source-route
no ip icmp rate-limit unreachable
ip cef
!
!         
!
!
no ip domain lookup
no ipv6 cef
!
multilink bundle-name authenticated
!
!
!
!
!
!
!
!
!
redundancy
!
!
ip tcp synwait-time 5
! 
!
!
!         
!
!
!
!
interface Loopback0
 ip address 1.1.1.1 255.255.255.0
 !
!
interface FastEthernet0/0
 ip address 192.168.12.1 255.255.255.0
 duplex half
 !
!
interface FastEthernet1/0
 no ip address
 shutdown
 duplex auto
 speed auto
 !
!
interface FastEthernet1/1
 no ip address
 shutdown 
 duplex auto
 speed auto
 !
!
interface FastEthernet2/0
 no ip address
 shutdown
 duplex auto
 speed auto
 !
!
interface FastEthernet2/1
 no ip address
 shutdown
 duplex auto
 speed auto
 !
!
!
router ospf 1
 log-adjacency-changes
 network 1.1.1.0 0.0.0.255 area 0
 network 192.168.12.0 0.0.0.255 area 0
!
ip forward-protocol nd
no ip http server
no ip http 

Open in new window

0
EIGRP/RIP Metric in the redistribution

I have the topology below.
I do not understand after I redistributed EIGRP into RIP, one route shows with the metric of 2 as we specified it in redistribution command, but the other route shows with metric of 1.

R2(config-router)#redistribute eigrp 12 metric 2

R3(config-router)#do sh ip route rip
1.0.0.0/24 is subnetted, 1 subnets
R        1.1.1.0 [120/2] via 192.168.23.2, 00:00:10, FastEthernet0/0
R     192.168.12.0/24 [120/1] via 192.168.23.2, 00:00:10, FastEthernet0/0
R3(config-router)#

Thank you

rout
0
Hello,

I am looking into a solution for load balancing to 2 physical servers that sit on a cisco nexus switches, 5ks. Is this doable? if so, how? Also, if not an option on a nexus, I can move it to an IOS switch 6800.

2018-02-15-09_41_44-Book1---Excel.png
Thank you
0
Does any one know why might be causing a a lot of TCP DUP ACK and TCP Retransmission for a FTP transfer?  We also get a "426 File transfer failed" error in the packet capture.
0
The problem described below has been resolved.  What I am looking for is understanding as to why it happened, what was affected, and how might I safeguard against the problem happening again.

From one day to the next, my ipconfig went from this:
Wireless LAN adapter Wi-Fi:

   Connection-specific DNS Suffix  . : hsd1.ut.comcast.net
   IPv6 Address. . . . . . . . . . . : 2601:681:77f:c059:a1bf:653d:6494:f619
   Temporary IPv6 Address. . . . . . : 2601:681:77f:c059:5c7c:a1a4:1235:a8f0
   Link-local IPv6 Address . . . . . : fe80::a1bf:653d:6494:f619%5
   IPv4 Address. . . . . . . . . . . : 192.168.1.116
   Subnet Mask . . . . . . . . . . . : 255.255.255.0
   Default Gateway . . . . . . . . . : fe80::b675:eff:fe63:f4a4%5
                                       192.168.1.1

Open in new window


to this:
Wireless LAN adapter Wi-Fi:

   Connection-specific DNS Suffix  . :
   Link-local IPv6 Address . . . . . : fe80::89f9:299b:1f80:bb7b%9
   Autoconfiguration IPv4 Address. . : 169.254.187.123
   Subnet Mask . . . . . . . . . . . : 255.255.0.0
   Default Gateway . . . . . . . . . :

Open in new window


Notice a few things that are different:
-Connection-specific DNS suffix was wiped-out
-IPv4 address was assigned 169.254.x.x (which I laterlearned was a symptom of the DHCP server assigning a default IP????)
-Subnet mask changed from 255.255.255.0 to 255.255.0.0
Default Gateway was wiped-out / unassigned.  Which meant, of course, that I could not see or get to my router.

I tried …
0
Dear Team,

I want to block UDP port 123 for time sync between my Domain controller and external time server time.windows.com

Also i want the internal time sync of member with domain controller on tcp port rather than UDP. Is it possible. Can you please help.

Regards,
0
Hi
I have a mac and android mobile phone both connectes to same wifi.
how can i use my android to control mac.
few things that i want to do is.
play youtube video from mobile to laptop.
or browse o. chrome.

Thanks
0
Hello,

I have a customer who will not use Office 365 and has an Exchange 2016 server on a shoestring budget, they will not go for an Exchange Edge Server or WAP though I did get them to buy a firewall (Sonicwall)

I want to implement HTTP redirect for the OWA service and would like to know if opening port 80 on the Exchange server makes it significantly more vulnerable or is it a definite NO-NO.

I know there is a scale of security and normally I wouldn't do this but the client wants people to access webmail through webmail.company.com for ease.

One option I thought if it's possible it to spin up a basic VM in Azure to act as a redirect. Would that be better?

Cheers, as always I welcome input.

Dave
0
Is it possible to setup and establish VPN connections to a SonicWALL TZ600 router without having to purchase special licenses or subscriptions?

I have a client who has a SonicWALL TZ600 router that currently doesn't have any licenses or subscriptions purchased and we are wondering if we can setup and establish any VPN connections to this router.
0
Hello.
I am looking for anybody who would assist me to set up my Zabbix server. It's already installed but I need a complete guide how to set up Items, Triggers and so on... we use SNMP. I also need some recommendations which items and triggers use while monitoring switches, APs, servers, disk arrays, virtual machines and domain computers.

I appreciate any help. Thank you.
0
I have a client with a Sonicwall TZ 215  (SonicROM 5.0.5.6 ) that is using a SonicPointN for wireless access. The SonicPoint is setup on Physical interface X2 with a 192.168.17.0 network and the X2 interface also has two VLAN Sub-Interfaces on it, X2:V18( 192.168.18.0) and X2:V19 (192.168.18.0). These VLAN’s are used to create the two wireless zones, one for Guest and one for employee’s. The customer now wants to add a remote lighting “Hub” that is manipulated via an Android or iPhone apps. Even though the “Hub” is accessed via the internet the initial setup has to be done with the phone app being able to see the unit on the same local network segment. Since the hub only has a Ethernet jack and the phone only has wireless, the phone and the hub need to be on the same wireless network. So I what I am trying to accomplish and can’t seem to get working it make the X3 interface on the Sonicwall be on the same VLAN Sub-Interface as the wireless access point. In this case that would be X2:V18. So to sum the whole deal up.  I need to get X3 interface assigned to the same network (192.168.18.0) and the VLAN-Sub-Interface as X2:V18. I can’t seem to get it the way I need, no problem getting the X3 on the X2 network (192.168.17.0) but not on the X2:V18. Any help would be appreciated. Thanks

Glenn Thibeault
Onsite Information Technologies
0
I was reading as below

TCP - is a transport layer protocol. It works over an IP network
HTTP - is an application protocol. It works using TCP on an IP network

i was not clear. Does HTTP also uses HTTP
what other protocols there in networking.

nay good link, resources or free video tutorial to understand clearly these things?
please advise
0
I am trying to figure out why R2 does not see S2 as its eigrp nei (see diagram). R1 can see S1 and R2. The only difference is a L2 switch between R2 and S2.

diagram
R2#sh ip eigrp nei

IP-EIGRP neighbors for process 100

H   Address         Interface      Hold Uptime    SRTT   RTO   Q   Seq

                                   (sec)          (ms)        Cnt  Num

0   10.10.200.2     Gig0/0         12   01:02:56  40     1000  0   11

Open in new window


R1#sh ip eigrp nei

IP-EIGRP neighbors for process 100

H   Address         Interface      Hold Uptime    SRTT   RTO   Q   Seq

                                   (sec)          (ms)        Cnt  Num

0   10.10.200.1     Gig0/0         12   01:03:19  40     1000  0   9

1   10.10.20.254                   13   00:41:23  40     1000  0   10

Open in new window


S1#sh ip eigrp nei

IP-EIGRP neighbors for process 100

H   Address         Interface      Hold Uptime    SRTT   RTO   Q   Seq

                                   (sec)          (ms)        Cnt  Num

0   10.10.101.2     Gig0/2         13   00:43:10  40     1000  0   7

1   10.10.20.250    Vlan           11   00:42:57  40     1000  0   12

Open in new window



S2#sh ip eigrp nei

IP-EIGRP neighbors for process 100

H   Address         Interface      Hold Uptime    SRTT   RTO   Q   Seq

                                   (sec)          (ms)        Cnt  Num

0   10.10.101.1     Vlan           12   00:43:56  40     1000  0   9

Open in new window

0
I would like to have an Expert explain line by line (in plain English) the configuration below.

Thank you in advance.

Hub(config)#ip route 0.0.0.0 0.0.0.0 null 0
Hub(config)#ip prefix-list DEFAULT_ROUTE permit 0.0.0.0/0
Hub(config)#route-map SPOKE_ROUTERS permit 10
Hub(config-route-map)#match ip address prefix-list DEFAULT_ROUTE

Hub(config)#router bgp 65001
Hub(config-router)#bgp listen range 172.16.123.0/24 peer-group DMVPN_SPOKES
Hub(config-router)#neighbor DMVPN_SPOKES peer-group 
Hub(config-router)#neighbor DMVPN_SPOKES remote-as 65023
Hub(config-router)#neighbor DMVPN_SPOKES route-map SPOKE_ROUTERS out
Hub(config-router)#network 0.0.0.0 mask 0.0.0.0

Open in new window

0
Hello EE, We have Honeywell handhelds and we've set them down in the warehouse and lost them.
I'm looking at the following: https://www.thetileapp.com/store/tiles/mate?defaultproduct=mate-1-pack&utm_campaign=702894687&utm_source=google&utm_medium=cpc&utm_content=213401926926&utm_term=-&adgroup=47867352387&gclid=EAIaIQobChMI_JjI3JLs2AIVkhuBCh3SqgB7EAYYASABEgLEnvD_BwE

but concerned if the Bluetooth will interfere with the handhelds ability to connect to WIFI if they are fixed to the handheld.
Anyone use these and can speak to it?
0
We have a Window 10 that has smb protocol negotiation problem. We find that it can establish a smb connection with a multi-function printer for file scanning.

The printer has initial a SMB session with Window 10 and Window 10 firewall has logged the request. However, it never response and no packet is dropped on Window firewall log.

Any idea ?

Thx
smb.png
0
when running the command : show ip ospf neighbors, I can see in some configurations
Full/Drother
and in other configurations
Full/-

I would like to know the difference between  OSPF  Full/Drother and  Full / -

Thank you
0
Dear all,

I am an IT support for a small company consist of 5 users. I assigned a static IP address on each computer.
Around 3 weeks one of my colleague was not able to browse the connection or see the shared folder on the server until I changed his PC's IP address. This issue reoccurred again today on his PC and on another PC.
I have done a lot of troubleshooting and the last step was changing the IP address. After changing the IP address on two PCs they were able to browse the internet connection and see the shared drives.

I am wondering what is the magician with changing the IP address. Please assist me because I am looking for a solution to avoid keep changing the IP addresses form time to time.
0

Networking Protocols

12K

Solutions

16K

Contributors

Networking software modules are interfaced with a framework implemented on the machine's operating system that implements the networking functionality of the operating system. The best known frameworks are the TCP/IP model and the OSI model. Systems typically do not use a single protocol to handle a transmission. Instead they use a set of cooperating protocols, sometimes called a protocol family or protocol suite.[9] Some of the best known protocol suites include: IPX/SPX, X.25, AX.25, AppleTalk and TCP/IP. Other protocols indirectly related to networking include the hypertext transfer protocol (HTTP) and its related technologies, Dynamic Host Configuration Protocol (DHCP), Domain Name Server (DNS) and other Internet protocols.