Networking Protocols

12K

Solutions

16K

Contributors

Networking software modules are interfaced with a framework implemented on the machine's operating system that implements the networking functionality of the operating system. The best known frameworks are the TCP/IP model and the OSI model. Systems typically do not use a single protocol to handle a transmission. Instead they use a set of cooperating protocols, sometimes called a protocol family or protocol suite.[9] Some of the best known protocol suites include: IPX/SPX, X.25, AX.25, AppleTalk and TCP/IP. Other protocols indirectly related to networking include the hypertext transfer protocol (HTTP) and its related technologies, Dynamic Host Configuration Protocol (DHCP), Domain Name Server (DNS) and other Internet protocols.

Share tech news, updates, or what's on your mind.

Sign up to Post

We were having a bad quality audio during a large conf. call (around 45 attendees) on Lync and customer thinks it is coming from lack of CoS configuration on LAN devices. Do switches (L2) also need to have a CoS Configuration? Is there an approved std. template for Lync Voice/Video ports etc. ?

Thanks;
1
I have  router R1 connected to router R2.
R1 has some loopbacks and the networks that the loopbacks are on, are advertised to EIGRP

R1 has some Networks(172.16.0.0 0.0.255.255) that I need to filter out, so that they do not end up in R2 routing table:
on R1 , I have created Route Map , but before even I specify anything in Access-List and make route map match the Access-list . I have found that the Network 172.16.0.0 has already  been filtered out from R2 routing table... I wonder what has filtered it out .



R2(config)#do sh ip route | inc 172.16
R2(config)#

you see there is nothing about 172.16.0.0  in R2
Thanks



R1(config-route-map)#    do sh ip interface br
Interface                  IP-Address      OK? Method Status                Protocol
FastEthernet0/0            192.168.12.1    YES NVRAM  up                    up      
FastEthernet0/1            unassigned      YES NVRAM  administratively down down    
FastEthernet1/0            unassigned      YES NVRAM  administratively down down    
FastEthernet1/1            unassigned      YES NVRAM  administratively down down    
Loopback0                  172.16.0.1      YES manual up                    up      
Loopback1                  172.16.2.1      YES manual up                    up      
Loopback2                  172.16.3.1      YES manual up                    up      
R1(config-route-map)#

Open in new window






 
R1(config-route-map)#do sh run
Building configuration...

Current 

Open in new window

0
We have ten gigabit interfaces. How much tunneled traffic would the device be able to push?
0
I have 2 routers  R1 directly connected to R2. R1 has a loopback interface with ip address 1.1.1.1/32
However in EIGRP when I advertised the loopback network  I used:
router eigrp 1
 network 1.1.1.0 0.0.0.255

Now if I go to R2 routing table I see that route showing as:
R2#sh ip route eigrp
Gateway of last resort is not set

      1.0.0.0/32 is subnetted, 1 subnets
D        1.1.1.1 [90/156160] via 192.168.12.1, 00:06:20, FastEthernet0/0

***I thought it would show as /24 instead 32

Any idea ?

Thank you
0
Any Experts to explain the meaning of Default Networks in the routing tables below:

I see "*"  next to C* and D*
what does that mean ?

Thank you

R2#sh ip route connected 
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area 
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route, + - replicated route

Gateway of last resort is not set

      192.168.12.0/24 is variably subnetted, 2 subnets, 2 masks
C        192.168.12.0/24 is directly connected, FastEthernet1/0
L        192.168.12.2/32 is directly connected, FastEthernet1/0
 *    192.168.23.0/24 is variably subnetted, 2 subnets, 2 masks
C*       192.168.23.0/24 is directly connected, FastEthernet0/0
L        192.168.23.2/32 is directly connected, FastEthernet0/0
R2#

Open in new window


R1#sh ip route eigrp
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area 
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route, + - replicated route

Gateway of last resort is not set

D*    192.168.23.0/24 [90/30720] via 192.168.12.2, 00:01:47, FastEthernet0/0
R1#

Open in new window

0
Hi, I have a weblogic server running with different port numbers for HTTP and HTTPS. In our workstation we setup HTTP pointing to same port in the ISSPROXY.INI file. We could access from the local IIS URL to connect to the weblogic server; but when try to connect to secured server from IIS gets 2 different errors in the event viewer Event ID 1000 and Event ID 1001. below are the errors captured

EVENT ID 1000:

Faulting application name: w3wp.exe, version: 8.5.9600.16384, time stamp: 0x5215df96
Faulting module name: iisproxy.dll, version: 0.0.0.0, time stamp: 0x59966438
Exception code: 0xc0000005
Fault offset: 0x0000000000030410
Faulting process id: 0x2514
Faulting application start time: 0x01d35a3fff6328df
Faulting application path: c:\windows\system32\inetsrv\w3wp.exe
Faulting module path: \\?\C:\xxxxxx\XXXXXXXXX\lib\iisproxy.dll
Report Id: 3dddc54c-c633-11e7-812e-005056886b10
Faulting package full name:
Faulting package-relative application ID:


EVENT ID: 1001
----------------------

Fault bucket , type 0
Event Name: APPCRASH
Response: Not available
Cab Id: 0

Problem signature:
P1: w3wp.exe
P2: 8.5.9600.16384
P3: 5215df96
P4: iisproxy.dll
P5: 0.0.0.0
P6: 59966438
P7: c0000005
P8: 0000000000030410
P9:
P10:

Attached files:

These files may be available here:



Our iisproxy.ini has the below information:
--------------------------------------------------------------

ISSPROXY.INI

WebLogicHost=ssl-server-name
0
eiI configured EIGRP in R1 and R2 , but for some reason I cannot ping from R1 to 192.168.23.3, even though there is an EIGRP route in R1 for 192.168.23.0

1#sh run | sec eigrp
router eigrp 1
 network 192.168.12.0
R1#

Open in new window


router eigrp 1
 network 0.0.0.0
ip route 0.0.0.0 0.0.0.0 FastEthernet0/0

Open in new window



R1#sh ip route eigrp

D*    0.0.0.0/0 [90/30720] via 192.168.12.2, 00:06:03, FastEthernet0/0
D     192.168.23.0/24 [90/30720] via 192.168.12.2, 00:06:03, FastEthernet0/0
R1#

Open in new window


I cannot ping  R3 from R1



R1#ping 192.168.23.3

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.23.3, timeout is 2 seconds:
.....
Success rate is 0 percent (0/5)
R1#

FRom R2 I can ping:
R2#ping 192.168.23.3

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.23.3, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 12/19/24 ms
R2#
Screen-Shot-2017-11-09-at-8.38.50-PM.png
0
A company I am supporting has a SonicWALL TZ600 firewall.

We need to audit and determine how much internet bandwidth each user is using and what type of bandwidth is being used (for streaming video, streaming audio, file downloads, etc.)

How can this be setup within the SonicWALL TZ600 firewall?
0
any of you ever seen a lan ip that starts with 205.162.2.x ?   is this normal?
0
In the example blow - Juniper firewall has heard from two WAN routers of a default route via OSPF.
It seems basically happenchance that 13.79.23.63 is the preferred default route. What could I do on the juniper to make 13.79.23.63 to always and purposely be chosen over the .62?

myjuniper> show route
0.0.0.0/0          *[OSPF/150] 1w6d 16:05:01, metric 26, tag 0
                      to 13.79.23.62 via reth0.0
                    > to 13.79.23.63 via reth0.0
0
Hi;
How do we find out if a given ACL statemet in acl set (Cisco) did have had a match in past, that this on running traffic if certain IP Address and port had a match?

Thanks;
0
EIGRP Lab example for Query Scoping.

I have read about EIGRP Scoping , and in most of articles they recommend Summarization at the Edge router. I have tried that, and enabled Debug EIGRP Packets Query on other routers, and shut down interface on one of the routers behind the Edge router, but I still saw a Query sent by the Edge Router to other routers.

I am not sure if that's normal behaviour or the lab is not the right set up to test EIGRP Query Scoping.

Any Lab Example from EIGRP Expert that demonstartes EIGRP Query Scoping might  help understand this topic..

Thank you
0
When does EIGRP Equal Load-Balancing happen

I have managed to Test Unequal load-balancing using Traceroute multiple times and quickly.

However for Equal Cost , I tried Traceroute multiple times and quickly , but it keeps going through one path..

I am not sure now if Equal Cost Load-balancing happens only when there is congestion on one path...if so why this does not happen on Unequal Cost..

Any Clarification will be very much appreciated.

Thank you
0
Imagine a remote site - call it Dallas - with two WAN routers. Router WAN1 connects to the data center in Denver over a 1Gbps circuit and router WAN2 connects to the data center over another 1Gbps circuit. All the routers are participating in OSPF.

[core-sw1]---[WAN1]~~~~ckt1~~~~[DC-Core-1]
[core-sw1]---[WAN2]~~~~ckt2~~~~[DC-Core-2]

The Dallas site has network 172.25.0.0/16 and currently that gets advertised such that traffic to Dallas goes equally over WAN2 and WAN1. I would like a specific subnet say 172.25.200.0/23 to prefer ckt2 unless ckt2 goes down then it would use ckt1. What would I do in OSPF to color the route for 172.25.200.0 so that the data center prefers sending via ckt2?

Thank you.
0
I am writing a netflow collector in .net, which has lots of interesting challenges including reading the RFC!

However, I need a specific piece of information  

Here is a link to a copy of the RFC:

https://www.ietf.org/rfc/rfc3954.txt


From this I read this excerpt:
The life of a template at the Collector is limited to a fixed refresh
   timeout.  Templates not refreshed from the Exporter within the
   timeout are expired at the Collector.  The Collector MUST NOT attempt
   to decode the Flow or Options Data Records with an expired Template.

I cannot find any default expiry timeframe for a netflow Flowset Template.  

It says it must be configurable at the exporter and the collector.  When I set up a PRTG to collect netflow packets, there was not an option to specify the template expiry.  I can't see any record in the RFC that the exported can use to tell the collector when to expire templates.  PRTG works though.  

Therefore there must be a reasonable default value for how long to keep an un-refreshed template before expiring it.  

My question is, what is the default timeframe to expire a template - OR - how else can the collector learn this from the exporter? (someone manually configuring it is not the answer I want)

There must be some way in which netflow collectors work out of the box without the user specifying the template expiry.  I need to do this.
0
Hi, We have following error
Port is Busy: All pipe instances are busy

Configuration server error: Communication error : Port is Busy: All pipe instances are busy
Port is Busy: All pipe instances are busy
What is the best way to handle this issue.Without restarting the Server

Server :Windows 200R2  Data center ,Service Pack 1
1


R4 has Loopback 0 4.4.4.4 in area 0
other physical interfaces as shown in the topology they are in area 1,2,3


I have configured on R4:
R4#sh run | beg ip prefix
ip prefix-list INTO-AREA3 seq 5 deny 2.2.2.2/32
ip prefix-list INTO-AREA3 seq 10 permit 0.0.0.0/0 le 32
ip prefix-list INTO-AREA3 seq 15 deny 192.168.14.0/24
ip prefix-list INTO-AREA3 seq 20 deny 192.168.24.0/24

router ospf 1
 area 3 filter-list prefix INTO-AREA3 in

when I go to R3 I see the routes below still there when they should be filtered out:
192.168.14.0/24
192.168.24.0/24

I have changed the sequence number of this command to sequence 25:
ip prefix-list INTO-AREA3 seq 25 permit 0.0.0.0/0 le 32

and now I see the filtering worked. When I go to R3 which is in area 3. I do not see the routes:

192.168.14.0/24
192.168.24.0/24

Any Expert to explain the logic that the route has used in regard to the  ip prefix-list sequences. ?

Thank you
0
I have been troubleshooting an issue of some voip problems at a site. A colleague who's now left mentioned he had run into some spanning tree issues that had caused problems. He fixed that problem he said by adding "portfast" to the access switches. I'm seeing most of these ports set to port type "access" and BPDU guard is set. But I want to verify that changes in spanning tree are not happening which might affect traffic. Are there command that would let me see recent spanning tree change events? Or would I only be able to see this with debug?
0
I have read that Windows 2012 and 2008 IIS do not natively support SFTP. They support FTPS or FTP over. What would be the best options for securing FTP file transfers? Maybe using HTTPS?

DLH
0
FR
I have Frame Relay set up as shown in the screenshot above.
I have set up OSPF and manually configured Neighbors .
I can ping from the Hub to the Spokes  and back, but cannot ping between Spokes.

Any Help ?

Thank you


Hub#sh run
Building configuration...

Current configuration : 1431 bytes
!
! Last configuration change at 13:29:27 UTC Sun Oct 22 2017
!
upgrade fpd auto
version 15.0
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname Hub
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
!
!
!
ip source-route
no ip icmp rate-limit unreachable
ip cef    
!
!
!
!
no ip domain lookup
no ipv6 cef
!
multilink bundle-name authenticated
!
!
!
!
!
!
!
!
!
redundancy
!
!
ip tcp synwait-time 5
! 
!         
!
!
!
!
!
!
interface FastEthernet0/0
 no ip address
 shutdown
 duplex half
 !
!
interface Serial1/0
 ip address 192.168.123.1 255.255.255.0
 encapsulation frame-relay
 serial restart-delay 0
 !
!
interface Serial1/1
 no ip address
 shutdown
 serial restart-delay 0
 !        
!
interface Serial1/2
 no ip address
 shutdown
 serial restart-delay 0
 !
!
interface Serial1/3
 no ip address
 shutdown
 serial restart-delay 0
 !
!
!
router ospf 1
 log-adjacency-changes
 network 192.168.123.0 0.0.0.255 area 0
 neighbor 192.168.123.2
 neighbor 192.168.123.3
!
ip forward-protocol nd
no ip http server
no ip http secure-server
!
!
!
no cdp log mismatch duplex
!
!
!
!
!
!

Open in new window

0
Sorry if this question is too basic. I have setup 2  cisco routers 1841 model. I have the first one configured with the following

Fe0 dhcp <------this interface is connected directly to the internet
Fe1 10.0.3.1 <----This interface is connected to the LAN

My problem is how do you get Internet traffic from FE0 to FE1 and other interfaces.

I am using OSPF and i can route  traffic from 10.0.3.x to any other private ip address within the 10.x.x.x network. How can I forward ISP traffic to my internal network, thanks
0
Screen-Shot-2017-10-16-at-9.01.37-PM.png
in the topology above , I  configured on R3 area 1 as stub in the first LAB then configured the same area 1 as NSSA in the second LAB.
In matter of OSPF Routing table Stub or NSSA the effect is the same , both have made R2 and R1 unable to reach any interface of R3 and the other way around also is true.

In matter of LSDB there was difference,, NSSA has created LSA type 7 on R3 area 1  

***My question is what's the purpose of LSA 7 if OSPF routing tables gave the same results between  , when I configured area 1 as Stub then NSSA ?


the output below is when I configured area 1 NSSA on R3

R1#sh ip route ospf 
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area 
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route, + - replicated route

Gateway of last resort is not set

      2.0.0.0/32 is subnetted, 1 subnets
O        2.2.2.2 [110/2] via 192.168.12.2, 00:00:45, FastEthernet0/0
O IA  192.168.23.0/24 [110/2] via 192.168.12.2, 00:00:45, FastEthernet0/0
R1#

Open in new window


R2#sh ip route ospf 
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area 
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route, + - replicated route

Gateway of last resort is not set

      1.0.0.0/32 is subnetted, 1 subnets
O        1.1.1.1 [110/2] via 192.168.12.1, 00:03:24, FastEthernet0/0
      11.0.0.0/24 is subnetted, 1 subnets
O E2     11.11.11.0 [110/20] via 192.168.12.1, 00:03:24, FastEthernet0/0
R2#

Open in new window


R3#sh ip route ospf 
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area 
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route, + - replicated route

Gateway of last resort is not set

R3#
R3#

Open in new window


Thank you
1
I have :

R1---R2---R3

OSPF is configured at the Global configuration level on all routers.

R1  has 2 loopbacks: loopback0 (1.1.1.1/24) and loopback1 (11.11.11.11/24)
R1 has interface fa0/0 (192.168.12.1) connected to R2

Router OSPF 1
Network 1.1.1.0 advertised into area 0
Network 192.168.12.0 into area 0

** 11.11.11.0 network is not advertised, it is redistributed

R2 has loopback 2.2.2.2/24
R2 has interface fa0/0(192.168.12.2) connected to R1
Network 2.2.2.0 advertised into area 0
network 192.168.12.0 avertised into area 0

R2  has also interface fa0/1(192.168.23.2) connected to R3
so R2 has advertised Network 192.168.23.0/24 into area 1

***Let 's not worry about R3 , since it has all its interfaces in area 1

Now on R1 : I have "redistribute connected subnets"
this has redistributed the prefix 11.11.11.0 into area 0

Well, when I check R1 ospf routing table there is no prefix 11.11.11.0 , it shows on its global routing table as directly connected.

on R2, the prefix 11.11.11.0/24 shows as E2.

My question now is why in R1 the prefix 11.11.11.0 is not showing as E2 ?

Sorry I have my topology and configuration in the Lab , this is why I cannot paste the topology and/or the configuration.

Any clarification will be very much appreciated.

Thank you.
0
What are some good VPN software or services that will allow me to use the same external IP address every time and also change to different external IP addresses around the world whenever I need to?

I need to be able to use this both within Windows 10 and the latest Mac OS X software.
0
Around the time some of our traffic dipped to our site - I saw a number of changes of BGP path with lots of prepended AS's indicating less preferred routes. If those changes were beyond our directly connected ISP, what is the best way to find out why the path changed at that time? Is there a way to find out? There were perhaps 10 path changes in 10 minutes before things got back to normal.
1

Networking Protocols

12K

Solutions

16K

Contributors

Networking software modules are interfaced with a framework implemented on the machine's operating system that implements the networking functionality of the operating system. The best known frameworks are the TCP/IP model and the OSI model. Systems typically do not use a single protocol to handle a transmission. Instead they use a set of cooperating protocols, sometimes called a protocol family or protocol suite.[9] Some of the best known protocol suites include: IPX/SPX, X.25, AX.25, AppleTalk and TCP/IP. Other protocols indirectly related to networking include the hypertext transfer protocol (HTTP) and its related technologies, Dynamic Host Configuration Protocol (DHCP), Domain Name Server (DNS) and other Internet protocols.